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Introduction to Logizian
This chapter gives you an introduction about Logizian. The following topics will be covered:

 

About Logizian

A brief description of Logizian which outlines some of the key features that Logizian supports.

 

Editions

A summary of editions and their supported features.

 

Features

A list of supported features.

 

Licensing

Logizian need to run with a key. This page shows you how to import different kinds of key into Logizian.

 

Software maintenance

Describes what software maintenance provides and tell you why you need it.

 

System requirements

A description of hardward requirements.
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Logizian product overview
Logizian  is a fast and cross-platforms business process design tool which supports Business Process Modeling Notation (BPMN) 2.0, data flow
diagram (DFD), and organization chart. Further to basic business modeling features, Logizian enables you to specify step-by-step working procedures
to all business process elements, animating business process diagram, simulating business process diagram, generating reports and publishing project
to website.

Business process modeling

With Logizian, you can design and model your system with the following diagrams:

• Business process diagram

• Conversation diagram

• Process map diagram

• Event-driven process chain (EPC) diagram

• Data flow diagram

• Organization chart

Glossasry management

Record customers' needs with textual analysis tool, identify important terms from the recorded text and form a project-wide glossary.

Data modeling

Business analysts model processes with diagrams like business process diagram (BPD) and process map diagram. They model that data that is
required or produced by processes using entity relationship diagram. ERD, short for entity relationship diagram, presents data in entities form, with
relationships show in between, presenting the inter-relationship among pieces of data.

Process simulation

Simulacian is a set of tools to help business analysts simulate the execution of business process for studying the resource consumption (e.g. Human
resources, devices, etc.) throughout a process, identifying bottlenecks and improving the current business by process refinement and resources re-
allocation. 

Team collaboration

For users that work as a team, team collaboration support lets you perform modeling collaboratively and concurrently with any one of the following tools
or technologies:

• VP Teamwork Server (Need to buy Visual Paradigm Teamwork Server additionally)

• CVS

• Subversion

• Perforce

• ClearCase

Interoperability

The interoperability support allows you to exchange model data with other tools. The following tools are supported:

Import Export

Visio drawing  

BPEL for Oracle workflow engine  

BPEL for JBoss workflow engine  

Diagram (JPG, PNG, SVG, EMF, PDF)  

Microsoft Excel

XML (native)

VP project

List of standard or tools that are covered by interoperability support

 

Documentation generation

Share your design with your customers in popular document formats, including:

• HTML (report generation)

• HTML (project publisher)

• PDF

• Word

http://www.visual-paradigm.com/product/lz/
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Editions
Belows are the kinds of features that can be found in each edition of Logizian. For details, please visit:  http://www.visual-paradigm.com/product/lz/
editions/

 Simulacian Analyst Modeler

Business Process Diagram

Data Flow Diagram  

Simulacian

Business Process Execution

Data Modeling

Glossary Management

Impact Analysis

PDF, Word and HTML Report Generation

Report Template Designer  

Visual Diff  

Animacian   

Team Collaboration

  The filled circle indicates the support of certain feature in certain edition

A summary of features supported by Logizian

 

http://www.visual-paradigm.com/product/lz/editions/
http://www.visual-paradigm.com/product/lz/editions/
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Licensing
Logizian  needs to run with a valid license. The various licensing options listed in this page vary in price and functionality.

Various licensing options

Single seat license
Visual Paradigm's single-seat (team-member-based) license allows a licensee to install the software on a computer that belongs, and provides sole
access, to the named user only. Since the license is team-member-based, the software must be used by the licensee only, without running more than
one instance concurrently. The single-seat license only allows installation on a maximum of three computers.

Edition Unit price Unit price (with 1 year maintenance)

Simulacian $799.00 $958.50

Analyst $199.00 $238.50

Modeler $99.00 $118.5

Viewer Free Not applicable

Price of single seat licenses (Prices are provided in US dollars)

Floating license
The floating license supports sharing of the pool of licenses among your team. Instead of purchasing a single-seat license for each team member,
optimize your budget by purchasing floating licenses for the maximum number of simultaneous software users or access points. This approach allows
greater flexibility in using our software. Users can then export the license files to a laptop to use the software offsite (to deliver a presentation, for
example), and then import the license back to the server at a later time.

Edition Unit price Unit price (with 1 year maintenance)

Simulacian $1038.50 $1246.00

Analyst $258.50 $310.00

Modeler $128.50 $154.00

Viewer Not applicable Not applicable

Price of floating licenses (Prices are provided in US dollars)

In order to work with the floating license, installation of a VP Server that stores the license key file(s) and also automatically manages access requests
from clients is required. The client must enable the connection to the license server when requesting access to the software.

For more information about floating licenses, please visit
http://www.visual-paradigm.com/shop/floatinglicense.jsp

Subscription license

Edition Unit price (per month)

Simulacian $39.00

Analyst $9.00

Modeler $5.00

Viewer Not applicable

Price of subscription licenses (Prices are provided in US dollars)

Academic license
Academic licenses are available for higher education, with the aim of providing free site licenses for the teaching of software engineering. Educational
institutions that join the Academic Partners Program are entitled to free licenses for the Standard Edition of Visual Paradigm's software, which can
then be used solely for educational purposes. The academic license is not limited to use on campus, but can also be used at home by students and
teachers.

For more information about academic licenses, please visit
http://www.visual-paradigm.com/partner/academic/ .

http://www.visual-paradigm.com/product/lz/
http://www.visual-paradigm.com/shop/floatinglicense.jsp
http://www.visual-paradigm.com/partner/academic/
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Software maintenance
The Visual Paradigm Software Maintenance package includes both version upgrades and technical support services for our customers. The following
benefits are all included in the Visual Paradigm Software Maintenance package.

Version upgrades
Typically, Visual Paradigm produces two to three versions per year, with approximately five to ten major new features and enhancements per version.
You are entitled to install any new versions of Visual Paradigm product that are released within your software maintenance period.

Technical support
You and your team members can submit technical support tickets to our Technical Support Team at  http://www.visual-paradigm.com/support/
technicalsupport.jsp

Our Technical Support Team will respond to your message within one working day. Normally, you will receive our response by email within a few
hours.

Visual Paradigm is committed to delivering extraordinary technical support to our customers. Our Technical Support Team employs the following
technologies to back up our products.

Email with text and screen shot attachments

In most cases we can provide assistance by guiding you with the aid of screen shots.

Flash demo

Sometimes, a short movie is more descriptive than a thousand words. If the answer to your question is complex, we can prepare a short Flash
demonstration to guide you in resolving your difficulty.

Secure online sessions

We can schedule an online meeting with you to take an interactive look at your issue. Online meetings are held using a secure Internet connection.
During the meeting, our team can remotely access and operate your PC while speaking with you by telephone or while chatting with you using the built-
in chat program.

Telephone

You can leave a callback request at the following URL. Our Technical Support Team will return your call as soon as possible. To make a call, visit: 
http://www.visual-paradigm.com/support/callme.jsp

Price
Software maintenance is purchased on an annual basis (e.g., June 20, 2012 to June 19, 2013).

If you decide to purchase the software maintenance package with your product, or if you decide to extend a current maintenance contract, the yearly
cost is 20% of the product list price. To take advantage of this 20% offer, you must extend your maintenance contract at least one week prior to its
expiration date.

If you decide to purchase a software maintenance package separately, the yearly cost is 30% of the product list price.

You can purchase software maintenance to cover up to three years from the date of purchase.

Detailed software maintenance package pricing is listed below.

Single seat license

Prices are provided in US dollar

Edition 1 Year Maintenance

(extend current maintenance)

1 Year Maintenance

(buy maintenance separately)

Simulacian $159.5 $239.5

Analyst $39.5 $59.5

Modeler $19.5 $29.5

Viewer not applicable not applicable

The above software maintenance contract prices are for 1 year only.

Price for single-seat license

Floating license

http://www.visual-paradigm.com/support/technicalsupport.jsp
http://www.visual-paradigm.com/support/technicalsupport.jsp
http://www.visual-paradigm.com/support/callme.jsp
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Prices are provided in US dollar

Edition 1 Year Maintenance

(extend current maintenance)

1 Year Maintenance

(buy maintenance separately)

Simulacian $207.5 $311.5

Analyst $51.5 $77.5

Modeler $25.5 $38.5

Viewer not applicable not applicable

The above software maintenance contract prices are for 1 year only.

Price for floating license
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System requirements

Hardware requirements
• Intel Pentium 4 at 2.0 GHz or higher

• Minimum 512MB RAM, but 1.0 GB is recommended

• Minimum 800MB disk space

• Microsoft Windows (98/2000/XP/2003/Vista/7), Linux, Mac OS X, Solaris or all other Java-enabled platforms

• JDK 1.6 for Mac OS X
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Getting started
This chapter covers mainly the installation of Logizian on various platforms, as well as the steps of switching between product editions and how to
remove Logizian.

 

Installing Logizian on Windows 2000/NT/2003/XP/Vista/7

List the steps of installing Logizian on Microsoft Windows as well as the use of no-install (zip) version.

 

Installing Logizian   on Mac OS X

List the steps of installing Logizian on Mac OS X as well as the use of no-install (zip) version.

 

Installing Logizian   on Linux and Unix

List the steps of installing Logizian on Linux and Unix as well as the use of no-install (zip) version.

 

Starting Logizian 

List the steps of starting Logizian, with a brief description on 'workspace'.

 

Changing edition

You can switch between editions without re-installation. This page shows you how to do.

 

Uninstalling Logizian

List the steps of uninstalling Logizian.



Windows 2000/NT/2003/XP/Vista/7 P. 11

Installing Logizian on Windows 2000/ NT/ 2003/XP/ Vista/7
Having downloaded the installer of  Logizian , execute it, run through the installation to install Logizian. If you are using the "no-install" zip version,
you just need to unzip it and run Logizian directly. In this chapter, we will go through the installation of Logizian both with installer (.exe) and "no-
install" (.zip).

Using installer (.exe)
1. Execute the downloaded Logizian installer file. The setup wizard appears as below.

Logizian welcome screen

2. Click Next to proceed to the License Agreement page.

3. Read through the license agreement carefully. Make sure you accept the terms before continuing with the installation. If you accept the
agreement, select I accept the agreement and click Next to proceed to the Select Destination Directory page.

The License Agreement

4. Specify the directory for installing Logizian. Click Next to proceed to the next page.

5. Specify the name of the Start Menu folder that will be used to store the shortcuts. Keep Create shortcuts for all users checked if you want the
shortcut to be available in all the user accounts in the machine. Click Next to proceed.

6. In the File Association page, keep Visual Paradigm Project (*.vpp) checked if you want your system able to open the project file upon direct
execution (i.e. double click). Click Next to start the file copying process.

7. Upon finishing, you can select whether to start Logizian or not. Keep Logizian  selected and click Finish will run Logizian right away.

Using "no install" version (.zip)
Decompress the downloaded zip file into a directory. This creates a subdirectory named "Logizian 10.1" where 10.1 is the version number. That's it. To
start Logizian, execute bin\Logizian 10.1.exe.

Installation FAQ
Question: What is the difference between Installer and "No Install" Version?
Answer: Installer version creates shortcut and registers the menus that make the system more easy to use. We suggest user to use installer version for
a long term usage. The "No Install" version is good for evaluation and testing the release candidate.
Question: I cannot complete the installation due to a file is missing when copying files. What can I do?
Answer: This can be caused by a corrupted installer file. Please download the installer file again with a different mirror site and run it again to solve the
problem.
Question: I cannot start the application after installing the software. What can I do?
Answer: There are several possible causes of the problem. If you are sure that your installation was performed correctly, contact Visual Paradigm's
support team (  support-team@visual-paradigm.com ) for assistance. It is recommended to include the lz.log file in %HOME-DIR%\visualparadigm\
(e.g. C:\Users\Peter\visualparadigm\lz.log).
Question: I don't have administrator right, can I install the software?
Answer: Yes, you can.
Question: The installer file is detected to contain a virus. What can I do?
Answer: Our installer files are all packed by ourselves in a secure environment, and are scanned for virus before releasing to public. If a virus is
detected, please update to the latest virus profile first. After that, we recommend you perform a full system scan, download the installer file from our
official site, and run the installation again. If the problem remain, please contact us (  support-team@visual-paradigm.com ) or the virus scanner vendor
for assistance.

 

http://www.visual-paradigm.com/product/lz/
mailto:support-team@visual-paradigm.com
mailto:support-team@visual-paradigm.com
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Installing Logizian on Mac OS X
Having downloaded the installer of  Logizian , execute it, run through the installation to install Logizian. If you are using the "no-install" .tgz version,
you just need to unzip it and run Logizian directly. In this chapter, we will go through the installation of Logizian both with installer (.dmg) and "no-
install" (.tgz).

Using installer (.dmg)
1. Execute the downloaded Logizian installer file. The setup wizard appears as below.

Logizian welcome screen

2. Click Next to proceed to the License Agreement page.

3. Read through the license agreement carefully. Make sure you accept the terms before continuing with the installation. If you accept the
agreement, select I accept the agreement and click Next to proceed to the Select Destination Directory page.

The License Agreement

4. Specify the directory for installing Logizian. Click Next to proceed to the next page.

5. In the File Association page, keep Visual Paradigm Project (*.vpp) checked if you want your system able to open the project file upon direct
execution (i.e. double click). Click Next to start the file copying process.

6. Upon finishing, you can select whether to start Logizian or not. Keep Logizian  selected and click Finish will run Logizian right away.

Using "no install" version (.tgz)
Decompress the downloaded .tgz file into a directory. This creates a subdirectory named "Logizian 10.1" where 10.1 is the version number. That's it. To
start Logizian, execute bin\Logizian 10.1.app.

Installation FAQ
Question: What is the difference between Installer and "No Install" Version?
Answer: Installer version creates shortcut and registers the menus that make the system more easy to use. We suggest user to use installer version for
a long term usage. The "No Install" version is good for evaluation and testing the release candidate.
Question: I cannot complete the installation due to a file is missing when copying files. What can I do?
Answer: This can be caused by a corrupted installer file. Please download the installer file again with a different mirror site and run it again to solve the
problem.
Question: I cannot start the application after installing the software. What can I do?
Answer: There are several possible causes of the problem. If you are sure that your installation was performed correctly, contact Visual Paradigm's
support team (  support-team@visual-paradigm.com ) for assistance. It is recommended to include the lz.log file in %HOME-DIR%\visualparadigm\
(e.g. C:\Users\Peter\visualparadigm\lz.log).
Question: The installer file is detected to contain a virus. What can I do?
Answer: Our installer files are all packed by ourselves in a secure environment, and are scanned for virus before releasing to public. If a virus is
detected, please update to the latest virus profile first. After that, we recommend you perform a full system scan, download the installer file from our
official site, and run the installation again. If the problem remain, please contact us (  support-team@visual-paradigm.com ) or the virus scanner vendor
for assistance.

 

http://www.visual-paradigm.com/product/lz/
mailto:support-team@visual-paradigm.com
mailto:support-team@visual-paradigm.com
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Installing Logizian on Linux and Unix
Having downloaded the installer of  Logizian , execute it, run through the installation to install Logizian. If you are using the "no-install" zip version,
you just need to unzip it and run Logizian directly. In this chapter, we will go through the installation of Logizian both with installer (.sh) and "no-
install" (.tar.gz).

Using installer (.sh)
1. Execute the downloaded Logizian installer file.

bash ./%Logizian-INSTALLER-FILENAME%
The setup wizard appears as below. If you are prompted an error like "bin/unpack200: /lib/ld-Linux.so.2: bad ELF interpreter: No such file or
directory. Error unpacking jar files. The architecture or bitness (32/64)", make sure you are executing the right installer - 64 bit / 32 bit. You can
download any of them from our  official website .

Logizian welcome screen

2. Click Next to proceed to the License Agreement page.

3. Read through the license agreement carefully. Make sure you accept the terms before continuing with the installation. If you accept the
agreement, select I accept the agreement and click Next to proceed to the Select Destination Directory page.

The License Agreement

4. Specify the directory for installing Logizian. Click Next to proceed to the next page.

5. Select a folder for creating symlinks. You may uncheck Create symlinks if you do not want to. Click Next to the start file copying process.

6. Upon finishing, you can select whether to start Logizian or not. Keep Logizian selected and click Finish will run Logizian right away.

Using "no install" version (.tar.gz)
Decompress the downloaded .tar.gz file into a directory: tar -zxf %NO-INSTALL-FILE.tar.gz% -C %DESTINATION-FOLDER%

This creates a subdirectory named "Logizian 10.1" where 10.1 is the version number. That's it. To start Logizian, execute bin\Logizian 10.1.

Installation FAQ
Question: What is the difference between Installer and "No Install" Version?
Answer: Installer version creates shortcut and registers the menus that make the system more easy to use. We suggest user to use installer version for
a long term usage. The "No Install" version is good for evaluation and testing the release candidate.
Question: I cannot complete the installation due to a file is missing when copying files. What can I do?
Answer: This can be caused by a corrupted installer file. Please download the installer file again with a different mirror site and run it again to solve the
problem.
Question: I cannot start the application after installing the software. What can I do?
Answer: There are several possible causes of the problem. If you are sure that your installation was performed correctly, contact Visual Paradigm's
support team (  support-team@visual-paradigm.com ) for assistance. It is recommended to include the lz.log file in %HOME-DIR%\visualparadigm\
(e.g. C:\Users\Peter\visualparadigm\lz.log).
Question: The installer file is detected to contain a virus. What can I do?
Answer: Our installer files are all packed by ourselves in a secure environment, and are scanned for virus before releasing to public. If a virus is
detected, please update to the latest virus profile first. After that, we recommend you perform a full system scan, download the installer file from our
official site, and run the installation again. If the problem remain, please contact us (  support-team@visual-paradigm.com ) or the virus scanner vendor
for assistance.

 

http://www.visual-paradigm.com/product/lz/
http://www.visual-paradigm.com/download/vpuml.jsp
mailto:support-team@visual-paradigm.com
mailto:support-team@visual-paradigm.com
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Starting Logizian

Ways of starting Logizian
Logizian  can be started through accessing the Start Menu. For Linux users, Logizian can be started through the shortcuts in desktop, created by the
installer.

Start Logizian via Start menu

Starting Logizian (for floating license client whose host is IP-4-enabled)
If you are a floating license client, and if your host is IP-4 enabled, you need to start Logizian with a startup script in order to connect to the server. Here
are the steps:

1. Copy Logizian.bat under the scripts folder of Logizian installation directory to become Startup.bat

2. Edit Startup.bat

3. Add -Djava.net.preferIPv4Stack=true to the script

Editing the start up script

4. Save

5. From now on, execute Startup.bat to run Logizian.

Starting Logizian the first time
When you start Logizian the first time, you are asked to select a way to "unlock" Logizian.

Select a way to unlock Logizian

http://www.visual-paradigm.com/product/lz/
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30 Days FREE Evaluation
If you want to evaluate Logizian, click this. You will then be asked to select the edition of product to evaluate. Logizian features vary by product edition.
For more details on the features supported by different editions, check the  Edition Comparison  page. Click on the Evaluate button to confirm your
edition selection. Then, you can start your 30 days evaluation.

To evaluate the Simulacian Edition

Perpetual License
If you have purchased a license and you want to unlock Logizian with it, click this.

There are several ways you can take to import your license key into Logizian. The first way is to enter the activation code and click Activate. You
can obtain the code by visiting your customer account at our Customer Service Center. Alternatively, the licensee should have received our Email
notification with activation code included.

The second way is to import the .zvpl license key file by expanding the License Key section and clicking on the button ... to select the key file. Again,
you can find the key file in your customer account.

If you are using a floating license, expand the Floating License section, enter the connection settings of the host machine where the license is
installed and click Apply.

Subscription Account
If you have subscribed to run Logizian for certain period of time, click this. Enter the login details of your customer account and click Sign in to
continue.

Selecting workspace
A workspace is a directory used to store all settings, user interface perspectives and other preferences defined for the working environment (settings
can be configured via Tools > Application Options... in Logizian). A workspace also stores all the teamwork login information and local copies of
teamwork projects. In the case of switching computers, you simply need to copy the whole workspace directory to the new computer and specify the
new workspace when starting Logizian. All your teamwork information and settings will then be transferred to the new computer.

The Workspace Launcher appear when running Logizian.

Workspace Launcher

Specify the workspace folder.

If you do not want this dialog box to appear again, check Use this as the default and do not ask again. This will cause Logizian to open the specified
workspace folder automatically the next time.

If you already have an existing workspace, you can import the settings from there by clicking Import Workspace....

Click OK to continue.

http://www.visual-paradigm.com/product/lz/editions/
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Changing edition
You may want to run the product in a different to use the functions supported by that edition. This is particularly common during evaluation. You want
to try out different editions to find out the one that suit you best. Product edition can be changed by updating the license applied, without the need of re-
installation.

1. Select Tools > License Manager... from the main menu.

2. Click Change License... at bottom left. Answer OK when you are prompted to delete the existing license.

3. If you want to evaluate another edition, click on the smiley face and click Evaluate at the column of edition you want to switch to. If you own
a perpetual license of the target edition, click on Perpetual License and enter the activation code of the license, or update the connection of
floating license access if your team owns a floating license. If you have subscribed antoher edition of product, click on Subscription Account
and sign in with your licensee ID and password.
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Uninstalling Logizian
Uninstalling  Logizian  will remove Logizian from your machine. If you installed BP-VA through installer, you can uninstall it by running the uninstall
file right under the installation directory. If you are using a no-install version of Logizian, you just need to delete the extracted folder to have Logizian
removed.

http://www.visual-paradigm.com/product/lz/
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User interface
This chapter walks through the various panes and components in user interface.

 

Interface overview

A summary of the user interface you can see when Logizian is started.

 

Main menu

The main menu enables you to access most of the core functions in Logizian.

 

Toolbar

The toolbar is a by default horizontal bar below the main menu bar which covers most of the core functions in Logizian.

 

Dockable user interface

Dockable user interface refers to the ability to drag out a pane and dock it to another part of the application screen.

 

Diagram navigator

Diagram navigator is a pane that lets you access and create diagrams.

 

Model explorer

Model explorer is a pane that lets you access and create models, and browse for their specifications.

 

Logical view

Logical view is a pane that lets you organize diagrams with user-named views.

 

Property pane

Property pane is a pane that lets you read and edit chosen element(s) 's properties.

 

Diagram overview

Diagram overview is a thumbnail of diagram which enables you to navigate and zoom into a diagram.

 

Documentation pane

Documentation pane is a pane that lets you read and edit documentation of chosen element.

 

Stencil pane

Stencil pane is a pane that list stencil, and lets you drag out a shape to diagram.

 

Diagram specification

Diagram specification enables you to adjust some of the diagram settings

 

Perspective

Perspective define way to position panes.

 

Model element specification

Properties of model elements can be set and read through the specification dialog box.
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Interface overview
Logizian 's user interface comprises a menu bar, a toolbar, several panes for model navigation, a message pane and a diagram pane that occupy most
spaces.

User Interface of Logizian

No. Name Description

1 Menu bar The menu bar at the top of the window allows you to select and perform various operations in Logizian.

2 Toolbar Toolbar, which is below the menu bar, is the extension of menu. All buttons are presented as groups of icons that handily placed
for users.

3 Diagram
navigator

A place where diagrams are listed, and where you can create and access diagrams base on their types.

4 Property
pane

The properties of chosen model/ shapes will be shown on properties pane upon selection.

5 Diagram
pane

The diagram will be displayed in diagram pane.

6 Message
pane

Possible information, notification or warnings will be shown here.

Description of user interface

http://www.visual-paradigm.com/product/lz/


Menu bar P. 20

Main menu
The main menu, which is on the top of the window, allows you to select and perform various operations in  Logizian .

File menu

The  File menu

The File menu enables you to:

• Create a project

• Create a diagram

• Open project

• Save project

• Save and manage project template

• Import project data from the following media: Logizian Project, XML, Excel, Visio and Linked Project (Referenced projects)

• Export project into the following formats: Logizian Project, XML, Active diagram as Image, Diagrams as Image, Selection as Image, Active
Diagram to Excel and Excel

• Export images (JPG, PNG, SVG, EMF, PDF)

• Printing

• Set project properties

• Exit

Edit menu

http://www.visual-paradigm.com/product/lz/
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The Edit menu

The Edit menu enables you to:

• Undo and Redo

• Cut

• Copy

• Duplicate

• Delete

• Repeat an action

• Select everything in diagram

• Find a model element/diagram

• Jump to a diagram or an element

• Add or manage bookmarks

• Grouping

• Shapes alignment and distribution

View menu
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The  View menu

The View menu enables you to:

• Show/Hide a pane

• Show and manage grid

• Manage Layers

• Change Resource Centric behavior

• Save, open and manage perspective

• Change Logizian to show in full screen

• Zoom diagram in and out

• Manage nickname

• Manage style

Modeling menu

The Modeling menu

The Modeling menu enables you to:

• Launch Animacian

• Launch Simulacian

• Compare diagrams with Visual Diff

• Configure stereotypes

Tools menu

The Tools menu

The Tools menu enables you to:

• Generate report
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• Publish project

• Configure stereotypes

• Launch Shape Editor

• Launch License Key Manager

• Configure application options through the Options dialog box

Teamwork menu

The Teamwork menu

The Teamwork menu enables you to:

• Checkout project from server

• Commit project

• Update project

• Revert

• Switch to another trunk/branch

Window menu

The Window menu

The Window menu enables you to:

• Navigate between diagrams

• Rearrange diagram windows

• Switch to another diagram

• Show the Start Page

• Close Diagrams

Help menu

The Help menu

The Help menu enables you to:

• Browse the help contents

• Check the instruction of Mouse Gesture

• Visit Visual Paradigm online support
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• Repair project

• Customize the user interface

• Check the environment using the About dialog box
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Toolbar
Toolbar, which is below the menu bar, is the extension of menu. All buttons are presented as groups of icons that handily placed for users.

Showing/Hiding toolbar
A toolbar can be shown or hidden. To show a toolbar, right click on the standard toolbar, and check Standard to show. Similarly, you can uncheck it to
hide it.

Check toolbar(s) from toolbars' pop-up menu

Repositioning toolbars
You may reposition the toolbar by pressing on the handle of toolbar, which appears on the left hand side of a toolbar, and drag to the target position.

Drag the toolbar

Locking toolbar
To freeze toolbars' position and make the toolbars immovable, right click on any toolbar and uncheck Rearrangable from the pop-up menu.

Make toolbars immovable by unchecking the Rearrangable option

Standard toolbar

The Standard toolbar

Icon Name Description

New Project Create a project.

Save Project Save the changes made in the working project.

Cut Cut selected diagram elements.

Copy within
Logizian

Copy selected diagram elements ready to be used within Logizian.

Copy to
Clipboard as
Image (JPG)

Copy selected diagram elements as JPG image.
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Copy to
Clipboard as
Image (EMF)

Copy selected diagram elements as EMF image.

Copy to
Clipboard as
XML

Copy selected diagram elements as XML data.

Paste View Paste copied diagram elements as view of original model element.

Paste Model
Element

Paste copied diagram elements as a new model element.

Undo Roll back undesired changes.

Redo Rerun an undone task.

Business
Process

Select and create a diagram type under Business Process Modeling, including: Business Process Diagram, Conversation
Diagram, Data Flow Diagram, Event-driven Process Chain Diagram, Process Map Diagram, Organization Diagram, WSDL
Diagram, Business Rule, Business Rule Grid and Fact Diagram.

Database Select and create Entity Relationship Diagram.

Requirement Select and create a diagram type under Requirement Modeling, including: Textual Analysis and Glossary Grid.

Diagrams Select and create other diagrams, including: Overview Diagram and Grid Diagram.

Format Click it to open Formats dialog box. You can format font name, font style, font size, font color, line style, shape's foreground and
background color and style, etc.

Copier Copy the selected diagram element's format and apply on another shape.

Modeling Click it to perform the following: Visual Diff, Animacian, Simulacian, Nicknames, Apply Design Pattern and Transit to New Diagram.
   Visual Diff: Launch Visual Diff for comparing diagrams.
   Animacian: Launch Animacian for animating the active diagram.
   Simulacian: Launch Simulacian for simulating the execution of business process.
   Nicknames: Manage and select the nickname to be applied on the working project.
   Apply Design Pattern: Apply the defined design pattern to the target diagram.
   Transit to New Diagram: Transit the current diagram to a new diagram.

Generate
HTML Report

Open the Generate HTML dialog box to generate HTML report.

Generate PDF
Report

Open the Generate PDF dialog box to generate PDF report.

Generate Word
Report

Open the Generate Word dialog box to generate Word report.

Project
Publisher

Publish project to Web pages through Project Publisher.

Open
Teamwork
Client

Open the Teamwork Client dialog box.

Commit Commit changes to server.

Update Update changes from server.

Tag Create a tag.

Branch Create a branch.

Merge Merge changes between trunk and branches.
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Switch Switch between trunk, branches and tags.

Revert Click it to undo all non-committed changes in working project.

Interoperability Import: Logizian Project...: Import an Logizian project into the opening project.
             XML...: Import diagrams and model elements from XML.
             Telelogic System Architect...: Import diagram and model elements from Telelogic System Architect.
             Excel...: Import Excel file back into the working project.
             Visio...: Import Visio diagrams into Agilian.
             Referenced Project...: Import referenced projects into the opening project.

Export: Logizian Project...: Export the open project into an Logizian project file.
             XML...: Export XML from the opening project.
             Active Diagram as Image...: Export active diagram as image file.
             Diagrams as Image...: Export any diagram(s) as image file(s).
             Selection as Image...: Export selection on active diagram as image file.
             Active Diagram to Excel...: Export active diagram into Excel report.
             Excel...: Export any diagram(s) into Excel report(s).
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Dockable user interface
Logizian  adapts a dockable User Interface which allows you to drag UI components around to customize your favorite working environment. You can
save the environment as a perspective which you can reopen later. It allows you to use different perspectives for different purposes.

Using the dockable user interface
The dockable User Interface is composed of a number of windows called dockable frames. A dockable frame may be standalone (floating) or docked
into another container (split pane/ tab pane).

You can press on its title bar of a dockable frame or press on a tab to drag it to your preferred place.

Drag the frame and dock it to elsewhere

You will notice a grey outline appears while you are dragging a tab or the whole frame. This outline helps you to set the location for docking the
dockable frame/tab.

Docking a dockable frame to elsewhere
By dragging out a dockable frame/tab, and move the cursor to certain position, the frame/tab will be repositioned accordingly.

If you drag the dockable frame/tab and release it over another container, the grey outline will change its shape to fit into the dockable area for the
container. If you release the frame/tab, it will be docked into the underlying container and also removed from its original container.

A frame docked to the right of application screen

You also can drag a frame/tab out to be a floating window.

http://www.visual-paradigm.com/product/lz/
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You can also drag a frame/tab and dock it into another tab pane. You will see the outline changed to a tab shape if you drag over a tab pane.

A frame docked to another frame

Auto-hiding a dockable frame
A dockable frame can be set to "auto hide" that means it will automatically fold when it isn't in active. To set a dockable frame to "auto hide", click on
the Toggle auto-hide button on the top right corner of the frame (it is represented by a pin icon, refer to the figure below)

Hide Diagram Navigator automatically
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Diagram navigator
Diagram navigator is the location where diagrams are listed. You can create your own diagrams easily as they are listed by categories, such as
Requirements Capturing, Business Modeling, Database Modeling, Impact Analysis and Others. With diagram navigator, you can create, open
and delete diagrams.

The diagram navigator

The toolbar

Name Icon Description

New diagram To create a new diagram through the New Diagram dialog box.

Collapse To collapse the selected diagram.

Expand To expand the selected diagram.

Show Diagram View To overview the diagram elements in the selected diagram.

Sort Diagram Element
By Name

To sort diagram elements by their name in alphabetical order.

Sort Diagram Element
By Type

To sort diagram elements by their type, disregard their name.

Move Selected Diagram To move the selected diagram down or up. This option only works within the same diagram type when there are
multiple diagrams.

Refresh To update the content of diagram tree.

The description of icons on diagram navigator

Pop-up menu

Pop-up menu of Diagram Navigator
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The pop-up menu of Diagram Navigator

Menu Title Description

Filter Model Element... Open the Model Element Filter dialog box to filter the diagram elements to appear in the Diagram Navigator.

Show Carriage Return
Character

Display line breaks of multi-lined diagram name as carriage return character.

Sorting Select the way to sort diagram elements in Diagram Navigator.

Group by Category Categorize diagrams base on their types.

Teamwork Perform teamwork activities.

Manage Dependent Project... Add or remove dependent project.

Refresh Refresh diagram navigator content.

Collapse All Collapse all tree nodes.

Expand All Expand all tree nodes.

Show Diagram View Expand all diagram types' nodes to show the diagrams nodes, but it will not display diagram element nodes.

The description of pop-up menu of diagram navigator

Pop-up menu of project

The pop-up menu of project node

Menu Title Description

No View Model
Elements...

It lists the model element(s) that either has not been visualized (no view) or has no master view.

Rename... Rename the project node.

Nicknames Configure or switch to another nickname.

New Diagram... Create a new diagram.

Group by Category Categorize diagrams base on their types.

Sorting Select the way to sort diagram elements in diagram navigator, either Sort Diagram Element by Name or Sort Diagram
Element by Type.

Teamwork Perform teamwork activities, including open teamwork client, commit, update, tag, branch, merge, switch and revert.

Refresh Refresh diagram navigator.

Collapse All Collapse the project node.

Expand All Expand the project node.

The description of pop-up menu of project node

Pop-up menu of diagram category
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The pop-up menu of diagram category

Menu Title Description

New Diagram... Create a new diagram.

Export Logizian Project... Export all diagrams in the selected category as Logizian project.

Export XML... Export all diagrams in the selected category as XML.

Export as Image... Export all diagrams in the selected category as image files.

Print... Print the diagrams in the selected category.

Collapse Collapse the selected diagram category node.

Expand Expand the selected diagram category node.

Show Diagram View Expand all diagram types' nodes to show the diagrams nodes, but do not display any diagram element nodes.

The description of pop-up menu of diagram category

Pop-up menu of diagram type

The pop-up menu of diagram type

Menu Title Description

New [diagram type] Create a new diagram in the selected type.

New Diagram... Create a new diagram with the pop-up dialog box.

Export Logizian Project... Export all diagrams in the selected type as Logizian project.

Export XML... Export all diagrams in the selected type as XML.
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Export as Image... Export all diagrams in the selected type as image files.

Print... Print the diagrams in the selected type.

Sort [diagram type] by name Sort the diagram nodes of the selected type node in alphabetically.

Collapse Collapse the selected diagram type node.

Expand Expand the selected diagram type node.

The description of pop-up menu of diagram type

Pop-up menu of diagram

The pop-up menu of diagram

Menu Title Description

Open [diagram name]
Specification...

Open the specification of the selected diagram.

Open [diagram name] Open the selected diagram if closed or inactive.

Close [diagram name] Close the selected diagram if opened.

Rename... Rename the selected diagram.

Delete Delete the selected diagram.

Edit Nickname... Pop-up a dialog box for defining the nick name of model elements appears in the diagram. This option is available only
after you have configured a nickname.

Analysis... An analysis diagram will be formed to analyze the selected diagram with others and the result will be shown. Relationship
like diagram transition can also be found.
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Export Logizian
Project...

Export the selected diagram as Logizian project.

Export XML... Export the selected diagram as XML.

Export Selected as
Image...

Export the selected diagram as image Excel.

Export as Image... Export diagram(s) as image via the Diagram Exporter.

Export to Excel... Export the selected diagram as image Excel.

Print... Print the selected diagram.

Move Up Move the selected diagram node upwards.

Move Down Move the selected diagram node downwards.

Collapse Collapse the selected diagram node.

Expand Expand the selected diagram node.

Sorting Change the way of sorting diagram elements.

The description of pop-up menu of diagram

Closing and opening diagram navigator
Diagram navigator is opened by default. To close it, press the X button at the top right corner. On the other hand, it can be opened by selecting View >
Panes > Diagram Navigator from the main menu.

Creating a diagram
Approach 1 &ndash; Direct creation
If you want to create a diagram in shortcut and don't supply the documentation of diagram (for time-saving), use this approach. To create a diagram:

1. Right click on the diagram type that you want to create.

2. Select New diagram type from the pop-up menu. Here, diagram type means the type of diagram you want to create.

NOTE: You can immediately enter the diagram name in the pop-up box at the top left corner of diagram.

Approach 2 &ndash; Through the  New Diagram dialog box
This approach allows you to create a diagram and enter the name and documentation simultaneously. To create a diagram:

1. Right click on the diagram type that you want to create.

2. Select New Diagram from the pop-up menu.

In the New Diagram dialog box, you can enter the name and documentation of diagram, and click OK button to proceed.

New Diagram dialog box
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Opening a diagram
Double click in the diagram you want to view in the diagram tab.

Sorting diagram elements
In diagram navigator, diagram elements are listed under diagram nodes. You can sort diagram elements by their names, or by their types (e.g. use
case, package, etc.)
To sort by name, click Sort Diagram Element by Name button. The elements will be listed by name, in alphabetical order.

Click Sort Diagram Element by Name

On the contrary, click Sort Diagram Element by Type button. As a result, the elements will be listed by type.

NOTE: The feature of sorting applies to the entire diagram tree instead of the selected node.

Reordering diagrams
Select the diagram(s) you want to reorder. If there are multiple diagrams you want to select, just click one while pressing Ctrl button and make the
other selection.
Click Move Selected Diagram Up button to move the selection upwards, or Move Selected Diagram Down button to move the selection downwards.

Filtering model elements
You can choose which model elements you want to be displayed or not on the diagram tree.

1. Right click on the diagram navigator's background and select Filter Model Element. Model Element Filtering Dialog will then be pop-up.

2. Select the types of model element(s) you want to be displayed by checking to the type. Otherwise, uncheck the one you don't want to be
displayed.

Model Element Filtering dialog box

NOTE: You can check Display model element types in-use to list only types of model elements used in project. The text box Filter enables you
to filter model element type base on the type name (e.g. enter class to list only class).

Showing/hiding carriage return character
If it is the case that the name of the diagram and diagram elements is in multi-line, the character &para; will be revealed.
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When Show Carriage Return Character is selected, line break will be shown.

Carriage return character is shown

When deselected, the character &para; is hidden.

If you want to hide it, uncheck Show Carriage Return Character and the character will automatically be unshown.

Grouping or ungrouping by category
As it is said before, default groups are automatically arranged by category
If you want to ungroup diagram, right click on the diagram navigator's background and uncheck  Group by Category, and then all diagram types will
be ungrouped.

Ungrouped diagrams

Connecting to server for team collaboration
Logizian's team collaboration support enables your team members work together on projects.
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To connect to server and perform related activities, right click on the diagram background, select Teamwork and the action you want to perform (e.g.
commit and update, etc) from the pop-up menu.

Perform teamwork

Displaying only diagram nodes but not diagram elements
If you only want the diagram nodes to be shown but not the diagram elements under them, just click on Show Diagram View button.

NOTE: This option applies to all diagram nodes, but not just the selected one.
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Model explorer
It would be much more efficient to make use of model explorer for your middle to large scale project which has considerable numbers of diagrams and
model elements, rather than using diagram navigator.

The Model Explorer

The toolbar

Name Icon Description

New Model Element To create a new model element.

Collapse To collapse the selected model element.

Expand  To expand the selected model element.

No Sorting To arrange model elements without grouping.

Sort By Name To sort model elements by their names in alphabetical order.

Sort By Type To sort model elements by their types.

Move Selected Model
Element

To move the selected model elements down or up.
This option only works within the same model element type when there are multiple model elements.

Refresh To update the content of model explorer

The description of icons on Model Explorer

Pop-up menu
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Pop-up menu of model explorer
The model explorer lists all the model elements in the project.

The pop-up menu of model explorer

Menu Title Description

Model Create a new model.

New Model Element... Create a new model element in model explorer without the need of creating through diagramming.

Filter Model Element... Open the Model Element Filtering Dialog to filter the diagram elements to appear in  diagram navigator .

Show Relationships Show relationship model elements in model explorer (default hidden).

Show Sub Diagrams Show sub-diagrams in model explorer so that user can browse and open sub-diagrams in model explorer.

Show Data Types Show data types in model explorer (default hidden).

Show Carriage Return
Character

Display line breaks of multi-lined diagram name as carriage return character.

Sorting Select the way to sort model elements in model explorer.

Teamwork Perform teamwork activities.

Manage Dependent Project... Add or remove dependent project.

Refresh Refresh model explorer content.

Collapse All Collapse all tree nodes.

Expand All Expand all tree nodes.

The description of icons on model explorer

Pop-up menu of project node
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The pop-up menu of project node

Menu Title Description

No View Model
Elements...

Select the model element(s) that you don't want it/ them to be shown on diagram navigator.

Rename... Rename the project.

Nicknames Configure or switch to another nickname.

Create Profile Create a package-like profile which can create profile diagram for modeling the stereotypes used in this project.

Model Create a new model.

New Model Element... Create a new model element in model explorer without creating through diagramming.

Sorting Select the way to sort model elements in model explorer.

Show Relationships Show relationship model elements in model explorer (default hidden).

Show Sub Diagrams Show sub-diagrams in model explorer so that user can browse and open sub-diagrams in model explorer.

Show Data Types Show data types in model explorer (default hidden).

Teamwork Perform teamwork activities.

Manage Dependent
Project...

Add or remove dependent project.

Refresh Refresh model explorer.

Collapse All Collapse the project node.

Expand All Expand the project node.

The description of pop-up menu of project node

Closing and opening the model explorer
Model Explorer is opened by default. To close it, press the X button at the top right corner. On the other hand, it can be opened by selecting View >
Panes > Model Explorer from the main menu.

Creating a model
A model is a package that can store model elements and diagrams. Users are recommended to structure project by using model in order to maintain a
clear structure for accessing project data and improve the application performance.
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Right click on the project node in Model Explorer and select  Model from the pop-up menu. You can either create a custom model by selecting New
Model..., or create a pre-defined model by selecting it in the list.

Select New Model in pop-up menu

Creating a model element
A model element is created when you create a shape on a diagram. If you want to create a model element without visualizing it, you can create it
through the Model Explorer.

To create a model element, right click on the root node, select  New Model Element... from the pop-up menu. You can select the model element type
and enter its name simultaneously in the New Model Element dialog box.

Select New Model Element in pop-up menu

Sorting model elements
In model explorer, model elements are listed under project node(s). You can sort model elements by their names, by their types (e.g. use case,
package, etc.) or without sorting.

To sort by name, click Sort by Name button. The elements will be listed by name, in alphabetical order.

Sort model elements by name

To sort by type, click Sort by Type button. As a result, the elements will be listed by type. To arrange model elements without sorting, click No sorting.

Reordering model elements
Select the model element(s) you want to reorder. If there are multiple model elements you want to select, just click one while pressing Ctrl button and
make the other selections.
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Click Move Selected Model Element Up button to move the selection upwards, or Move Selected Model Element Down button to move the
selection downwards.

NOTE: This option only works within the same model element type when there are multiple model elements.

Filtering model elements
You can choose which model elements you want to be displayed or not on the model explorer.

Right click on the model explorer's background and select Filter Model Element. In  Model Element Filtering Dialog, check the types of model
element(s) you want to be displayed. Otherwise, uncheck the one you don't want to be displayed.

Model Element Filtering Dialog

NOTE: Instead of displaying all types of model elements, checking Display model element types in-use to display the types of model elements
used in the project.

Showing/hiding carriage return character
If it is the case that the name of model elements is in multi-line, the character &para; will be revealed.

When Show Carriage Return Character is selected, line break will be shown.

Show Carriage Return Character is selected

When deselected, the character &para; is hidden.

If you want to hide it, right click on the model explorer's background and uncheck Show Carriage Return Character from the pop-up menu. As a
result, the character will automatically be unshown.

Connecting to server for team collaboration
Logizian's team collaboration support enables your team members work together on project(s).
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To connect to server and perform related activities, right click on the model explorer's background, select Teamwork and an option for performing from
the pop-up menu.

Perform teamwork
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Logical view
The logical view provides a hierarchical view of a project's structure.  With the logical view, users can create and customize the diagrams in their
project with meaningful categorization by adding domain specific view(s).

In addition, users can customize a default logical view for their preference, rather than re-creating a new logical view for every new project. The logical
view can be exported to xml files which can be used in other projects or distributed among the development team. Different views, thereby, can be
merged automatically through the teamwork server.

The Logical View

The toolbar

Name Icon Description

Collapse To collapse the selected diagram.

Expand To expand the selected diagram.

Refresh To update the content of logical view.

Set Logical View Structure as Default
 

To set default structure for logical view in all projects.

The description of icons on Logical view

Popup menu

Popup menu of logical view

The pop-up menu of Logical View

Menu Title Description

Show Carriage Return Character Display line breaks of multi-lined diagram name as carriage return character.

Teamwork Perform teamwork activities.

Manage Dependent Project... Add or remove dependent project.

Refresh Refresh Logical View content.

Collapse All Collapse all tree nodes.
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Expand All Expand all tree nodes.

Popup menu of project

The pop-up menu of project node in Logical View

Menu Title Description

Rename... Rename the project.

Add View Add a view under project.

New Diagram Create a diagram under root view.

Add Existing Diagram... Add an existing diagram under root view.

Import View from XML Import logical view configuration file.

Export View to XML Export logical view as configuration file.

Set Logical View Structure
as Default

Set the current view structure as default so that another project that will be created under the same workspace will
share the same structure.

Sort Child by Name Sort the views by name.

Teamwork Perform teamwork activities.

Collapse All Collapse the project node.

Expand All Expand the project node.

Popup menu of view

The pop-up menu of view in Logical View
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Menu Title Description

Add View Add a child view under the selected view.

New Diagram Create a diagram under the selected view.

Add Existing Diagram... Add an existing diagram under the selected view.

Sort Child by Name Sort the views/diagrams by name.

Collapse Collapse the selected view node.

Expand Expand the selected view node.

Rename... Rename the selected view.

Delete Delete the selected view.

Move Up Move the selected view upwards.

Move Down Move the selected view downwards.

Close and open the Logical view
Logical view is opened by default. To close it, press the X button at the top right corner. On the other hand, it can be opened by selecting View >
Panes > Logical View from the main menu.

Create a new view node
Right-click a root node on Logical View and select  Add View from the pop-up menu. 

Click Add View from the pop-up menu

Enter the name for the new view node in the  Input dialog box and then click OK button to confirm editing and close the dialog box. A new view node
is, therefore, created under the chosen node.

Created new view node
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Add diagram to view
After you create a few diagrams, right-click on a view node and select Add Existing Diagram... from the pop-up menu.

Select Add Existing Diagram... from the pop-up menu

In Select Diagrams Dialog, check the diagrams you would like to insert in the view node.

Check diagrams in Select Diagrams Dialog

Click  OK to confirm the selection.
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Create a new diagram
Right click the newly created view node, select New Diagram from the pop-up menu and select New Diagram... or a pre-defined diagram.

Select New Diagram... from the pop-up menu

A new diagram is, therefore, created under the view node.

Open a diagram
Double click on the diagram you want to view in the logical view.

Set Default View Structure
Logizian provides a feature where you can set the current logical view structure as default, therefore, you may save your time and do not have to re-
create the structure every time you create a new project.

Either click  Set Logical View Structure as Default button on the top of logical view or right click a root node to select  Set Logical View Structure as
Default.

Click Set Logical View Structure as Default button

In the pop-up Message dialog box, click OK button. The logical view structure in the new project will then follow the default style you have just
customized.
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Sort diagram by name
In  logical view, diagram are listed under diagram nodes by default. You can sort child diagrams by their names as well.
To sort by name, click Sort Child by Name button. The child diagrams will be listed by name, in alphabetical order.

Click Sort Child by Name

NOTE: The sort function applies to the entire logical view instead of the selected node.

Show/hide carriage return character
If it is the case that the name of the diagram is in multi-line, the character &para; will be revealed.

When Show Carriage Return Character is selected, line break will be shown.

To show carriage return character

When off, the character &para; is hidden.

If you want to hide it, uncheck Show Carriage Return Character and the character will automatically be unshown.

Export View Structure to XML
Logizian allows you to export the current logical view structure as an XML file and to re-use it again on other projects.



Logical view P. 50

Right click the root node and select Export View to XML from the pop-up menu.

Click Export View to XML from the pop-up menu

Find a location for exporting the project and enter its file name in Save dialog box. At last, click the Save.

Import View Structure from XML
Logizian also allows you to import the existing xml file in your new project.

Right click on the root node and select Import View to XML from the pop-up menu.

In Open dialog box, browse and select the xml file to be imported. You can choose one out of two following choices provided for importing a logical
view structure:

1. Append to existing structure: the imported structure will be added to the current structure without deleting the old one.

2. Replace existing structure: the new imported structure will replace the current structure. Therefore, the current structure will be removed.

Connect to server for team collaboration
Logizian's team collaboration support enables your team members work together on projects. To connect to server and perform related activities:

1. Right click on the logical view's background.

2. Select Teamwork and the action you want to perform from the pop-up menu.

Performce teamwork
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Property pane
Property pane is the location where the properties of a diagram, model element or shape are listed. With property pane, you can view and edit
properties directly.

The Property pane

The toolbar

Name Icon Description

Categorized View To sort all properties by their category.

Alphabetical View To sort all properties in ascending order base on their names.

Collapse To collapse all properties of each sub-item.

Expand To expand all properties of each sub-item.

The description of icons on property pane

Closing and opening the property pane
Property pane is opened by default. To close it, press the X button at the top right corner. On the other hand, it can be opened by selecting View >
Panes > Property from the main menu.

Viewing the properties
Click a shape that you would like to view its properties directly when the shape is shown on diagram pane. There are not only the properties of shapes,
but also the properties of diagrams in diagram navigator  and the properties of model elements in model explorer  that can be viewed in property pane.

Click a diagram on diagram navigator to view the properties of diagram while click a model element in model explorer  to view the properties of model
element.

Viewing the properties in shortcut
When a diagram, model element or shape is selected, its properties are shown on property pane. Meanwhile, you are allowed to view other properties,
which are in the same diagram, in shortcut by selecting the diagram, model element and shape from dropdown menu at the top of the property pane.

Select  Post Office Officer - Pool from drop-down menu
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Sorting the properties
In property pane, the properties of a diagram, model element and shape are listed. You can sort the properties by their category, or in ascending order.
To sort by the name of properties, click Alphabetical View button. All properties will be listed in ascending order base on their names.

Click Alphabetical Vie wbutton 

To sort by category, click Categorized View button. As a result, all properties will be listed by category.



Diagram overview P. 53

Diagram overview
Diagram overview is a pane where users can view and zoom in an active diagram directly and shortly. 

The Diagram overvi ew

Closing and opening the diagram overview
Diagram overview is opened by default. To close it, press the X button at the top right corner. On the other hand, you can open it by selecting View >
Panes > Diagram Overview from the main menu.

Viewing an active diagram
You can view an active diagram in diagram overview automatically. As the diagram is shown on the diagram pane, it can be viewed in diagram
overview.

An active diagram is shown on Diagram Overview

Viewing a particular part of diagram in shortcut
Viewing a large diagram is such an annoying task, especially you need to focus on a particular part of such diagram. The utmost important feature of
diagram overview is to navigate a particular part of diagram. As the purple rectangle which represents the visible area of diagram in diagram overview,
you can move the purple rectangle to the part of diagram you want to view.
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1. Press on the purple rectangle and drag it to the specific part of diagram you want to view.

Drag to the preferred part of diagram

2. As a result, the part of diagram will be subsequently shown on the diagram pane.

The particular part of diagram is shown on diagram pane

Zooming in a particular part of diagram
Drag the bottom right corner of purple rectangle to zoom in a particular part of diagram. The smaller you drag the purple rectangle, the more the
specific part of diagram will be magnified.

Drag the bottom right corner of purple rectangle
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On the contrary, the larger you drag the purple rectangle, the more the part of diagram will be dwindled.
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Documentation pane
Documentation pane enables you to document project data such as model elements, shapes or diagrams either in written or verbal form. For written
content, it can be a plain text or HTML text with formats like bold, italic, table, etc.

The Documentation pane

The toolbar

Name Icon Description

HTML It enables you to read and edit 3 different types of content. The 3 types of content include HTML, HTML Source and Plain
Text.
HTML: Read and edit the original content.
HTML Source: Read and edit the HTML source of content.
Plain Text: Read and edit content without formats.

Bold Set the highlighted text to bold.

Italic Set the highlighted text to italic.

Underline Underline the highlighted text.

Left Justify Set the alignment of highlighted text to left.

Center
Justify

Set the alignment of highlighted text to center.

Right Justify Set the alignment of highlighted text to right.

Ordered list Add a numbered list.

Un-ordered
list

Add a list with bullet points.

Font Select the font family of highlighted text.

Font size Select the size of highlighted text.

Font color Select the color of highlighted text.

Table Add a table. A few formats of insertion for rows and columns can be selected, including:  Insert Row Above, Insert Row
Below, Insert Column on Left and Insert Column on Right.
Insert Row Above: Insert a row above the row you selected.
Insert Row Below: Insert a row below the row you selected.
Insert Column on Left: Insert a column on the left of the column you selected.
Insert Column on Right: Insert a column on the right of the column you selected.

Background
color

Select the background color of highlighted text.

Clear
formats

Clear formats of whole editor to convert the content to plain text.

Link Add a hyperlink in a specific place of documentation pane.

Image Add an image in a specific place of documentation pane.
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Add Model
Element   

Add a model element in a specific place of documentation pane.

Save as
template...

Save the documentation as template.

Manage
Template...

Preview or delete a saved template.

Print Print the custom content.

The description of icons on documentation pane's toolbar

Close and open the Documentation pane
Documentation pane is opened by default. To close it, press the X button at the top right corner. On the other hand, you can open it by selecting View
> Panes > Documentation from the main menu.

Document project data in text
Documentation pane enables users to type in the textual description for project data, for instance, model elements, shapes and diagrams.

Define a glossary item
A word or lexis can be defined as a glossary item for explication.

1. Highlight the word or the lexis you would like to be defined and then right click on it. Select Add "..." to Glossary from the pop-up menu to
switch to Glossary Grid.

Select Add "premium plan" to Glossary from the pop-up menu

2. In Glossary Grid, you can right click on a term and select Open Term Editor from the pop-up menu in order to fill more details about the new
item. Altenatively, you can also click Open Term Editor button.

Click Open Term Editor button
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3. In Term Editor page, click Add button to type the alias for the new item.

Add an alias

4. Further information about the new item can be given by typing in the space under Definition.

Enter term definition

5. Finally, click OK to confirm editing. The window will then return to Glossary Grid.

6.
Moreover, you can insert as many new terms as you prefer. In Glossary Grid, click   to create another new term.

Check spelling
When you type an incorrect word carelessly,  documentation pane can offer you a help.

For correcting a word, right click on the incorrect word with a red curved line and select one out of the suggested words from the pop-up menu.

Select a correct word from the pop-up menu

Moreover, you can add a new word to the dictionary if the word you typed is a rare word or a newly created word. Right click the new word and select
Add to dictionary from the pop-up menu. When you type the word next time, it won't be marked as an incorrect word again.

Document a shape in voice
In addition to textual description, documentation pane also enables users to document for project data in verbal form.
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Click Record... button for recording voice.

Click  Record... button

In Record Voice dialog box, enter the name for the audio clip. Click Record button to start recording while click Stop button to terminate. Click OK
button if you want to save the voice recording; click Cancel button, and vice verse.

Record Voice dialog box

Name Icon Description

Record

 

Press it to start recording.

Play Press it to play the voice you recorded.

Stop

 

Press it to stop recording.

Clear

 

Press it to clear the voice you recorded.

The description of icons on Record Voice dialog box
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Stencil pane
Stencil pane is a library of custom shapes or images that can be used on diagrams. With stencil pane, users can create custom shapes and display
stencils by selecting stencils and drag them on diagram. Furthermore, stencils can be created in Shape Editor.

The Stencil pane

The toolbar

Name Icon Description

Add Stencil Select a stencil to create a new shape. Different sorts of stencil are categorized into two folders: Computers and Shapes and
a large amount of sub-folders are subdivided into these two folders.

Import Stencil... Import a stencil that created externally in Microsoft Visio to Logizian.

The description of icons on stencil pane

Closing and opening the stencil pane
Stencil pane is opened by default. To close it, press the X button at the top right corner. On the other hand, you can open it by selecting View > Panes
> Stencil from the main menu.

Creating a stencil
Instead of keeping the existing shapes, users can create a stencil to replace an existing one.

Click Add Stencil button on the toolbar of stencil pane and select a sub-folder from the pop-up menu.

Select Folders from the pop-up menu
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When the sub-folder is unfolded, press the preferred stencil and drag it on the diagram pane.

Drag a stencil on the diagram pane

Editing a stencil
A stencil can be customized in accordance with users' preference in Shape Editor.

Right click on the stencil pane's background and select Open Shape Editor from the pop-up menu.

Select Open Shape Editor from the pop-up menu

In Shape Editor dialog box, click New Shape button.

Click New Shape button

Press on the stencil you want to be edited and drag it on the diagram pane.
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Insert any shape(s) from the diagram toolbar with your preference and edit the format for the shape(s) in Format tab.

Format the selected stencil

Importing a stencil
The function of importing stencil enables you to import a stencil which is created in Microsoft Visio externally and send it to Logizian by making using of
the plug-in "VisioSendToVP". Note that you are able to execute this function only after you have installed Microsoft Visio and have sent a stencil from
Visio.
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Diagram Specification Dialog
You can customize the settings of each diagram you created in diagram specification dialog box. Those settings include: general diagram information,
grid setting, references, project management and comments. Diagram specification dialog box is similar with model element specification dialog box in
which you can also enter general information, add/ remove references, enter project management and add/ remove comments.

Opening diagram specification dialog box
1. Right click on the target diagram on Diagram Navigator and select Open [diagram name] Specification... from the pop-up menu.

Open a diagram's specification dialog box

2. As a result, the diagram specification dialog box prompts out.

The overview of diagram specification dialog box
A diagram specification dialog box consists of 5 tabs: General, Grid Setting, References, Project Management and Comments respectively. You may
notice that an icon named Maximum located at the right hand side of dialog box. We'll introduce it after giving you a brief on 5 tabs.

Diagram specification

General tab
You can specify diagram name, select zoom ratio and diagram background color, and enter documentation for the diagram. Furthermore, you can
record voice documentation for the diagram. You can set all shapes including existing and future shapes to be fit size automatically.

Grid Setting tab
You can visualize the grid of diagram background by checking Grid visible. Moreover, you can set the size and select the color for the grid of diagram
background.

References tab
You can add/ remove internal and external references for the diagram. Those references refer to file(s), folder(s), URL, diagram(s), shape(s), model
element(s) and A&sup3; resource(s).

Project Management tab
You can specify diagram process, priority, status, etc for project details.
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Comments tab
You can add/ remove comment(s) for the diagram.

Maximum tab

Click   to enlarge the specification dialog box to the maximum screen size. After that, click it again to reduce it to the default size.
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Perspective
There are four types of pre-defined perspectives in Logizian: Default, Drawing, Informative and Resource. With Logizian, you can not only apply the
pre-defined perspectives, but also customize your favorite perspective for executing tasks efficiently.

Saving your customized perspective
1. In your current perspective, select View > Save Perspective as... from the main menu.

2. In the Save Perspective As dialog box, enter name and description for the new perspective. Click OK button.

Enter name and description

Opening a perspective
1. Select View > Open Perspective > Others... from the main menu to a perspective.

2. Besides the pre-defined perspectives, your customized perspectives are listed in the Select Layout Perspective dialog box.

The Select Layout Perspective dialog box

3. Select a perspective under Name and click Open button.

Managing perspective
You can remove your customized perspective or even the pre-defined perspective(s) in the Layout Perspective Configure dialog box.

1. Select View > Manage Perspectives... from the main menu.
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2. In the pop-up Layout Perspective Configure dialog box, select a perspective you want to remove and then press Remove button. Click OK
button to confirm.

Remove a perspective
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Model element specification
In Logizian, you can open a model's specification dialog box to view and edit the model's details. The options, such as references, project management
and comments are categorized into tabs in the specification dialog box. Furthermore, three buttons attached on the right-hand side of dialog box are
Pin, Auto open specification when select and Maximum. Model specification dialog box is similar with diagram specification dialog box in which you
can also enter general information, add/ remove references, enter project management and add/ remove comments.

Opening a model's specification dialog box
Right click on the target model which you want to view or edit its details and select  Open Specification... from the pop-up menu.

Open specification dialog box

As a result, the model's specification dialog box pops out.

The Entity Specification dialog box

The overview of three buttons on model's specification dialog box

Pin
To pin the specification dialog box, press Pin button.

Press Pin button

NOTE: This button works in combination with Auto open specification when select.

Auto open specification when select
After you've pinned the specification dialog box, press this button. After all, you don't have to close the current dialog box in order to open another
model's specification box.
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1. Press Auto open specification when select button.

Press Auto open specification when select button

2. Select another model to view its specification dialog box by clicking on the target model.

Click data store

Maximum
Press this button to enlarge the specification dialog box to the maximum screen size.

Click Maximum button

After that, click it again to reduce it to the default size.
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Working with projects
This chapter introduces how to create and save project. You will also see how to create model and organize diagrams with model.

 

Creating project

This page shows you how to create a new project in Logizian.

 

Saving project

This page shows you  how to save a project.

 

Organizing diagrams by model explorer

You may create models in model explorer for organizing diagrams. This page tells you how to do this in detail.

 

Maintaining backups

Backup files will be saved from time to time. This page tells you more about backup, and how to retrieve works from backup files.

 

Manage project properties dialog

Edit project properties like project name, author, company and project description.

 

Switch to diagram

You can open another diagram by double clicking on a tree node in Diagram Navigator. An alternative way is to open the Switch to Diagram dialog box,
select diagram and click Activate Selected Diagram.
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Creating project
Logizian  stores information like model elements and diagrams in a project. Therefore, you need to create a project before performing modeling. To
create a new project, select menu File > New Project from the main menu. When the New Project dialog box pops out, click Create Blank Project
button to create a new project.

Create a new project from the main menu

Overview of New Project dialog box

An overview of New Project dialog box

Name Description

UML version UML version has no meaning for Logizian project, and can be ignored.

Project name Enter the name of project.

Author Enter the author of project.

Company Enter the company of project.

Project
description

Enter the project description. You can make use of the toolbar at the top of the description pane to add formatted content.

Description of New Project dialog box

http://www.visual-paradigm.com/product/lz/
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Saving project
Logizian  saves all project content to a single file, with file extension .vpp.

To save project, select File > Save Project from the main menu. If you are saving the first time, the Save Project dialog box will appear. You can save
a project to workspace, or any location in the machine. For details, read the sections below.

Saving project to workspace
To save project to workspace, select Save to workspace. Enter the file name and click OK to save.

Save project to workspace

Saving project to specified directory
To save project to a specified directory, select Save to directory, and then specify in the Directory field the directory for saving project. Enter the file
name and click OK to save.

Save project to a specified directory

http://www.visual-paradigm.com/product/lz/
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Organizing diagrams by model explorer
For small scale project, it would be easy to use Diagram Navigator to manage it. However, for middle to large scale project which has considerable
numbers of diagrams and model elements, it would be better to use Model Explorer to organize the project.

Logizian  loads diagrams and model elements only when they are used. For example, opening a diagram will load all its diagram elements, and
opening the specification dialog box of a model element will cause it (and the model elements it referenced) to be loaded. Besides, selecting a tree
node in the Model Explorer will cause the corresponding element(s) to be loaded as well.

For this reason, we recommend you to group diagrams using Model instead of laying them flat in the project. This can avoid accidentally loading
diagrams and model elements that you never use, and thus can speed up project loading and saving.

Creating model
To create a model, right click on the project node in Model Explorer and select  Model from the pop-up menu. You can create a custom model by
selecting New Model..., or create a pre-defined Model (e.g. As-is Process) by selecting it on the list.

Create a new model

http://www.visual-paradigm.com/product/lz/
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Creating diagram from model
To create a diagram from the model, right click on the model, select Sub Diagram > New Diagram... from the pop-up menu. Then, choose the diagram
type in the New Diagram window, give the diagram a name and confirm.

Create a diagram from model

NOTE: When you create a shape, its model element will be placed under the same model as diagram.

Moving diagrams between models
If you haven't organized project structure with model yet, you may want to do it now. You can move a diagram from root node into a model, or to
transfer a diagram from one model to another.

To move diagram from one model to another, right click on the target model in Model Explorer and select Sub Diagram > Existing Diagram... from
the pop-up menu.

Add existing diagram to model
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Select the diagrams you want to move in the Add Sub Diagrams dialog box and click OK.

  

Select a diagram to move

As a result, the selected diagrams will be moved to the target model.

NOTE: If you move a diagram which has the master view of model element(s), the model element(s) will be moved together with the diagram to
the new model.
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Maintaining backups
Backup is a copy of project file. The major advantage of backup is to allow you to recover your work, in case you have made some undesired
modification on your project. The backup file is usually put along with the project.

Backup is a default setting. After you save your project, it will be produced subsequently. The name of backup file is basically similar to the name of
project file, but an extra ~ and a number are appended to it.

Backup copy is produced

Setting the backup level
You can set the amount of backup copy for your own reference. Select Tools > Application Options... from the main menu.

In Application Options dialog box, click General and select a number from the drop-down menu of Backup level under Project tab. The number of
backup level represents the amount of backup copy that is produced after a project is saved.

Select the amount of backup level in Options dialog box
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Manage Project Properties window
In  Logizian , you can specify the project name, main author of project, your company's name and a description of your project (in rich text format).
With  Project Properties dialog box, you can edit and review your project properties. For your convenience, when you create another new project, all
the properties of previous project are set as default, except project name. However, you can modify those default properties in accordance with your
preference.

1. Open Project Properties dialog box by selecting File > Project Properties... from the main menu.

2. Enter project name, author, company and project description. Click OK button to confirm and close the dialog box. Note that you can enter
formatted text for project description.

http://www.visual-paradigm.com/product/lz/
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Switch to Diagram
After you've opened a few diagrams, you can switch to your target diagram easily with the feature of Switch to Diagram. Moreover, you can close
diagram(s) with this feature as well.

1. After you've opened a few diagrams, select Window > Switch to Diagram... from the main menu.

NOTE: Alternatively, you can right click on any diagram tab and select Switch to Diagram... from the pop-up menu.

2. In the Switch to Diagram dialog box, you can select a diagram to activate or select a diagram to close. To activate a diagram, select a diagram
under Diagram Name and then click Activate Selected Diagram button.

Select a diagram to activate

On the other hand, select a diagram under Diagram Name and then click Close Selected Diagram(s) button to close the selected diagram.
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Business process diagram
This chapter briefly talks about how to create a business process diagram, with description to most of the common notations, about their usage and tips
when creating or editing them.

 

Creating business process diagram

Shows you how to create a business process diagram as well as to update the format of ID.

 

Pool and lane

Pool and lane are used to model roles in a process. This part will cover some of the common operations with pool and lane, such as to change their
orientation, to define a black box and to move lanes up and down, left and right (depending on the orientation of pool).

 

Task and sub-process

Task and sub-process are used to model the activity needed to do in a process. This part will cover the use of marker, a description of various types of
task, how to define working procedure for task and how to create a sub-process.

 

Event

An event in a business process refers to something that happens and affects the flow of process. This part will description the various types of start,
intermediate and end event.

 

Gateway

Gateway is a kind of flow objects which is used to direct sequence flows within a process, base on certain condition(s). There are several kinds of
gateway for different kinds of control behavior. We will go through each of them in detail.

 

Sequence and message flow

There are two types of connectors for modeling flows in a process - Sequence flow and Message flow. You will see how to correct invalid flow, and how
to visualize message that pass between pools.

 

Choreography task and sub-process

A choreography is a type of process which defines the sequence of interaction between participant. You will learn how to set participants to
choreography task and sub-process.

 

Data object

You can use data objects to model data within process flow. You will learn how to define states for data object.
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Creating business process diagram
Business Process Modeling Notation (BPMN) is a graphical representation for designing and modeling business processes visually. It is a standard for
business process modeling, and provides a graphical notation for specifying business processes in a business process diagram (BPD).

A sample business process diagram

Creating business process diagram
When you create a new project in Logizian, a blank business process diagram named Business Process Diagram1 will be created as a default diagram
for process modeling. If you want to create a diagram yourself:

• Click on Business on toolbar and select Business Process Diagram from the drop down menu .

• Right click on Business Process Diagram   in Diagram Navigator, under the Business Modeling category, and select New  Business
Process Diagram from the popup menu.

• Select File > New Diagram > Business Modeling >  Business Process Diagram from the main menu.

Assigning IDs to model elements
It is possible to assign IDs to objects in business process diagram. By default, IDs are assigned by following the order of object creation, starting from
number 1. However, you can define the format, or to enter an ID manually.

Defining the format of ID
To define the format of ID, open the Options dialog box by selecting Tools > Project Options from the main menu. Select Diagramming from the
list on the left hand side, and open the Business Process tab. From there you can adjust the format, and control whether or not to display the ID on
diagram, and the position of ID.

Defining format of ID
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Below is a description of options.

Option Description

Prefix Text to add before the number

Num of digits The number of digits of the number. For example, when digit is 3, ID "1" will become "001"

Suffix Text to append to the number

Show ID
option

Whether or not to show ID on diagram, and whether to show it as label that attach to a shape, or as text below caption

Options for formatting ID

Showing ID on diagram
By default, ID is just a text property that won't appear on diagram. However, you can make it appear either near or within a shape.

Different looks of a task when ID is not shown, ID is shown as label and ID is shown below caption

To configure how to show ID (or not to show ID), you can either set the global option (refer to the previous section), or set it through diagram's option
by right clicking on the business process diagram, selecting Presentation Options >Configure Show ID Options from the popup menu.

To show ID on a diagram
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In the Configure Show ID Options dialog box, click on the drop down menu Show ID Options and select if you want to show IDs, and if yes, where to
show - below caption or as a label.

To configure the whether or not to show ID

If you selected to show as label, you can adjust in further the position of ID, relative to the shape (e.g. Top right of task) and the rotation.

To make ID of task show as label, position at the left of shape

ID assignment
There are several ways that you can assign an ID to an element, including:

• Through the specification dialog box (Right click on it and select Open Specification... from the popup menu)

• Through the ID label (available only when ID is shown as label on diagram)

• Through the Property Pane

Nested ID
When you draw something in a lane/pool, or to drill down a sub-process into another level and draw something, this forms a nested element hierarchy
such like a task is contained by its parent pool. ID is formed nested according to the hierarchy. For instance, while a pool has '3' as ID, its children have
3.1, 3.2... as IDs. You can turn this function on and off.

To turn on or off, right click on a BPD and select Diagram Content > Edit IDs... from the popup menu. At the bottom of the dialog box, check or
uncheck the option Sub-Level ID.

Showing process statistic
Process statistic refers to the results of the statistical analysis that can be conducted upon your process. There are three types of figures: number of
message flows, total process-costs and the total processing hours.

To show process statistic:

1. Right click on the background of the business process diagram.
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2. Select Utilities > Show Statistic... from the popup menu. This opens the Statistic window, like this:

Process statistic

Below is a description of figures.

Figure Description

Number of Message Flows The number of message flows that exist in the current diagram.

Total process-costs A summation of costs specified for tasks and sub-processes in the current diagram.

Total processing hours A summation of duration specified for tasks and sub-processes in the current diagram.

Description of figures in process statistic
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Pool and lane
A pool represents a participant who takes part in a process. It is visually a rectangular box that can contain flow objects like task and activity.  A lane is 
a sub-partition in a pool. It is often used to represent internal roles or a department under the role represented by pool.

Horizontal pool that contains two lanes

Orientation of pool and lane
In a business process diagram, pool and lane can show either vertically or horizontally. There is no restriction to the orientation of pool. You can
choose an orientation that gives the best layout to your design. To change the orientation of pool and contained lane, right click on the pool header and
select Orientation > Vertical/Horizontal from the pop-up menu.

Changing the orientation of pool from vertical to horizontal

NOTE: You can only change the orientation of pool/lane when it contains no flow object.
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Defining black box pool
A pool can be shown as an empty box, called a black box. A black box represents a role solely, with all details hidden - You cannot create flow objects
in it. To define a black box pool, right click on an empty pool and select Black Box from the popup menu.

Defining a black box

NOTE: You can only create a black box for an empty pool that has neither flow objects nor lanes in it.

You can create message flows between black boxes to represent the collaboration between participants, or create message flows between flow objects
in another pool/lane with and a black box.

Black boxes with message flows in between

Stretching of pool
When you create a pool, it is automatically expanded to fit the width or length of diagram. We call this behavior stretched. When a pool is stretched,
the pool and the contained lane(s) will expand or collapse following the size of diagram, and you cannot resize it manually. If you want to make a pool
freely resize-able, you need to turn the stretch behavior off. To change the stretch option, right click on the pool involved and select Presentation
Options > Auto Stretch > Off from the popup menu.

Pool can be resized freely when auto-stretch is turned off
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Creating nested lanes
While a lane represents a sub-partition of a pool, a lane itself can contain lanes, to form a nested structure. To create a nested lane, right click on a
lane and select Add Child Lane from the pop-up menu.

Nested lanes

Reordering lane
You can change the position of lanes within a pool by moving them up and down. To reorder a lane, right click on the lane you want to reorder and
select Selection > Move Down from the pop-up menu.

Moving a lane downward
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Task and sub-process
A business process is mainly formed by activities that need to be performed to complete the process. There are two kinds of activities - task and sub-
process. A task is an atomic activity which represents work that cannot be broken down. On the contrary, sub-process represents work that can be
broken down to a finer level of detail.

Task and sub-process

Task markers
You can assign markers to task. There are three markers: Loop, Multi-Instance, Compensation. A task can have one or two of these markers.
Assignment of markers is done through the specification dialog box of task.

NameRepresentation Description

Loop This marker indicates that the task will loop as long as the condition that defined in the loop is true. The condition is evaluated in each iteration, at either the beginning or the end of iteration. This marker can be used in combination with the compensation marker.

Multi-
instance
(parallel
instances)

This marker indicates the execution of task in a desired number of instances, or in a data driven approach. The instances will be started at the same time.

Multi-
instance
(sequential
instances)

This marker indicates the execution of task in a desired number of instances, or in a data driven approach. The instances will be executed one after the other.

CompensationTo undo (cancel) the result of another activity that were already successfully completed. The execution of compensation task is due to the undesired results and possibily side effects produced by antoher activity, that need to be reversed.
 

A compensation task is performed by a compensation handler, which performs the steps necessary to reverse the effects of an activity.

Different markers of task

Adding a Loop marker
1. Right click on a task and select Open Specification... from the popup menu.

2. Select Standard Loop for Loop type. Click OK to confirm the changes.

NOTE: You can click on the ... button next to Loop type to set the loop condition, counter and the maximum number of iteration.

Adding a Multi-instance marker
1. Right click on a task and select Open Specification... from the popup menu.

2. Select Multi-Instance Loop for Loop type. Click OK to confirm the changes.

NOTE: You can click on the ... button next to Loop type to set the ordering of loop, either parallel or sequential.

Adding a Compensation marker
1. Right click on a task and select Open Specification... from the popup menu.

2. Check Compensation at the bottom of specification and click OK to confirm the changes.
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Task types
There are several types of task for you to separate the behavior of different tasks. You can set a type by right clicking on a task and selecting Type,
then the type from the popup menu.

Name Representation Description

Service A service task is a task that uses some sort of service, e.g. a Web service.

Send A send task is a task that sends a message to an external participat. The task is said to be completed once the message has
been sent.

Receive A receive task is a task that waits for a message to arrive from an external participant. The task is said to be completed once the
message has been received.

User A user task is a task performed by a human with the assistance of a software application.

Manual A manual task is a task that is performed without the aid of any business process execution engine.

Business
Rule

A business rule task let the process to provide input to a business rules engine, and to get the output from engine.

Script A script task involve a script defined by modeler or implementer in a language that a business process engine can understand,
and is executed by a business process engine.

Reference A reference task refers to anthoer task for its content.

Types of tasks

Sub-process markers
You can assign markers to sub-process. There are four markers: Loop, Multi-Instance, Ad-hoc and Compensation. A sub-process can have up to three
markers, excluding the marker for collapsed: A loop/multi-instance marker, a Ad-hoc marker, and a Compensation marker. Assignment of markers is
done through the specification dialog box of sub-process.

NameRepresentation Description

Loop This marker indicates that the sub-process will loop as long as the condition that defined in the loop is true. The condition is evaluated in each iteration, at either the beginning or the end of iteration. This marker can be used in combination with the ad-hoc and/or compensation
marker.

Multi-
instance
(parallel
instances)

This marker indicates the execution of sub-process in a desired number of instances, or in a data driven approach. The instances will be started at the same time.

Multi-
instance
(sequential
instances)

This marker indicates the execution of sub-process in a desired number of instances, or in a data driven approach. The instances will be executed one after the other.

Ad-hoc This marker indicates that a sub-process is a group of activities that have no required sequence relationships. The sequence and number of performances for activities are determined by the performers of the activities.

CompensationTo undo (cancel) the result of another activity that were already successfully completed. The execution of compensation sub-process is due to the undesired results and possibily side effects produced by antoher activity, that need to be reversed.
 

A compensation sub-process is performed by a compensation handler, which performs the steps necessary to reverse the effects of an activity.

Different markers of sub-process

Adding a Loop marker
1. Right click on a sub-process and select Open Specification... from the popup menu.
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2. Select Standard Loop for Loop type. Click OK to confirm the changes.

NOTE: You can click on the ... button next to Loop type to set the loop condition, counter and the maximum number of iteration.

Adding a Multi-instance marker
1. Right click on a sub-process and select Open Specification... from the popup menu.

2. Select Multi-Instance Loop for Loop type. Click OK to confirm the changes.

NOTE: You can click on the ... button next to Loop type to set the ordering of loop, either parallel or sequential.

Adding an Ad-hoc marker
1. Right click on a sub-process and select Open Specification... from the popup menu.

2. Make sure the type of sub-process is set to be Embedded Sub-Process. Check Ad-hoc in the Details section and click OK to confirm the
changes.

Adding a Compensation marker
1. Right click on a sub-process and select Open Specification... from the popup menu.

2. Check Compensation at the bottom of specification and click OK to confirm the changes.

Sub-process types
There are several types of sub-process for you to separate the behavior of different sub-processes. You can set a type by right clicking on a sub-
process and selecting Type, then the type from the popup menu.

Name Representation Description

Embedded An embedded sub-process is a sub-process that models its internal details in another process.

Reusable A reusable sub-process calls a pre-defined process.

Reference A reference sub-process refers to anthoer sub-process.

Types of tasks

Breaking down a sub-process
A sub-process can be opened up to model the detail in a lower level. To open up a sub-process, click on the plus marker in sub-process and select
New Business Process Diagram. This will create a new business process diagram that belongs to the sub-process.

To break down a sub-process

NOTE: Once a sub-process diagram is created, its detail will be shown as the sub-process shape as a thumbnail of the diagram. To hide the
thumbnail, click on the minus marker at the bottom of sub-process to turn it off.
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Re-using elements from parent diagram
In the sub-process diagram, you can re-use pools, lanes and flow objects that appear in the parent diagram. To do this, right click on the sub-process
diagram and select Add Pools/Lanes/Sub-Processes/Gateways from Parent Diagram... from the popup menu, and choose the element to reuse.
Elements being re-used will have dog ear appear at their corners.

A sub-process diagram with a lane reused from parent diagram

You can jump from a re-used element back to the parent diagram through the resource-centric interface.

Jump to parent diagram

Defining procedure of activity
An activity within a process represents work need to be done. Each activity can be formed by a number of steps. For example, a task Process
Application involve 2 steps - validate application, confirm application. To document the steps of an activity, you can make use of the procedure editor.

Procedure of a task

An overview of procedure editor
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An overview of procedure editor

No. Name Description

1 Collapse/Expand Click on the triangle on the left hand side to maximize the editor. On the contrary, click on the inverted triangle to minimize the
editor.

2 Procedure
selector

You can define multiple set of procedure per activity. Click on this drop down menu to select the one you want to read/edit.

4 Step Click on this button to create a step under the step selected in editor.

5 Font formats
selector

There are three buttons. The first one increases the font size for one level, while the second one decreases the font size for
one level. The third button resets the font size setting to default.

6 Font size setting
selector

Click on this drop-down menu to select the sizes of highlighted text. Press Grow Font button to increase the font size for one
level, while press Shrink Font button to decrease the font size for one level. Press Default Font button reset the font size
setting to default. Moreover, you can adjust the font size for the highlighted text manually by slider.

7 Reorder step Click on Move Up button to move the selected step upward while Move Down button to move the selected step downward.

8 Decrease Indent/
Increase Indent

Click on Decrease Indent button to reduce the indentation of the selected step while click on Increase Indent button to
indent the selected step.

9 Undo/ Redo Click on  Undo button to revert change while click on Redo button to redo reverted change.

10 Close editor Click on this button to close the editor.

11 Steps editor The place where you can read and edit steps.

Description of procedure editor

Show/Hide procedure editor
The procedure editor is opened in business process diagram by default. To hide it, right click on the background of business process diagram and
deselect Show Procedure Editor from the popup menu. You can select the same menu to show it when hidden.

NOTE: Alternatively, you can close the editor by clicking on the cross button at the top right corner of editor panel.

Documenting the procedure
1. Select the task or sub-process that you want to document its procedure.

2. Click on the first row labelled 1 and enter the first step.

3. Press Enter to go to the next step. You can create a sub-step by pressing Tab on a step. Pressing Shift-Tab decreases the indentation of a
sub-step. Repeat step 2 and 3 to enter the remaining steps the activity involve.
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Event
An event in a business process refers to something that happens and affects the flow of process. There are three types of events: Start, intermediate
and end.

Start, intermediate and end events with different kinds of triggers and results

Start event
A start event indicates the place where and possibly why a process start. Since start event is used for initiating a process, it does not have any
incoming sequence flow.

You can define a trigger for start event, to show the condition(s) that will cause a process to initiate.

Trigger

name

Representation Description

None The none start event does not have a defined trigger.

Message This trigger starts the process by receiving a message from a participant.

Timer This trigger starts the process in a specific time-date or a specific cycle (e.g. every Friday).

Error This trigger starts an in-line event sub-process when an error occurs. Note that this trigger can only be used with an event-sub-
process.

Escalation This trigger starts or not to start an in-line event sub-process when the constraint specified is not satisfied. Note that this trigger
can only be used with an event-sub-process.

Compensation This trigger starts an in-line event sub-process when an compensation occurs, which require undoing some steps. Note that
this trigger can only be used with an event-sub-process.

Conditional This trigger starts the process when a specific condition become true.

Signal This trigger starts the process when a signal broadcasted from another process has arrived. Note that signal is different from
message, which has a specific target for message.

Multiple This means that there are multiple triggers of the process. Any one of them can cause the process to start.

Parallel
Multiple

This means that there are multiple triggers of the process. All of the triggers must be triggered in order to start the process.

Link This trigger provide a mean to connect the end result of one process to the start of another.

Different types of start event trigger
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Defining a trigger
To define a trigger on an event, right click on the event and select Trigger, then the type of trigger from the popup menu.

To define a start event trigger

If you want to edit the properties of the trigger, such as the condition of a conditional trigger, right click on the event and select Open Specification...
from the popup menu. Then, click on the ... button next to the drop down menu of Trigger to edit its properties in the popup dialog box.

Interrupting or Non-interrupting event sub-process
Start event can be attached to the border of an event sub-process, to initiate the sub-process inline. You can define this kind of trigger as either
interrupting or non-interrupting, which means to interrupt its containing process or not to interrupt its containing process respectively. To set a trigger to
be Interrupting or Non-Interrupting, right click on the event and select/de-select Triggers > Interrupting from the popup menu.

Interrupting (left) and Non-Interrupting (right) events

NOTE: Only triggers that can be attached to event sub-process can set as interrupting/non-interrupting. The supported trigger types include:
Message, Timer, Escalation, Error, Cancel, Compensation, Conditional, Signal, Multiple, and Parallel Multiple.
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Intermediate event
An intermediate event indicates where something happens in between the start and end event of a process. You can use an intermediate event to
show where messages are received or sent, show the necessary delay, perform exception handling and show the need of compensation. You can
place an intermediate even in two places: Attaching the boundary of task/sub-process, Normal flow (i.e. connected from a flow without attaching to an
activity).

Trigger

name

Representation Description

None The none intermediate event does not have a defined trigger. It is used to indicate change of state in the process. You can only
use a none intermediate event in a normal flow.

Message This trigger represents either a send or receive of message

Timer This trigger acts as a delay mechanism on a specific date-time or cycle (e.g. every Friday). You can only use a timer intermediate
event in a normal flow.

Error This trigger reacts to a named error, or to any error if no name is specified.

Escalation The trigger indicates where an escalation is raised. You can only use an escalation intermediate event in a normal flow.

Cancel This trigger will be fired when a cancel end event is reached within the transaction sub-process. It also shall be triggered if a
Transaction Protocol "Cancel" message has been received while the Transaction is being performed.

Compensation The trigger indicates the need of compensation.

Conditional The event will be triggered when the condition specified become true.

Link This trigger is used for linking two sections of a process. You can use it to mode a looping of flow or to avoid having long sequence
flow connectors appear on diagram. You can only use a link intermediate event in a normal flow.

Signal This trigger indicates the sending or receiving of signals, which is for general communication within and across process levels,
across pools, and between business process diagrams.

Multiple This means that there are multiple triggers defined. Any one of them can cause the event to be triggered.

Parallel
Multiple

This means that there are multiple triggers defined. All of the triggers must be triggered in order to trigger the multiple event.

Different types of start event trigger

Defining a trigger
To define a trigger on an event, right click on the event and select Trigger, then the type of trigger from the popup menu.

To define a intermediate event trigger

If you want to edit the properties of the trigger, such as the condition of a conditional trigger, right click on the event and select Open Specification...
from the popup menu. Then, click on the ... button next to the drop down menu of Trigger to edit its properties in the popup dialog box.
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Throw and catch
You can set an event to be catch or throw. Catch means to react to a trigger, while throw means to create a trigger. To set, right click on an event and
select Trigger, then either Catching or Throwing from the popup menu.

A catch event (left) and a throw event (right)

NOTE: The trigger types that can set as throw/catch include: Message, Escalation, Compensation, Link, Signal, and Multiple.

Interrupting or Non-interrupting event
Intermediate event can be attached to the border of an activity. You can set an event to interrupt or not to interrupt the activity to which it is attached.
To set a trigger to be Interrupting or Non-Interrupting, right click on the event and select/de-select Triggers > Interrupting from the popup menu.

Interrupting (left) and Non-Interrupting (right) events

NOTE: Only triggers that can be attached to event sub-process can set as interrupting/non-interrupting. The supported trigger types include:
Message, Timer, Escalation, Conditional, Signal, Multiple, and Parallel Multiple.

End event
As an opposite of start event, end event indicates where a process will end. Since end event is used for terminating a process, it does not have any
outgoing sequence flow.

You can define a result for end event, to show what will happen when reaching the end.

Trigger

name

Representation Description

None The none end event does not have a defined result.

Message This result ends the process by sending a message to a participant.

Error This result indicates the generation of a named error when the process ends.

Escalation This result indicates the trigger of escalation when the process ends.

Cancel This result indicates that the transaction should be cancelled.

Compensation This result indicates the need of compensation, which require undoing some steps.

Signal This result indicates that a signal will be broadcasted when the process ends. Note that signal is different from message, which
has a specific target for message.

Terminal This result indicates that all activities in the process should be immediately ended.

Multiple This result indicates that there are multiple consequences of ending the process.

Link This result provide a mean to connect the end result of one process to the start of another.

Different types of end event result
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Defining a result
To define a result on an event, right click on the event and select Result, then the type of result from the popup menu.

To define an end event result

If you want to edit the properties of the result, such as the message produced by a message result, right click on the event and select Open
Specification... from the popup menu. Then, click on the ... button next to the drop down menu of Result to edit its properties in the popup dialog box.



Gateway P. 96

Gateway
Gateway is a kind of flow objects which is used to direct sequence flows within a process, base on certain condition(s). It acts like a gate that either
allow or disallow passage, and possibly to control the selection of outgoing flow that pass through the gateway.

A typical use of gateway - for modeling a situation of decision making

Gateway types
There are several kinds of gateway for different kinds of control behavior, such as making decision, branching, merging, forking and joining.

Gateway type Representation Description

Exclusive

 or 

An exclusive gateway can be used to model alternative paths within a flow. It is where
the diversion take place.

Event-based An event-based gateway can be used to model the alternative paths that follow the
gateway are based on events that occur instead of the expression of flow.

Inclusive An inclusive gateway can be used to model alternative and parallel paths within a
process. Unlike exclusive gateway, all condition expressions are evaluated. All the
outgoing paths that gives a possitive result of evaluation will be taken.

Complex A complex gateway can be used to model complex synchronization behavior.

Parallel A parallel gateway can be used to create and join parallel flows. It creates the paths
without checking any conditions.

Different types of gateway

Showing internal indicator "X" for exclusive gateway
You can optionally show the letter "X" inside the shape of exclusive gateway to distinguish it from other gateways (see the table above). To do this,
right click on the background of business process diagram and select Presentation Options > Gateway Display Options > Data-Based gateway
Markers Visible from the popup menu.
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Sequence and message flow
There are two types of connectors for modeling flows in a process - Sequence flow and Message flow. A sequence flow is used to connect flow objects
in a process or a choreography, to show the flow. Message flow is used to show the flow of messages between separate pools/lanes. You cannot use
message flow to connect flow objects within the same participant.

Sequence and message flows can be used to connect flow objects

Correcting invalid flow
As mentioned before, you can use sequence flow to connect flow objects within a participant, and use message flow to connect flow objects in
separate participants. If you attempt to use a type of flow incorrectly, like to connect flow objects within participant with message flow, you will be
prompt to correct your flow.

Invalid connector is detected

There are several actions you can perform. First, you can correct your invalid flow by changing its type, like to change from message to sequence flow.
If the connector should not be there, you may select to delete it. If you really want to keep the invalid connector, choose Ignore all at the bottom of
dialog box. Click OK to confirm.

Possible actions of handling invalid connector - Correct it or delete it
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Modeling and visualizing message pass by message flow
You can define a message that pass by message flow, and visualize it.

A sample BPD with messages

To do this:

1. Right click on the message flow that you want to model its message, and select Open Specification... from the popup menu.

2. Click on the drop down menu of Message and select Create Message (Business Process) from the popup menu.

Create a message

3. Name the message in the Message specification and click OK to confirm.

4. You should see the message added appear in the drop down menu of Mesasge. Click OK to confirm the change and go back to diagram.

5. Although the message is defined, you still need to visualize it. To visualize the message, right click on the diagram background and select
Presentation Options > Message Flow Display Option > Show Message of Message Flow from the popup menu, then select the way of
visualzing the message.

Ways of showing message (from left to right) - Do Not Show, Associated with Message Flow, Overlapping Message Flow
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Choreography task and sub-process
A choreography is a type of process which defines the sequence of interaction between participant. Unlike a standard BPMN process, which defines
the flow of activities in a process. Choreography does not belong to any pool. It exist outside or in between pools, and shows the messages that pass
between pools.

Choreography task
A choreography task is an atomic activity which represents an interaction among participants (pools), and consists of one or more messages that
exchange between the pools. A choreography shape is formed by multiple parts. We call them bands. The name of choreography task and each of the
participants are all displayed in different bands.

Setting participants and initiating participant
1. Right click on the choreography task and select Open Specification... from the popup menu.

2. In the specification dialog box, choose the pools for participant 1 and 2.

3. Select the pool which starts the interaction from the drop down menu of Initiating participant.

Selecting initiating pool

4. Click OK to confirm editing and go back to diagram.

Choreography task

Choreography sub-process
A choreography sub-process is a compound activity in that it has detail that is defined as a flow of other activities.

Setting participants and initiating participant
1. Right click on the choreography sub-process and select Open Specification... from the popup menu.

2. In the specification dialog box, open the Participants tab.

3. Select the pools the choreography sub-process involve and click > to assign them.
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4. Check the initiating pool.

Selecting initiating participant

5. Click OK to confirm editing and go back to diagram.

Choreography sub-process
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Data object
You can use data objects to model data within process flow. Typical examples of data object include purchase order, receipt, e-mail, delivery notice,
etc.

Defining state
You can optionally record the state of data object. For example, the data object Order has states created, submitted and processed. To define state:

1. Right click on data object and select State > Create... from the popup menu.

To create a state

2. In the Create State dialog box, enter the name of state and click OK to confirm.

NOTE: State is a view based option. You may copy a data object, paste as a new view, and set the state to the new view. This enables you to
show the change of state of a data throughout a process flow.
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Conversation diagram
Conversation diagram gives you a high level understanding to the relationships between pools under the domain being modeled. This chapter teaches
you how to create a conversation diagram.

 

Creating conversation diagram

This page teaches you how to create a conversation diagram through the diagram navigator.
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Creating conversation diagram
Conversation diagram gives you a high level understanding to the relationships between pools under the domain being modeled.

A sample conversation diagram

Creating conversation diagram
• Click on Business on toolbar and select Conversation Diagram from the drop down menu .

• Right click on Conversation Diagram   in Diagram Navigator, under the Business Modeling category, and select New  Conversation 
Diagram from the popup menu.

• Select File > New Diagram > Business Modeling >  Conversation  Diagram from the main menu.
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Data flow diagram
Data flow diagram is a well known approach to visualize the data processing in business analysis field. This chapters teaches you how to create a data
flow diagram.

 

Creating data flow diagram

There is a list of supported notations in data flow diagram. You will also see how to decompose a process.
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Creating data flow diagram
Data flow diagram is a well known approach to visualize the data processing in business analysis field. A data flow diagram is strong in illustrating the
relationship of processes, data stores and external entities in business information system.

A sample data flow diagram

Creating data flow diagram
• Click on Business on toolbar and select Data Flow Diagram from the drop down menu .

• Right click on Data Flow Diagram   in Diagram Navigator, under the Business Modeling category, and select New  Data Flow Diagram from
the popup menu.

• Select File > New Diagram > Business Modeling >  Data Flow Diagram from the main menu.

</h2>

Notations

Name Representation Description

Process A process takes data as input, execute some steps and produce data as output.

External Entity Objects outside the system being modeled, and interact with processes in system.

Data Store Files or storage of data that store data input and output from process.

Data Flow The flow of data from process to process.

Bidirectional Data Flow The flow of data that flow both from and to process.

A list of supported notations in data flow diagram

Decomposing a process
You can create multiple data flow diagrams for different levels of detail. A new level can be decompose from a process in diagram. To decompose a
process, right click on the process and select Decompose from the popup menu.

Decompose process
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You will be asked whether to add related data stores and external entities to the new data flow diagram. If you choose Yes, those connected data
stores and external entities will be copied to the new diagram.

Choose whether to add related model elements to diagram
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Event-driven process chain diagram
EPC diagram, short for event-driven process chain diagram, is a flowchart based diagram that can be used for resource planning and identifying
possible improvements of a business process. This chapters teaches you how to create a EPC diagram.

 

Creating event-driven process chain (EPC) diagram

This page teaches you how to create a EPC diagram through the diagram navigator. There is a list of supported notations in EPC diagram.
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Creating event-driven process chain (EPC) diagram
EPC diagram, short for event-driven process chain diagram, is a flowchart based diagram that can be used for resource planning and identifying
possible improvements of a business process.

A sample EPC diagram

Creating EPC diagram
• Click on Business on toolbar and select EPC Diagram from the drop down menu .

• Right click on EPC Diagram   in Diagram Navigator, under the Business Modeling category, and select New  EPC Diagram  from the popup
menu.

• Select File > New Diagram > Business Modeling >  EPC Diagram  from the main menu.

</h2>

Notations

Name Representation Description

Event An event describes what circumstances a function or a process works or which state a function or process results
in.

Function A function describes the transformations from an initial state to a resulting state.

Operator

 or

or 

And - An and operation corresponds to activating all paths in the control flow concurrently.

Or - An or operator corresponds to activating one or more paths among control flows.

XOR - An XOR operator corresponds to making decision of which path to choose among several control flows.

Organization unit An organization unit determines which person or organization within the structure of an enterprise is responsible
for a specific function.

Control flow A control flow connects events with function, process paths, or operators creating chronological sequence and
logical interdependencies between them.

Process path A process path shows the connection from or to other processes.

Organiztion unit
assignment

An organization unit assignment show the connection between an organization unit and the function it is
responsible for.

Information
resource

An information resource portrays objects in the real world that can be input data serving as the basic of a function,
or output data produced by a function.

Information flow Information flows show the connection between functions and input or output data, upon which the function reads
changes or writes.

A list of supported notations in EPC diagram

Applying stereotype to EPC elements
A stereotype defines how a model element may be extended, and enables the use of platform or domain specific terminology or notation in place of,
or in addition to, the ones used for the extended metaclass. You can apply one or more stereotypes to model elements, and decide whether or not to
visualize the stereotype or tagged values in views. To apply stereotype to model element:
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1. Right click on the model element, or the view of the model element that you want to apply stereotype to. Select Stereotypes > Stereotypes...
from the pop-up menu. As a side note for you, once you have ever applied a stereotype on the selected kind of element, you can re-select the
same stereotype in this popup menu.

Opening Stereotypes page

2. In the Stereotypes page of the element specification, click on Edit Stereotypes... .

Editing stereotypes
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3. In the Configure Stereotypes dialog box, click Add....

Adding stereotype

4. In the Stereotype specification dialog box, enter the name of stereotype and click OK.

Naming stereotype
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5. This goes back to the specification dialog box. Select the stereotype you want to apply, then click > to assign it to the Selected list.

Selecting stereotype

NOTE: You can also double click on a stereotype to apply it.

NOTE: While clicking on > applies the selected stereotype to model element, you can click < to remove a stereotype selected in Selected list.

If you want to apply all available stereotypes to model element, click >>, and likewise, clicking on << removes all the applied stereotypes.

6. Click OK to confirm. The stereotype will then be shown within a pair of guillemets above the name of the model element. If multiple stereotypes
are applied, the names of the applied stereotypes are shown as a comma-separated list with a pair of
guillemets.

Stereotype is applied to element
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Process map diagram
Process map diagram gives an overview that shows the processes needed to approach a business goal. This chapters teaches you how to create a
process map diagram.

 

Creating process map diagram

This page teaches you how to create a process map diagram through the diagram navigator. There is a list of supported notations in process map
diagram.
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Creating process map diagram
Process map diagram gives an overview that shows the processes needed to approach a business goal. It is rather in a upper level of analyzing and
understanding a business process.

A sample process map diagram

Creating process map diagram
• Click on Business on toolbar and select Process Map Diagram from the drop down menu .

• Right click on Process Map Diagram    in Diagram Navigator, under the Business Modeling category, and select New  Process Map
Diagram from the popup menu.

• Select File > New Diagram > Business Modeling >  Process Map Diagram  from the main menu.

</h2>

Notations

Name Representation Description

Process A process is a part of process flow in achieving a goal.

Send An event that initiate the process chain.

Receive The result of process chain.

Process Link The flow of process.

A list of supported notations in process map diagram



Organization chart P. 114

Organization chart
An organization chart is a diagram that visualizes the formal structure of an organization as well as the relationships and relative ranks of its positions.
This chapters teaches you how to create an organization chart.

 

Creating organization chart

This page teaches you how to create an organization chart through the diagram navigator, as well as the steps to create subordinate, coworker and
relocate branch.
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Creating organization chart
An organization chart is a diagram that visualizes the formal structure of an organization as well as the relationships and relative ranks of its positions.
It is usually drawn and read from the top to the bottom. The default unit will pop out when a new organization chart is created.
In Logizian, organization chart is not only a diagram, but also a reference used for other parts of your model. For example, you may use an
organization chart to depict the company hierarchy involved in a business process model. Its prime function is to help a business analyst to visualize
efficiently the company structure as well as the division of works when performing business analysis.
The completed organization chart is shown as follows:

Sample organization chart

Creating an organization chart
• Click on Business on toolbar and select Organization Chart from the drop down menu .

• Right click on Organization Chart    in Diagram Navigator, under the Business Modeling category, and select New  Organization Chart 
from the popup menu.

• Select File > New Diagram > Business Modeling >  Organization Chart  from the main menu.

</h2>

Creating a subordinate
Subordinate, which is subject to the superior, is belonging to a lower rank. To create a subordinate under a superior unit:

1. Move mouse pointer on a unit and press its resource icon New Subordinate.

Create subordinate

2. Name the newly created subordinate unit and press Enter to confirm editing.

Creating a coworker
The coworker is a fellow worker of the same rank to the branch next to it. To create a coworker next to an existing unit:

1. Move the mouse pointer a unit and click its resource icon  New Coworker, either on its left or right hand side.

Create coworker

2. Name the newly created coworker unit and press Enter to confirm editing.

NOTE: Clicking left resource icon will create coworker on the left of the unit, while clicking right resource icon will create coworker on its right.

Relocating a branch
A unit can be relocated even when it has been placed under the subordination of another unit. 
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1. Press on a branch you want to relocate and drag it to the preferred branch.

Moving a unit

2. Release the mouse to confirm the position.

Completed relocating a branch

NOTE: If you are not satisfied the relocation, press  Esc to cancel the
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RACI chart
A  RACI chart  is a matrix capable of showing how people or roles are related to business activities in a business process. You may form a RACI chart
from a BPD to record the responsibility roles among swimlanes (i.e. Pool and lane) and activities (i.e. Task and sub-process.

 

Creating RACI chart

This page teaches you how to create a RACI chart through generating one from BPD.

http://en.wikipedia.org/wiki/Responsibility_assignment_matrix
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Creating RACI chart
A  RACI chart  is a matrix capable of showing how people or roles are related to business activities in a business process. You may form a RACI chart
from a BPD to record the responsibility roles among swimlanes (i.e. Pool and lane) and activities (i.e. Task and sub-process. At any intersection of the
participant and activity you can assign participant any of the four available responsible roles for a particular activity:

• Responsible - The participant who do the activity.

• Approver - The participant who approves or disapprove against an activity.

• Consulted - The participant who need to comment on the activity.

• Informed - The participant who need to be informed for any update about the activity.

To create a RACI chart from BPD:

1. Right click on the background of a BPD and select Utilities > Generate RACI Diagram from the popup menu.

Generate RACI chart from BPD

2. The role R, abbreviation for responsible, is automatically assigned to the intersection of participant and activitiy whenever the activity is put
inside an participant. You may add or remove roles by clicking on a cell in the chart and update the role selection.

Update the responsibility roles

 

http://en.wikipedia.org/wiki/Responsibility_assignment_matrix
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Business rule
A business rule defines guideline with necessary constraint(s) needed for executing certain business operations. You will learn how to manage
business rules.

 

Managing business rules

Shows you how to use the rule editor to edit business rule.

 

Business rule grid

Shows you how to use the rule grid to manage business rules.
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Managing business rules
A business rule defines guideline with necessary constraint(s) needed for executing certain business operations. You can record and describe
business rules with rule editor, as well as to identify the term (vocabulary) involved in the rule, which helps tracing fact concepts around rules.

Defining a business rule
If you want to define a business rule, you need to create the rule and define it in the rule editor. Here are the steps:

1. Click on Business in toolbar, and select Business Rule from the drop down menu.

To create a business rule

2. This shows the rule editor. An ID, which is a number indicating the order of rule creation, is assigned automatically. You may change it if you
like. Name the rule with a short and descriptive phrase. Fill in the rule content in the Rule field.

Rule editor

An overview of rule editor
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Overview of rule editor

No. Name Description

1 Rule A tab that shows the primary rule information such as its name and definition

2 Stereotypes A list of stereotypes applied to the rule. You can extend a rule from a stereotype to add domain specific meaning to it. For example,
you can extend a rule from stereotype critical to represent an important rule.

3 Attributes Read, add and remove attributes from the rule. Attributes can be added to denote extra properties to a rule.

4 ID A value that makes each rule unique. When you create a rule, an ID will be assigned automatically. The assigned ID indicates the
order of rule creation.

5 Name A short phrase that describes the rule.

6 Rule
definition

A longer and more detailed description of rule.

7 Synchronize
selection

When the checkbox is checked, the Terms and Facts' active node selection will follow the selection as pointed by the mouse pointer
in the Rule definition field.

8 Terms A list of terms that involve in the rule definition.

9 Term
definition

By selecting a term in Terms list, its definition will appear in the Definition field.

10 Facts A list of facts that involve in the rule definition.

11 Term
definition

By selecting a term in Facts list, its definition will appear in the Definition field.

Description of rule editor

Visualizing business rule on diagram
Instead of creating a business rule as described above, you can also create a business rule shape on a diagram. Although there is no specific type of
diagram made for presenting business rule, you can draw business rule on any type of diagram. To draw a business rule on a diagram:
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1. Scroll to the Common category in diagram toolbar and select Business Rule.

Selecting Business Rule in diagram toolbar

2. Click on the diagram to create a business rule. Name the rule with a short and descriptive phrase and press Enter to confirm.

A business rule is created

If you need to describe the rule in detail, right click on the rule shape and select Open Rule Editor from the popup menu. After that, fill in the
rule definition in rule editor as mentioned above.

Open the rule editor to define the rule

Expanding and collapsing rule
A business rule shape has two visual states - collapsed and expanded. In collapsed state, business rule hideaway the definition of rule, while in
expanded state, a new compartment will appear in the middle rule shape for showing the rule definition.

To expand or collapse a rule shape, click on the top left corner of rule shape.

Expand a collapsed rule shape
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An expanded rule shape

Business rule group
If you find a number of rules are of the same category, you can group them.

1. Select the rule shapes.

Select rules

2. Right click on the selection and select Group Business Rules from the popup menu.

To group rules

Rules are grouped
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Business rule grid
Business rule grid is a table with business rules listed in it. It lets you to access all business rules in a project or diagram, lookup and create business
rule.

Creating business rule grid
• Click on Business on toolbar and select Business Rule Grid from the drop down menu .

• Select File > New Diagram > Business Modeling > Business Rule Grid from the main menu.

The overview of business rules grid

The business rules grid

Button Name Description

Configure Grid Click this button to reveal Name and Model Element. To hide them, click this button again.

Create business
rule

Create a new business rule.

Find To find a business rule by providing its name or documentation.

Open Rule
Editor

Click this button to enter more details for business rule in Business Rule Editor.

Open
Specification...

To open the specification of business rule selected in grid.

Export to Excel You can export business rules grid to an Excel file by clicking this button.

Import to Excel You can import changes made externally in Excel file back to Agilian to update the business rule grid. Only
Excel exported from Agilian can be imported.

Show View... To show the view(s) of business rule selected in grid.

Visualize... To visualize a business rule selected in grid.

Configure
columns...

Add/ remove property column(s) in Business Rule list.

Refresh To update the display on the Business Rule list.

Project To filter business rules by selecting the diagram(s) (or all diagrams) that contain the business rules.

Business Rule's
name filter

To filter business rules by name. The rubber on the right hand side is for clearing the filter content.

The fields in business rules grid
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Creating business rule
1.

Click on  above the grid.

2. To enter more details of business rule, right click on the new business rule and select Open Rule Editor from the pop-up menu.

Open business rule editor

NOTE: The business rules created in business rules grid are automatically put under the business rules model. You may move to another model
through dragging and dropping in Model Explorer.

3. In Business Rule Editor, enter name and rule for the newly created business rule.

Enter name and rule

Creating fact
Highlight a word which you want to create it to be a fact and select Create Fact from the pop-up menu.

Create check as fact

Creating term
Highlight a word which you want to create it to be a term and select Create Term from the pop-up menu.

Create changes as term

Exporting and importing Excel
You can export business rules grid to an Excel file and import changes made externally in Excel file back to VP-UML to update the business rule grid.
Only Excel exported from VP-UML can be imported.

1.
Click .
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2. In the  Export Excel dialog box, enter output path and then click Export button.

3. After you have modified the business rules in Excel file, save the file.

4.
Click   .

5. In the Import dialog box, select the directory you have stored the Excel file previously. Click OK button. The data on business rule grid is
changed according to the imported Excel file.

Visualizing a business rule
You can form a diagram with business rule, or show it in an existing diagram by visualizing it in business rules grid. To visualize a business rule:

1. Select the business rule to visualize.

Select a business rule to visualize

2.
Click on  above the grid.

3. If you want to visualize business rule in a new diagram, keep Create new diagram selected, select the type of diagram to create and specifying
the diagram name.

Name a new diagram

If you want to visualize business rule in an existing diagram, choose Show in existing diagram and select a diagram in the diagram list.

Select an existing business rule diagram to visualize the business rule

4. If you choose Create new diagram in the above step, click Create button at the bottom of the dialog box. On the other hand, if you choose
Show in existing diagram, click Show button.

Filtering business rules
By filtering business rules, business rules that do not match the required naming convention are filtered. To filter, enter the name of business rule, or
part of its name at the top right of grid. You can make use of the asterisk (*) character to represent any character(s).

Filter business rule by name

Finding business rule
To find out business rules that match specific naming/ alias/ label/ documentation pattern:

1.
Click .

2. In the Search Text text box, enter the text to search, check Name and/or Documentation to specifiy whether to search the names and/or
documentation of business rules. Click  Find button. As a result, the grid is updated to highlight the matched business rules.
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Fact diagram
Record and related terminologies under specific business domain by using fact diagram.

 

Creating fact diagram

Shows you how to use the fact diagram to model the relationships between terms in a business domain.
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Creating fact diagram
Record and related terminologies under specific business domain by using fact diagram. In a fact diagram, terms are visualized as rectangular blocks.
You can link terms up with connectors, and specify the kind of relationship in between. A fact diagram is closely related to business rules. It helps you
identify the rules by studying the relationship between terms.

A sample fact diagram

Creating fact diagram
• Click on Business on toolbar and select Fact Diagram from the drop down menu .

• Right click on Fact Diagram  in Diagram Navigator, under the Business Modeling category, and select New Fact Diagram from the popup
menu.

• Select File > New Diagram > Business Modeling > Fact Diagram from the main menu.

Notations

Name Representation Description

Term A meaningful noun or noun phase that business participants recognize and use in communication.

Fact Type A fact type represents the relationship between terms.

Fact Association A fact association connects terms for visualizing the relationship in between.

Term-Fact Type
Association

By connecting a term to a fact type, it represents a u-nary fact-type that provides a simple yes or no answer
to business question.

Generalization Represents a parent and child relationship between terms.

A list of supported notations in fact diagram

Spliting and joining binary fact
When a fact type involves more than two terms, we call it a n-ary fact type. For example, fact type worded "helpdesk answer customer's enquiry"
involves three terms helpdesk, answer and enquiry. If you have already created a fact model that involves two terms, and now want to add an
additional one, you need to split a fact type, and connect the split fact type with the new term.

1. Split a fact type by right clicking on the fact association and selecting Split Binary Fact from the popup menu.

Split a binary fact
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2. Move the mouse pointer over the added term. Press on the resource Term-Fact Type Association -> Fact Type and drag to the split fact type.

To connect term with fact type

3. Release the mouse button. This connects the new term with split fact type.

Term is connected with fact type

On the contrary, you can join a split fact type by right clicking on an association and selecting Join Fact Type from the popup menu.
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Decision diagram
Represent complex decision situations and business rules in the most simplest, organized manner.

 

Creating decision table

Shows you how to create and understand decision table.
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Creating decision table
Decision table provides a compact way to represent complex decision situations. Thanks to the easy to comprehend layout, decision table can be
understood by any users easily.

Decision table involves three sections - conditions, actions and rules. From developer&rsquo;s point of view, decision table is pretty much like the
tabular form of an if-then-else statement. Business users use decision table to document business rules, while system developers study a decision
table to think about the right way to implement those rules.

Decision table sample

The condition rows in a decision table list out the factors that can influence the final decision. The action rows list out the possible operations to
perform. Each of the rule columns represents a combination of condition(s) and action(s), meaning that when one or more conditions are met, action
or multiple actions will be performed accordingly. Decision table does not enforce any rule regarding the way cells are filled. People usually use simple
true/false (or simply T/F, Y/N) values to represent the matching of conditions and actions. Some prefer using ticks. There is real limitation though.

Creating decision table
• Click on Business on toolbar and select Decision Table from the drop down menu .

• Right click on Decision Table  in Diagram Navigator, under the Business Modeling category, and select New Decision Table from the popup
menu.

• Select File > New Diagram > Business Modeling > Decision Table from the main menu.

Creating conditions and actions
The first two buttons in the toolbar at the top of the decision table allows you to create conditions and actions respectively. By selecting an existing
condition or action and click on the create button, a new condition/action will be inserted after the selected condition/action. Then, enter the description
of condition/action. Alternatively, you can right click on a condition/action and add a new one after it via the popup menu.

Buttons to create conditions and actions

Creating rules
The third button in the toolbar at the top of the decision table allows you to create rules. By selecting an existing rule and click on the create button, a
new rule will be inserted after the selected rule. Find the conditions and actions that match your rule. Double click on the corresponding cell and place a
mark on it. For example, enter "Y" to indicate "Yes". Alternatively, you can right click on a rule and add a new one after it via the popup menu.

Buttons to create conditions and rules

Reorder conditions, actions and rules
To reorder conditions and actions, select them in the table and click on the Move Up/Down button in toolbar. Or right click on them and select Move
Up/Down from the popup menu. To reoder rules, select and right click on them, select Move Left/Right from the popup menu.
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Delete conditions, actions and rules
To delete conditions, actions and rules, select the rows or columns to delete, click on the Delete button in toolbar.
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Entity relationship diagram
ERD, short for entity relationship diagram, is a kind of diagram for presenting the properties as well as the relationships between data or participants.
This chapters teaches you how to create an ERD.

 

Creating entity relationship diagram

This page teaches you how to create an ERD through the diagram navigator, as well as to describe the differences between conceptual, logical and
physical model.

 

Database configuration

This page teaches you how specify the type of database (e.g. Oracle, MS SQL, MySQL...) ERD to conform to.
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Creating entity relationship diagram
ERD, short for entity relationship diagram, is a kind of diagram for presenting the properties as well as the relationships between data or participants.
Database designer use of ERD to model physical structure of a relationship database, while business analyst uses ERD to model the data that is
logically required or produced by processes.

A sample ERD

Creating entity relationship diagram
• Click on Diagrams on toolbar and select Entity Relationship Diagram from the drop down menu .

• Right click on Entity Relationship Diagram   in Diagram Navigator, under the Database Modeling category, and select New  Entity
Relationship Diagram from the popup menu.

• Select File > New Diagram > Database Modeling >  Entity Relationship Diagram from the main menu.

 

When a new diagram is created, you can name it at the top left corner of diagram. At the top right of diagram you can select a type of model of which
the diagram will present. The meaning of model types will be described in the next section.

Selecting a type of model

Creating entity and adding columns
To create an entity, select Entity in diagram toolbar and click on diagram. To add a column in entity, right click on the entity and select New Column
from the popup menu.

Conceptual, logical and physical model
Conceptual, logical and physical model are three different ways of modeling data in a domain. The all contain entities and relationships, but differs
in complexity and purposes. A general understanding to the three models is that, business analyst use conceptual and logical model for modeling
the data required and produced by system from a business angle, while database designer refine the early design to produce the physical model for
presenting physical database structure ready for database construction.
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Conceptual model is the simplest model among all. It consists of entities and relationships. You can add columns to entities to represent the properties
of entities.

A conceptual model

Logical model is more complex than conceptual model. You can include more details for columns by specifying their type (e.g. text, integer, date).

A logical model

Physical model is the most complex one. Database designers add primary or foreign keys to entities, and rename entities and columns to satisfy the
table or column naming convention. The physical model represents how to implement your data model in database.

A physical model

Creating partial table
Sometimes, you want to separate an entity into two, and create a one-to-one relationship in between. For example, to extract information on a Student
entity into another entity StudentInfo. You can split a table by creating a partial table through the resource centric-interface.
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1. To split a table, move the mouse over the entity you want to split and drag out the One-to-One Relationship -> Partial Table.

Create a partial table

2. Release the mouse button to create the split entity.

3. In the Split Table dialog box, select the columns you want to move to the split table and click  >.

Move columns to partial table

4. Click OK button. A split table is created.

Split table is created
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Database configuration

Opening database configuration dialog
Select Tools > Database > Database Configuration... from the main menu.

Selecting database
In the Database Configuration dialog box, check the target database.

Select database

You can select multiple databases, and set one of them as default database. The default database is used for rendering the column type and
generating SQL. To set a database as default, right click on the database and select Set as default from the pop-up menu.

Set as default database

Downloading JDBC driver
If the JDBC driver is free and available to public, Logizian can help you to download it automatically. Click the Download or Update button under
Database Setting section.

Download JDBC driver
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Configure proxy if required, click OK button to continue download.

Download JDBC proxy setting

The Download dialog shows the URL, file size, speed and progress information. Click Close button after download is completed.

The Driver file field shows the driver downloaded by Agilian.

Downloaded JDBC driver

Testing connection
After configure the database setting, click the Test Connection button to confirm the setting is valid.

Test connection

If it's successful, a dialog will show connection successful.
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Creating diagrams
In this chapter, you will learn not only how to create diagrams, but also some of the frequently used functions that aid in diagramming, including
resource-centric interface, using tagged values to add custom properties and spell checking.

 

Creating diagrams

You will see how to create a diagram, how to create shapes and draw freehand shapes.

 

Model element and view

When model element is seen as data, view is a representation of data. This page tells you more about the relationship between model element and
view.

 

Master view and auxiliary view

Multiple views can be added for model elements. Among the views, one master view can be set. The rest are called auxiliary views. This page provides
you with more information about views.

 

Resource centric interface

Resource-centric interface provides you with a set of function icons around shapes, for triggering functions in quick. You will learn how to make use of
resource-centric interface to create and connect shapes, and know the differences between types of resource icons.

 

Tagged values

Tagged values can be used to add domain specific properties to shapes. There are several types of tag, such as text, integer, floating point number,
etc. You will see how to create tagged values.

 

Spell checking

Spell checking is an automatically enabled feature for ensuring the accuracy of written content such as shape name and documentation. You will see
how to configure spell checking.
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Creating diagrams
You can create diagrams to help visualize what you did, what you are doing and what you need to do on your target system or application. There are
different types of diagrams to cater for different needs, categorized as Requirements Capturing, Business Modeling, Database Modeling and
Others.

Ways to create diagram
There are three ways of creating diagram: toolbar, menu and Diagram Navigator.

Toolbar
Click on a button of category in toolbar and select the type of diagram to create in the drop down menu.

Create diagram through toolbar

File Menu
Select File > New Diagram from the main menu. Then, select the diagram category and the type of diagram to create.

Create diagram through menu

Diagram Navigator
Right click on the type of diagram to create and select New [Type] Diagram from the popup menu (e.g. New Business Process Diagram).

Create diagram through Diagram Navigator

Creating and place diagram in a logical view
Logical view enables you to categorize diagrams in your own way by using view folders. When you create diagram, you may enter diagram name
immediately. At the same time, if there is at least one logical view in your project, you may select the view to store the diagram.
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To select a logical view when creating diagram:

1. Click on the button next to the box of diagram name.

Create and place diagram in a logical view

2. Select the view folder. If you want to create a new folder to store the diagram, click Create Folder.

Drawing shapes
After creating a new diagram, diagram elements can be created as well through the diagram toolbar. In this section, these techniques of drawing
shapes will be explicated:

• Creating Shapes

• Creating Connectors

• Creating Self-Connection

Creating shapes
To create a shape, click a diagram element from the diagram toolbar and click it on the diagram pane for creating. The generated element will appear
to have a default size.

Click a start event on the diagram pane

 

For defining a specific shape size, drag a specific boundary with the mouse after clicking a diagram element from the diagram toolbar.

Drag a specific boundary with the mouse

 

Alternatively, a diagram element can be created by dragging the diagram element and then dropping it on the diagram pane.

Drag and drop to create a shape
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In addition, you can add a shape through the pop-up menu of diagram. Right click on the diagram background, select  Add Shape and then a specific
shape from the pop-up menu.

Create a shape through the pop-up menu of diagram

Creating connectors
To create a connector, select the desired connector from the diagram toolbar, drag the connector from the source shape to the destination shape. If
you create an invalid connection, a stop sign will pop out. For instance, you are not allowed to draw a expression sequence flow from a task to a start
event.

An invalid connection is created

If the connection is valid, a blue rectangle surrounding the destination shape can be seen.

A valid connection is created

 

Moreover, connectors can be created through resource icons:

Move the mouse over the source shape, press a resource icon that associates with the destination shape and drag it to the destination shape.

Press a resource icon to connect shapes

If you release the mouse on an empty space, a new shape will be created with a connector.
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Creating self-connection
Some shapes can make a connection for itself, for example, self relationship of an entity  in Entity Relationship Diagram. To create a self-connection,
press  the target shape's resource icon directly.

Self-One-to-Many Relationship -> Entity is created

Creating turning point on connector
A turning point is a point on a connector where a bending take place. To create a turning point on an existing connector, press on the connector and
drag to bend the connector.

Create turning point on existing connector

You can also create a turning point when creating a creator through the resource centric interface. When dragging out a resource-icon, press the Shift
button at where you want to create the turning point.

Create turning points when creating shape by dragging a resource

If you try to create connector by clicking on a resource icon, click at where you want to create a turning point to create it.

Create turning points when creating shape by clicking a resource

Resource-centric interface
Visual Paradigm is the first vendor to introduce the resource centric diagramming interface. The resource centric interface greatly improves the
efficiency of modeling. You don't have to traverse between the toolbar and the diagram to create diagram elements, make connections and modify the
diagrams. The resource centric interface can make sure the modeler is able to create a diagram with correct syntax more quickly.

There are three types of resource icons:

• Connection Resource

• Manipulation Resource

• Split resource
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Connection resource
It is designed for creating elements and making connections.

Connection resource

Manipulation resource
You can use manipulation resource to modify properties or appearance of elements. For example, you can show/ hide compartments in classes, add
references, add sub-diagram and fit size.

 

Manipulation resource

Split resource
You can add an extra shape into a flow between two shapes without moving shapes manually.

Split resource

Drawing freehand shapes
Freehand shape is a kind of general graphic shapes. Pen shapes, pencil shapes, and some regular shapes like circle, rectangle and arrow are
available. Freehand shape can be used for annotating diagram. For example, you can use freehand shapes to emphasize some shapes.

A specific shape can be highlighted with a pencil shape.

Pencil
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An outstanding text can be shown with word art.

Word Art

A freehand shape style can be formatted in order to address your information.

Styled freehand shapes

Changing package header
You can specify the parent package of any diagram through Package Header.

Package header when diagram created
When a diagram is created, the package header will be unfolded as it allows you to specify the parent package of the diagram. Specify the package by
entering the fully qualifier name of the package.

Specify parent package in package header

You can open specification of parent package by pressing the Open Specification button on the right-hand side of the parent package name.

Open Specification

You can rename the parent package of the diagram by double clicking on it.

A new package will be created if you enter a completely new package name. If the previous parent package does not contain elements, it will be
deleted. That means the documentation (or other properties) of previous parent package will be lost.
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A package header can be either shown or hidden through the pop-up menu of data flow diagram. Right click on the diagram background and select
Presentation Options > Show Package Header from the pop-up menu.

Show/ hide package header

Justifying shape name
In Visual Paradigm, a shape name is aligned center horizontally, and top or middle vertically, depending on the characteristic of shapes. However, the
shape name can be realigned. Even if a language, such as Modern Hebrew, that is written from the right to the left can be displayed on a shape clearly.

Adjusting shape name's position
1. Right click on the diagram background, select Presentation Options > Model Element Name Alignment and then select a specific alignment

option from the pop-up menu.

2. As a result, all shapes' name in the whole diagram will turn into the alignment option you set previously.

All shapes' names turn into bottom right

Apart from the whole diagram setting, a specific shape can also be set:

1. Right click on a shape, select Presentation Options > Model Element Name Alignment and then select a specific alignment option from the
pop-up menu.

Select an alignment option from the pop-up menu
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2. As a result, the specific shape will turn into the alignment option you set previously.

In addition to the current diagram, future diagrams can also be set:

1. Select Tools > Project Options... from the main menu.

2. In the Project Options dialog box, select the Diagramming category, check an option in Model Element Name Alignment section under the
Appearance tab.

Check an alignment option in the Options dialog box

Exceptions
Although most shape' name can be justified, some are exceptional. Shapes neither with floating name label (freely movable) nor with a label outside
the shape can be justified. A start event of Business Process Diagram is an example of this kind of shape.

Floating name label

Enable and disable minimum shape size
Since all shapes have their own default minimum size, users are not allowed to resize them to smaller than the minimum size. The default setting
helps to ensure those compact shapes are clear enough to be seen on a diagram under normal circumstance. The minimum size of a shape can be
determined by pressing its fit size button.

Press its fit size button

 

Now, it is possible to disable such setting, so that shapes can be resized to extremely small in size, despite their minimum size:

1. To disable the function of the minimum size checking, select Tools > Project Options... from the main menu.

2. In the Project  Options dialog box, select the Diagramming category and uncheck Enable minimum shape size when resizing shape under 
Appearance tab. Click OK to confirm.

3. After that, you can resize a shape to the size as small as you want.

4. Furthermore, select other shapes and select an option  from the drop-down menu of resource icon Same Width.

Select an option from the drop-down menu of resource icons
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5. As a result, other shapes will turn into the same size as the shape you have done previously.

All shapes are turned into the same small size

Undo and redo
During the process of editing a diagram, you may make some careless mistakes, such as accidentally deleting a shape. You can use the Undo
function to cancel the previous action. On the contrary, you may re-perform the action through the Redo function. Note that the undo/redo feature in
Logizian is diagram based.

Undo
You can roll back undesirable changes by performing Undo. Undo function can be executed in the following three ways:

• Select Edit > Undo from the main menu.

•
Click the Undo button   on toolbar.

• Press Ctrl-Z.

Redo
This feature is to re-perform actions that have just been undone. Redo function can be executed in the following three ways:

• Select Edit > Redo from the main menu.

•
Click the Redo button   on toolbar.

• Press Ctrl-Y.

Showing name for undo and redo action
It's hard for us to remember all actions we have done previously. By Logizian, we can recall the actions we have done before.

You can find an  action name of  undo/ redo by clicking Edit from the main menu.

Menu shows Undo/Redo name

On the other hand, you can also find the action name of undo/ redo on toolbar button's tooltip. Move the mouse over the Undo or Redo button and
then a tooltip with Undo/ Redo action name will appear.

Toolbar button's tooltip shows undo action
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Model element and view
A model element is an elementary component of a model. It will be created when you create a shape on a diagram, or when we create one directly
through the Model Explorer. An example of model element is task.

Create a model element through Model Explorer

You can visualize an existing model element by dragging and dropping a model element from Model Explorer to diagram. We call the visualized
form of model element a view, or a shape, depending on whether we want to emphasis the differences against model element, or we want to focus on
diagramming operations.

Creating a view from an existing model element through drag and drop

When developing context-based diagrams, you will reuse a model element in different diagrams, resulted in creating multiple views. Each model
element can associate with zero to multiple views. When you make specification-level change, such as changing of name, on any view, the change will
be applied to all views.

Showing a view of a model element
If you want to open a diagram from a model element, right click on the model element in Model Explorer and select Show View... from the popup
menu. Then, select the view to open in the Show View dialog box and click Go to View to open the diagram.
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Master view and auxiliary view
When your project is simple, you are able to express all of the design ideas with just a few diagrams. The diagrams are simple and self-explanatory.
Each of them represents a distinct design idea and there is no overlapping between diagrams.
When you are dealing with a complex project, you may need to draw multiple diagrams to represent different contexts. You need to borrow shapes
from a diagram to make them appear in other diagrams (i.e. contexts). In fact, this is extremely common when modeling with business process
diagram, for visualizing the same pool (i.e. participant) under two business processes, as presented in two BPD.

Instead of re-creating those pools again and again in different diagrams, Visual Paradigm allows you to "re-use" them. Through simple copy and paste
( Ctrl-C and Ctrl-V), you can easily copy a shape from one diagram to another. Each shape is formally known as a "view". So with this, you can create
multiple views for a model element in representing different contexts. Changes made on a shape are all synchronized to other instances that appear in
other diagrams without extra effort. This is great, but there is a drawback though.

A master view is simply the specific view of model element that decides the placement of that model element within a model hierarchy. It can be
a shape on a diagram, or the representation in Model Explorer. When you create a model element the first time, either by drawing a shape or by
creating a model element under Model Explorer, the created view will be treated as the master. Subsequent views are all known as auxiliary views.
When you attempt to move a master view to another parent shape, you are updating the real model structure as well (as reflected in Model Explorer).
However, when you move any auxiliary view to a different parent shape, there will be no change at all on the model structure.

Selecting a master view
A model element can have multiple views. Yet, it can only have one master view. You can change the master view of a model element. By doing so,
the original master view will become auxiliary, and the assignment of parent element will be updated immediately base on the new master view.

1. Open the Show Views window. In Model Explorer, you can open it by right clicking on the target model element and selecting Show View...
from the popup menu. In diagram, you can open it by right clicking on the target view and selecting Related Elements > Show Other Views...
from the popup menu.

2. In the window you can see a list of views of the selected model element/view. Click Set Master View...at bottom left corner.

3. This shows the Set Master View window. You can select on the left hand side the Model Explorer or a specific diagram to be the master view
of selected element. To select Model Explorer means that the placement of model element will always follow the hierarchy as presented in
Model Explorer. Any re-positioning made in views in any diagram will not affect the model hierarchy. Click OK to confirm your
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Resource centric interface
Visual Paradigm is the first vendor to introduce the resource centric diagramming interface. The resource centric interface greatly improves the
efficiency of modeling. It can make sure the modeler is able to create a diagram with correct syntax more quickly. The utmost importance thing is
that you don't have to go back and forth between the toolbar and the diagrams for creating diagram elements, making connections and modifying the
diagrams.

Resource centric interface on task

NOTE: To check or uncheck the options (including Resources, Group Resources, Extra Resources and Generic Resources Only) on
resource centric interface, select View > Resource Centric from the main menu.

Creating shapes through resource centric interface
Instead of clicking shapes one by one from the diagram toolbar, you can create another shape from an existing shape on the diagram.

1. Move the mouse on a shape and select a resource icon when resource centric interface reveals.

Create a task with resource centric interface

2. Drag the resource icon and release it until reaching to your preferred place.

3. As a result, another shape is created and linked with the previous shape.

Release the mouse to create task

Connecting shapes through resource centric interface
For relating two shapes together, you have to link a shape to another. With resource centric interface, you can not only link them up, but also select an
appropriate relationship for them.

1. Move the mouse on the source shape and select a resource icon when resource centric interface reveals.

Select a resource icon

2. Drag the resource icon and release it until reaching to the destination shape.

3. As a result, two shapes are linked together.

Two shapes are connected

Using quick connect
With quick connect, you are able to search the preferred shape and connect to it on the diagram accurately and quickly.
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1. Move the mouse on the source shape and click a resource icon when resource centric interface reveals. The Quick Connect dialog box will be
shown subsequently.

Quick Connect dialog box

2. You can either create a new shape or select an existing shape by typing its name in the text field of Quick Connect dialog box. To select an
existing shape, enter its full name directly or just type the first letter of its name. As a result, a list of shapes which match with the word(s) you
typed will display.

3. After you click a shape's name on the drop-down list, the shape will be spotlighted on the diagram immediately.

Task is spotlighted

4. Press Enter to confirm the selection. The two shapes will be linked automatically.

Two shapes are linked

NOTE: You should click the resource icon in accordance with the existing shapes on your diagram. If the shape does not exist on the diagram,
the Quick Connect dialog box will not pop out even when you click the resource icon.

Managing transition of shapes
Model transitor enables you to trace between model elements across different phrases of development. Once a transition is created between two
shapes, you can navigate between them through the resource centric interface.
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Move the mouse on a shape and select Model Transitor> Transit To and then select the shape's name you would like to transit to/from from the pop-
up menu. As a result, the vision will be diverted to the selected shape after transition is selected. Thereafter, you can transit to/ from between these two
shapes.

Transit from one shape to another

NOTE: Transition does apply not only on two shapes on the same diagram, but also two shapes in different diagrams.

Adding and opening reference
For providing extra information to shapes, you can insert both internal and external resources, such as a shape, a diagram, a file, a URL through the
resource centric interface. After editing references, they can be opened throughout the resource centric interface.

1. Move the mouse on a shape that you would like to insert references for, press resource icon Resources at the bottom left corner and select a
reference option from the pop-up menu.

Add a file
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2. Insert the resource in References tab of your shape's specification dialog box.

Insert a file in Task Specification dialog box

3. After adding reference, you can click resource icon Resources again and the reference you have just created will be shown on the pop-up
menu.

The newly created reference

Splitting connection by shape
Resource centric supports some connectors (e.g. Sequence Flow in Business Process Diagram) with splitting the connector by adding another shape.

1. Move the mouse on the connector between two shapes, press Split with Shape icon and select a shape you want to insert between them from
the pop-up menu.

Press split resource icon



Resource-centric interface P. 155

2. As a result, an extra shape is inserted between two shapes.

Two tasks are split by Gateway

NOTE: The split resource icon is shown with orange asterisk.

Group selection resource
When a great amount of shapes are displayed on the diagram disorderly, resource centric interface can support alignment and grouping after selecting
several shapes.

1. Select several shapes on diagram and move the mouse on the final selected shape (i.e. shape with non-filled selector) and group selection
resources will be shown instantly.

Group Selection Resources are shown

2. Select an alignment option for those selected shapes.

Select Align Top from the drop-down menu
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Tagged values
In Logizian, tagged values are properties defined by user and can be added to a model element. Logizian supports either defined tagged values in
stereotype or tagged values without stereotype.

Adding user-defined tags
1. Right click on the selected shape and select Open Specification... from the pop-up menu.

Open specification

2. In Specification dialog box, select Tagged Values tab and click Add button to select an option of value type.

Add an option of value type

Different types of tagged values

Text
Text supports string-based value.

In Specification dialog box, select Tagged Values tab, click  Add button and select Text from the pop-up menu. Enter the text in the text field directly.

Add text

Multi-line Text
Multi-line Text supports multi-line string. 

1. In Specification dialog box, select Tagged Values tab, click  Add button and select Multi-line Text from the pop-up menu. Click the ... button
of Value.

Add multi-line text
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2. When Edit Value dialog box pops out, enter the multi-line text. Click OK button to finish editing.

The Edit Value dialog box

Model Element
Model Element supports reference(s) of model element.

1. In Specification dialog box, select Tagged Values tab, click  Add button and select Model Element from the pop-up menu. Click the reverse
triangle  button of  Value.

Add model element

2. When the Select Model dialog box pops out, check Model and select a model element. Click OK button to confirm.

Select a model element

Integer
Integer supports values with numbers only.
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In Specification dialog box, select Tagged Values tab, click  Add button and select Integer from the pop-up menu. Enter a number in Value.

Add integer

Floating Point Number
Floating Point Number supports values with decimal places.

In Specification dialog box, select Tagged Values tab, click  Add button and Floating Point Number from the pop-up menu. Enter a number with
decimal places in Value.

Add floating point number

HTML
HTML is a hidden tagged value. To reveal this option, select Tools > Options... from the main menu. When the Options dialog box pops out, select
Diagramming > Environment tab and check Stereotype support HTML tagged value.

In Specification dialog box, select Tagged Values tab, click  Add button > HTML Text from the pop-up menu and click  ... button in Value when the
option for HTML is revealed.

Add HTML text

When Edit Value dialog box pops out, enter the text. You can format the HTML text content with the toolbar, for example, changing the font color of
selected text and underlining selected text.

Format the HTML text content

Click OK button to finish editing.
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Editing tagged values
You can enter the user-defined tagged value's name, select its type and enter its value.

Edit name, type and value on user-defined tagged value

The value of stereotype can be edited, however, its name and type cannot be edited as they are defined in stereotype.

Visualizing tagged values on diagram
Right click on the diagram background and select Presentation Options > Show Tagged Values from the pop-up menu.

Show tagged values

If it is defined, the tagged values will be seen within the shape(s) on the diagram.

Tagged values are shown
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Spell checking
You will never find it hard to avoid making mistakes in your diagram after using spell checking. It can help you to correct both typing mistakes and
spelling mistakes, however, it is slightly different from other spelling and grammar checking tools you have used before. It doesn't check your whole
diagram automatically, but underlines wrong words with a curve line.

Correcting a word
If you type an incorrect word mistakenly, you can:

• Either re-type the word correctly or

• Right click on the wrong word and then select one out of the suggest words.

Adding a new word to dictionary
Sometimes, the dictionary cannot recognize the word you type and it doesn't always mean you type an incorrect word. It may be a rare word or a new
word that you create, you can simply right click on the wrong word and select Add to dictionary to add a new word to dictionary. You type this word
again next time, it won't be marked as a wrong word.

Add a new word to dictionary

Changing the language of dictionary
The dictionary usually defaults as American English for spell checking. If you want to change the language of dictionary, you just need to:

1. Click Tools > Application Options from the main menu.

2. When the Application Options dialog box pops out, select Spell Checking on the left hand side of the dialog box.

3. You can change into your preferred language from the drop-down menu of Dictionary.

Change the language of dictionary

NOTE: There are a few more languages in dictionary that can be used, such as French and German.
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More options of spell checking
There are a few more options of spell checking, including Check spelling as you type,  Ignore words in UPPERCASE, Ignore words with numbers
and  Ignore Internet and file address. Check the item you want to be included in spell checking. Otherwise, uncheck the item you don't want to be
included.

Check other options of spell checking



Project management properties P. 162

Project management properties
Project management properties are a set pre-defined properties, made for recording additional management-level information for all kinds of project
data (e.g. diagrams, model elements, diagram elements).

 

Using project management properties

You will see a list of project management properties with their description.

 

Configuring project management properties look-ups

Add available value selection for project management properties, and set defaults.
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Using project management properties
Project management properties  are a set pre-defined properties, made for recording additional management-level information for all kinds of project
data (e.g. diagrams, model elements, diagram elements). Here are all the project management properties you can find:

Property

name

Description

Process Specify the part of the process where the editing element is involved. Three sub-properties for further specification. They include: Iteraction,
Phase and Discipline.

Version The stage of the editing element. For example, you may have two class diagrams for modeling the a system from design and
implementation angles respectively. The two diagrams will have version 1.0 and 2.0, to show the progress of work.

Priority The importance of editing element.

Status The status of editing element. It is particular useful for use case and BPMN activity shapes, for setting their status such as Proposed,
Planned, Tested, etc.

Difficulty How difficult it is to complete the goal as modeled by the edting element.

Author The person who created the editing element. This is particular useful in a team working environment. Once the author is known you can
contact that person in case you have questions about a part of a model.

Create
date
time

The date and time when the editing element was created. This property is a read-only property that is filled automatically to all elements
when creation.

Last
modified

The date and time when the editing element was modified. This property is a read-only property that is filled automatically to all elements
when the project file is being saved .

A list of project management properties

Further to recording project management properties, you can print those properties in report, too.

Editing project management properties
Like all the other specification level properties, project management properties can be edited through the specification dialog box of all diagrams, model
and diagram elements. Select the desired diagram/model element/diagram element. Right click and select Open Specification... from the popup
menu. Under the tab Project Management you can find the properties of the chosen element.

Editing project management properties

http://www.visual-paradigm.com/product/lz/provides/diagramtools.jsp#projectmgmtprop
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Project management properties in report generation
Like most other properties, project management properties will be presented in PDF, HTML and Word report, too. Furthermore, you can filter the
elements to present in report by project management properties when editing template.

Editing project management filter in editing report template
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Configuring project management properties
For each  project management property , there are several default values available for selection. For example, values "1.0" and "2.0" can be selected
for property Version. You can edit an existing value, or add additional values to a property by editing the look-ups.

To configure a property:

1. Select Modeling > Project Management Look-ups... from the main menu.

2. In the Project Management Look-ups dialog box, open the tab of the property that you want to edit its look-ups.

3. If you want to rename a value, double click and re-enter its value. If you want to add a lookup value, click Add at the bottom right corner.

Add a version

http://www.visual-paradigm.com/product/lz/provides/diagramtools.jsp#projectmgmtprop
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Documenting model elements
You can document your model through the documentation editor. In this chapter, you will learn how to use the RTF documentation editor and how to
record voice for shapes.

 

RTF documentation

Rich text format documentation can be entered to shapes. You will see a description about different formatting functions, as well as the steps for
defining a template.

 

Voice documentation

Instead of text, you also can record audio clip as a voice documentation. You will see how to do this in the page Voice documentation.
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RTF documentation
With rich text format (RTF), you can format the text in documentation editor, such as making it bold, italic, or adding tables within the text.  In addition to
formatting, RTF supports users to add linkage to another model element, save documentation as template and furthermore reuse the template.

Viewing and editing the documentation of model element
To view or edit the documentation of model element, right click on the shape and select Open Specification... from the pop-up menu.

Open specification

Alternatively, click the Documentation pane after select a specific shape on the diagram pane.

Documentation pane

Documentation editor
The documentation pane is where you can describe the selected model element. With the editor's toolbar, you can format the content, save as
template, reuse the existing template, add model elements and print the content.

The overview of documentation editor

 

The toolbar on documentation editor

No. Name Description

1  HTML HTML - Read and edit the real content.
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HTML Source - Read and edit the HTML source of content.

Plain Text - Read and edit plain text of content without formatting.

2 Bold Set the highlighted text to bold.

3 Italic Set the highlighted text to italic.

4 Underline Underline the highlighted text.

5 Alignments Set the alignment of highlighted text to the left, the center or the right.

6 Ordered list Add a numbered list.

7 Un-ordered list Add a list with bullet points.

8 Font Select the font family of highlighted text.

9 Font size Select the size of highlighted text.

10 Font color Select the color of highlighted text.

11 Table Add a table.

12 Background color Select the background color of highlighted text.

13 Clear formats Clear formats of the whole editor to convert the content to plain text.

14 Link Add a hyperlink.

15 Image Add an image.

16 Add Model Element Insert an existing model element or create a new one.

17 Template Save as Template...: Save the current documentation content as a template.

Manage Template...: Delete the saved template.

18 Print Print the documentation content.

19 Editor pane Enter and start editing the documentation content.

The description of documentation editor

Editing documentation

Saving a template
1. The documentation you typed can be saved as template in the documentation editor. Choose  Save as template... from the drop-down menu of

Template.

Choose Save as template...
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2.  In the  Input dialog box, enter the template name and click OK button to confirm.

Enter template name

Reusing a template
1. In the documentation editor, an existing template can be reused. Select a saved template from the drop-down menu of Template.

Select a template

2. As a result, the selected template will be shown on the documentation editor.

Adding model element
1. Click Add Model Element button on the editor's toolbar after decided a place for inserting a model element.

Click Add Model Element button

2. In Select Model dialog box, select an existing model element on the list. If you want to modify the selected model element, you can click Open
Specification... button. On the other hand, you can create a new model element by clicking New... button after select a model element on the
list.

Select a model element

3. Finally, click OK button to confirm.
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4. Consequently, the name of inserted model element will be shown on the documentation pane with underline. If you want to preview the inserted
model element, you can right click on its name and select Show View... from the pop-up menu. After the Show View dialog box pops out, you
can preview it in the Preview window. If you want to view the actual model element on the diagram, you can click Go to View button.

Click Show View... from the pop-up menu

Printing documentation
1. After clicking the Print button, the Page Setup dialog box will pop out.

Click Print button

2. In Page Setup dialog box, select size and source for paper, check an option under Orientation and enter the inches for the paper margins.

The Page Setup dialog box

3. Click OK button  to confirm printing.
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Voice documentation
In addition to textual description for your model elements, you can record voice documentation, or embed audio files.

Viewing and editing the documentation of model element
To play or edit the voice documentation of model element, right click on a shape and select Open Specification... from the pop-up menu to unfold
Specification dialog box.

Open specification

Alternatively, click the Documentation pane after select a shape on the diagram.

Documentation pane

Recording voice
1. Right click on a model element and select Open Specification... from the pop-up menu.

2. In Specification dialog box, click Record... button on the bottom left corner of dialog box.

Click Record... button

3. In the Record Voice dialog box, click the Record button to start recording.

Start recording

NOTE: Make sure your audio input device is active before operate voice documentation.

4. Click the Stop button when you want to end the recording.

NOTE: Play the recorded voice by pressing the Play button; record again by pressing the  Clear button, and rerun the previous steps.
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5. Enter the name for recorded voice clip in the text field of Name.

Name voice clip

6. Click OK button  to confirm recording.

Linking voice to documentation
1. Right click on a model element and select Open Specification... from the pop-up menu.

2. In Specification dialog box, choose Manage... button on the bottom left corner of dialog box.

Click Manage... button

3. In the Manage Voice dialog box, click the Add button, and choose  either  Embedded or  Link to File.

Click  Add button

4. If you choose Embedded, record a voice clip when the Record Voice dialog box pops out; if you choose Link to File, select an audio file when
the  Open dialog box pops out.

5. The voice clip can be renamed in the text field of Name.

Rename a voice clip

6. Click OK button  to confirm.
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Style and formatting
You can change shapes' appearances freely by editing their fill color, font and line style. In this chapter, we will walk through in detail.

 

Applying fill, line and font styles on diagrams

Shows how to edit the fill, line and font of shapes.

 

Managing and applying styles

You can save formatting properties as a style to aid in reusing in other shapes. This page tells you how to save a style, and reuse it on another shape.

 

Setting line style

Controls how connector routes. There are five options: rectilinear, oblique, curve, round oblique and round rectilinear.

 

Setting line jumps options

When two connectors intersect with each other, the line jump option determines how the intersection will be rendered.

 

Setting connector caption orientation

Controls how a caption of connector appear against different connector orientations.

 

Format copier

Shows you how to copy the formatting properties of a shape and copy to another.

 

Set connection point

Determines how to position the end point of connector, whether to point to the shape's border or point into the center.
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Applying fill, line and font styles on diagram elements
You can format the diagram elements with your preference. To unfold the Formats dialog box, right click on the target shape and select Styles and
Formatting > Formats... from the pop-up menu.

Select Formats... from the pop-up menu

Formats dialog box

You can change the following settings from the  Formats dialog box:

• Changing shapes foreground style

• Changing shapes font style

• Changing shapes background style
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Changing shapes foreground style
In the Format dialog, you can change the foreground style under the Font section. Click the ... button in Font Color to select a color either from the
Default page (which shows pre-defined colors) or from the Custom page (which shows a variety of colors and allows you to define any custom colors).

Color pane

If you want to specify a custom color, you can switch to the Custom pane. After change the font color, the preview will update automatically.

Changing shapes font style
In the Font section, you can also change the font family, style and size.

Font section

Field Description

Font
Name

Select a type for font. The amount of fonts depends on the fonts available in your computer.

Font
Style

Select a style for font. You can select one of the 4 styles and a preview will be shown for each of the style items.

Font
Size

Select the size for font. You may either select a font size by rolling the scrollbar or enter the font size in the text fields.

The Preview pane will display the selected font format.
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Changing shapes background style
You can click on the Background tab to custom the background style.

Background tab

In the Background tab, it allows you to select a solid fill color or a gradient fill color as well as define its transparency.

Field Description

Fill
Style

Select the fill style of the fill color. It can either be Solid (a single color) or Gradient (a fill color that is mixed with two colors).

TransparencySpecify the transparency of the fill color. The greater the value, the more transparent the shape will become. 0 (zero) transparency makes
the fill color completely opaque, while 100 (one hundred) transparency makes the fill color completely transparent.
You can adjust the transparency by dragging the slider, or by typing the value in the text field.

Alternatively, you can click the Opaque button   to set the fill color to opaque, or click the Transparent button  to set the fill color to
transparent.

Preview The Preview pane displays a rectangle that is filled with the editing fill color. The background is checked so that you can also preview the
transparency of the fill color as well.

Save
as
Default

To save the current fill color as the default fill color for new shapes, click the Set as Default button.

Reset
to
Default

To reset the current fill color to the default fill color, click the Reset to Default button.
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Upon checking Gradient in Fill style field, you will see the detail pane for formatting a gradient fill color.

Gradient Fill style

Field Description

Color 1 You can select the first color of the gradient from the Color 1 field. To select a color click the ... button or double-click on the color editor. A
color chooser will appear for you a select a color.

Color 2 You can select the second color of the gradient from the Color 2 field. To select a color click the ... button or double-click on the color
editor. A color chooser will appear for you to select a color.

Gradient
Color
Themes

The Gradient Color Themes pane displays a list of pre-defined gradient color themes.
To add a new color theme select Color 1 and Color 2 then click the Add to Themes... button. Please note that you must select a
combination of colors that does not already exist in the color themes.
To rename a theme click on the Rename... button or double-click on the desired theme. An input dialog will appear for you to enter a new
name.
To remove a theme select the theme and click on the Remove button, or use the Delete key instead.

Gradient
Style

The Gradient Style pane allows you to select the gradient style of the gradient fill color (the angle of how the gradient color is drawn). There
are sixteen pre-defined gradient styles, which are shown as toggle button in the Gradient Style pane. To select a gradient style to use click
on one of the styles.

After you finish editing, click OK to apply to the selected shape.

Formatted shape
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Changing connector line style
To change the connector line style through Property pane, select the target connector on the diagram, click the ... button in Foreground row of the
Property pane.

Click the ... button in the Property pane

You can format the line style in the line section. It allows you to adjust its weight (thickness), color and transparency.

Line section

Field Description

Weight Adjust the weight (thickness) of a line. The greater the value, the thicker the line will become. You can use the up/down button to increase/
reduce the line weight, or you can type directly into the text field. The line weight ranges from 1 to 20.

Color Specify the line color. Click on the ... button next to the Color field to select a color, either from the Default page (which shows predefined
colors) or from the Custom page (which shows a larger variety of colors, and allows you to define any custom colors).

NOTE: You can only enter integer values for line weight. If you type 2.8 in the text field, 2 will be applied instead.

TransparencySpecify the transparency of the line. The greater the value, the more transparent the line. 0 (zero) transparency makes the line completely
opaque, while 100 transparency makes the line completely transparent.
You can adjust the transparency either by dragging the slider, or by typing the value in the text field. Alternatively you can click on the

Opaque button  to set the fill color to opaque, or click on the Transparent button  to set the fill color to transparent.

PreviewThe Preview pane displays the line with the selected line format applied.
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Managing and applying styles
You can format shapes and connectors in  Logizian  by changing their attributes, such as line style, weight, color and transparency. Moreover, you
can apply your preferred styles or remove them after creating. Since adding and applying styles of shapes and connectors is as simple as clicking few
clicks, the newly created format settings will be applied on the selected shapes/ connectors easily and instantly.

Adding style
To open the Style dialog box, Select View > Styles... from the main menu.

In the Style dialog box, click Add... to create and edit a new style.

Style dialog box

In the  Edit Style dialog box, you can change the name, foreground line style, font style, background style and arrow style. Click OK button after you
finish editing the setting.

Edit Style dialog box

As a result, the style is created.

Newly created style

http://www.visual-paradigm.com/product/lz/
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Applying style
Upon keeping the Style dialog box open, select a target shape on the diagram and click Apply in the Style dialog box.

Apply style to selected shape

As a result, the shape is changed into the newly created style.
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Setting line style
Connectors are the lines that connect two shapes. It is much harder for us to distinguish the straight spaghetti-like connectors when more shapes
and more connectors are created. Logizian provides five connector styles to help you deal with the connectors, namely Rectilinear, Oblique, Curve,
Round Oblique and Round Rectilinear.

Setting connector line style
To change the style of a particular line, right click on the target connector and select Style and Formatting > Connector Style and one of five line
style options from the pop-up menu.

Change line style

As a result, the connector is changed into the selected line style.

Curve line

Line style options

Name Sample

Rectilinear

Oblique

Curve
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Round Oblique

Round Rectilinear

The description of five line style options

 

Setting diagram base line style
Additional to the five styles mentioned above, Follow Diagram feature is provided. If you want to change all connectors in the diagram, select Follow
Diagram and you don't have to change the line one by one after all.

To change the style of all lines on diagram, right click on the diagram background and select Connectors and one of five line style options  from the
pop-up menu.

Change diagram line style

As a result, all lines on the diagram are changed into the selected line style.

All lines are changed into curve
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Setting line jumps options
As more diagram elements on your diagram, more miscellaneous connectors are overlapped with each other. It is impossible to explicate on those
intersections which connector you indicate. The advantage of Line Jumps is to make one of the two connectors different to another to indicate that
which connector links with which diagram element clearly. Logizian provides four line jumps options to help you to distinguish connectors.

Setting connector line jumps options
To change the jumps option of a connector, right click on the connector, select Style and Formatting > Connector Style and then select an option
under Line Jumps.

Set Arc

Arc sample

NOTE: The line jumps options are available only when two connectors are overlapped.

Line jump options

Name Sample

 Off

  

 Arc
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 Gap

  

 Square

  

The description of 4 line jump options

Setting diagram base line jumps options
In addition to the 4 options mentioned above, Follow Diagram is another choice for altering the connectors. The prime feature of Follow Diagram is,
instead of setting it one by one, all connectors in the diagrams can be changed simultaneously instead of setting one by one.

Right Click on the diagram background, select Connectors and select one of four options under  Line Jumps from the pop-up menu.

Select Arc from the pop-up menu

Setting Line Jump for New Project
Select Tools > Project Options from the main menu.

In the Project  Options dialog box, open the Diagramming page, switch to the Connector tab and select the Line Jumps style, or select  Off to
disable it. At last, Click OK to confirm the changes.

Check  Arc in Options dialog box

Setting different line jump size
You can enlarge the line jump size to make the selected line jump (or all line jumps) on the connector(s) more obvious. Furthermore, the size of line
jump can be customized in either the current diagram or the future diagram. If you only want to set to the connectors of current diagram, right click
on the diagram's background, select Connectors and then a size option from the pop-up menu. Otherwise, if you want to set to the connectors of
future diagram, set it through Options dialog box. Three size are availabe for chooising. Normal is the standard size by default while extra large is the
maximum size.

Setting line jump size for current diagram
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1. Right click on the diagram's background, select Connectors and then a size option from the pop-up menu.

Set Large

2. The line jump(s) on the current diagram will turn into the size you selected.

Arc in large size

Setting line jump size for future diagram
1. Select Tools >  Project  Options from the main menu to open the Options dialog box.

2. In the Project  Options dialog box, click Diagramming page and open  Connector tab.

3. Under the Line Jumps section, check an line jump option and then select a line jump size option from Line jump size's drop-down menu.

Select  Large
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Setting connector caption orientation
Visual Paradigm supports a number of ways of aligning connector caption, which apply on different modeling preferences. By default, the caption
of a connector is aligned horizontal only, but you also can customize it to Follow Diagram, Horizontal Only, Horizontal or Vertical Only, Follow
Connector Angle, and Follow Connector Angle and  Keep Text Up Right. You can either customize it one by one or change all connectors in the
diagram which defined Follow Diagram.

Setting connector caption orientation
To customize the caption orientation option of a specify connector, select the connector, right click and select Style and Formatting > Connector
Style, and then select one of four options under Caption Orientation.

Change caption orientation to Follow Connector Angle

As a result, the caption orientation of connector is changed into the selected caption orientation option.

Follow Connector Angle

Caption orientation options

Name Sample Description

Horizontal Only The caption of connector is aligned horizontally.

Horizontal or Vertical Only The caption of connector is aligned either horizontally or vertically, according to the
connector.
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Follow Connector Angle The caption of connector is aligned the diagonal angles of both shapes.

Follow Connector Angle and Keep
Text Up Right

The caption of connector is aligned the diagonal angles of both shapes, but keeps
top right.

The description of 4 caption orientation options

 

Setting diagram base connector caption direction
In addition to the 4 options mentioned above, Follow Diagram is another choice for altering the connector. The main feature of Follow Diagram is, all
connectors in the diagrams can be changed simultaneously instead of setting one by one.

Right Click on the diagram background, select Connectors and select one out of four options under  Caption Orientation from the pop-up menu.

Change caption orientation

Workspace wide
Workspace wide setting affects the new connectors being created in projects created or will be created under the current workspace, including the
opening project. To set, select Tools >  Project  Options from the main menu.
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In the Project  Options dialog box, open the Diagramming page, switch to the Connector tab and select the desired way of aligning caption under
the Caption Orientation drop down menu. At last, click OK to confirm the changes.

Select Horizontal only in Options dialog box



Format copier P. 189

Format copier
Format is defined as the properties for a shape in terms of fill, line and font. Shapes are formatted for two major reasons: making your project more
attractive and giving emphasis on the meaning of shapes. However, it would be troublesome and time-consuming to repeat the same action when you
need other shapes to have exactly the same format as the previous one you have already done. Format copier can deal with this problem for you. It's
so handy that you can clone the formatting properties from one shape to another or even more.

To copy format to another shape
If you want another shape to have exactly the same formatting properties as the previous one you have done, you can simply:

1. Click on the shape that you want its format to be cloned.

2. Click on the  Copier button in toolbar.

Click Copier button

3. Click the shape you want to format.

Clone the format property from one shape to another

NOTE: You can copy formatting to another type(s) of shape.

To copy format to multiple shapes
If you want the format properties of your previous shape to be cloned to more than one shapes, you should:

1. Click on the shape that you want its format to be cloned.

2. Double click the Copier button on toolbar.

3. Click the shapes you want to format one by one.

Clone the format property from one to multiple shapes

NOTE: If you don't want the format properties to be cloned to other shapes any more, you should cancel cloning by clicking the Copier button
once again.

NOTE: You can only copy format to shapes within the same diagram.
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Set connection point style
The connection point of a connector is used to connect from the original shape to the target shape using a connector. In Logizian, you can choose one
of two kinds of connection point style: either Round the shape or Follow center for each shape. Round the shape allows you to set the last connection
point of the connector moving along the boundaries of the original shape while Follow center refers the last connection point of the connector depends
on the center of the original shape. The most attractive point of connection point style feature is that the animation of a connection point style will be
playing repeatedly once you select the corresponding connection point style.

 

You can compare the differences of two kinds of connection point style shown as follows:

Compare two kinds of connection point style

 

To set a connection point style:

1. Right click on shape and select Styles and Formatting > Connection Point... from the pop-up menu.

Open Select Connection Point Style dialog box



Set connection point style P. 191

2. In the Select Connection Point Style dialog box, choose a connection point style option. Click OK button.

Choose Follow center option
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Present shape as primitive shape
In addition to the standard appearance of notations (e.g. document for data object, circle for event, etc), here you have one more option - the primitive
option. The primitive option enables you to present any kind of shape as simple rectangle/oval/rounded rectangle shape. You can specify custom text
to such "primitive shape", which is particular useful for modeling for general-purposes. A sample use would be to present an actor that represents a
computer as a rectangle, and then describe its role with custom text and have it presented on diagram.

To show a shape as primitive shape:

1. Right click on the shape and select Presentation Options > Primitive Shape... from the popup menu.

2. Adjust the appearance of shape by setting Shape type.

3. Adjust the content of shape by setting Text. The Name option makes the name of shape presented. The Tagged value option enables you to
display the value of a specific tag. You need to enter the tag name in the drop down menu, or select from the list of existing tags. The Custom
option enables you to display whatever text you want.

4. Click OK when ready.
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General modeling techniques
This chapter covers all the general model techniques that increase the productivity of your work.

 

Automatic diagram layout

Helps you reorganize shapes and connectors on diagram to make diagram tidy. Several options are provided to produce different results of layout.

 

Fit shape size

To fit the size of shape against the update of shape content, or to fit manually.

 

Diagram element selection

Description of various ways of shape selection including traditional range selection and handi-selection.

 

Copy and paste

Common copy-and-paste editing features. Instead of pasting inside Logizian you can paste to external applications like MS Word, or to paste as XML
to aid in interoperability.

 

Alignment guide

Helps to make sure shapes are aligned well through the visible guide line.

 

Reverse connector direction

To immediately reverse the direction of connector without deleting and recreating it.

 

Visualize model elements on diagram

Shows you how to show a model element on a diagram.

 

Visualize related model elements

Shows you how to show related elements of a shape on a diagram.

 

Adding comments

Shows how to add comments to shapes or diagrams.

 

Pinning connector ends

By pinning a connector's end(s) you freeze their position and make them point to the desired position.

 

Align and distribute diagram elements

Describes the steps about aligning and distributing shapes.

 

Adjusting caption's position and angle

For BPMN event and gateway, their captions can be configured to show in specific orientation. You can also make it draggable (default not).

 

Zooming diagram

Magnify or diminish diagram content by zooming in and out.
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Automatic diagram layout
Logizian provides a layout facility for arranging diagram elements in diagrams. Diagram elements, which are re-layouts, do not overlap; the relationship
links, which are arranged, do not cross over each another. Different layout styles and configurable options are provided, which allows extremely flexible
and sophisticated layouts to be applied to diagrams.

Automatic layout diagram
There are a few different kinds of layouts: Auto Layout, Orthogonal Layout, Hierarchic Layout, Directed Tree Layout, Balloon Tree Layout,
Compact Tree Layout, Horizontal-Vertical Tree Layout, BBC Compact Circular Layout, BBC Isolated Circular Layout, Single Cycle Circular
Layout, Organic Layout, Smart Organic Layout.

Auto layout
Selecting auto layout signifies that the most suitable layout is arranged for shapes automatically. It is the best choice for users when they have no
preference in selecting a specific layout. To apply Auto Layout to the whole diagram, right click on the diagram background and select Layout > Auto
Layout from the pop-up menu.

Select Auto Layout

Auto layout of data flow diagram
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Auto layout

Orthogonal layout
Shapes are arranged based on the topology-shape-metrics approach in orthogonal layout. It is the best way for users to arrange shapes and
connectors in diagrams. As it is default layout in Logizian, every time you drag the models from the model tree to a diagram, the orthogonal layout will
be applied to arrange the newly created shapes in diagrams.

Orthogonal Layout

Layout Grid Size: the virtual grid size for layout. Each shape will be placed in accordance with its center point lays on a virtual grid point.

Orthogonal Layout dialog box
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Hierarchic layout
Hierarchic Layout arranges shapes in a flow.

Hierarchic Layout

Min. Layer Distance: the minimal horizontal distance between the shapes.
Min. Shape Distance: the minimal vertical distance between the shapes.
Min. Connector Distance: the minimal vertical distance of the connector segments.
Orientation: the layout direction for arranging nodes and connectors -top to bottom, left to right, bottom to top, and right to left.
Shape Placement: affects the horizontal spacing between shapes, and the number of bends of the connectors -pendulum, linear segments, polyline,
tree, simplex.

Hierarchical Layout dialog box
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Directed tree layout
Directed Tree Layout, which is one of the tree layouts in Logizian, arranges shapes in a tree structure. It is the best way for users to arrange shapes
except those which have hierarchical relationships, such as generalization relationships and realization relationships.

Directed Tree Layout

Min. Layer Distance: the minimal horizontal distance between the shapes.
Min. Shape Distance: the minimal vertical distance between the shapes.
Orientation: the layout direction for arranging nodes and connectors &ndash; top to bottom, left to right, bottom to top, and right to left.
Connector End Point Style: how the connector end points will be placed &ndash; shape centered, border centered, border distributed.
Orthogonal Connector: whether the connectors will be arranged in orthogonal.

Directed Tree Layout setting
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Balloon tree layout
Balloon Tree Layout, which is one of the tree layouts in Logizian, arranges shapes in a tree structure in a radial fashion. It is the best way for users to
arrange large trees.

Balloon Tree Layout

Min. Connector Length: the minimal distance between the connectors and shapes.
Preferred Child Wedge: the angle at which the child node will be placed around its parent node.
Preferred Root Wedge: the angle at which a node will be placed around the root node.
Root Node Policy: determines which node is chosen as the tree root node for layout &ndash; directed root, center root, and weighted center root.

Balloon Tree Layout setting
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Compact tree layout
Compact Tree Layout, which is one of the tree layouts in Logizian, arranges shapes in a tree structure. The aspect ratio (relation of tree width to tree
height) of the resultant tree can be set.

Compact Tree Layout

Horizontal Spacing: the horizontal spacing between the shapes.
Vertical Spacing: the vertical spacing between the shapes.
Min. Connector Length: the vertical distance of the connector segments.
Aspect Ratio: the relation of the tree width to the tree height.

Compact Tree Layout setting
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Horizontal-Vertical tree layout
Horizontal-Vertical Tree Layout, which is one of the tree layouts in Logizian, arranges shapes in a tree structure horizontally and vertically.

Horizontal-Vertical Tree Layout

Horizontal Spacing: the horizontal spacing between the shapes.
Vertical Spacing: the vertical spacing between the shapes.

Horizontal-Vertical Tree Layout setting
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BBC compact circular layout
BBC Compact Circular Layout, which is one of the circular layouts in Logizian, arranges shapes in a radial tree structure. The detected group is laid out
on the separate circles. It is the best way for user to arrange shapes that belong to more than one group with a ring structure.

BBC Compact Circular Layout

Maximal Deviation Angle: the maximal angle of deviation.
Preferred Child Wedge: the angle at which the child node will be placed around its parent node.
Minimal Edge Length: the minimal distance between the shapes.
Compactness Factor: the parameter that affects the length of connector. The smaller the compactness factor, the length of connectors will be shorter
and the layout will be more compact.
Allow Overlaps: whether the shape can be overlapped.

BBC Compact Circular Layout setting
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BBC isolated circular layout
BBC Isolated Circular Layout, which is one of the circular layouts in Logizian, arranges shapes into many isolated ring structures. It is the best way for
users to arrange shapes that belong to one group with ring structure.

BBC Isolated Circular Layout

Maximal Deviation Angle: the maximal angle of deviation.
Preferred Child Wedge: the angle at which the child node will be placed around its parent node.
Minimal Edge Length: the minimal distance between the shapes.
Compactness Factor: the parameter that affects the length of connector. The smaller the compactness factor, the length of connectors will be shorter
and the layout will be more compact.
Allow Overlaps: whether the shape can be overlapped.

BBC Isolated Circular Layout setting
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Single cycle circular layout
Single Cycle Layout, which is one of the circular layouts in Logizian, arranges shapes in circular structure in single circle.

Single Cycle Circular Layout

Choose radius automatically: determine the radius of circular structure automatically or manually.
Minimal Node Distance: the minimal distance between the nodes.
Fixed radius: the radius of circular structure.

Single Cycle Circular Layout setting
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Organic layout
Organic Layout, which is one of the organic layouts in Logizian, arranges shapes in a star or ring structure. It is the best way for users to arrange the
shapes that have highly connectivity relationship.

Organic Layout

Activate Deterministic Mode: whether the layouter is in deterministic mode.
Activate Tree Beautifier: whether or not to activate the subtree beautifier.
Attraction: the degree of the attraction between shapes.
Final Temperature: the factor that affects the distance between shapes.
Gravity Factor: the factor that affects the distance between shapes and the center.
Initial Placement: the initial value of placement.
Initial Temperature: the initial value of temperature.
Iteration Factor: the degree of iteration.
Maximum Duration: the maximum degree of duration.
Obey Node Size: the size of obey shapes.
Preferred Edge Length: the preferred length between the nodes.
Repulsion: the factor that affects the distance between shapes which belong to the same ring or star structure.

Organic Layout setting
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Smart organic layout
Smart Organic Layout, which is one of the organic layouts in Logizian, is a variant of the Organic Layout. It can set the ratio of the quality: producing
time of layout and controls the compactness of layout.

Smart Organic Layout

Compactness: the factor that sets less/more compact layout.
Deterministic: whether the layouter is in deterministic mode.
Minimal Node Distance: the minimal distance between nodes.
Node Overlaps Allowed: whether the node can be overlapped.
Node Size Aware: whether the node size can be aware.
Preferred Minimal Node Distance: the preferred minimal distance between the nodes.
Quality Time Ratio: the ratio of the quality of layout to the producing time of layout.

Organic Layout setting
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Automatic layout selected shapes
To layout all the shapes in the diagram, right-click on the diagram and select Layout and then select one of five layout options from the pop-up menu.
On the other hand, if you want to layout the selected shapes, right click on one of the selected shapes and select  Layout  and then select one of five
layout options from the pop-up menu (make sure there are more than one shapes selected).

Perform layout with selected shapes

Automatic route connectors
There are 2 kinds of layouts which do not change the location of shapes, only change the connectors: Organic Edge Route Layout and Orthogonal
Edge Route Layout.
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Organic edge route layout
Organic Edge Route Layout, which is one of the edge route layouts in Logizian, arranges the connectors without affecting the location of shapes. It can
ensure that the shapes will not overlap and keep a specific minimal distance.

Organic Edge Route Layout

Minimal Distance: the minimal distance of the connectors.
Route All: whether all the connectors will be routed.
Use Existing Beans: whether using existing bends.

Organic Edge Route Layout setting



Automatic Diagram Layout P. 208

Orthogonal edge route layout
Route Connectors can arrange the connectors using vertical and horizontal line segments only. It is the best way for users to arrange the connectors
that have complicated route.

Orthogonal Edge Route Layout

Center to space ratio: the ratio of center to the distance between center and nodes.
Coupled distances: the distance between coupled nodes.
Crossing cost: the cost of crossing connectors.
Custom border capacity: the capacity of the border.
Local crossing minimization: whether the local crossing of connectors will be minimized.
Minimum distance: the minimum distance of connectors.
Minimum distance to node: the minimum distance between the shapes.
Rerouting: whether the connector that has many crossings will be rerouted.
Routing style: the style of routing.

Orthogonal Edge Route Layout setting
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Fit shape size
In some cases, shapes are found oversized. For better presentation, you may need to resize them smaller. Fit size can help you adjust shapes into the
smallest size based on their content, such as the name of shape. The size of shapes can be fixed either manually or automatically.

NOTE: The size of shapes can be fixed automatically by right clicking on the diagram's background and checking Diagram Content> Auto Fit
Shapes Size.

Fit selected shapes size
To adjust a particular shape size, move the mouse over the shape and fit size resource centric interface will be revealed. Click Fit Sizeresource icon at
the bottom of the shape.

Click Fit Size

To fit several shapes' size, select those shapes on diagram, right click on one of the selected shapes and then select Selection > Fit Size from the
pop-up menu.

Fit size for several shapes from the pop-up menu

Each shape will be adjusted to its fit size in accordance with its content, instead of fixing all selected shapes into the exactly same size.

Shapes are fitted size
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Check/uncheck automatic fit shape size mode
You can check/ uncheck the Auto Fit Shapes Size on diagram to make all the shapes on the diagram to be fitted size automatically. To do so, right
click on the diagram's background, select Diagram Content > Auto Fit Shapes Size from the pop-up menu.

Check Auto Fit Shapes Size from the pop-up menu

All the shapes are subsequently fitted size and they will become non-sizable.

If the content of shape is changed, the shape itself will be resized automatically.

Shape is resized automatically

You can also check Auto Fit Size for future usage.

1. Select Tools >  Project  Options... from the main menu to unfold Options dialog box.

2. In the Project  Options dialog box, press the Diagramming category, select the Shape tab and check Auto fit size (diagram-based).

Check Auto fit size (diagram-based) in the  Options dialog box
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Diagram element selection
When a number of diagram elements need selecting simultaneously, diagram element selection supports this purpose. You can either click directly with
hot keys or select a range of selection with the mouse. A specific type of diagram element(s) on a diagram can be selected as well.

Selecting multiple shapes
Multiple shapes can be selected by either selecting a range of shapes with the mouse on diagram or clicking shapes with pressing hot keys.

Selecting a range of shapes with the mouse
1. For selecting multiple shapes, drag them from corner to corner diagonally with the mouse. They will then be surrounded by a rectangle

individually.

Select multiple shapes with the mouse

2. After releasing the mouse, those shapes will be selected.

Shapes are selected
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Clicking with pressing ctrl/Shift key
Click a shape in advance and then click other shapes with pressing Ctrl or Shift key. As a result, those shapes will be selected.

Click shapes with pressing Ctrl or Shift key

Handi-Selection
In some cases, the shapes are too complicated and more seriously, the whole diagram is extremely enormous that neither selecting a range of shapes
with the mouse nor clicking shapes with pressing Ctrl or Shift key are the most suitable application. It is hard to drag the mouse on the large diagram,
or is troublesome to click on many shapes. Using Handi-Selection is probably the best choice for you in this situation.

1. Right click on the diagram's background where is in the vicinity of those shapes you are going to select, select Handi-Selection and then select
a scope for selecting shapes (i.e. above/ below/ left/ right) from the pop-up menu.

Select all shapes on the right from the pop-up menu

2. As a result, all the shapes of the particular scope will be selected.

All shapes on the right are selected
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Selecting same type of shapes
When you want to select a few shapes of same types on the diagram, right click on a shape and select Selection > Select All of Same Type from the
pop-up menu. As a result, other shapes of same type as the shape you selected previously will be selected.

All shapes of same type are selected

Inverse selection
Shapes can be selected inversely. Right click on a shape that you don't want to be selected and select Selection > Select Inverse from the pop-up
menu. As a result, all shapes will be selected except the shape you previously right clicked on.

Selection is inversed
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Copy and paste
You can create a view of a model element by copying a view and pasting as view, while pasting as model creates a new model from the copied one.

Copying within Logizian
1. Right click on the selected shape(s), select Copy > Copy within Logizian from the pop-up menu.

Copy selected shapes with Logizian

2. After you switch to the destination diagram, right click on the diagram background and select either Paste View or Paste Model from the pop-up
menu. The feature of Paste view refers to present the same model element in another view under a new context. The shape is pasted without
creating model; while the feature of Paste Model refers to duplicate the shape and present it in a new view. The model will be copied and
pasted on the diagram. The new model will be named with appending a sequential number.

Paste the selected shape

Copying to clipboard as image (JPG)
1. Right click on the selected shape(s) and select Copy > Copy to Clipboard as Image (JPG) from the pop-up menu.

2. When the Copy as Image Option dialog box pops out, select an option from the drop-down menu of Copy type. Click Copy button to proceed.

Select an option from the drop-down menu of Copy type
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3. You should select a destination document (e.g. MS Word) for pasting the copied shape(s) to do further documentation. After you switch to the
destination document, right click on the desired place and select Paste from the pop-up menu.

4. As a result, your selected shape(s) will be pasted on the destination document.

Copying to clipboard as image (EMF)
1. Right click on the selected shape(s) and select Copy > Copy to Clipboard as Image (EMF) from the pop-up menu.

2. When the Copy as Image Option dialog box pops out, select an option from the drop-down menu of Copy type. Click Copy button to proceed.

3. EMF is a kind of scalable image which can be pasted on a document for further documentation. After you switch to the destination document,
right click on a desired place and select Paste from the pop-up menu.

4. As a result, your selected shape(s) will be pasted on the destination document.

Copying as XML
You can convert selected shapes into XML which contain the data of selected shapes in XML format. The XML data can then be imported into another
project.

1. Right click on the selected shapes and select Copy > Copy as XML from the pop-up menu.

2. Open a text editor and create a new text file. Paste the XML there and save it as an XML file.

3. After that, the file can be imported to another project by selecting File > Import > XML.

4. When  Import XML dialog box pops out, select the xml file path. Finally, click OK button to proceed.

Select the xml file path

Copying to Diagram
1. You can also copy the selected shape(s) to either a new diagram or an existing diagram. Right-click on the selected shapes, select Copy >

Copy to Diagram... from the pop-up menu.

2. When the Copy to Diagram dialog box pops out, check Create new diagram if you want to paste to a new diagram or check Select an
existing diagram if you want to paste to an existing diagram.

Check Create new diagram
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3. Click Copy to button. As a result, the selected shape(s) will be duplicated on the selected diagram.

Duplicating
With the feature of duplicate, shapes can be duplicated on the same diagram instantly.

1. Right click on the selected shape(s) and select Duplicate from the pop-up menu.

Duplicate a selected shape

2. As a result, the selected shape(s) will be duplicated.

The shape is duplicated
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Alignment guide
Alignment is the adjustment of an object in relation with other objects. Therefore, the diagram alignment means adjusting a shape's position with
another's (or others') in a straight line or in parallel lines. When you drag shapes, alignment guide will appear to let you position the dragging content in
accordance with existing shape(s).

Show edges alignment guide
When you drag a shape upward or downward, two horizontal lines will reveal on the both edge of the shape as an offer of assistance for adjusting the
shape's position.

Drag upward

Similarly, when you drag a shape to the left or the right, two vertical lines will reveal on the both edge of the shape.

Drag to the right

Show center alignment guide
When you drag a shape upward or downward, a horizontal line will reveal in the center of the shape as an offer of assistance for adjusting the shape's
position.

Drag upward

Similarly, when you drag a shape to the left or the right, a vertical line will reveal in the center of the shape.

Drag to the right

Change alignment guide options
If you want the alignment guide to help you position when you drag shapes, check Show diagram alignment guide; on the contrary, uncheck it if you
don't need a help. Two Choices are provided in alignment guide: Show edges and Show center. Choose  Show edges if you want two horizontal
lines to reveal on the both edge of the moving shape while choose Show center if you want a horizontal line to reveal in the center of the shape.

1. Select Tool > Application Options... from the main menu to unfold Options dialog box.
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2. In shortcut, typing Alignment guide on top-left text field for searching. It will be shown that the option of alignment guide is on Diagramming
category, Environment tab shortly. As you see, the option will be highlighted for your convenience.

Change  alignment guide options

3. The option for  alignment guide is checked as default. The next step you need to do is to choose either Show edges or Show center for your
diagrams.

4. Uncheck Show diagram alignment guide if you do not want the assistance of alignment guide when dragging shapes.



Reverse Connector Direction P. 219

Reverse connector direction
The flow between shapes is represented by connectors, for example, a sequence flow between task 1 and task 2 which represents the sequence of
task from task 1 to task 2. If the flow is created mistakenly, or the flows need reverting due to an updated data, the flows can be fixed by reverting
connectors.

Reverse connector direction
1. Right click on the connector between two shapes and select Reverse Connector from the pop-up menu.

Select  Reverse Connector from the pop-up menu 

2. As a result, the flow of connector is reversed.

Connector is reversed

NOTE: This feature is only available for sequence flow of business process diagram.
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Visualize model elements on diagram
Model elements are fundamental parts of a project. While a model element can be shown on more than one diagram, a diagram can also show a
model element more than once. They, which can be found in Model Explorer, contain metadata and can be shown in diagram for visualizing the data.

To visualize a model element or several model elements:

1. Select a model element (or as many as model elements you preferred) from Model Explorer.

Select several model elements from Model Explorer

2. Hold on the mouse and drag it on the diagram pane. As a result, the views of the selected model element(s) will be shown on diagram.

Drag the model elements on diagram
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Visualize related model elements
Sometimes, several model elements that related to the current model element(s) are hidden for various reasons. These related model elements, in
fact, can be revealed through the feature of visualize related model element. With this feature, the relationship between model elements can be viewed
thoroughly.

1. Right click on a model element and select Related Elements > Visualize Related Model Element... from the pop-up menu.

Select Visual Related Model Element...

2. When Visualize Related Model Element dialog box, check the related element(s) you want to be shown with the corresponding relationship on
the diagram in Visualize. Click Visualize button to proceed.

Visualize Related Model Element dialog box
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3. As a result, the related models with connectors are shown on the diagram.

Related model elements are visualized
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Adding comments
Logizian supports comments on model elements. Since comments are usually used to record the progress and status of model elements, they are
regarded as a textual annotation for model elements.

Adding comment to model element
1. For adding comment in a particular shape, right click on the shape and select Open Specification... from the pop-up menu.

Open specification

2. In specification dialog box, select Comments tab and click Add... button to create a comment.

Add comment

3. In  Comment Specification dialog box, enter summary, author and date time respectively. Select OK button to confirm editing.

Enter information in Comment Specification dialog box
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4. As a result, the comment you entered previously is shown on Specification dialog box.

Managing comment of model element
1. To modify comment in a particular shape, right click on the shape and select Open Specification... from the pop-up menu.

2. In Specification dialog box, click Comments tab, select a specified summary comment and click Open Specification... button to proceed.

Open specification

3. In Comment Specification dialog box, modify information and select OK to confirm changing.

Modify information
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Pinning connector ends
Connectors can be either pinned temporarily or pinned permanently. Connector ends help you to point out a specific position of shapes with pin.

Adjusting connector ends temporarily
1. Connectors can be joined at same point of a shape on the diagram. To do so, drag one end of a connector to the shape.

Drag one end of a connector to a shape

2. The connector is temporarily pinned. A dialog box will be shown on the top right corner of diagram to instruct you how to pin the connector.

Connector is temporarily pinned

3. Since the connector that links from shape and to shape together is temporarily pinned, either from shape or to shape is moved, the connector
between them will be unpinned.

Connector is unpinned

Pinning connector ends
1. Move the mouse over a connector and press its resource icon Pin.

Press resource icon Pin

2. Drag one end of connector to point out a specific position. Note that no dialog box of temporary pin will be shown this time.

Drag one end of connector to point out a specific position
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3. Moving either from shape or to shape will not unpin the connector.

Connector is still pinned
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Align and distribute diagram elements
Logizian supports two types of positioning features: alignment and distribution which allow the positioning of selected shapes in accordance with the
alignment/ distribution option through the toolbar or grouping resource icons. Alignment refers to the edges and the centers of selected shapes are
aligned to each other while distribution refers to selected shapes are distributed in same direction based on their centers or edges.

Aligning diagram elements
Select a few model elements on the diagram pane before executing alignment.

Selected shapes

 

Through toolbar
Select Edit > Align Shapes from the main menu and then select an align option.

Through grouping resource icons
1. When move the mouse over one of the selected shapes, grouping resource icons will be shown.

2. Select an alignment option from the drop-down menu of Align Top on the grouping resource icons.

Select  Align Left on resources

3. As a result, all selected shapes are aligned in accordance with the last selected shape.

Shapes are aligned

Setting model elements same width and height
Besides aligning the shapes, shapes can also be resized through the main menu, grouping resource icons or Align Shapes Dialog.

Through main menu
Select Edit > Align Shapes  and then select an option from the main menu after select a few shapes on the diagram.
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As a result, the shapes are resized.

Shapes are resized

Through grouping resources
Select an option from the drop-down menu of Same Width on grouping resource icons after select a few shapes on the diagram pane.

Resize through grouping resources

Through align shapes dialog
After select a few shapes on the diagram pane, select Edit > Align Shapes > Align Shapes... from the main menu to unfold Align Shapes Dialog.
You can select an option by clicking the option button directly.

Align Shapes Dialog
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Distribute diagram elements
In addition, model elements can be distributed in various directions through Distribute Shapes Dialog, the main menu or grouping resource icons.

Through Distribute Shapes Dialog
After select a few shapes on the diagram pane, select Edit > Distribute Shapes > Distribute Shapes... from the main menu to unfold Distribute
Shapes Dialog. You can select an option by clicking the option button directly.

Distribute Shapes Dialog

Through main menu
Select Edit > Distribute Shapes and then select a distribution option from the main menu after select a few shapes on the diagram pane.

Through grouping resource icons
Select a distribution option from the drop-down menu of  Distribute Horizontally on grouping resource icons after select a few shapes on the diagram
pane.

Distribute shapes on grouping resource icons
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Adjusting caption's position and angle
For shapes like event and gateway, their names are put outside and below the shape, which may overlap with outgoing sequence or message flow,
making the name hard to read. To solve this problem, you can choose to place the caption elsewhere. Furthermore, you can rotate the caption to make
it easier to read in print out.

To set the position and angle of start, intermediate or end event, or gateway:

1. Right click on the shape and select Presentation Options > Caption Placement... from the popup menu.

To change caption placement

2. Choose the placement, which is the position of caption. For some of the placement options, you can choose additionally the rotation of
placement. You can preview the changes in the preview pane.

To choose a placement option

3. Click OK to confirm.

Caption position updated
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Zooming Diagram
An active diagram can be viewed in Diagram Overview automatically. If the diagram on diagram pane isn't clear enough, you can zoom in the diagram
with your desired size through  Diagram Overview .

1. Open Diagram Overview.

Diagram Overview

2. Drag the bottom right corner of the right purple box to zoom in/out the diagram. Alternatively, click on the buttons in toolbar or input the zoom
ratio into the combo box to adjust the zoom ratio.

Roll up the mouse wheel

http://www.visual-paradigm.com/support/documents/lzuserguide/588/592/32562_diagramoverv.html
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Advanced modeling techniques
This chapter covers less frequently used or comparatively complex modeling techniques.

 

Sweeper and magnet

Sweeper and magnet are handy tools for moving a group of shapes back and forth.

 

Mouse gestures

You can create shapes, connect shapes, or perform certain operations through pressing and dragging your right mouse button. You can gain more
information in the Mouse gestures page.

 

Jumping to shape

When you are looking for a shape, a diagram or a model element, you can make use of the jump to feature to enter its name and jump to it
immediately. It's like a commonly-known search function, but a faster approach.

 

Grouping diagram elements

You can more and format shapes by grouping them together. You will see how to group diagram elements on a diagram.

 

Show/hide diagram elements

You can optionally hide away some of the diagram elements on a diagram, or hide specific type of elements.

 

Layer

Layer provides a logical shape division in diagram. For example, a comment layer for annotation shapes. You can hide, lock and set active to a layer.

 

Making shape non-selectable

You can make shape non-selectable to avoid accidental movements for particular shapes. This is particular helpful when trying to move shapes in a
container like package, without moving the package by mistake.

 

Showing model element in multiple diagrams

A model element can have multiple views. In this page you can see how to make use of drag and drop to create multiple views for a model element.

 

Using overview diagram

Overview diagram is best used to illustrate the relationship between diagrams, hence the content (e.g. interaction) they represent.
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Sweeper and Magnet
Modifying your diagrams from time to time is no longer a drag-- let's take our utilities: sweeper and magnet which can help you modify your diagrams
efficiently. With these two features, you can move diagram elements easily without worrying too much about the layout. Sweeper can help you to
increase more space between the diagram elements while Magnet can help you diminish the space.

Sweeper
The sweeper is one of the useful features for editing your diagrams. If you have ever experienced of moving the diagram elements without any tools,
you probably understand how hard it is to manage the space between the diagram elements. Using sweeper to extend the space between the diagram
elements allows you to move your diagram elements conveniently.

You can move the diagram elements by following the simple steps below:

1. Click Sweeper button from the diagram toolbar.

Click Sweeper

2. Move the mouse over the diagram pane where you would like to move diagram elements.

3. Hold onto your mouse and move the line horizontally or vertically.

Moving the diagram element to the right

Magnet
The magnet is another convenient feature for you to move your diagram elements. If you want to move a few diagram elements, you should try
magnet. Its function is to diminish the space between the diagram elements and make your diagrams much tidier for printing. The steps of applying
magnet on your diagram are shown as follows:

1. Click Magnet button from the diagram toolbar.

Click Magnet

2. Move the mouse on the diagram pane where you would like to move diagram elements.
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3. Hold onto your mouse and move the line horizontally or vertically.

Moving the diagram element to the left
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Mouse gestures
A variety of shapes and model elements can be created by sketching a path directly on the diagram pane with dragging the right mouse button to form
a gesture. For your convenience and quick creation, mouse gestures allow you to execute common commands and create most shapes within all
diagrams.

Drawing shapes
1. To start using a mouse gesture, press the right mouse button and drag it until finish drawing a shape.

Draw a shape

2. When the shape is done, release the mouse. After the shape is created, the action description  will be shown on top right corner of the diagram.

Task created

Connecting shapes
1. Draw a line from one shape to another.

Drawing from a shape to another

2. After the mouse is released, a connector is created between two shapes.

Two shapes are connected

Creating a new shape
1. A new shape can also be created. To do so, draw a line from an existing shape to your preferred place.

Drawing a line
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2. After the mouse is released, a pop-up menu will be shown. You can select your preferred type of connector and shape from the pop-up menu.

Pop-up menu is shown

3. A new shape is created with connector.

A new task is created

List of supported mouse gestures

General

Icon Description

Layout diagram

Open diagram specification

Connect new shape

Connect existing shape

Close Diagram

Thumbnail view

The description of general mouse gestures

Business process diagram

Icon Description

Sub-process

Pool/ Task
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Horizontal Lane (you should create a horizontal pool before create horizontal lane)

Vertical Lane (you should create a vertical pool before create vertical lane)

The description of mouse gestures for business process diagram

Data flow diagram

Icon Description

Process

External Entity

Data Store

The description of mouse gestures for data flow diagram

Entity relationship diagram

Icon Description

Entity

Add column

The description of mouse gestures for entity relationship diagram

Overview diagram

Icon Description

Diagram Overview

The description of mouse gestures for class diagram
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Jumping to shape
For searching shape/shapes faster, the application of the jump to shape/shape facility is introduced. You can select either jump to a model element in
an active diagram, or jump to any model elements in the current project, or even jump to a diagram in current project.

Jumping to a diagram/model element in project
If an active diagram is opened, you can jump to the model element in the active diagram. 

1. You can select Edit > Jump to Element in Active Diagram... from the main menu or press Ctrl+J to unfold Jump to dialog box.

2. Apart from jumping to element in active diagram, you can also jump to any element within the project. You may select Edit > Jump to
Element... from the main menu or press Ctrl+Shift+J to unfold Jump to dialog.

3. In Jump to dialog box, if you want all elements within project to be searched, uncheck the Active diagram only checkbox. In some cases, the
checkbox is disabled because no diagram is opened.

Jump to dialog box is shown

4. Enter a word in the text field, a list of model element's name that starts with the word you typed will be shown .

 A list of possible shapes is shown
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5. Press Down key to search for the model element's name if the list is too long. Click your preferred model element's name and it will be spot-
lighted on the active diagram.

Shape is spot-lighted

6. Press Enter to confirm jump to the model element. Finally, the Jump to dialog box will then be hidden and the model element will be selected
on diagram.

Shape is selected after confirm jump to
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Filtering with wild card character
For quick search, you can type a word with * in the text field. The asterisk can substitute a character or a word when you don't remember the exact
spelling. As a result, all names of shape that similar to the word you typed will be shown.

Entering name with *

Jumping to diagram
1. To do so, select Edit > Jump to Diagram... from the main menu or press Ctrl+Shift+D to show Jump to dialog box.

2. Jump to dialog box is shown with selected Diagram in combo box. It means Jump to dialog box will search all diagrams within the project.

Jump to dialog is shown

3. Enter any key word of the whole diagram's name will show a list of diagrams' names similar with the word you typed . Select the diagram and
press Enter will open the diagram.

Easy navigation to connected elements
If you have an oversized diagram that the from/to model elements of connector can't be shown on the screen, it is hard for you to know the from/to
model elements. VP-UML supports Scroll to function to scroll to from/to model element of a connector. If you want to know which model element is the
from model element that is connected with a model element .

To achieve this:
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1. Right click on the connector and select Scroll to and then select Source with parentheses from the pop-up menu. (The word in parentheses is
the name of the from model element.)

Scroll to from model element

2. The from model element is subsequently selected on diagram.

From model element is selected
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Grouping diagram elements
After you have aligned shapes to a group of shapes, in some cases, you want to move a number of shapes simultaneously, or share the same
formatting properties with each other shapes, like background color and line formatting. Grouping can help you for this purpose exactly. By grouping
shapes, shapes within the group will move together when moving any shape inside the group. If you edit formatting of one shape, all shapes will also
be shared.

Grouping diagram elements
1. Select those shapes you want them to be grouped together.

Select shapes

2. Click resource icon  Group to group the selected shapes.

Group through resource icon Group

3. When you move a shape, other shapes within the same group will also be moved.

All shapes in group are moved together

Ungrouping diagram elements
To ungroup the shapes, click resource icon Ungroup.

Click Ungroup
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Show/hide diagram elements
On a complex diagram, to hide or show some of the shapes is necessary. You can choose to hide away diagram elements on a diagram temporarily.
For example, hiding away annotation shapes which record internal communications before printing out a diagram for customers' review. In Logizian,
hiding of diagram elements can be done per shape, per shape type or by stereotype.

Hiding selected diagram element(s)
Right click on the selected shape(s) and select Selection > Hide from the pop-up menu.

Select Hide from the pop-up menu

Apart from the selected shapes, its related shape(s) (e.g. children and relationship) will also be hidden.

The selected shape and its relationship are hidden

NOTE: To hide a shape will also make the connectors that attached to it hidden.

NOTE: To hide a container shape (e.g. package) will also make the contained shapes hidden.
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Hiding diagram elements by shape type
All the shapes with same type from the diagram can also be hidden. Right click on the diagram's background and select Diagram Content > Show/
Hide > Hide by Shape Type, and then select  the shape you want to be hidden from the pop-up menu. As a result, all shapes with the same type you
selected will be hidden.

Hide all shapes by shape type
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Hiding diagram elements by stereotype
The stereotype of all diagram elements from the diagram can be hidden. Right click on the diagram's background and select Diagram Content >
Show/Hide > Hide by Stereotype, and then select one stereotype out of the list from the pop-up menu. As a result, all shapes with same stereotype
you selected will be hidden.

Hide all shapes by stereotype

Showing all hidden diagram elements
All hidden shapes from the diagram can be shown again. Right click on the diagram's background and select Diagram Content > Show/Hide > Show
all Diagram Elements. As a result, the hidden shapes will be shown on the diagram.

Managing show/Hide of specific diagram element(s)
A better management of showing and hiding the shapes can be done in Show Hide Diagram Elements dialog box.
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1. Right click on the diagram's background, select Diagram Content > Show/Hide > Show/Hide Diagram Elements... from the pop-up menu.

Select  Show/Hide Diagram Elements... from the pop-up menu

2. When Show Hide Diagram Elements dialog box is unfolded, you may select the shape(s) you would like to be hidden or to be shown. Click the
diagram element you would like to move to Hide list and press  Hide Selected button; on the other hand, click the diagram element you would
like to remove it back to Show list and press Show Selected button. For moving all diagram elements to Hide list, press Hide All button; press
Show All button, vice verse. Finally, click OK to confirm.

Select a diagram element to be moved to Hide list

NOTE: If a shape is selected from Show list, the related shape(s) and relationship of the selected shape will be also removed to Hide list.
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Layer
Occasionally, you may experience deal with a number of shapes with difficulties. Logizian supports multi-layers to help you to manage different shapes
efficiently. The functions of layer assist you in assigning different shapes into different layers, hiding unnecessary shapes, locking for shapes and
selecting shapes in shortcut. 

Creating a layer
1. Right click on the diagram background and select Layers... from the pop-up menu.

Select Layers... from the pop-up menu

2. In  Diagram Layers dialog box, click Create new layer button to create a new layer.

Create a new layer in Diagram Layers dialog box
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3. Finally, define the name for the newly created layer.

New layer will be an active layer

Sending shapes to a layer
The existing shapes are kept in default layer. However, both existing shapes and the newly created shapes on diagram can be sent to a new layer.

Create a new layer just like the steps of previous section. Right click on a shape and select  Layers, and then select the new layer you have created.

Send the shape to a new layer

As a result, the shape you selected will be sent to the new layer.
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Hiding shapes on a layer
In Diagram Layers dialog box, you can make a layer invisible on diagram. To do so, uncheck Visible of the layer.

Shapes on the layers are invisible on diagram
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Locking shapes on a layer
In Diagram Layers dialog box, check Locked to make all shapes in that layer immovable and unable for editing while uncheck Locked to make them
movable and editable.

Shapes on the selected layer are locked
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Selecting shapes on a layer
You can also select all shapes of the selected layer. To do so, click Select shapes in selected layers button on Diagram Layers dialog box.

Shapes of the layer are selected on diagram
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Making shape non-selectable
If you find it annoying to move some shapes carelessly or select some shapes accidentally, the selectable/non-selectable feature would be your ideal
trouble-shooter. This page is going to teach you how to make shapes non-selectable or even change them back to selectable with only few clicks.

Changing the shape to non-selectable
1. Right click on the selected shape(s), uncheck Selection > Selectable from the pop-up menu.

Uncheck selectable for the selected shape

2. After the shape is non-selectable, click the shape cannot make it to be selected. Neither will the shape be selected by mouse dragging on
diagram.

3. Therefore, the non-selectable shape(s) will not be moved when other shapes are moved.

Changing the shape to selectable again
To make the shape selectable again, right click on the non-selectable shape and select Selectable from the pop-up menu.

Select Selectable

Setting all shapes to selectable or non-selectable
To makes all shapes on the diagram to be selectable or non-selectable, right click on the diagram background, select Diagram Content and then
select Make All Shapes Selectable if you want all shapes on the diagram to be selectable or select  Make All Shapes Non-Selectable if you want all
shapes to be non-selectable from the pop-up menu.

Select Make All Shapes Selectable
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Showing model element in multiple diagrams
You can show a model element in multiple diagrams to fit into different contexts. To show model elements on different diagrams, you may drag and
drop the model element(s) from the tree to the diagram, or copy and paste it as view. 

Reusing model elements
In Model Explorer, a model element or several model elements from the source diagram can be dragged from the tree and drop it/ them on the
destination diagram.

Drag a model element from the tree

Alternatively, you may copy and paste the selected model element(s) as view in destination diagram. Right click on the selected model element(s) in
the source diagram and select  Copy > Copy with Logizian from the pop-up menu.

Copy a model element

When you switch to the destination diagram, right click on the preferred place that you want the copied model element(s) to be pasted on and select
Paste View from the pop-up menu. 

Entity Engine is pasted as a new view

NOTE: Choosing  Paste Model means a new model element will be created and shown on the destination diagram.

The relationship between the model elements may not be shown on diagram. If you want their relationship to be revealed, right click on the model
element, select Related Elements > Visualize Related Model Element... from the pop-up menu.

When the Visualize Related Model Element dialog box pops out, check a relationship for the model element(s) and then click the Visualize button to
proceed.



Showing model element in multiple diagrams P. 254

As a result, their relationship is shown on the diagram.

Relationship is visualized

Opening other views
You can find out the source diagram of a model element by right clicking on it and select Related Elements > Show Other Views... from the pop-up
menu.

Click Show Other Views...
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All diagrams, which contain the same model elements you selected, are listed and shown in the Show View dialog box. You can check a diagram
under Views and preview it under  Preview; furthermore, click Go to View button to jump to and view the actual diagram.

Show View dialog box



Using Overview Diagram P. 256

Using overview diagram
When various diagrams with different contexts are modeled in your system, an overview diagram can be created to illustrate their relationships related
each other. With the overview diagram, you can have an overview of your system, after all, you can study their relationships. Since the overview
diagram is consist of thumbnail of diagrams that you have created previously, the overview of each diagram if find to be related to another diagram can
be linked up with connectors.

Creating an overview diagram
• Click on Diagrams on toolbar and select Overview Diagram from the drop down menu .

• Right click on Overview  Diagram   in Diagram Navigator, under the Others category, and select New Overview  Diagram from the popup
menu.

• Select File > New Diagram > Others >  Overview  Diagram from the main menu.

As a result, an empty overview diagram is created. Create overviews of diagrams and relate them to illustrate their relationship with each other.

The overview diagram

Creating an overview of new diagram
You can create a diagram from overview diagram. To create a new diagram from overview diagram, select your preferred diagram type from the
diagram toolbar and drag it on the diagram pane.

Create a data flow diagram overview

The new diagram will be opened subsequently. Enter a name for new diagram and start working on it.
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If you go back to the overview diagram, the preview of newly created diagram can be seen. If you realize that the diagram in diagram overview is too
small and vague for previewing, you may resize the diagram overview by dragging its bottom right corner.

The newly created diagram is shown on overview diagram

Creating an overview of existing diagram
Besides creating an overview diagram of new diagram, you can also create an overview of existing diagram.

1. Create a diagram overview from the toolbar of overview diagram.

Create a diagram overview

2. Right click on the diagram overview and select Associate to Diagram... from the pop-up menu.

3. Select a diagram that you want to be shown on diagram overview  and select OK button.

Select an existing diagram

4. As a result, the selected diagram will be shown on diagram overview. If you realize that the diagram in diagram overview is too small and vague
for previewing, you may resize the diagram overview by dragging its bottom right corner.

The selected diagram is shown
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Visualizing sub-diagram
When a diagram overview you created has a sub-diagram, you can connect them together and make them shown on the current overview diagram.

Move the mouse over a diagram overview and click its resource icon Visualize Related Diagrams.

Press Visualize Related Diagrams

As a result, the sub-diagram will be shown and both diagram overviews are connected.

Two diagram overviews are connected

Selecting a connector for diagram overviews
In order to present a relationship between two diagrams, different connectors should be used. Diagram containment is used when a diagram contained
is a part of the containing diagram overview while directional generic connector is used to model the sequence of diagrams, from advance to another.

Select a connector from the diagram toolbar and drag it from the source diagram overview to the destination diagram overview.

Select Diagram Containment
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Annotations and freehand shapes
There are some types of shape which let you annotate shapes on diagrams. They include text annotation, callout and freehand shape.

 

Text annotation

A standard BPMN notation which can be added to diagram, and connect to shapes with association for annotation purpose.

 

Callout shape

A speech-bubble like shape made for annotation purpose. It's pointer can be adjusted to point to specific position.

 

Freehand shape

A set of shapes that can be bended to different styles to fit in different ways of annotation.
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Text annotation
In Logizian, text annotation can be created and attached to a shape via resource centric. You can use it to annotate a specific model element on the
diagram and can format the text as well.

Creating a text annotation with resource centric
1. Move the mouse over a shape and select resource icon Association -> Text Annotation.

Select text annotation icon

2. Drag it to a desired place on the diagram pane.

Drag the resource icon

3. Release the mouse and a text annotation is created.

Text annotation is created

Editing text annotation content
1. Double click the text annotation to start editing its content. Note that the toolbar above the text annotation can be used to format its content.

Start editing

2. If you find the text annotation is too big or too small, you can drag its bottom right corner to resize it.

Resize the text annotation

3. Click on the diagram background to confirm editing the text annotation.
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Callout shape
Callout shape is a label that is used for explicating your model elements. Inserting callout shape aims to draw others' attention and give them additional
remarks. Basically, its function is similar to a photo caption or a comment. However, it does more than merely either a photo caption or a comment. In
fact, it looks more likely to a dialog box that you can place it next to your model elements.

Adjusting the direction of callout shape pointer
1. A remark can be inserted by selecting Callout button from the diagram toolbar and dragging it to the model elements directly on the diagram

pane.

2. The direction of callout shape pointer can be adjusted by simply dragging the pointer's end.

Adjust the pointer

3. The pointer can be adjusted to point out a more specific position, such as pointing to the name of diagram element, or a specific class member
(attribute/operation) out of a class.

Adjust the pointer to a specific column

NOTE: You can not only adjust the pointer's direction, but also its length.

Repositioning the shape
The position of callout shape can be moved by dragging the + icon that is located on the top right corner of the callout. This icon is used to reposition
the shape in a straight and simple way.

Reposition the callout

NOTE: The callout shape will be moved but the position of its pointer won't be changed if you only drag the + icon. This helps you to remain the
pointing and move the callout shape simultaneously.

Editing callout shape content
The content of callout shape can be edited by double clicking on the callout shape.
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Emphasizing the content of callout shape
Formatting buttons can be used to insert formatting for the text in order emphasize your key points while you are editing the content, such as changing
font color. This helps to enhance the visual effect of the text as well.

Format the text
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Freehand shape
Freehand shapes are multi-functional features in Logizian. With freehand shapes, you can not only draw various kinds of shapes, but also insert an
annotation. If you want to stress an important message with visual effect, you may use word art rather than using a note or a callout because you can
reshape the text in word art, however, not in a note or a callout. Moreover, the shapes in freehand are flexible that you can twist them freely, but you
can only resize a note or a callout.

Freehand toolbar interface

Summary of freehand shapes

Shape Type Sample

 Pencil

 Pen

 Calligraphic Tool

 Connector

 Line

 Label Line

 Path Rectangle

 Rectangle
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 Rounded Rectangle

 Rounded Rectangle 2

 Diamond

 Parallelogram

 Trapezoid

 Isosceles Trapezoid

 Path Ellipse

 Ellipse

 Arc

 Chord

 Pie

 Regular Polygon
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 Isosceles Triangle

 Hexagon

 Arrow

 Two Head Arrow

 Spiral

 Text

 Word Art

Summary of freehand shape

NOTE: Freehand can be switched on by clicking on diagram toolbar and select Category > Freehand from the pop-up menu.

Drawing free style path with pencil
1. Press on the empty space on diagram pane and drag to form the outline.

Drawing with pencil

2. Release the mouse and new freehand shape will then be created.

Activating the fine editing selector
Fine editing selector shows a second later after the freehand shape is being selected. To show it immediately, press keyboard ' N' key.

Press on a yellow selector for selecting and the selected selector will turn into orange. More fine editing selectors will appear for curve adjustment.

Selected fine editing selector

Drawing curve with pen
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1. Click on empty space on diagram pane and drag it to create the first stroke.

Straight line created

2. To create a curve, press and move the mouse. The indication line will appear. Release the mouse button when finishing editing. On the other
hand, the last stroke can be cancelled by right clicking on the diagram.

Creating curve

3. To confirm editing of the freehand shape, double click on diagram and a new freehand shape will be created. If the point returns to the starting
point, it will form a closed path.

A close path

Drawing calligraphic path with calligraphic tool
1. Press on the diagram and drag to form the outline of shape. Release the mouse to create the shape.

Freehand shape created

2. By combining several other calligraphic shapes, you can create a complete diagram.

Calligraphy example

Draw straight and curve line with connector
1. Press on a source shape and drag it to the destination shape.

Connecting shapes
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2. Release the mouse and a new connector will be created between them.

A line is created

Bend a straight connector into a curve
1. Press on a straight connector.

Clicking on straight line

2. Bend it to your preferred direction and it will become a curve connector.

A curve connector

Split a straight connector
1. Press the Ctrl key.

2. Click on the specified location to split. A new point at where you have clicked will turn into orange.

Splitting line

3. Drag on that point to split the line.

Moving mid point

Drawing straight and curved line
1. Press on the diagram pane and drag to form the outline.

2. Release the mouse button and a straight line will be created.

Line created
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Bend a straight line into a curve
1. Select a straight line for a second to wait for the fine editing selectors popping out.

Showing fine editing selector

2. Press on the straight line. Drag it to bend into your preferred direction.

Dragging line as curve

Split straight line
1. Press the Ctrl key.

2. Click on the specified location to split. A new point at where you have clicked will turn into orange.

Splitting line

3. Drag on that point to split the line.

Moving mid point

Drawing labeled line
1. Press on the diagram and starting dragging to form its outline.

2. Release the mouse button to create the labeled line.

Freehand shape created

3. Double click on the line. Enter the name for the line.

4. Press Enter to confirm editing.

Label Line
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5. You may drag the yellow selector to modify the line's outline.

Drawing rectangle
Click on the diagram to create a rectangle.

Freehand shape created

Drawing path rectangle
Click on the diagram to create a path rectangle.

Freehand shape created

What's the difference between rectangle and path rectangle?
Path rectangle is formed by path, which enables you to freely reshape it, while rectangle always keeps shape as a rectangle.

Drawing rounded rectangle
Click on the diagram to create a rounded rectangle.

Freehand shape created

Drawing rounded rectangle 2
Click on the diagram to create a rounded rectangle 2.

Freehand shape created

What's the difference between rounded rectangle and rounded rectangle 2?
Rounded rectangle uses a single control point to control the deepness of corner, which ensures that the four corners remain consistent while rounded
rectangle 2 uses two points to control the deepness of corner, which can produce irregular corners.
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Drawing diamond
Click on the diagram to create a diamond shape.

Freehand shape created

Drawing parallelogram
Click on the diagram to create a parallelogram shape.

Freehand shape created

Drawing trapezoid
1. Click on the diagram to create a trapezoid shape.

2. You can adjust the slope by dragging the fine editing selectors in yellow.

Other trapezoid outline

Drawing isosceles trapezoid
1. Click on the diagram to create an isosceles trapezoid shape.

2. You can reshape the Isosceles Trapezoid by dragging the fine editing selectors in yellow.

Other isosceles trapezoid outline

Drawing ellipse
Click on the diagram to create an ellipse shape.

Freehand shape created
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Drawing path ellipse
Click on the diagram to create a path ellipse shape.

Freehand shape created

What's the difference between ellipse and path ellipse?
Path ellipse is formed by path, which enables you to freely reshape it while ellipse always keeps shape as an oval.

Drawing arc
1. Click on the diagram to create an arc shape.

2. You can extend the line by dragging on the fine editing selectors in yellow.

 Other arc outline

Drawing chord
1. Click on the diagram to create a chord shape.

2. You can extend the arc of chord by dragging on the fine editing selectors in yellow.

Other Chord outline

Drawing pie
1. Click on the diagram to create a pie shape.

2. You can extend the arc of pie by dragging on the fine editing selectors in yellow.

Other pie outline

Drawing hexagon
Click on the diagram to create a hexagon shape.

Freehand shape created
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Drawing regular polygon
1. Click on the diagram to create a regular polygon shape.

2. You can modify the outline of shape by dragging the fine editor selectors in yellow.

Other regular polygon outline

Drawing isosceles triangle
Click on the diagram to create an isosceles triangle shape.

Freehand shape created

Drawing single head arrow
1. Click on the diagram to create an arrow shape.

2. You can reshape it by dragging the fine editing selectors in yellow.

Other Arrow Outline

Drawing two head arrow
1. Click on the diagram to create a two head arrow shape.

2. You can reshape it by dragging the fine editing selectors in yellow.

Other two head arrow outline

Drawing spiral
1. Click on the diagram to create a spiral shape.
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2. You can reshape it by dragging the fine editing selectors in yellow.

Other Spiral outline

Inserting text
1. Click on the diagram to create a text shape, and input the text. You can press Enter to insert line break.

Input the text in text shape

2. You can click Ctrl while pressing Enter to confirm editing.

Inserting word art
1. Click on the diagram to create a word art shape, and input the text. You can press Enter to insert line break.

2. You can click Ctrl while pressing Enter to confirm editor.

Freehand shape created

3. You can reshape it by dragging the fine editing selectors in yellow.

Editing word art
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Resource referencing
To include more information you can link to both internal and external material as reference. In this chapter, you will see how to refernece to shape,
diagram, external file, folder and URL, as well as how to add sub-diagram.

 

Reference to external resources

File, folder and URL can be attached to a shape as references. This page will teach you how to do.

 

Reference to diagrams and shapes

In addition to external reference, internal reference can be added, too. You will learn how to refernece to another shape and diagram.

 

Elaborating model element with sub-diagram

Sub-diagram helps you describe a model element in detail by making use of a separate diagram.

 

Showing sub-diagrams and reference indicators

To indicate that a shape has sub-diagram or reference added, you can show the indicators on diagram. The indicators will show in exported image, too.
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Reference to external resources
Additional references can be attached to a shape through resource icon References, such as inserting a file, a folder and a URL. After that, you can
open and view the inserted references through resource icon References.

Adding external resources

Adding a file reference
1. Move the mouse over a shape to add reference, click the resource icon References and select Add File... from the pop-up menu.

Click Add File...

2. When the specification dialog box pops out, enter the referenced file path or select the file path by clicking  ... button. You may also enter the
description for the file in Description.

Enter file reference path

3. Click OK button to confirm the creation for file.

Adding a folder reference
1. Move the mouse over a shape to add reference, click the resource icon  References and select Add Folder... from the pop-up menu.

Click Add Folder...
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2. When the specification dialog box pops out, click the ... button in Path to select a folder path.

Click the ... button

3. When Select Directory dialog box pops out, select a folder to be referenced and click OK button.

4. You may enter the description for the folder. Finally, click OK button to confirm the creation for folder.

Adding a URL reference
1. Move the mouse over a shape to add reference, click the resource icon  References and select  Add URL... from the pop-up menu.

Click Add URL...

2. When the specification dialog box pops out, enter the URL path. You may also enter the URL name and the description for the URL.

Enter URL path

3. Click OK button to confirm the creation for URL.

Opening external resources
Move the mouse over a shape to open reference, click the resource icon References and select an external resource from the pop-up menu.

If you select a URL reference to open, it will be opened by default web browser. If you select a file reference to open, it will be opened by your system
with the program used to open this kind of file. If you select a folder reference to open, it will be opened by your system automatically.

Open a file reference
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Editing references
1. Move the mouse over a shape and press it resource icon References and select Edit References... from the pop-up menu.

2. When the specification dialog box pops out, double click on the row of reference you want to enter its description or modify it.

3. Enter the description or modify it under Description column.

Enter the description

4. Finally, click Enter button to confirm editing.

Removing a reference
1. Move the mouse over a shape which has references, click its resource icon References and select Edit References... from the pop-up menu.

2. When the specification dialog box pops out, select a reference to be removed on the list and press Remove button to delete the selected
reference.

Select a reference to remove

3. Finally, click OK button to confirm the reference removal.
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Reference to diagrams and shapes
Additional references can be attached to a shape through resource icon References, for example, inserting a diagram and a shape. After that, you can
open and view the inserted references through resource icon References.

Reference to diagrams
1. Move the mouse over a shape, press its resource icon References and select  Edit References... from the pop-up menu.

Click Edit References...

2. When the specification dialog box pops up, click Add Diagram... button.

Click Add Diagram...

3. In Select Diagram dialog box, check an existing diagram or create a new diagram by clicking the icon under Diagrams.

Check an existing diagram
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4. You may enter the description for the diagram in the specification dialog box. Finally, click OK button to confirm the reference creation.

Enter description

Reference to shapes
1. Move the mouse over a shape, press its resource icon References and select  Edit References... from the pop-up menu.

2. When the specification dialog box pops up, click Add Shape... button.

Click Add Shape...

3. In Select Shape dialog box, check a shape to be referenced and click OK button.

Check a shape

4. Enter the description for the shape in  the specification dialog box. Finally, click OK button to confirm the creation of shape.
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Opening a reference
Move the mouse over a shape, press its resource icon References and select  a shape/ a diagram to open  from the pop-up menu. If you select a
shape to open, it will switch to the diagram where the shape belongs to and the shape will be selected by filled-selector. If you select a diagram to
open, it will switch to the selected diagram immediately.

Open a diagram reference

Editing references
1. Move the mouse over a shape and press it resource icon References and select Edit References... from the pop-up menu.

2. When the specification dialog box pops out, double click on the row of reference you want to enter its description or modify it.

3. Enter the description or modify it under Description column.

Enter the description

4. Finally, click Enter button to confirm editing.

Removing a reference
1. Move the mouse over a shape which has references, click its resource icon References and select Edit References... from the pop-up menu.

2. When the specification dialog box pops out, select a reference to be removed on the list and press Remove button to delete the selected
reference.

Select a reference to remove

3. Finally, click OK button to confirm the reference removal.
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Elaborating model element with sub diagram
Each notation has its own meaning and semantic. In order to model other aspects like the dynamic behavior of a specific model element, you can
elaborate it with a proper type of sub-diagram and contribute on its details.

Creating a new sub diagram
Move the mouse over a shape, press its resource icon Sub Diagrams and select Add > Other Diagrams and then a preferred type of diagrams from
the pop-up menu.

Add a sub diagram

NOTE: Inserting a sub diagram on a model element, all child model elements of the sub diagram will also be attached.

Adding an existing diagram as sub diagram
Right click on the target shape, select Sub Diagrams > Add Existing Diagrams... from the pop-up menu.

Add an existing diagram as sub diagram
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When the Add Sub Diagrams dialog box pops out, select a sub diagram and then click OK button.

Add Sub Diagrams dialog box

Removing sub diagram
1. Move the mouse over a shape, press its resource icon Sub Diagrams and select Edit Sub Diagrams... from the pop-up menu.

Click Edit Sub Diagrams...

2. In the specification dialog box, click References tab and select a sub diagram that you want it to be removed from the list and click Remove
button. When the Confirm Remove dialog box pops out, click Yes button to confirm the deletion.

3. Finally, click OK button to proceed.
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Showing sub diagrams and reference indicators
The indicator of sub-diagrams and references helps you to identify which shapes in diagram have sub-diagrams and/ or attached with references. The
indictor can be shown through the button on diagram toolbar.

1. Click  Always Show Reference, Sub Diagram, Model Transitor and Documentation Resource button on diagram toolbar.

Click  Always Show Reference, Sub Diagram, Model Transitor and Documentation Resource button

2. As a result, references resource icon and sub-diagrams resource icon are shown.

References resource icon and sub-diagrams resource icon are shown

NOTE: The indicator of sub-diagrams and references can be hidden by clicking Always Show Reference, Sub Diagram, Model Transitor and
Documentation Resource button once again.
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Using shape editor
Shape editor is a diagramming tool for you to design your own notation (stencil). In this chapter, you will learn how to make use of shape editor to
create your own shapes.

 

Creating shape in shape editor

Teaches you how to start shape editor and create a shape in it.

 

Creating shapes from stencil pane

Shows you how to create a shape from a stencil.
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Creating shape in shape editor
Although Logizian has a well-established notation, sometimes it is still not rich enough to express domain specific idea. Shape editor is a diagramming
tool for you to design your own notation (stencil). Notations created can be incorporated into diagrams in Logizian.

To launch shape editor, select Tools > Shape Editor... from the main menu.

When shape editor unfolds, you can create a shape by creating a gallery in advance. It is because a shape needs to be created under a stencil, while a
stencil is put under a category of a gallery.

Shape Editor dialog box

To create a gallery, right click on the Stencil pane background and select Add Gallery from the pop-up menu.

Add a gallery
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To create a stencil, right click on a category and select Add Stencil from the pop-up menu. The newly created gallery is named as Gallery1 by default.
If you want to rename it, right click on it and select Rename from the pop-up menu. Enter your preferred gallery name in the pop-up Input dialog box
and press  OK button to confirm.

Rename a gallery

To create a category, right click on a gallery and select Add Category from the pop-up menu. Enter the category name in the pop-up Input dialog box
and click OK button to confirm.

Add a category

To create a stencil, right-click on a category and select Add Stencil from the pop-up menu. The newly created stencil is named as Stencil 1 by default.
If you want to rename it, right click on it and select Rename from the pop-up menu. Enter your preferred stencil name in the pop-up Input dialog box
and press  OK button to confirm.

Add a stencil
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To create a shape, click the New Shape button at the bottom part of the Stencil pane to create a blank drawing for drawing the shape.

Add a shape

Create your preferred shape on the pane and you can also format its color in Fill tab of Format pane.

Create a shape on pane

To save the shape, select File > Save in the main menu.

Save the shape

Shapes created in shape editor can be used in Logizian. For details, please refer to the next page.



Creating Shapes from Stencil Pane P. 288

Creating shapes from stencil pane
The Stencil pane is where user-created stencil shapes are stored. User can create a stencil shape on diagram by first displaying a stencil, dragging
and dropping a shape from Stencil pane to diagram. Below are the steps in detail.

Let's create a shape from the Stencil pane which is resided at the panes at the bottom left of Logizian by default. If the Stencil pane is hidden, select
View > Panes > Stencil from the main menu to reveal it.

Click the Add Stencil button on the top of Stencil pane. Select a category from the pop-up list of galleries.

Select a category from Stencil pane

When all shapes of the selected category is unfold on the Stencil pane, move the mouse over the target shape and drag it on the diagram pane.

Drag a shape on the diagram pane

You can use generic connector to connect built-in notations shapes and stencil shapes. To do so, select Generic Connector from the diagram toolbar
under the Common category.

Select Generic Connector from diagram toolbar
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Move the mouse over the source shape, drag the connector from the source shape and release the mouse until it reaches on the target shape. As a
result, two shapes are linked with connector.

Connect two shapes

 



Customizing user interface P. 290

Customizing user interface
You can hide away certain menu/toolbar button, or to configure the font of user interface through user interface customization.

 

Hiding user interface components

Hide away certain menu/toolbar button to ignore functions that you are not interested to use.

 

Adjusting user interface font

Adjust show the user interface with your favorite font.
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Hiding user interface components
You may want to hide away some diagram types, menu items or toolbar items to avoid your team creating wrong types of model. This can be done by
user interface (UI) customization.

1. Select Help > Customize UI from the main menu.

2. In the Customize UI dialog box, select the menu(s)/toolbar button(s)/popup menu(s) to hide, and click on the > button to hide them.

Select the menus to hide

3. Click OK to confirm. By restarting the application, the chosen user interface componenets will be hidden.

User interface components are hidden
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Adjusting user interface font
Logizian runs with a screen design that is friendly enough for most users, so that you can customize it to make it suit your preference. One of the
possible customization is to adjust the font settings for text appears on user interface, like the button caption for tools in toolbar, diagram editor tab's
title, menus' captions, etc. The settings will be stored in workspace. Hence, you can keep the settings every time you run Logizian.

To adjust font settings:

1. Select Tools > Application Options from the main menu.

2. Select General from the list on the left hand side.

3. Open the Appearance page.

4. Check Change application font in the Font section. Adjust the font type and size.

Adjusting font settings

5. Click OK.
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6. Restart the application to let the settings take effect.

Updated user interface
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Organizing works with model
A Model is a component that you can create in your project for organizing shapes and diagrams which acts like a folder. Modelers generally use
models to differentiate stages or nature within project, such as an "as-is" model for storing diagrams and model elements about the current system, and
a "to-be" model for recording blueprints of the system to be implemented. In this chapter, you will learn how to use model to organize your work.

 

Using model

Concepts about model will be discussed in this page.

 

Creating diagram under model

Shows to steps of creating model in Model Explorer.

 

Moving diagram to model

You can move a diagram to another move. This page shows you how to do.
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Using model
A Model is a component that you can create in your project for organizing shapes and diagrams which acts like a folder. Modelers generally use
models to differentiate stages or nature within project, such as an "as-is" model for storing diagrams and model elements about the current system,
and a "to-be" model for recording blueprints of the system to be implemented. The use of model improves not only the structuring of work, but also the
performance by reducing the number of root model elements to load. As a result, you can look up diagram or model element you needed easier.

To create a model:

Right click on the Model Explorer's background and select Model from the pop-up menu. You can either create a custom model by selecting New
Model..., or create a pre-defined model (e.g. As-is Process model) by selecting it on the list.

Create a new model

Once the model is created under the project node on the Model Explorer, the Model Specification dialog box pops out. You may specify the model's
details in the  Model Specification dialog box. Note that if you create a pre-defined model, the Model Specification dialog box will not pop out.

Model Specification dialog box
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Creating diagram under model
When a model has been created on the Model Explorer, you can start creating diagram(s) under the model. It is recommended to group diagrams
using Model instead of laying them flat in the project. This can avoid accidentally loading diagrams and model elements that you never use, and
thereby can speed up project loading and saving.

To create a diagram under model:

Right click on the model and select Sub Diagrams > New Diagram... from the pop-up menu.

Create a new diagram under model

NOTE: Alternatively, you can select a specific diagram under categories from the pop-up menu.

When the New Diagram dialog box pops out, select a specific category and the target diagram under the selected category. The new diagram name
is Business Process Diagram1 by default, you can rename it by entering in Diagram name text field. Click  OK button to confirm and close the dialog
box.

New Diagram dialog box
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Moving diagram to model
If you haven't organized project structure with model previously, but want to do it at this stage, you can move a diagram from root into a model, or
transfer a diagram from one model to another.

To move diagram from one model to another:

Right click on the target model in Model Explorer and select Sub Diagrams > Add Existing Diagram... from the pop-up menu.

Add existing diagram

When Add Sub Diagrams dialog box pops out, check the diagram(s) you want to move and then click OK button to proceed.

Check a diagram in Add Sub Diagrams dialog box

As a result, the selected diagram(s) will be moved to the target model.

NOTE: If you move a diagram which has the master view of model element(s), the model element(s) will be moved together with the diagram to
the new model.
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Animacian
Animacian is a tool that helps you make possible paths in an active diagram by presenting the paths in animation form. This chapter will describe
Animacian in detail, and tells you how to animate a business process diagram and export the result to Adobe Flash.

 

What is Animacian?

Describe Animacian in detail.

 

Animate business process diagram

Shows you how to animate a BPD and describe the various parts of Animacian dialog box.

 

Exporting animation to Adobe Flash

Shows you how to export the animation to Adobe Flash movie to play externally.
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What is Animacian?
Animacian is a tool that helps you make possible paths in an active diagram by presenting the paths in animation form. This can make your design
more attractive by animating it. Besides, you can control the flow of animation yourself to help demonstrating your work to client with your annotation. It
also calculates all possible paths of the interaction, making the design more accurate.

Animating Paths in Diagram
Animation can be played directly on diagram. When the animation begins, a tiny black dot will be attached to the begining of the path selected to
animate. During the animation, the black dot will traverse through the path, shapes that lie on the path will be painted in purple one by one, when being
approached by the black dot, until the black dot reached the end of the path.

An animating path

Automatic Paths Identification
Interconnected shapes form a path. It is possible to have multiple paths on a diagram. Animacian helps finding out all possible paths in a diagram.
When opening the Animacian dialog box, valid paths on the opening diagram will be identified and listed for selection. You can then select a path to
animate. Unclosed paths or paths that does not obey the notation are classified as invalid, thus won't be available for playing animation.

Filtering Business Paths Base on Conditions
In BPD, BPMN gateway can be used to control how process flows. It can have multiple incoming and outgoing flows. There are several kinds of
gateways that result in different flow behaviors. When you add an animation for process that involves gateway, you can select the outgoing flows for
gateway(s).

Selecting outgoing flow for gateway
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Walking through a Path Step-by-Step
Instead of auto animation, you can control it manually. The horizontal bar that appears at the bottom of Logizian when animating lets you control the
animation. Besides pausing, playing and stopping the animation, you can also move a shape backward or forward. By making use of the forward and
backward buttons, you can walk through a path shape by shape.

Walk though a path step by step
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Animating Business Process Diagram
By animating a business process diagram with Animacian, you can see the flow of tasks within a process, from the beginning until the end. This does
not only help to understand a process, but also trace the bottleneck and look for improvements.

Adding an Animation
1. Select Modeling > Animacian... from the main menu. At the bottom of the diagram, you can see the Animacian Panel opened. If it is not there

yet, open it manually by right clicking on the background of the diagram and selecting Show Animacian Panel from the popup menu.

2. Click Add Animation (graphically, a plus sign) at the top of the Animacian Panel.

Add animation

3. Give a meaningful name to the animation based on the flow you want to animate. Press Enter to confirm editing.

Named animation

4. When you add an animation for a process that involves gateway, you need to select the outgoing flows for gateway(s) in order to complete the
path. To resolve an exclusive gateway requires the selection of the outgoing path. To resolve inclusive gateway requires the selection of zero to
multiple outgoint paths. Make your selection and click the green arrow button to confirm.

Select the outgoing path for an exclusive gateway

The path of the animation is determined automatically by evaluating the flow modeled in the diagram. Shapes that form the path are shown in
the Animacian Panel as icons. If you click on any of them, it will jump right to the corresponding model element in the diagram.

Select a shape in Animacian Panel
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Overview of Animacian Panel
The Business Process Diagram Animacian dialog box will pop out after clicking Animacian.... This dialog box is where you can select an execution
path to play an animation.

The Animacian Panel

No. Name Description

1 Expand/
Collapse

Expand or collapse Animacian Panel

2 Backward Move one shape backward in the flow.

3 Play Play or continue to play the animation with Animacian minimized.

4 Stop Terminate the animation.

5 Forward Advance to the next shape in the flow.

6 Add
Animation

Create a new animation.

7 Slider It is used for controlling the flow of animation.

8 Current
Animation

The name of the animation.

9 Animation
selection

Click on this button to select another path to animate.

10 Refresh It is used for re-identifying the flow of animations base on the diagram content.

11 Options Click to configure Animacian.

12 Close Click to close the Animacian Panel.

13 Flow of
shapes

It displays all shapes of the current animation. Pressing on a shape here will highlight the corresponding shape in diagram.

14 Shape
name

The name of the selected or animating shape. A question mark indicates that the shape is a decision shape. You can click on the
question mark to re-select its outgoing flow.

15 Parallel flow Parallel flow is presented as a branch.

Description of Animacian Panel

Animacian Options - General
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Animacian Options - General

Name Description

Dim other path It dims the components that are not a part of the selected path.

Show start node when
switch path

Jump to the first node of the selected path, or keep staying at the current viewing field.

Flow All Flow: Re-evaluate added animations to accept all available paths.
Sequence Flow: Re-evaluate added animations to accept only paths that are joined by sequence flows.
Message Flow: Re-evaluate added animations to accept only paths that are joined by message flows.

Show documentation It shows documentation of shape when playing the animation in exported HTML.

Play voice Voice can be recorded as documentation of model element. Check this if you want to play recorded voice when playing
the animation in exported HTML.

The description of Animacian Options (General) window

Animacian Options - Advanced

Animacian Options - Advanced

Name Description

Color set Select a color set to controls the line and fill color of visited shape.
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Line color The line color of visited shapes.

Fill color The fill color of visited shapes.

Line weight The thickness of rectangle that surround the visited shapes'.

Ball color The color of ball that goes through a path during animation for indicating the progress of flow.

Speed The pace of animation.

Export progress bar background - Color 1 The background color for the top of progress bar in exported HTML.

Export progress bar background - Color 2 The background color for the bottom of progress bar in exported HTML.

The description of Animacian Options (General) window

Exporting Animation
You can export the animation to Web contents so that you can play it externally in another computer just by playing in a Web browser. To export
animation, right click beside the name of animation in Animacian Panel and select Export... from the popup menu. Then, fill in the file path and click
OK in the Export window. You can add paths to be exported by clicking the plus button.

Export animation
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Maintaining project reference
To reference another project enables you to link to another project, and use its model elements in developing your own project. In this chapter you can
see how to add and maintain referenced project.

 

Referencing another project

Shows you how to add a referenced project.

 

Referencing other projects' model elements

Having added a referenced project, you can make use of referenced elements in current project.

 

Mirroring model element

Mirror is a technique to create a partial copy of referenced element in current project. This make it possible to create shapes in a mirroed container
shape like package.

 

Viewing referenced diagrams

You can read the diagrams in referenced project without actually opening it. Click on the diagram in Diagram Navigator to open it.

 

Duplicating element from linked project

You can clone an element from referenced project through the duplicate function.
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Referencing another project
To reference another project enables you to link to another project, and use its model elements in developing your own project. You can organize your
model elements in a more disciplined approach by having one project per library project. This also helps you to "slim up" projects through breaking
down a project into smaller pieces. Moreover, you can reference to other projects, and create an overview project for them.

To reference to another project:

1. Right click on the background of any of the following panes and select Manage Referenced Project... from the pop-up menu.
• Diagram Navigator

• Model Explorer

• Logical View

Click Manage Referenced Project...

2. In the Manage  Referenced  Projects dialog box, click Add button.

Click Add button

3. In the Open dialog box, choose the Logizian project file (*.vpp) to reference to and click Open.

4. When you return the Manage  Referenced  Projects dialog box, click Close button.
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Referencing other projects' model elements
Once a referenced project has been established, you can develop your model using model elements in referenced project. To do this:

1. In Model Explorer, click on the drop-down menu at the top of the pane and select the project that contains the model elements you want to use.

Selecting a referenced project

NOTE: By selecting the first selection (Current), model elements in the current project will be listed.

2. In the model element list, drag the target model element(s) and drop it/ them on diagram. This creates views from them. In addition, you may
continue modeling with the referenced elements. Note that Views for referenced project are read-only (i.e. non edit-able).

Drag model elements from referenced project

NOTE: Alternatively, you can right click on the model elements and select Create View in Active Diagram from the pop-up menu.

Indicating referenced elements on diagram
In order to know which shape(s) on a diagram comes from a referenced project, you can enable to model element indicators. Click on the Show Model
Element Indicators button at the top of diagram toolbar.

To show model element indicators

After that, you can see the indicator, which is a small arrow, appear at the shapes that are referencing a referenced project.

Model element indicator appears
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Mirroring model element
Due to views of referenced model elements are read-only, you cannot add shapes in it. This may be a problem when you want to use referenced
packages in your project, and to add model elements such as classes in it. To overcome this problem, you can create a mirror of container-typed
referenced model element. By mirroring, a referenced element is localized partially by keeping a mirrored copy in your project which echoes the
element in referenced project. The mirrored copy can be accessed in Model Explorer that lists model elements in current project, but not editable.

To create a mirror from a container-typed referenced model element (e.g. package, pools/lanes), right click on the element in Model Explorer and
select Create Mirror Model Element from pop-up menu.

Mirror a referenced package

By doing so, you can use it in your project and add shapes in it. If you have already created a view for a non-mirrored element and you want to create a
mirror, you may right click on the shape and select Convert to Mirror from pop-up menu.
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Viewing referenced diagrams
Sometimes, you may want to take a look at the design created in referenced project to make yourself familiar with it. Instead of the traditional way of
opening a project, you can read diagrams of referenced diagrams by scrolling down to the bottom of Diagram Navigator, expanding the referenced
project node and double clicking on a diagram node to open it. Note that the diagram is read-only.

Reading diagram in referenced project
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Duplicating element from linked project
When we have added a referenced project, we say we are referencing that project. By reference, it&rsquo;s like a linkage that points to the actual data
stored in referenced project. Those elements borrowed from referenced project are not editable by current project.

Sometimes, you need the elements created in another project, not to appear as form of references, but to make it become your own data. You will
need to duplicate element from linked project. To duplicate a model element:

1. Open the Model Explorer.

2. Right click on the element you want to duplicate ands elect Duplicate to Current Project from the popup menu.

Duplicate a model element

The duplicated element can be found in Model Explorer, under current project.

Duplicated element appear in model explorer
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Refactoring
Refactoring is a technique of improving your modeling efficiency by allowing you to extract part of a project to a higher level of abstraction so that other
(projects) can get the common part(s) included without the need of re-definition. Let's say, for example, you are modeling an online store. You have
created two projects for the distinct parts of the business - Buy order and refill inventory. When modeling buy order with BPD, you have found that pool
like Store is needed by the refill inventory model, too. You then refactor the pool to a referenced project so that the refill inventory model can link with it
and have the pool included.

What is refactoring?

Refactoring not only reduce the time you need to spend by redefining same project data among projects. It also guarantees the correctness of model
definition by enforcing common project data to be defined just once. This is also, in fact, the benefit of using project referencing.

How to refactor?
You can refactor model element(s) or a diagram along with its contained element to referenced project. No matter which way you take, make sure
project referencing was established. If you are unclear about project referencing, please read the previous chapters.

Refactor model elements
1. Open the Model Explorer.

Open Model Explorer
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2. Select and right click on the model elements you want to refactor to referenced project. Select Refactor to Referenced Project... from the
popup menu.

Refactor pool

3. You are prompted for saving project. Click Yes. If you click No, refactor will stop.

4. If the Include Related Diagrams window appears, this means that one or more of the selected elements has been visualized in at least one
diagram (as listed on the left of window) with master view created.
Here you may take any of the following actions to continue.
• Include the diagrams - Click Include Diagram(s) at the bottom right corner. This will move not only the model elements, but also

the diagrams listed on the left hand side of window to the referenced project. Since the action is not undoable, think carefully before
continuing.

• Remove the master views - Click Stop Refactor at the bottom left corner. Open the diagrams where the master views of the selected
model elements exist. Delete them. When delete, make sure you are deleting the VIEW instead of model element. Once all master views
are removed, re-run step 1.

Delete only views of element, not model elements
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5. Refactor not only moves the selected elements to referenced project, but also those related elements. Here is an example:
• Connectors that connect between the selected elements.

If such related elements exist, you will be listed with those elements. Check them. If you accept moving them to referenced project, click
Continue at the bottom right corner to continue. Otherwise, click Stop Refactor at bottom left corner to terminate the refactoring.

Elements to refactor (including those related elements)

6. Once the refactoring is complete, the project will reopen itself. From now on, you can access and use the refactored elements through the
Model Explorer. Select the referenced project under the drop down menu. Drag to diagram the element(s) to use.

To re-use referenced pool on current project

Note that auxiliary views of refactored elements are now referencing the elements in referenced project.

Refactor diagram
To refactor diagram means to refactor the diagram as well as the elements on the diagram. As the steps are pretty close to refactoring model element,
as described above, please read refactor model elements before reading this section.
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1. Right click on the diagram that you want to refactor and select Utilities > Refactor to Referenced Project... from the popup menu.

Refactor a BPD

2. You are prompted for saving project. Click Yes. If you click No, refactor will stop.

3. If the Include Related Diagrams window appears, this means that one or more of the elements in the selected diagram has been visualized
in another diagram (as listed on the left of window) with master view created. Read step 4 in the previous section to learn how to resolve the
relationships.

4. Refactor not only moves the selected elements to referenced project, but also those related elements. Read step 5 in the previous section to
learn how to carry on.

5. Once the refactoring is complete, the project will reopen itself. From now on, you can access and use the refactored elements through the
Model Explorer. Select the referenced project under the drop down menu. Drag to diagram the element(s) to use. Note that auxiliary views of
refactored elements are now referencing the elements in referenced project.
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Model element nicknaming
Nickname enables you to creat multiple name and documentation set for your model. You can keep multiple language sets of your model by using the
translation feature. In this chapter, both the nickname and translation feature will be covered.

 

What is nickname?

Introduce element nickname support.

 

Configure nickname

Shows you how to create a nickname or a language.

 

Using nickname

Shows you how to work with a new nickname and how to switch between nicknames.

 

Translation

Shows you how to make use of the translation feature to maintain model with multiple language.

 

Export and import word document of nickname

Export a Word document of nickname and nick-documentation, give it to a translator to perform translation, and import the work back to the tool.
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What is nickname?
We all have a name and have multiple names such as nicknames or names in other languages on the other hand. This is the same for your Logizian
project content. While we have applied certain language in naming and documenting model elements, we may have the need to model with another
language to satisfy the readers of model. The nickname feature is designed to let you define multiple language sets for a model. Further to the
definition of nickname, you also can make use of the translate function to translate your work into another language.

One model element can have one Original name and multiple nicknames, and the same for documentation. With nickname, you can define and
view different names without affecting the original name of model elements. You can disable the effect of nickname anytime by switching to Original
nickname.

After you define a nickname and rename model element, click Modeling > Nicknames and then select the newly created nickname from the toolbar.
As a result, the whole diagram will turn into the selected nickname.

Selecting a nickname

Multi-national team
If you are working in a team and your members using different languages, you can define model elements name and documentation in multiple
languages. Each member can choose their own language for modeling or view diagrams. The following example demonstrates the Business Process
Diagram in English and Chinese (Traditional):

Original version of a business process
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You can create a Chinese (Traditional) nickname and rename the model elements:

Chinese version of a business process

You can switch between English (Original) and another language anytime, or even create more nicknames.
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Configure nickname
You can add a nickname through the nickname drop-down menu that locates on toolbar, or through  View > Nicknames > Configure Nicknames...
from the main menu. By adding a nickname, you can start editing the names and documentations of model elements under the new nickname.

Overview of Configure Nickname dialog box

An overview of Configure Nickname dialog box

No. Name Description

1 Original user
language

The language (e.g. English) of the Original nickname. The selection only affects the outcome of translation.

2 Nickname list All the nicknames are listed in here.

3 Add Click to add a nickname with a name.

4 Add user
language

Click to add a nickname with selected language.

5 Rename Click to rename a chosen nickname.

6 Remove Click to delete a chosen nickname.

7 Export Click to export an XML file that contains information about the original name and nickname of the name and documentation of
model elements that are named differently in nickname.

8 Import Click to import the XML exported from Configure Nickname dialog box.

9 OK Click to apply the nickname configuration and close this dialog box.

10 Cancel Click to close the dialog box without applying the changes.

Description of Overview dialog box

 

Adding nickname
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1. The current working copy is by default in Original nickname, with English as user language. If you want to add a nickname, click the drop-down
menu of Original and choose Configure Nicknames... from the drop-down menu.

Configure Nicknames

2. When the Configure Nickname dialog box unfolds, click Add button. 

3. In the Input dialog box, enter the name of the nickname set and click OK to confirm. Click OK to confirm editing and close the Configure
Nickname dialog box.

Renaming nickname
1. Click the drop-down menu of Original, and select Configure Nicknames... from the pop-up menu.

NOTE: If you do not see this drop-down menu, you can reveal it by right clicking on the empty space on the toolbar and selecting Nickname
from pop-up menu. Alternatively, you can select View > Nicknames > Configure Nicknames... from the main menu.

2. In the Configure Nickname dialog box, select the target nickname to rename while click Rename button.

NOTE: You are not allowed to rename the original nickname.

3. In the Input dialog box, enter the name of the nickname set and click OK to confirm. Click OK to confirm editing and close the Configure
Nickname dialog box.

Removing nickname
1. Click the drop-down menu of Original, and select Configure Nicknames... from the pop-up menu.

NOTE: If you do not see this drop-down menu, you can reveal it by right clicking on the empty space on the toolbar and selecting Nickname
from pop-up menu. Alternatively, you can select View > Nicknames > Configure Nicknames... from the main menu.

2. In the Configure Nickname dialog box, select the nickname to remove while click Remove button. Click Yes when you are asked for
confirmation.

NOTE: You are not allowed to remove the original nickname.

Specifying user language for the nickname
An original nickname exists in every project, namely Original, representing the standard version of language of project. You can specify the language
for the original nickname, such as German. The language you set will affect the translation outcome.

Select original user language
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To add a nickname in specific language, click on the Add User Language... button and select a language in  Add User Language dialog box. 

Add a user language
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Using nickname
Once you have defined a nickname, you can start updating your model by entering the new names and documentations of model elements.

Start updating elements' nickname
1. From the application toolbar, select the nickname you need to work with.

Selecting a nickname

2. Start renaming model elements and updating their documentation. The changes you make will only be applied to the selected nickname.

Updating the name and documentation of elements under a nickname

Switching between nicknames
The names and documentations of model elements are language specific. This means that, the change you make applies only to a specific nickname.
Once you have switched to another nickname, the names and documentations of model elements will be updated to show the definition under the new
nickname.

To switch between nicknames, select the nickname to switch to from the drop-down menu of nickname on toolbar.

Switching nickname



Export and import word document of nickname P. 322

Export and import word document of nickname
Exporting and importing the nickname of your diagrams to word document enables you to manage translation with ease. After all, you can update the
nickname of exported Word document and import it back to synchronize the changes to the nickname of model elements, especially when you ask your
team member (or your translator) to translate the project without providing the project to him/her.

In the following steps, let's try to export your project to word document and import the translated word document back to Logizian:

1. Switch your project to your target nickname. Select Modeling > Nicknames > [your target nickname] from the toolbar.

Switch your project into Chinese (traditional)

NOTE: If you haven't created your target nickname before, the nickname will not display on the list. To configure your nickname, select Modeling
> Nicknames > Configure Nicknames... on the toolbar. Click Add button to enter a nickname directly or click Add User Language...
button to select one.

2. To export your project's model elements, select Modeling > Nicknames > Configure Nicknames... from the toolbar.

3. In Configure Nickname dialog box, click Export button.

Export your project's model elements

4. In Save dialog box, select a directory for saving it as word document in your computer. Click Save button after you name the file.

5. Next, you send the word file to your team member (or your translator).

6. After s/he has translated the word file, you get it back from him/her and save it in your computer. Now, you can import the translated word
document back to Logizian. Open your project with Logizian. Switch your project to your target nickname, and then open Configure Nickname
dialog box.
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7. In Configure Nickname dialog box, click Import button.

Import the translated word document back to Logizian

8. In Open dialog box, select the directory where you save your translated word document and click Open button.
As a result, you can see your project is updated.

The name of your project's model elements has been updated to show the selected nickname
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Visual diff
You can use visual diff for comparing two diagrams, and to show their differences. The comparison can be made between diagrams in the same or
different. In this chapter, you will see how to compare an as-is and to-be BPD with visual diff.

 

What is visual diff?

You will learn what is visual diff, and have a look at its configuration options.

 

Comparing as-is and to-be business process diagram

An example of comparing as-is and to-be BPD will be presented to help you understand how to use visual diff in practice.
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What is Visual Diff?
The situation of comparing two diagrams is common. For example, comparing an ERD of conceptual model with an ERD of physical model. Logizian
allows you to compare the differences between diagrams in order to trace the changes between them.

Diagram comparison
With the feature of Visual Diff, two diagrams can be compared to recognize their differences. Changes, such as modification of properties (e.g. name)
and addition/removal of containing models, thereby can be found easily.

The overview of Visual Diff dialog box

Various comparison strategies
A comparison strategy determines how two diagrams will be compared. Each strategy is used for its own specific purpose. You can select the
appropriate strategy that suits your case most. The following is the description of strategies:

Strategy Description

ID Shapes will be matched base on their internal ID. Differences between shapes that have same ID will be displayed in the result pane. This
strategy is usually used to visualize the changes of same shapes in two projects.

Name Shapes will be matched base on their names. This strategy is useful when visualizing differences for external works. One of typical
examples is to compare databases and class models.

Transitor Shapes will be matched base on their transition established by Model Transitor. This way of comparison is usually used to visualize the
differences between model elements.

Description of comparison strategies

Comparing view only, model element only, or both
Comparison is divided into view, model element and both of them. The selected option from the drop-down menu of Compare determines the display
for comparison. By selecting View, the differences in view settings, such as the coordination of shapes, will be considered as changes. By selecting
Model Element, the differences in model element level, such as their names, will be considered as changes. By selecting All, the differences in both
view settings and model element level are displayed.
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The following screenshot displays both view and model element differences:

Compare All

The result of selecting View is shown as follows:

Compare View
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The result of selecting Model Element is shown as follows:

Compare Model Element

Comparing from the left to the right and vice versa
Comparisons are made between two diagrams, which are put on the left and the right hand side in the Visual Diff dialog box respectively. By default,
comparison is based on left hand side, which means, if a shape does not exist on the left hand side but on the right hand side, the shape will be
considered as newly added in the result pane. The base can be swapped from the right to the left, and vice versa. By doing so, the absence of shape
on the left hand side will result in a report of deleted shape.

Comparing diagrams with right hand side as base
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The result of left hand side as base is shown below. The deleted model element is regarded as an addition (it indicates as New).

Comparing diagrams with left hand side as base

Exporting a report of differences
A report of the current comparing diagrams can be saved in your computer as PDF. Click Export PDF... button on the bottom left corner of the dialog
box. Select a directory for storing in  Export PDF dialog box and then click Save button.

Click Export PDF... button
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Comparing as-is and to-be business process diagram
In this page, two Business Process Diagrams are compared: one for modeling the As-is Process and another for modeling the To-be Process. The
features of Visual Diff are applied in order to find the differences between them.
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1. In As-Is Process diagram, select Modeling > Visual Diff... from the main menu.

NOTE: Alternatively, you may start Visual Diff as follows:
• Right click on diagram background and select Utilities > Visual Diff... from the pop-up menu.

• Click the Visual Diff button on the toolbar.

The overview of Visual Diff dialog box:

The Visual Diff dialog box

No. Name Description

1 Strategy It determines how two diagrams will be compared. Select the appropriate strategy that suits your application most.
ID : Shapes will be matched base on their internal ID. Differences between shapes that have same ID will be displayed in the
result pane. This strategy is usually used to visualize the changes of same shapes in two projects.
Name : Shapes will be matched base on their names. This strategy is useful when visualizing differences for external works.
One of typical examples is to compare databases and class models.
Transitor : Shapes will be matched base on their transition established by Model Transitor. This way of comparison is
usually used to visualize the differences between model elements.

2 Compare It determines how two diagrams will be displayed for comparison.
All: Both view and model elements are displayed.
View : Differences, such as coordinates, width, height and color of shapes, are displayed.
Model Element : Differences, such as model name, are displayed.

3 Base It determines which diagram is used as a base for comparison.
Left hand side: Comparison is based on the diagram on the right hand side. For example, if there is a shape absent on the
left hand side, but appear on the right hand side, the shape is said to be a new shape.
Right hand side : Comparison is based on the diagram on the right hand side. For example, if there is a shape absent on
the left hand side, but appear on the right hand side, the shape is said to be a removed shape.

4 Filter It determines what kind of comparing data will be displayed on the result pane.
All: Display all kinds of differences including the addition, modification and removal of shapes.
New: Display only results about the addition of shape and then hide the rest.
Modified: Display only results about the modification of shapes and then hide the rest.
Deleted: Display only results about the removal of shapes and then hide the rest.

5 Filter
Model
Type...

It determines what type of model elements will be shown on the result pane. When Filter Model Type dialog box pops out,
uncheck the type of model elements if you don't want it to be shown; otherwise, check it if you want it to be shown.

6 Diagram
list

It lists all diagrams on projects selected in the left hand side and the right hand side respectively.

7 Use
Working
Project

Check it if you want to select a diagram for comparison within the current working project.

8 Project Select and open a project directory for comparison.

9 Diagram Select and open a specific diagram for comparison after selecting a project.

10 Display
pane

A pane that has two sides. Each side displays a diagram out of a project.

11 Result
pane

The differences of the two projects are shown here. When the word New is shown behind a task that means it is newly
added, the word  Deleted is shown behind a task that means it is deleted.

12 Export
PDF...

Click it to save a report of the two compared diagrams in your computer as PDF.

13 Launch
viewer

Open the exported file after you have export a PDF file. Check it to open the PDF file. If you uncheck it, nothing will happen
even after you have exported a PDF file.

14 Close Close Visual Diff dialog box.

The description of features in Visual Diff dialog box
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2. In Visual Diff dialog box, the left hand side window shows the currently opened diagram by default. You may remain it unchanged; otherwise
uncheck Use Working Project on the left hand side if you want to select a diagram in other projects to compare with. Click ... button in  Project
to select the directory of other projects. Similarly, check/ uncheck Use Working Project on the right hand side window.

Check Use Working Project

3. Select the To-be Process diagram to compare with from the drop-down menu of Diagram.

Select a diagram for comparison

The two diagrams are shown side by side on display pane. However, the ways of comparison has not yet been configured. Let's configure them
one by one in the following steps.

Two diagrams are selected

4. Select an option in Strategy.

Select a strategy
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5. Select an option in Compare.

Select a compare

6. Choose an option in Base.

Choose a base

7. Select an option in Filter.

Select a filter

8. Once everything is set, the differences of the two diagrams will be shown on the result pane.

9. If you want to view a specific shape, you may click its node on the result pane, and then the selected shape will be painted in dark purple on the
display pane.

Select a node on the result pane
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Using design pattern
Design pattern is a part of diagram that can be used in many different diagrams. In this chapter, you will learn what design pattern is, and how to apply
it in your design.

 

Defining design pattern

You need to draw the pattern, and define it afterwards.

 

Applying design pattern

Defined patterns can be applied to your project, or another project (through an export and import of pattern).

 

Synchronize design pattern with teamwork server

Patterns can be shared among team members through the team collaboration support.
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Defining design pattern
In Logizian, design pattern is a part of diagram that can be used in many different diagrams, thus it is time-saving to form a pattern. Design pattern
typically shows the shapes and more importantly, the relationships between the shapes. You can define and reuse design pattern in your project,
across projects, or share with your team members. Furthermore, you can define and apply design patterns on any kinds of diagram.

You have to define a design pattern and save it as a pattern file before applying it. To define a design pattern:

Select those shapes you want to be defined, right click on one of them and select Define Design Pattern... from the pop-up menu.

Define design pattern

When the Define Design Pattern dialog box pops out, specify the name and file name for the pattern, with .pat as extension. You can save the
pattern file either to workspace or to another directory. Select Save to workspace if you want to share with other projects that will be opened in current
workspace easily while select Save to directory if you want to share the .pat file with your team member for reusing. Click OK button to confirm
defining design pattern.

Define Design Pattern dialog box
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Applying design pattern
After you have previously defined a design pattern into your diagram, you can modify it to fit into your design. To apply a design pattern:

Open an existing diagram where you want to apply a design pattern or create a new diagram. Right click on the diagram background and select
Utilities > Apply Design Pattern... from the pop-up menu.

Apply design pattern

In Design Pattern dialog box, a list of defined patterns is listed on the left hand side of dialog box, select your target design pattern from the list and
then the selected pattern will reveal on the right hand side of dialog box at once.

Select a pattern in Design Pattern dialog box

Alternatively, you can click Add button to import a .pat file into the list. Enter name and specify file path for the new pattern in the pop-up Add Pattern
dialog box, and then click  OK button to confirm.

Click Add button to unfold  Add Pattern dialog box
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For searching a specify shape on the defined pattern, select the shape from the drop-down menu of Diagram Element to filter the list.

Filter pattern element from the drop-down menu of Diagram Element

Finally, click OK button in Design Pattern dialog box to confirm applying the selected pattern.
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Synchronize design pattern with teamwork server
Teamwork server can synchronize design patterns defined and saved to workspace, you can then share the design patterns with your team members.
This feature is available to Visual Paradigm Teamwork Server, Subversion, CVS and Perforce.

Synchronizing local design pattern to server
1. After you have defined a design pattern, open Teamwork Client from Toolbar, or Teamwork > Open Teamwork Client... from the main menu.

2. Login to the teamwork server.

3. In the Teamwork Client dialog box, select Repository > Synchronize Design Pattern to Server from its menu.

Click Synchronize Design Pattern to Server

4. In the Pattern Synchronization dialog box, verify your desired design pattern and action and click OK button to continue. The pattern will be
committed to teamwork server.

Pattern Synchronization dialog box

Synchronizing design pattern from server
1. After you open the Teamwork Client dialog box, select Repository > Synchronize Design Pattern to Server.

Click Synchronize Design Pattern to Server
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2. When the Pattern Synchronization dialog box pops out, it displays that your pattern is available for update from teamwork server. Click OK
button and the pattern will be updated from teamwork server to workspace.

Pattern Synchronization dialog box

3. Open an existing diagram where you want to apply a design pattern or create a new diagram. Right click on the diagram background and select
Utilities > Apply Design Pattern... from the pop-up menu. The design pattern is available on the list of Design Pattern dialog box. You can
now select the pattern and apply to your project.

Design pattern is available in Design Pattern dialog box
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Model transitor
Model transitor helps define the transition of phrasees of work and maintain the traceability in between. Both the use of model transitor for shape and
diagram will be covered in this chapter.

 

Model transitor for shape

Shows you the steps of adding and maintaining transition between shapes.

 

Model transitor for diagram (diagram transitor)

Shows you the steps of adding and maintaining transition between diagrams.
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Model transitor for shape
You can use different diagrams for modeling different phrases of development, such as a diagram for modeling the current system, and another
diagram for modeling to system to be implemented. In order to trace the evolution of model elements across diagrams, you can make use of model
transitor. Model transitor enables you to establish transit relationship between shapes. With the transition relationship, you can trace between shapes
across diagrams.

Adding a transition between shapes
1. Right click on the shape you want to add a transition. It can be the source or target shape within the transition to add. If you are right clicking on

the source shape, select Related Elements > Transit To > Manage Transit To... from the pop-up menu.

Manage transition

If you are right clicking on the target shape, select Related Elements > Transit To > Manage Transit From... from the pop-up menu.

2. In the Manage Transit To/From Model Elements dialog box, select the shape(s) you want to transit to/from. You can select multiple shapes to
transit to/from. For example, an initial Purchase Order class will be transited to an Order class and an OrderItem class.

Select shapes to transit to

Navigating transited shape
Once a transition is added between two shapes, you can navigate between them. There are two methods to navigate to a transited shape. The first
way is to go through the transitor popup menu of a shape. Right click on a shape and select Related Elements > Transit From/To from the popup
menu, then the shape to navigate to.
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Alternatively, make use of resource centric interface by following the steps below:

1. Move the mouse pointer over the shape that you want to navigate to its transited shape.

2. Press on the Model Transitor resource icon below the shape. Select Transit From/To, then the shape to navigate to.

Navigate to a transited shape through model transitor

Removing a transition
To remove a transition between shapes:

1. Right click on a shape and select Related Elements > Transit From/To > Manage Transit From/To from the popup menu.

2. In the Manage Transit To/From Model Elements dialog box, de-select the shapes that you do not want to transit with. Click OK to confirm.

De-select shapes to withdraw from transition
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Model transitor for diagram (diagram transitor)
You can use different diagrams for modeling different phrases of development, such as a diagram for modeling the current system, and another
diagram for modeling to system to be implemented. Sometimes, diagrams across phrases are similar, but little variation. Model transitor enables you
to duplicate a diagram with transition added in between. You can then continue modeling in the new diagram by using the original diagram's content as
base.

Transiting to a new diagram
Right click on the background of diagram that you want to transit from and select Utilities > Transit to New Diagram... from the pop-up menu.

Transit to a new diagram

When the Select Parent Model of New Diagram dialog box pops out, select a model for storing diagram. Visual Paradigm encourages you to
structure your project with model for easier accessing of model elements and enhancing application performance. If you want to place a new diagram
in a model, click New Model button on the top right corner of the dialog box.

Select a model for storing the new diagram

NOTE: If you do not want to store diagram inside any model, do not make any model selection. Click OK to continue.

As a result, the source diagram is transited to a new diagram. You may start editing the new diagram with the source diagram's content as base.

Edit the transited diagram
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Navigating transited shape
After a transition is added between two diagrams, transition is automatically added between shapes in the two diagrams. With the transition between
shapes, you can navigate between them.

You can go through the transitor pop-up menu of a shape. Right click on a shape, select Related Elements > Transit From or  Transit To and then
the shape for navigation  from the pop-up menu.

Navigate to a transited shape through the pop-up menu

Alternatively, you may make use of the resource centric interface. Move the mouse over the shape that you want to navigate to, press its resource icon
Model Transitor and select Transit From or Transit To, then the shape for navigation from the pop-up menu.

Navigate to a transited shape through model transitor
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Using stereotypes
A stereotype defines how a model element may be extended, and enables the use of platform or domain specific terminology or notation in place of, or
in addition to, the ones used for the extended metaclass. In this chapter, you will learn things about stereotypes and see how to apply stereotypes in
your model.

 

Applying stereotype to model element

Tells you what stereotype is and how to apply to a model element.

 

Configure stereotypes

Shows you how to configure a stereotype like to define its color and add tagged values.

 

Shortcut of creating stereotyped model element

You can create a stereotyped element type easily through the diagram toolbar.
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Applying stereotype to model element
A stereotype defines how a model element may be extended, and enables the use of platform or domain specific terminology or notation in place of, or
in addition to, the ones used for the extended metaclass. In Logizian, you can apply one or more stereotypes to model elements, and decide whether
or not to visualize the stereotype or tagged values in views.

To apply stereotype to model element:

1. Right click on the model element, or the view of the model element that you want to apply stereotype to and select Stereotypes >  Edit
Stereotypes... from pop-up menu.

Apply a stereotype

NOTE: The list of suggested stereotypes listing in the pop-up menu may be varied, depending on the type of model element you are selecting.
The recently used stereotypes and stereotypes that place at the top of stereotype list are shown on the list. If you see the stereotype you
want to apply on the pop-up menu, select it directly instead of clicking Stereotypes....

2. In the Stereotypes page of your shape's specification dialog box, select the stereotype you want to apply on the All list and then click > to
assign it to the Selected list. Click OK button  to confirm.

Stereotype Primary is selected

NOTE: You can also double click on a stereotype to apply it.

NOTE: While clicking on > applies the selected stereotype to model element, you can click < to remove a stereotype selected in Selected list. If
you want to apply all available stereotypes to model element, click >>; similarly, clicking on << removes all the applied stereotypes.

3. As a result, the stereotype will then be shown above the model element's name within a pair of guillemets. If multiple stereotypes are applied,
the names of the applied stereotypes are shown as a comma-separated list with a pair of guillemets.

Stereotype Primary is applied to a task

Presenting a shape as stereotype icon
You can specify icon for a stereotype (Read the next chapter for details). When a stereotype is applied to a model element, the stereotype icon can be
shown above the name of model element, which is the default presentation, or the model element is shown as the icon.
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To present a shape as stereotype icon, right click on the target shape and select Presentation Options > Stereotype Icon from the pop-up menu.

Different presentations of a model element with a stereotype that has icon defined

Showing or hiding stereotype
By default, applied stereotypes are shown within a shape. You can choose whether to show or hide them. Furthermore, you can choose not to display
the stereotypes, but to display only their tagged values.

To update the visibility of stereotypes, right click on the diagram background where the target shapes exist. Check/ uncheck Presentation Options >
Show Stereotypes from the pop-up menu.

Task with hiding stereotype
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Configure stereotypes
You can configure stereotypes, not just to create and name stereotypes for specific model element types, but also to format stereotypes like to set their
colors, line formatting and font, and to define their tagged values. By configuring stereotypes, domain specific stereotype set can be built.

To configure stereotypes:

1. Select Modeling > Configure Stereotypes... from the main menu.

2. Select either Workspace or Project from the drop-down menu of  Scope in the Configure Stereotypes dialog box. The selection means
whether you want to configure stereotypes in workspace or in the opening project.

Select a scope

NOTE: Initially, stereotypes exist in workspace rather than in project. When you apply a stereotype to any model element, a copy of that
stereotype will be made from workspace to project.
By modifying stereotype in workspace, changes will apply to neither current project nor any project that has used the stereotype because
the stereotype copied to project is being followed. If you want to configure stereotype only in current project, you must select Project as
scope, or select Workspace but select Apply changes to stereotypes in current project to make changes apply on both workspace
and project.

3. Select the type of model element that you want to add stereotype or edit its existing stereotypes. If you want to edit an existing stereotype,
select the stereotype and click Edit... button. If you want to add a stereotype, click Add... button. If you want to remove a stereotype, select the
stereotype and click Remove button.

Select data output to edit its stereotype

4. If you add or edit a stereotype in the Stereotype Specification dialog box, after modify its details, click OK button to confirm editing. For details
about editing a stereotype, read the following section. Finally, click OK button to confirm in Configure Stereotypes dialog box.

An overview of Configure Stereotypes dialog box
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An overview of Configure Stereotypes dialog box

No. Name Description

1 Scope Initially, stereotypes exist in workspace rather than in project. When you apply a stereotype to any model element, a copy of that
stereotype will be made from workspace to project. By modifying stereotype in workspace, changes will apply to neither the current
project nor any project that has used the stereotype because the stereotype copied to project is being followed. If you want to configure
stereotype only in current project, you must select Project as scope, or select Workspace but let the option Apply changes to
stereotypes in current project on to make changes apply on both workspace and project.

2 Model
element
list

A list of categorized model element types. You can select a type to configure its stereotypes.

3 StereotypesA list of stereotypes of the selected model element type.

4 Apply
changes
to
stereotypes
in
current
project

Available only when scope is Workspace, this option cause the stereotype configuration applies to both stereotypes in workspace and
project, when pressing OK.

5 Duplicate Click to duplicate the stereotype selected in Stereotype pane.

6 Import Click this to import stereotype configuration (an XML) produced by others. Once clicked, the Import Stereotypes dialog box will pop
out. You need to choose the XML file to import. At the bottom of the dialog box, there is an option Add and update only (do not delete
stereotypes). When checked, Logizian will only add and update stereotypes from XML. When unchecked, Logizian will add and update
stereotypes, and additionally delete stereotypes that are not defined within the XML.

7 Export Click to export stereotype configuration to an XML file.

8 Add Click this to add a stereotype for the selected type of model element.

9 Edit Click to edit the selected stereotype.

10 Remove Click to delete the selected stereotype.

11 OK Click to apply the configuration and close the dialog.

12 Cancel Click to discard the changes (if any) and close the dialog box.

13 Help Click to open the Help contents.

Description of Configure Stereotypes dialog box
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Editing stereotype
By adding or editing a stereotype, you can specify its icon and adjust its fill, line and font style in the General page within the Stereotype
Specification.

Edit stereotype

By applying a stereotype that has icon defined to a model element, the icon above the name of model element, near the stereotype. You can optionally
make the model element show as the icon. For details, read the previous chapter. To specify icon, click on the ... button near the preview of Icon. Then,
select the image file of icon.

Fill, line and font styles will be applied automatically to model elements that have the stereotype applied. To adjust fill/line/font, check the corresponding
Use button. Then, click on the ... button to edit the settings.

Defining tagged values for stereotypes
A stereotype may have properties, which may be referred to as tag definitions. When a stereotype is applied to a model element, the values of the
properties may be referred to as tagged values.

You can define tagged values for stereotypes. By doing so, when you apply the stereotype with tagged values defined to a model element, you can fill
in the values for the model element.

1. Select Tools > Configure Stereotypes... from the main menu.

2. In the Configure Stereotypes dialog box, select the stereotype that you want to define tagged value and click Edit button. If you want to add a
new stereotype, select the base model type and click Add... button.

3. In the Stereotype Specification dialog box, unfold the Tagged Value Definitions tab.

4. Click Add button to select the type of tagged value to define. Note that the type of tagged value limits the type of content user can enter for a
tag.

Add a tag

Tag type Description

Text The most common and general type of tagged value that consists of words.

Multi-line Text The value of tag is a text in multiple lines.

Model element The value of tag is a model element in project.

Enumeration The value of tag can be chosen from a list of possible values. For example, to select "red" out of values red, green
and blue.

Integer The value of tag must be a real number.

Floating point
number

The value of tag must be a number that consists of one or more digits.

Type of tags
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5. Double click the name cell to rename the name of tag. If you want to add more tagged values, repeat step 4 and 5. You can assign a default
value to a tag by editing the Default Value cell. Usually, you give a tag a default value when the value is true in most cases. For example, a tag
"in-door-temperature" can have "25" as default value.

Define stereotype
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Shortcut of creating stereotyped model element
Selecting the element type in diagram toolbar and clicking on diagram is one of the ways of creating a shape of that type. If you want to apply a
stereotype to that model element, you have to open the specification dialog box and select a stereotype. These steps can be simplified by adding a
shortcut in diagram toolbar, for creating a type of model element with specific stereotype pre-set.

To create a shortcut of creating stereotyped model element:

1. In a diagram, click on the double down arrow button at the top of diagram toolbar, then select Configure Buttons... from the popup menu.

Click Configure Buttons...

2. In the Configure Buttons dialog box, expand the node(s) of model element type(s) that you want to add shortcut for. Select the stereotype that
you need to apply to that type of model element in future. Click > or double click on it to assign. Click OK to confirm.

Select a stereotype in the Configure Buttons dialog box

3. As a result, you can find the shortcuts in diagram toolbar under the selected type(s) of model elements. By selecting a stereotyped model
element type and clicking on diagram, you can create a shape with stereotype applied.

Create a stereotyped shape
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Customizing BPD with profile
A profile provides a generic extension mechanism for customizing model elements for different purposes. It is closely related to stereotype and tagged
value. Details will be covered in this chapter.

 

Creating a profile

You will see how to create a profile in Model Explorer.

 

Drawing a profile diagram

A profile can be modeled through a profile diagram.
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Creating a profile
A profile provides a generic extension mechanism for customizing model elements for different purposes. Profiles are defined using stereotypes and
tagged values definition for specific types of model elements. You can tailor meta model for different domains and platforms by creating and developing
a profile.

1. In Model Explorer, right click on the project root node and select New Profile from the pop-up menu.

Create a profile

2. When the Profile Specification dialog box pops out, enter name for the profile and click OK button to confirm. A clear naming is needed to
identify the part of the domain you want to create a profile for. For example, a Vehicle profile for managing stereotypes around different car
types; a Transaction profile for managing stereotypes related to trading and loaning of cars.

Name the profile

3. You may create as many profiles as you want, just repeat step 1 and 2.

Profiles are created

A profile consists of domain-specific stereotypes and tagged values definition. To develop a profile, you need to create a profile diagram. For details
about how to create and draw a profile diagram, read the next chapter.
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Drawing a profile diagram
A profile diagram enables you to create domain and platform specific stereotypes and define the relationships between them. You can create
stereotypes by drawing stereotype shapes, and relate them with composition or generalization through the resource-centric interface. You can also
define and visualize tagged values of stereotypes.

Creating a profile diagram
To create a profile diagram:

1. Right click on a profile in Model Explorer and select Sub Diagrams > New Profile Diagram from the pop-up menu.

Create a new profile diagram

2. Name the diagram and press Enter to confirm. By default, the name of profile is applied as the name of diagram. If you attempt to create only
one profile diagram for a profile, and if your profile was well-named, you can keep using the profile name as diagram name.

Name a profile diagram

Drawing a stereotype
To draw a stereotype in profile diagram:

1. Select Stereotype in diagram toolbar and click on the diagram to create the stereotype.

Select Stereotype in diagram toolbar

2. In the Select Base Type of Stereotype dialog box, check the base type of stereotype from the specific model type tree. A base type defines the
type of model element that the stereotype will extend. Click OK button to proceed.

Check a base type

NOTE: You can check Display model element types in-use to list only types of model elements used in project. The text box Filter enables you
to filter model element type base on the type name (e.g. enter class to list only class).

3. As a result, the stereotype is created. Name it and press Enter to confirm creation.

Defining tagged values for stereotypes
A stereotype may have properties, which may be referred to as tag definitions. When a stereotype is applied to a model element, the values of the
properties may be referred to as tagged values.
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You can define tagged values for stereotypes. By doing so, when you apply the stereotype with tagged values defined to a model element, you can fill
in the values for the model element.

1. Right click on a stereotype shape and select Open Specification... from the pop-up menu.

Open specification

2. In the Stereotype Specification dialog box, open the Tagged Value Definitions tab.

3. Click Add button to select the type of tagged value to define. The type of tagged value limits the type of content user can enter for a tag.

Add a tag

Tag type Description

Text The most common and general type of tagged value that consists of words.

Multi-line Text The value of tag is a text in multiple lines.

Model element The value of tag is a model element in project.

Enumeration The value of tag can be chosen from a list of possible values. For example, to select "red" out of values red, green
and blue.

Integer The value of tag must be a real number.

Floating point
number

The value of tag must be a number that consists of one or more digits.

Type of tags

4. Double click the name cell and enter the name of tag. You may create as many tagged values as you want, just repeat step 3 and 4.

Tags defined for stereotype

5. You can assign a default value to a tag by editing the Default Value cell. Usually, you give a tag a default value when the value is true in most
cases. For example, a tag "in-door-temperature" can have "25" as default value. By confirming changes, you can see the stereotype show on
diagram, with tagged values shown below the stereotype name.

Stereotypes with tagged values defined

Relating stereotypes
Stereotypes can be related with each other by composition or generalization. Relating stereotypes not just affect the modeling in profile, but also the
model elements that the stereotypes will be applied to.
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Composition
A composition relationship shows a "part of" relationship between stereotypes. The composite stereotype has responsibility for the existence and
storage of the composed stereotype.

Composition between stereotypes

To create a composed stereotype:

1. Move the mouse over a stereotype and press its resource icon Composition > Stereotype.

Create a composition

2. Drag it and release it until it reaches the position you want to create the composed stereotype. Select base class, name the stereotype and
press Enter to confirm creation.

Since composition models are a "part of" relationship, when you apply a composite stereotype to a model element, you can add tagged value defined
in composed stereotype in the model element. For example, stereotype Development Team Member is composed of stereotype Developer. If you
apply stereotype Development Team Member to a unit, you can specify the properties of tagged values as defined by both stereotype Development
Team Member and Developer.

Generalization
A generalization relationship shows a "kind of" relationship between stereotypes.

A generalization relationship

To create a specific stereotype from a general stereotype:

1. Move the mouse over a stereotype. Press on the resource icon Generalization > Stereotype from the pop-up menu.

Create a generalization relationship

2. Drag it out. Release it until it reaches the position you want to create the specialized stereotype. Select base class, name the stereotype and
press Enter to confirm creation.

Since generalization models are a "kind of" relationship, when you apply a specialized stereotype to a model element, you can add tagged value
defined in general stereotype in the model element. For example, stereotype Developer is a generalized stereotype of Senior Developer. If you apply
stereotype Senior Developer to a unit, you can specify the properties of tagged values as defined by both stereotype Developer and Senior Developer.
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Brainstorm
Logizian enables you to record important ideas during a meeting through a note-taking feature called "Brainstorm". During the meeting, you create note
(shapes) in a corkboard -like diagram. When the meeting ends, you may organize the notes, and derive a diagram from them.

 

Using Brainstorm

Introduce to Brainstorm and shows you how to create a Brainstorm diagram.

 

Realize Brainstorm Notes

Teaches you how to realize notes into model elements.
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Using Brainstorm
Very often, you model a system not just by imagination, but with facts, knowledges and customers' ideas. You may meet with users, understand how
they work, identify their requirements and proceed to visualize their needs with models.
   Logizian enables you to record important ideas during a meeting through a note-taking feature called "Brainstorm". During the meeting, you create
note (shapes) in a corkboard -like diagram. When the meeting ends, you may organize the notes, and derive a diagram from them. This helps ensure
all important thoughts from users are well recorded and won't be lost when constructing a model.

A sample Brainstorm diagram

Creating Brainstorm diagram
In order to start taking notes, you need to create a Brainstorm diagram. There are three ways you may take to create a Brainstorm diagram:

• Diagram Navigator - Right click on Brainstorm in Diagram Navigator and select New Brainstorm from the popup menu.

• Toolbar - Click on the Diagrams button in toolbar and select Brainstorm from the drop-down menu.

• Menu - Select File > New Diagram > Others > Brainstorm from the main menu.

Creating a note
Brainstorm diagram applies a corkboard theme. You may add notes to it to record ideas and thoughts collected. To create a note:

1. Press and drag in diagram toolbar a note with the desired color.

Creating a note

2. Release the mouse button on the diagram to create a note.

3. Enter the note content. Press Ctrl-Enter to finish editing.

A note is created

Imagine when you are having a meeting with user and taking notes with Brainstorm, you may not be perfectly sure whether the notes you
create are utlimately important or not. As long as you think that the information may help you model, it is worthwhile to note it down for now. The
key idea is to add notes in a casual manner. Do not spend too much time on judging the importance of the content. Otherwise, you may miss out
information that is really important during the process of strenuous sorting.

Deleting a note
If a note has been created by mistake or the note text is no longer correct/meaningful, you may want to delete the note. To delete a note, you may
select it and press the Delete key. Alternatively, press on the cross button at top left of note shape to perform a deletion.
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Realizing Brainstorm Notes
Logizian enables you to record important ideas during a meeting through a note-taking feature called "Brainstorm". During the meeting, you pay
attention to what the participants say and create note (shapes) in a corkboard -like diagram to record the key points. After the meeting, you may make
use of the notes collected to help you construct the model. To optimize the process, Logizian supports a realize function to transform notes into model
elements.

Producing a task from a note

To realize a note:

1. Look for the note that can help you construct a model element. For example, when you see a note with text "ship goods", you may want to
create a task Ship Goods from it.

2. Click on Tag at bottom left of note body. Select the type of element from the popup menu, such as Task.

Select note type

3. Click the tag at bottom left and select Realize... from the popup menu.

4. In the Transit Model Element window, enter the properties of the model element you are going to produce. Click OK at bottom right to continue.

5. The Visualize Model Element window enables you to show the model element on a diagram. You may show it on a new diagram by selecting
Create new diagram and entering the diagram name. Or, show it in an existing diagram by selecting Show in existing diagram and selecting the
diagram to show. Or, not to show it on any diagram by selecting Do note visualize. Click Create/ Show/ Close at bottom right.

Changing note tag
If you have selected a tag for a note and you want to change it, click on any tag at bottom left of note shape and select Type > [New Tag] from the
popup menu. This will clear the previously select tag and apply the newly selected one. Note that once a tag has been realized, you cannot change it to
another type anymore.

Adding note tag
You may add multiple tags to a note and realize multiple model elements from different tags (one model element per tag). To add another tag, click on
any previously added tag at bottom left of note shape and select Add > [New Type] from the popup menu.

Deleting note tag
If you think that a note tag is no longer suitable for the note, you may delete it. To delete a tag, click on the tag you want delete from note and select
Delete from the popup menu. Note that if the tag has been realized, deleting the tag would not delete the realized model element. And if you add the
tag again, the realization relationship will be maintained.
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Generating HTML/PDF/Word report
Report generation is the process of producing a report for sharing your design work and model specification with teammates and clients. You can
generate reports in different formats such as HTML, PDF or MS Word for reading or publishing in different environments. In this chapter, you will see
how to generate a report, and how to configure the generation process and output.

 

Generating report

Shows you the basic steps in generating a HTML, PDF or MS Word report.

 

Configuring report

Gives you a description of all the report generation options.
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Generating report
Report generation is the process of producing a report for sharing your design work and model specification with teammates and clients. You can
generate reports in different formats such as HTML, PDF or MS Word for reading or publishing in different environments. They differ in file format, but
have the same layout. In this chapter, we will go through the core steps in report generation.

To generate a report:

1. Select Tools > Report from the main menu. Then select Generate HTML Report..., Generate PDF Report... or Generate Word Report...
depending on the type of report you want to generate.

2. In the Generate HTML/PDF/Word dialog box, fill in the output path where the report should be generated to.

NOTE: For HTML report, specify the folder of the HTML files to be generated.
For PDF report, specify the file path of PDF file (*.pdf) to be generated.
For MS Word report, specify the file path of the document file (*.docx) to be generated.

3. Select the grid(s) and/or diagram(s) to be included in report.

Select diagram to include in report

4. Make any necessary configuration such as the page layout, cover page, etc. For details about configuration, refer to the next chapter.

5. Click Generate to proceed with generation.

Overview of report generation dialog box

Overview of report generation dialog box
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The bottom part of report generaition dialog box for MS Word report

No.Name Description

1 ContentThe main page of report generation that lets you select the diagram(s) to generate report.

2 OptionsConfigurable options for detailed report configuration.

3 Page
Setup

The setup of layout of report.

4 Cover
Page

The cover page of report.

5 Header/
Footer

The content of header and footer.

6 Document
info

To define document info.

7 WatermarkTo define the watermark pattern on exported report.

8 TemplateYou can define a template for report generation by clicking on the drop down menu next to Template, and selecting <New>. Once a template is defined, you can select it from the same drop down menu, and proceed with generation with the template. For details about report customization, read the next chapter.

9 Use
external
template

Click to link to an external template file.

10 Edit
template

Click to edit the template selected in the drop down menu of Template.

11 Delete
template

Click to delete the template selected in the drop down menu of Template.

12 Import
template

Click to import a template file into the current project.

13 Output
path

The output path of report to be generated.

14 Launch
viewer

Check to open the report automatically after generation.

15 Available
diagram
list

The list of diagrams in opening project.

16 Selected
diagram
list

The list of diagrams selected to generate report.

17 PreviewPreview of diagram being selected in the list of selected diagram

18 ResetReset changes made in this dialog box

19 Reset
to
default

Reset changes made in this dialog box to default settings.

20 Set
as
default

Set the settings in this dialog box to default.

21 GenerateClick to generate report.

22 CancelClick to close the report dialog box.

23 ApplyClick to apply the changes made in report, causing reopening of this dialog box to restore the applied settings.

24 HelpClick to read the help contents.

25 Word
template
path

Available only to MS Word report generation, this option enables you to specify the path of MS Word document file that you want the generator to use as template. Report generator will append the template file content in front of generated report. In other words, you can prepare a file for cover page. Apart from this, style will also follow the definition in template file. For details, please read the section Generating MS Word report with template (MS Word report
only).
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Description of report generation dialog box

Generating MS Word report with template (MS Word report only)
At the bottom of the MS Word report generation dialog box, there is an option Word template path, with a text box next to it for filling in the path of
template file. A Word template file provides the start up contents and defines the style of report. During report generation, the generator will make a
copy of the template file, treat the copied file as base, append the generated content to the copied file, and save the file to the destination path. By
using a word template, you can define your own headers/footers, cover page, start up content, styles for your generated report.

A generated report with style defined in template applied

Sorting diagrams in report
By default, diagrams show in report follows the order defined in diagram tree in the Generate PDF dialog box. We may, however, sort the diagrams to
make them appear in desired sequence. To sort diagram(s), select the diagram(s) to be ordered on the list at the center of dialog box, and click    or
   to sort.

Reorder diagram

Sorting shapes in report

Custom sorting
1. Select the diagram to sort and click   to expand it.

2. Select the shape(s) to sort.
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3. Click   or   to sort.

Sort shapes

Automatic sorting
1. Select the diagram to sort and click  to expand it.

2. Select from the drop down menu Sort element a way to sort.

Select the way to sort shape

Way of

sorting

Description

AutomaticThe way of sorting elements is automatically managed. The order is often based on the flow and/or position of elements, which is
the most logical order, following most users' understanding of that kind of diagram.

Sort
by
Tree

Sort diagram elements by following the order defined in Diagram Navigator.

Sort
by
Name

Sort diagram elements alphabetically base on their name, in ascending order.

Custom The way of sorting elements is controlled by user, through selecting elements and pressing  or .

Different ways of sorting
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Configuring report
Report generation can be configured to make the output much closer to your expectation. Common configuration options include whether to generate
table of contents/figure or not, whether to generate shape/diagram type as icon or text, and whether to generate a particular type of detail such as
children. Besides configuration options, you can also adjust the page setup, design the cover page and define header/footer. In this chapter, we will go
through all the options one by one.

Options

Options

Option Description

Generate
table of
contents

If this option is selected, table of content for this document will be generated to the report

Generate
table of
figures

If this option is selected, table of figures for this document will be generated to the report

Generate
diagrams

If this option is selected, the image of the selected diagrams will be generated to the report.

For PDF report, you can select the type of diagram. Here are the possible selections:

• PNG - Images will look exactly the same as the diagrams in your project, but not scalable against zooming.

• SVG - Due to its scalable nature, image content will remain clear regardless of the level of zooming. However, image may look
a bit different from the original diagram as there is a conversion re-construction from raster graphic data to SVG image.

• SVG (text as shape) - Base on SVG, this option makes any text on diagram become text object, making it possible to select
them in report content.

Generate
diagram
properties

If this option is selected, the properties of the selected diagrams will be generated to the report.

Generate
diagram
summary

If the option is selected, the summary of the selected diagrams will be generated to the report.

Include extra
details

If the option is selected, information like ID and stereotypes will be generated to the summary table of report.

Suppress
element
with blank
documentation
in summary
table

If the option is selected, diagram elements without documentation defined will not be generated to summary table.

Generate
reference
(file/URL)
link

Select to generate links for referenced files/URLs defined in models.

Generate
model

Select to generate links for navigating to related models and diagrams.
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elements/
diagrams
link

Skip heading
for empty
model
element
section

If this option is selected, heading for empty model element section will be skipped.

Convert
multiline
model
heading to
single line

If this option is selected, multiline model heading will be converted to single line.

Show
multiline
model name

If this option is selected, non heading multiline model name will remain in multiline, instead of being converted to single line.

Treat HTML
content
as HTML
source

If this option is selected, HTML content will be treat as HTML source.

Suppress
details if
duplicated

If this option is selected, duplicated details will be suppressed.

Table
cell keep
together with
page

If this option is selected, table cell will try to show on a page completely instead of breaking into separate pages.

Shape type
style

Icon - using Icon to represent the type of shape and diagram elements
Text - using text to represent the type of shape and diagram elements

RTF content
appearance

Preserve formatting - using original formatting for RTF content
Make font size consistent with the rest of the report - using same font size for RTF content in whole report
Display in plain text - using plain text for RTF content

Copy
reference
files

If this option is selected, referenced files will be copy to output folder of report. With this option, you can copy the whole report folder
to another machine and read there, without having broken file linkage for references.

Details Select a kinds of content to generate it.

Children - Everything a shape is containing. When selected, you can further select Model-based or Diagram-based for controlling
the scope of children. Model-based consider all children the model of view contained. Diagram-based only consider the view
in generating diagram. Let say if you have a package containing several classes. By selecting Model-based, all classes will be
considered. By selecting Diagram-based, only the classes that are contained by the package in the generating diagram will be
considered.

Members - Attributes and operations are example of members.

Properties - Name, documentation, abstract, leaf are example of properties.

Relationships - Association, dependency are example of relationships

References - File, diagram, folder, URL, shape are possible kinds of reference

References documentation - Determine whether to generate the referenced shape/diagram's documentation in reference table

Sub-diagrams - Sub-diagrams of a shape

Comments - Comments of shape

Tagged values - Tagged values of shape

ORM Class Details - ORM class details specialized for ORM Persistable class

Use Case Details - Use case details of use case

Anti-aliasing Determine the quality of report content.

Graphics - To enable/disable the graphic anti-aliasing of the diagram images.

Text - To enable/disable the text anti-aliasing of the diagram images.

Font Determines the font family of report content. This option is only available to PDF report.

Encoding Determines the encoding of HTML file to be generated. This option is only available to HTML report.

A description of general options
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Page Setup
Page setup controls the layout of report. You can adjust a report size, page orientation and margin.

Page setup

Option Description

Page size To select the paper size of the generated report.

Page
orientation

This option is used to select the orientation of the report (portrait/landscape). This option is only available to PDF and MS Word
report.

Page margin To specify the page margins of the report. This option is only available to PDF and MS Word report.

A description of options of page setup

Cover Page (Front Page for HTML report generation)
Cover page is the first page of report. You can add your company logo there, and enter the report title, organization namd and author name. Notice that
in HTML report generation, the tab Cover Page is named as Front Page.

Cover page

Option Description

Generate cover page
(PDF and MS Word)

Generate front page
(HTML)

If this option is selected, there will be a cover page generated to the report.
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Logo image path An image that appear at the report. You are expected to supply the file path of the image file. The drop down menu at the
right hand side is for controlling the position of image.

Logo scale Control the scale of logo image. This option is only available to PDF and MS Word report.

Title The title text

Organization name The organization name text

Author name The author name text

A description of options of cover page

Header/Footer
Header and footer refers to the content that appear in the top and bottom of every page in report. For MS Word report, there are two text boxes for
you to edit the header and footer. For PDF report, there are six boxes, three for each of header and footer. Each of the text box represent a region in
header/footer, such as the top left text box refers to the left region of header, while the bottom right text box refers to the right region of footer.

Instead of typing in the content of header/footer, there are a set of variables for you to apply with. The following table provides you with description with
each of the variable.

Header/Footer

Variable Name Description

Selection font Font settings of selected content

Align to left Align content to the left of header/footer. This option is available only to MS Word report.

Align to center Align content to the center of header/footer. This option is available only to MS Word report.

Align to right Align content to the right of header/footer. This option is available only to MS Word report.

Add image Insert an image to the position where the text cursor is placing.

Insert page number Insert page number to the position where the text cursor is placing.

Insert page count Insert page count to the position where the text cursor is placing.

Insert date Insert the date of when the report is generated to the position where the text cursor is placing.

Insert time Insert the time of when the report is generated to the position where the text cursor is placing.

Insert project name Insert the project name to the position where the text cursor is placing.

Insert report file name Insert the name of report file to the position where the text cursor is placing.

Insert user name Insert the name of the user logging into the system to the position where the text cursor is placing.
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A description of variables that can be used in header and footer

Document Info
For HTML report, document info refers to the meta information of HTML document. For PDF and MS Word report, document info refers to the possible
document properties that can be defined.

Document info

Option Description

Title The title of report.

Author The author of the report. This option is only available to PDF report.

Subject The subject of the report.

Keywords The keywords of the report.

Info header The info header of the report. This option is only available to PDF report.

Info header content The info header content of the report. This option is only available to PDF report.

Allow modify Select to allow modification on the report. This option is only available to PDF report.

A description of document info

Watermark
To protect your content, you can define watermark to print in the generated report.

Watermark
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Customizing report
Instead of generating a report in a way that BP-VA defined for you, you can develop report templates to customize the report content, to make output
match your needs. In this chapter, you will see how to make use of the template editor to customize a report template.

 

Customizing report

Shows you how to launch the template editor to perform basic editing. It also describes the editor window in brief.

 

Export/import report template

Shows you how to export a template to a template file and import it into another instance.

 

Diagram loop

Define diagram loop and show you how to use a diagram loop in practice.

 

Diagram summary

Define diagram summary and show you how to use a diagram summary in practice.

 

Diagram paragraph

Define diagram paragraph and show you how to use a diagram paragraph in practice.

 

Element loop

Define element loop and show you how to use a element loop in practice.

 

Element summary

Define element summary and show you how to use a element summary in practice.

 

Element paragraph

Define element paragraph and show you how to use a element paragraph in practice.

 

Custom content

Define custom content and show you how to make use of it to enter formatted free text.

 

Diagram image

Define diagram image and show you how to make use of it to add an image of diagrams.

 

Property value

Define property value and show you how to make use it to extract a property from a parent model element.

 

Page break

Shows you how to insert a page break.
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Customizing report
Instead of generating a report in a way that Logizian defined for you, you can develop report templates to customize the report content, to make output
match your needs. With report customization, you can select model elements and properties to generate to report. You also can add custom text
content. To customize report:

1. Select Tools > Report from the main menu. Then select Generate HTML Report..., Generate PDF Report... or Generate Word Report...
depending on the type of report you want to generate.

NOTE: Report templates are shared among HTML, PDF and Word reports. If you just want to design template, but have no preference on the
type of report to generate yet, just select either HTML, PDF or Word.

2. Press on the Template drop down menu and select <New> from the popup menu to open the report template editor and start editing template.

To create a template

3. In the Report Template dialog box, enter the template name at the top of dialog box.

4. Construct the report template. A report template is formed by different kinds of components that put together in a hierarchical structure. A
common way of building a template is to start with a diagram loop, which can be created from the editor toolbar. Then, select the diagram loop
and create children components through its toolbar, such as to create an image component or a element loop for accessing diagram elements
on diagrams being looped. To learn how to use the tools in detail, refer to the coming chapters.

A sample template showing the use of diagram loop, element loop, property and custom text components

5. Click Save to save your work.

6. Click Close.

An overview of tools in template editor

Tool Name Description

Save Save the opening template.

Save as Save the opening template as a new one.

Exoprt To export the opening template to a report template file (.vpr). You can import the file to other machines for reusing it.

Add diagram
loop

To add a component to template editor, indicating the need of looping specific type(s) of diagram.

Add diagram
summary

To add a component to template editor, indicating the need of looping specific type(s) of diagram for constructing a tabular
diagram summary.

Add diagram
paragraph

To add a component to template editor, indicating the need of looping specific type(s) of diagram for printing its properties in
paragraph form.

Add element
loop (Model)

To add a component to template editor, indicating the need of looping Model.
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Add root level
element loop

To add a component to template editor, indicating the need of looping specific type(s) of model element that are at project root
(i.e. not being contained).

Add element
summary

To add a component to template editor, indicating the need of looping specific type(s) of model element for constructing a
tabular element summary.

Add element
paragraph

To add a component to template editor, indicating the need of looping specific type(s) of model element for printing its properties
in paragraph form.

Add all level
element loop

To add a component to template editor, indicating the need of looping model elements of specific type(s) in whole project.

Add custom
content

To add a component to template editor, indicating the placement of text written by user.

Preview
template
content

Preview the template against the project content for report content. Rendering of report is costly especially when the project is
large. If your project is large, be patient when waiting for outcome.

Preview
template
structure

Preview the template against the project content for report structure.

Options Configure report options.

Description of differnet tools in template editor

Ignoring specific diagrams/shapes
A report template is independent of any project file. But if you try to apply a template on a project, you can ignore generating specific diagrams or
shapes in that project. To ignore specific diagrams/shapes:

1. Open the template in template editor.

2.
Preview the report by pressing  or  from the toolbar.

3. In the report structure tree, select the diagrams or shapes that you want to ignore in generated report.

4. Right click on your selection and de-select Generate from the popup menu.

To not generate model elements

More about Preview
When you try to preview a template, it tries to apply the template on the opening project to form the report structure and to render the preview. Due to
the connection between template and project, there are several actions that you can perform with the preview.

Ignoring specific diagrams/shapes

In the report structure tree, right click on the diagram(s) or shape(s) that you want to ignore when generating report and de-select Generate from the
popup menu.

Reordering diagrams/shapes

In the report structure tree, right click on the diagram(s) or shape(s) that you want to re-order and select Move Up or Move Down to reposition them.
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To edit a template
To edit an existing report template, select it in the generate dialog box such as Generate PDF, then click on the edit button.

To edit a template

To delete a template
To delete an existing report template, select it in the generate dialog box such as Generate PDF, then click on the delete button.

To delete a template
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Export/import report template
You can apply a report template on another project by exporting it as a report template file, and importing it to the target project. To export and import
template:

1. Open the report template in template editor.

To open a template in template editor

2.
Click on the   button at the top of template editor to export template.

3. In the Export dialog box, enter the file name and click Save.

4. Open the project that you want the template to import to. Open the report dialog box by selecting Tools > Generate HTML/PDF/Word Report
from the main menu.

5.
Click on the   button.

6. In the Import dialog box, select the report template file and click Open.
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Diagram loop
A diagram loop is a component in a report template, indicating the need of looping (i.e. walking through) specific type(s) of diagram. For example, to
loop all business process diagrams and class diagrams in a project. Diagram loop means nothing more than just to loop diagram. The content to print
for each diagram being looped is to be determined by the children components of loop.

Looping diagrams in project
To loop specific type(s) of diagrams in project, create diagram loop at template root. To create diagram loop at template root:

1.
In the template editor, click on the   on toolbar.

2. On the right hand side of the template editor, select the type of diagram(s) to loop and click   to confirm the selection.

Select to loop use case diagram

Including stereotypes and glossary grid in report
Stereotypes and glossary grid fall into the category of diagram. If you want to print them to report, follow the steps as described in the previous section,
and to select the appropriate content to include at the final step.

Choosing to include glossary grid in template

Looping sub-diagrams of specific element
Instead of looping diagrams in a project, you can also place diagram loop under an element loop to loop for sub-diagrams of specific type(s) of model
element. To create diagram loop under an element loop:

1. Select the element loop that you want to loop for its sub-diagrams.

Selecting an element loop
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2. Click on the Add Diagram Loop button from the toolbar of element loop.

Adding a diagram loop

NOTE: Make sure you are clicking on the button from the toolbar of element loop. If you are clicking on the button at editor toolbar, you will
create a loop at template root.

3. On the right hand side of the template editor, select the type of sub-diagram(s) to loop and click  to confirm the selection.

Switching from diagram loop to diagram summary table/paragraph
A diagram summary indicates the need of looping specific type(s) of diagram for constructing a tabular diagram summary, while a diagram paragraph
indicates the need of looping specific type(s) of diagram for constructing paragraphs of properties.

You can convert a diagram loop to diagram summary table or paragraph by right clicking on a diagram loop and selecting Change to Summary Table/
Paragraph from popup menu.

To convert a diagram loop to diagram summary table/paragraph
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Diagram summary
A diagram summary is a component in a report template, indicating the need of looping (i.e. walking through) specific type(s) of diagram, and
presenting their properties in tabular form. For example, to loop all business process diagrams in a project and form a table consisting of diagram
names and documentation. By default, a table of diagram names will be printed. You are expected to add property column(s) under a diagram
summary to indicate the diagram properties to print in the table.

Showing a property table for diagrams in project
To loop specific type(s) of diagrams in project for listing their properties in a table, create diagram summary at template root. To create diagram
summary at template root:

1.
In the template editor, click on the   on toolbar.

2. On the right hand side of the template editor, select the type of diagram(s) to loop and click   to confirm the selection.

Select to loop business process diagram

3. If you generate report with a template like this, you will obtain a table of diagram names, provided that there exists diagram(s) of the chosen
type(s). If you need to print specific diagram properties in table other than just name, click on the Add Property Column button in the toolbar of
diagram summary, then select the property(ies) to add into the table as column(s). For more details about the use of property, read the chapter
Property.

To add a property column in diagram summary

Switching from diagram summary to diagram loop/paragraph
A diagram loop indicates the need of looping specific type(s) of diagram, while a diagram paragraph indicates the need of looping specific type(s) of
diagram for constructing paragraphs of properties.

You can convert a diagram summary to diagram loop or paragraph by right clicking on a diagram summary and selecting Change to Diagram Loop/
Paragraph from popup menu.

To convert a diagram summary to diagram loop/paragraph
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Diagram paragraph
A diagram paragraph is a component in a report template, indicating the need of looping (i.e. walking through) specific type(s) of diagram, and
presenting their properties in paragraph form. For example, to loop all use case diagrams in a project and print out their documentation and last
modified data in a paragraph, one paragraph per diagram. You are expected to add property value(s) under a diagram paragraph to indicate the
diagram properties to print out.

Showing a property paragraph for diagrams in project
To loop specific type(s) of diagrams in project for listing their properties in paragraph form, create diagram paragraph at template root. To create
diagram paragraph at template root:

1.
In the template editor, click on the   on toolbar.

2. On the right hand side of the template editor, select the type of diagram(s) to loop and click   to confirm the selection.

Select to loop use case diagram

3. If you generate report with a template like this, you will obtain a list of diagram types and names, provided that there exists diagram(s) of the
chosen type(s). If you need to print specific diagram properties other than just name, click on the Add Property Value button in the toolbar of
diagram paragraph, then select the property(ies) to show. For more details about the use of property, read the chapter Property.

To add a property value in diagram paragraph

Switching from diagram paragraph to diagram summary table/loop
A diagram summary indicates the need of looping specific type(s) of diagram for constructing a tabular diagram summary, while a diagram loop
indicates the need of looping specific type(s) of diagram.

You can convert a diagram paragraph to diagram summary table or loop by right clicking on a diagram paragraph and selecting Change to Summary
Table/Diagram Loop from popup menu.

To convert a diagram paragraph to diagram summary table/loop
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Element loop
An element loop is a component in a report template, indicating the need of looping (i.e. walking through) specific type(s) of diagram/model elements.
For example, to loop all task and sub-process in a project. Element loop means nothing more than just to loop diagram/model element. The content to
print for each diagram/model element being looped is to be determined by the children components of loop.

Looping model elements in project
To loop specific type(s) of model elements in project, create element loop at template root. To create element loop at template root:

1. In the template editor, click on any of the buttons in the toolbar depending on your need.

Button Name Description

Add
Element
Loop
(Model)

To loop through all models in the project root. In other words, model being contained by other model element will not be
accessed. This is a shortcut for creating a root level element loop whose chosen element type is model.

Add
Element
Loop
(Package)

To loop through all packages in the project root. In other words, package being contained by other model element will
not be accessed. This is a shortcut for creating a root level element loop whose chosen element type is package.

Add Root
Level
Element
Loop

To loop through any kind of model element in project root. By selecting this option, you can choose the type of model
element to be looped.

Add All
Level
Element
Loop

To loop through any kind of model element within the project, regardless of their leveling. By selecting this option, you
can choose the type of model element to be looped.

Description of available type of element loop

2. If you have chosen to add a model or a package loop, you do not need to perform any actions in further.
If you have chosen to add either root level or all level element loop, select the type of element(s) to loop on the right hand side of the template

editor and click   to confirm the selection.

Select to loop pool

NOTE: You can switch between a root level and a all-level loop by changing the option Root Level above the element list. Notice that changing
the value of Root Level is not about changing available element selection, but also the end result, whether to access only root level
elements or not.

Looping diagram elements in a diagram
Instead of looping model elements in a project, you can also place element loop under a diagram loop to loop for diagram elements in specific type(s)
of diagram. To create element loop under a diagram loop:

1. Select the element loop that you want to loop for its sub-diagrams.

Selecting a diagram loop
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2. Click on the Add Element Loop button from the toolbar of element loop.

Adding an element loop

NOTE: Make sure you are clicking on the button from the toolbar of diagram loop. If you are clicking on the button at editor toolbar, you will
create a loop at template root.

3. On the right hand side of the template editor, select the type of diagram element to loop and click  to confirm the selection.

Switching from element loop to element summary table/paragraph
An element summary indicates the need of looping (i.e. walking through) specific type(s) of diagram/model element, and presenting their properties
in tabular form, while an element paragraph indicates the need of looping specific type(s) of diagram/model element for constructing paragraphs of
properties.

You can convert an element loop to element summary table or paragraph by right clicking on a element loop and selecting Change to Summary
Table/Paragraph from popup menu.

To convert an element loop to element summary table/paragraph
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Element summary
An element summary is a component in a report template, indicating the need of looping (i.e. walking through) specific type(s) of diagram/model
element, and presenting their properties in tabular form. For example, to loop all use cases in a project and form a table consisting of use case IDs
and documentation. By default, a table of element names will be printed. You are expected to add property column(s) under an element summary to
indicate the element properties to print in the table.

Showing a property table for elements in project
To loop specific type(s) of model elements in project for listing their properties in a table, create element summary at template root. To create element
summary at template root:

1.
In the template editor, click on the   on toolbar.

2. On the right hand side of the template editor, select the type of model element(s) to loop and click   to confirm the selection.

Select to loop task

NOTE: By default, element summary added to project root enables the looping of root level elements. If you want to change to access elements
in all levels, change the option Root Level above the element list. Notice that changing the value of Root Level is not about changing
available element selection, but also the end result, whether to access only root level elements or not.

3. If you generate report with a template like this, you will obtain a table of element names, provided that there exists element(s) of the chosen
type(s). If you need to print specific element properties in table other than just name, click on the Add Property Column button in the toolbar of
element summary, then select the property(ies) to add into the table as column(s). For more details about the use of property, read the chapter
Property.

To add a property column in element summary

Switching from element summary to element loop/paragraph
An element loop indicates the need of looping specific type(s) of model/diagram element, while an element paragraph indicates the need of looping
specific type(s) of diagram/model element for constructing paragraphs of properties.

You can convert an element summary to element loop/paragraph by right clicking on an element summary and selecting Change to Element Loop/
Paragraph from popup menu.

To convert a element summary to element loop/paragraph
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Element paragraph
An element paragraph is a component in a report template, indicating the need of looping (i.e. walking through) specific type(s) of diagram/model
element, and presenting their properties in paragraph form. For example, to loop all tasks in a project and form paragraphs consisting of task IDs and
documentation. By default, a list of element names will be printed. You are expected to add property value(s) under an element paragraph to indicate
the element properties to print out.

Showing a property paragraph for elements in project
To loop specific type(s) of model elements in project for listing their properties in paragraph form, create element paragraph at template root. To create
element paragraph at template root:

1.
In the template editor, click on the   on toolbar.

2. On the right hand side of the template editor, select the type of model element(s) to loop and click   to confirm the selection.

Select to loop task

NOTE: By default, element paragraph added to project root enables the looping of root level elements. If you want to change to access elements
in all levels, change the option Root Level above the element list. Notice that changing the value of Root Level is not about changing
available element selection, but also the end result, whether to access only root level elements or not.

3. If you generate report with a template like this, you will obtain a list of element names, provided that there exists element(s) of the chosen
type(s). If you need to print specific element properties other than just name, click on the Add Property Column button in the toolbar of element
paragraph, then select the property(ies) to show. For more details about the use of property, read the chapter Property.

To add a property value in element paragraph

Switching from element paragraph to element summary table/loop
An element summary indicates the need of looping specific type(s) of diagram/model element for constructing a tabular element summary, while an
element loop indicates the need of looping specific type(s) of diagram/model element.

You can convert an element paragraph to element summary table or loop by right clicking on a element paragraph and selecting Change to Summary
Table/Element Loop from popup menu.

To convert a element paragraph to element summary table/loop
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Custom content
Custom content is a component in a report template, which acts as a placeholder of user written text. For example, to add a section of acknowledgment
at the beginning of report with custom text. You can write custom content in rich text, and you can add custom content to template root or under a
diagram/element loop.

Adding custom content at template root
To add custom content at template root:

1.
In the template editor, click on   on toolbar.

2. On the right hand side of the template editor, enter the custom content. You can format your content through the buttons in the content pane.
For details, read the section below about editing custom content.

Entering custom content

Adding custom content into a loop
To add custom content into a diagram/element loop:

1. Select the loop that you want to add custom content under it.

Selecting an element loop

2. Click on the Add Custom Content button from the toolbar of loop.

Adding custom content

NOTE: Make sure you are clicking on the button from the toolbar of element loop. If you are clicking on the button at editor toolbar, you will
create a loop at template root.

3. On the right hand side of the template editor, enter the custom content. You can format your content through the buttons in the content pane.
For details, read the section below about editing custom content.

Editing custom content
You can write plain text in custom content as well as to add formatted text, images and tables through the help of the tools in the editor.

Custom content editor

No. Name Description

1 Editor pane The editor where you can enter and edit custom content.

2 HTML HTML - Read and edit the real content.

HTML Source - Read and edit the HTML source of content.

3 Bold Set the highlighted text to bold.

4 Italic Set the highlighted text to italic.

5 Underline Underline the highlighted text

6 Alignments Set the alignment of highlighted text to right, center or left.

7 Ordered list Add a numbered list.
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8 Un-ordered list Add a list with bullet points.

9 Font Select the font family of highlighted text.

10 Font size Select the size of highlighted text.

11 Font color Select the color of highlighted text.

12 Table Add a table.

13 Background color Select the background color of highlighted text.

14 Clear formats Clear formats of whole editor to convert the content to plain text.

15 Link Add a hyperlink.

16 Image Add an image.

17 Print Print the custom content.

A description of custom content editor

 



Diagram Image P. 385

Diagram image
Diagram image is a component in a report template, which represents a placeholder of the image of a diagram under a diagram loop. You must place a
diagram image under diagram loop. To add a diagram image:

1. Select the diagram loop that you want the images of diagrams to be printed.

Selecting a diagram loop

2. Click on the Diagram Image button from the toolbar of loop.

Adding a diagram image
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Property value
Property value is an element component in a report template, which represents the access of certain property of a diagram, model element or diagram
element. For example, to print out the ID (property) of a business task. You can add property value into a diagram loop, a diagram summary, an
element loop, an element summary. Property value added to a summary component will become a property column in summary table.

Adding property value into a loop or summary
To add property value into a loop or summary:

1. Select the loop or summary that you want to add property value under it.

Selecting a diagram loop

2. Click on the Add Property Value button from the toolbar of loop.

Adding property value

3. On the right hand side of the template editor, select the property to access.

Selecting a property to access

Adding a property below another property
To add property below another property:

1. Select an existing property value.

Selecting a property value

2. Click on the Add Property Value Below or Add Property Value Above button.

To add a property value below an existing one

3. On the right hand side of the template editor, select the property to access.
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Page break
Page Break is where the report should start the contents which follows in a new page. It can be placed within a loop, either a diagram or element loop.
To create a Page Break:

1. Select the loop that you want to insert a page break.

Selecting the loop for adding a page break

2. Click on the Add Page Break button from the toolbar of loop.

Adding a page break

3. Reposition the page break by pressing Move Up or Move Down from the toolbar of page break.

Repositioning a page break
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Publishing project to web site
The Project Publisher is a tool that exports the project, including detailed information in diagrams and models, into interactive and well-organized web
pages. This chapter shows you how to publish a project.

 

Publish project using project publisher

Gives a brief description of publisher dialog box and guides you through the steps of publishing.

 

About publisher output

Describes the interactive features supported in published content.
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Publish project using project publisher
The Project Publisher is a tool that exports the project, including detailed information in diagrams and models, into interactive and well-organized web
pages. The generated web pages can be read in any web browser with no additional plug-in required, so collaborative partners may see the published
product even if they do not have Visual Paradigm products installed.

To launch Project Publisher:

1. Select Tools > Project Publisher... from main menu.

2. In the Project Publisher dialog box, specify the output directory where you want to save the published content.

3. You can optionally configure the publisher by adjust the options or options. For details, refer to the sections below.

4. Click  OK button to start publishing.

An overview of project publisher

Overview of project publisher

No. Name Description

1 Output
directory

The folder where you want to publish the content to.

2 Preserve
image
size

When checked, published content will show images in exact width and height.

3 Copy
reference
files

You can add file references to model elements. When this option is checked, referenced files will be copied to the output directory so
that you can access any referenced file when browsing the published content in other machine easily.

4 Publish
voices

When checked, audio clips recorded/linked to documentation will be publisher so that you can play them in published content.

5 Launch
viewer

When checked, the system will launch the web browser and open the published Web contents.

6 Advanced
options

Click to configure advanced publisher options. For details about the options, read the next section.

7 OK Click to publish.

8 Cancel Click to close the dialog box without publishing.

Description of project publisher

Advanced options
On the Project Publisher dialog box you can configure some of the common options. You can also configure the advanced options for more detailed
settings by clicking the Advanced Options... button.

Option Description

Generate model
element list in
diagram page

Check to generate a list of model element in a diagram page.

Generate only
documentation in
model element page

Check to generate only documentation in model element page, and exclude other contents.

Generate only when
documentation is
defined

Generate element page only when that element has documentation. When this option is off, the shape will have no linkage
from image in diagram page due to the absent of element page.
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Generate page
header

Check to generate pre-defined header.

Generate page footer Check to generate pre-defined footer.

Show documentation
when hover over a
shape

Check to show element's documentation when moving the mouse pointer over a shape in an image of diagram.

Show procedure for BP task and sub-process - Popup the working procedures when you move the mouse pointer over
BPMN tasks and sub-processes in an image.

Show test plan for test case - Popup the test plan when you move the mouse pointer over a test case in an image.

Generate diagram
type

Check to generate the diagram type in addition to diagram name.

Remove paragraph's
top and bottom
margin in RTF
documentation

By default, top and bottom margins are added above and below RTF documentation text, due to the default style applied to
the RTF documentation. If you want to remove the margins, you can override the setting by unchecking this option.

Generate referenced
project diagrams

Check to include contents for diagrams in referenced project.

Generate quality
information

Quality of model is assessed during the modeling. If you want to see the comment for each of your model elements, check
this option to include in report.

Overwrite report style
sheets

Project publishing is an "overwrite" action. If you publish to the same folder twice, files produced the first time would be
overwritten. This option enables you to keep the style sheets file (.css) without being overwritten. This enables you to edit
the styles defined and re-use it in subsequent publishing.

Generate grid
configuration

Check to include configuration for grids, such as the type of elements to list and the scope (e.g. project/model/diagram, etc)

Generate menu By default a diagram and model menus are shown on the left hand side of the published outcome. You can decide whether
or not to generate the menus, or produce two index files, one with menu and another one without.

Always show
indicators

Indicators refer to the small icons that show over shape(s) in image(s). They appear to reflect different status of the view
or model element - Is documentation entered? Is it a master or auxiliary view? Is sub-process/reference added? Is it a
referenced element?

Drill down effect for
general models

Choose the action when pressing on model elements on a diagram.

Drill down effect for
business sub-process

Choose the action when pressing on sub-processes on a diagram.

Drill down effect for
process (Process
Map)

Choose the action when pressing on processes on a process map diagram.

Drill down effect for
events (BPMN)

Choose the action when pressing on (BPMN) events on a diagram.

Drill down effect for
diagram overview

Choose the action when pressing on diagram overviews on a diagram.

Drill down effect for
action

Choose the action when pressing on (activity diagram) action on a diagram.

Drill down effect for UI
elements

Choose the action when pressing on UI elements (e.g. Frame, Panel, Button) on a diagram.

Publisher engine Choose the engine for publishing. You are advised to use the new engine.

Default diagram Choose the diagram that first appear when opening the published content. If unspecified, a default page with project
information will be presented.

Sort elements in type
groups by

Choose the way of sorting elements show in summary or drop down menu in diagram page

Filtered content Choose the content for not to show in published content

Description of project publisher advanced options
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About publisher output
Go to the output directory of the published project and open the file 'index.html' with a web browser. The web page is organized in frames, namely the
Navigator Pane, Menu Pane and Content Pane.

Published project

No. Name Description

1 Navigator
pane

It comprises of the Diagram Navigator, Model Navigator and Class Navigator.

2 Menu
pane

It shows the sub-menus of the Navigator pane. The contents shown in this pane varies with the link you clicked in the Navigator Pane. For
more details about the possible contents please refer to the Navigator Pane section.

3 Content
pane

It shows the details of the item (diagram, model or package/class) you clicked in the Menu Pane or Content Pane.

Description of the interface of published Web content

Navigator pane
There are four tabs within the navigator pane - Diagram Navigator, Model Explorer, Class Navigator and Logical View. They are responsible for
eading the project from different angle.

Diagram Navigator
Diagram Navigator shows the categories of diagrams in the project. You can click on a category to view its diagrams in the Menu Pane, or click Show
All Diagrams to view all diagrams.

Diagram navigator
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Model Explorer
Shows the package models in the project. You can click on a package to view its child models in the Menu Pane, or click  Show All Models  to view all
model elements.

Model Navigator

Logical view
Echos the logical view defined in project. You can click on a diagram to open it.

Logical view

Menu pane
To view the details of something (i.e. diagram, shape, model element), click on its link in the Menu Pane and its details will be shown in the Content
Pane.

Menu pane

Diagram Content
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Diagram content

The diagram type, name, description, together with a full size image of the diagram are shown in the Content Pane. The image is mapped to different
clickable regions for each shape, so you can click on a shape in the image to view its details.

Shape link to descriptions

Using jump to
The Jump to drop down menu in the diagram content page lists all shapes in the diagram. You can select a shape to jump to. The content page will
scroll to the selected shape and the shape will be highlighted by a red border.

Jump to

Besides, there will be two shortcut buttons above the selected shape.

The Back to top button brings you to the top of the page, while the Open specification button, next to Back to Top, brings you to the details page of
the shape.

Back to top
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Model element content
The type, name and general model properties of a model are shown in the content page.

Model element content

Parent hierarchy
The parent hierarchy is shown as a list of models on top of the page. You can click on a parent in the hierarchy to view its details.

Parent hierarchy
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Report composer
Report composer provides a flexible way for you to design and construct report. After that, you can export the final to a HTML/ PDF/ Word document.
This chapter will instruct you how to develop a report and then how to export the report.

 

Developing a report

This page shows you how to drag and drop selected model elements to create a report. Moreover, various functions are demonstarted, such as
inserting an image, a table, a text box, and refreshing the report content and selecting page display option.

 

Exporting a report

This page shows you how to export your final report. There are three types of report for exporting: HTML, PDF and Word.
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Developing a report
Report provides a flexible way for you to design and construct report. All you need to do is to select your target model element/diagram, drag the target
template(s) from Property pane and then drop it/them on the report (diagram). You cannot type in the report directly, however, report allows you to
add text, image and table to diagram as necessary. After that, you can export the result to a HTML/ PDF/ Word document. Since report maintains the
linkage between project data and report content, you can refresh the report upon project changes. As a result, it saves your time on repeating the steps
for creating report. All predefined templates can be edited in order to fit into your specific needs. An efficient way to customize your own templates is
also available. Details about how to edit template will be covered in next chapter.

Creating a Report
Right click on Report on Diagram Navigator and select New Report from the pop-up menu.

Create a Report

Developing a report in Report
After you have created a Report, you can select your model elements, and drag and drop them on it.

1. Select element(s) you created previously on Diagram Navigator/ Model Explorer .

Select a diagram
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2. Select and drag your target template(s) from Property pane, and drop it/ them on the diagram.

Drag and drop target template on the diagram

NOTE: If the Property pane is hidden, you can open it by selecting View > Panes > Property from the main menu.

Refreshing report content
Refreshing report content would be time-consuming if you have to repeat the same steps of creating report to update your report content. Logizian
accommodates the refresh button on Report&rsquo;s toolbar to help you refresh your report content shortly. You can refresh the content of reports,
including model elements and diagrams, to retrieve the latest updates and changes.

Return to your Report and click Refresh button on its toolbar.

Refresh report content

As a result, the modified element(s) will be updated.

Adding custom text
The text box is used for editing data on report. The significant characteristic is, you can display many different types of data with applying RTF within
the text boxes.

1. Select the space where you want to insert text beforehand.

2. Click Text box button on the Report's toolbar.

Insert a text box
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3. Enter text in the text box. You can use the pop-up formatting toolbar to convert your plain text into RTF when you want to emphasize some
terms/ phrases.

Format text

Adding image
Report supports inserting images. An image can be a logo or picture that is placed on the report. You can not only place pictures on the empty space of
report, but also fit them inside table cells. In this sense, you can insert your company logo into any preferred place within the report when you are doing
a company report. The advantage is, you can spare no effort in arranging a series of images in report and then resize them.

1. Select the space where you want to insert an image beforehand.

2. Click Image button on the Report's toolbar.

Insert an image

3. Select the directory of your target image and then click  Open button in Choose image(s) dialog box.
As a result, the selected image is inserted.

Image is inserted

Editing image
You may find that the image on report template is not clear enough since the image is oversized. This also affects the quality of image in both exported
report and the printout. It is recommended that you would edit an image and split a diagram on report template to make it legible. After creating multiple
diagram templates (the same diagram template) on report, edit each diagram template to show different parts of diagram. It is regarded as splitting
diagram. Finally, you can combine those fragmentary diagrams (separate diagram templates) to form a complete diagram after you print out the report.

1. Drag multiple diagram templates on the diagram in advance.
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2. Click each image so that a bar will appear at the bottom of the image. You can edit the image through the bar. Initially, the whole diagram is
displayed to fit the placeholder. As you can see, the slider is placed on Display whole diagram. Now, the extra large diagram is quite blurred.

The whole diagram is displayed inside the placeholder

To zoom in the particular part of diagram, drag the slider to Zoom 100% (Actual Size).

Zoom in the image
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3. To resize the image, drag the border of placeholder.

Resize the image

NOTE: You can only edit the diagram templates you dropped on the report, but not inserted images.

NOTE: The default setting of image on Report is Disable Auto Fit Placeholder. Nevertheless, once you zoom or resize, it will turn to be Enable
Auto Fit Placeholder automatically.

Adding table
Table is one of the important elements while displaying data. It provides a presentable format for data representation. Report enables you to present
data with RTF in tabular form by simply pressing Table button on the Report&rsquo;s toolbar.

1. Select the space where you want to insert a table beforehand.

2. Click Table button on the Report's toolbar and select the table size, i.e. the number of columns and rows in the table.

Select the table size

3. Complete the table.

Various page display options
Page display is especially useful when you view the overview of report layout. Logizian supports 4 display options: single page, single page continuous,
two-up and two-up continuous.

• Single Page displays only one page at a time.

• Single Page Continuous displays pages in a consecutive and vertical column.

• Two-Up displays two pages side by side simultaneously.

• Two-Up Continuous displays pages side by side in two consecutive vertical columns.
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Click the Page Display Option button to select a page display option from the drop-down menu.

Select an option
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Exporting a report
After you have customized your report template on report, you can export it into report. There are three types of report available for exporting: HTML,
PDF and Word.

In report, click the Export button at the top right corner and select a type of report for exporting.

Click Export button

In the pop-up Export [report type] Report dialog box, specify output path and document info, and customize page setup, cover page and watermark.

Specify output path

At last, click Export button.

The overview of export report dialog box

The overview of Export PDF Report dialog box

No. Name Description
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1 Output path The output path of report to be generated.

2 Launch viewer Check to open the report automatically after generation.

3 Refresh before export Before proceed exporting, refresh the report content.

4 Document info To define document information.

5 Options To determine how data is to be printed in report by setting some of the configurable options.

6 Page Setup To customize the layout of report.

7 Cover Page To customize the first page of report.

8 Watermark To customize the watermark on report.

9 Export Confirm and export the report.

10 Cancel Close the export report dialog box without exporting.

Description of export report dialog box

NOTE: An additional Content tab is attached to  Export Word Report dialog box.

The overview of Document Info

The overview of Document Info tab

No. Option Description

1 Title The title of report. This option is only available for exporting PDF report.

2 Author The author of the report.

3 Subject The subject of the report. This option is only available for exporting PDF and Word report.

4 Keywords The keywords of the report.

5 Info header The info header of the report. This option is only available for exporting PDF report.

6 Info header content The info header content of the report. This option is only available for exporting PDF report.

7 Allow modify Select to allow modification on the report. This option is only available for exporting PDF report.

Description of Document Info tab

The overview of Options Setup
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The overview of Page Setup tab

No. Option Description

1 Diagram
image type

Select the type of image format for image that appear in the exported report.

2 Font Control the font of report text.

3 Apply User
Language

By default, report content will be printed in English. By checking this option, it will follow the language setting chosen in global
options.

4 Repeat Table
Header

By checking this option, table header would be repeatedly printed when the table span multiple pages.

Description of Page Setup tab

The overview of Page Setup

The overview of Page Setup tab

No. Option Description

1 Page size To select the paper size of the exported report.

2 Page Orientation This option is used to select the orientation of the report (portrait/ landscape). This option is only available to PDF and
Word report.

3 Header Check this option to insert header to the exported report. This option is only available to PDF and Word report.

4 Header Separator Check this option to insert header separator to the exported report. This option is only available to PDF and Word
report.

5 Footer Separator Check this option to insert footer separator to the exported report. This option is only available to PDF and Word
report.

6 Footer Check this option to insert footer to the exported report. This option is only available to PDF and Word report.

7 Page Margin To specify the page margins of the report: top, left, right and bottom. This option is only available to PDF and Word
report.
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8 Measurement Unit To choose the measurement unit of page margin of the report: inch and cm. This option is only available to PDF and
Word report.

9 Margin (Left/ Top/ Right/
Bottom)

Specify the width of spaces between the content and the page border.

Description of Page Setup tab

The overview of Cover Page

The overview of Cover Page tab

No. Option Description

1 Generate cover
page

Check this option to generate a cover page to the report.

2 Logo image path Insert an image to the cover page. You can specify the image's directory or select the directory by clicking the ... button.

3 Logo scale Resize the inserted image by adjusting the slider.

4 Title Specify the title of your report on cover page.

5 Organization
name

Specify the organization name of your report on cover page.

6 Author name Specify the author name on cover page.

7 Alignment Control the position of content, whether to appear at the left, center of right hand side of the page.

8 Cover Page
Preview

You can preview your cover page here.

Description of Cover Page tab

The overview of Watermark

The overview of Watermark tab

No. Option Description
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1 Generate Watermark Check this option to generate watermark on all diagrams of report.

2 Text Specify the text will be used for watermark.

3 Color Specify the color of text will be used for watermark by clicking the ... button.

4 Transparency To change the background transparency for watermark, move the Transparency slider or specify the percentage
of transparency directly.

5 Font Name Select the font name for watermark.

6 Font Style Select the font style for watermark.

7 Font Size Select the font size for watermark.

8 Sample Preview watermark here.

Description of Watermark tab

The overview of Content (Only for Word report)

The overview of Content tab

No. Option Description

1 Word Template Check this option to select a Word template for Word report.

2 Path Specify the directory of word template by clicking the ... button.

Description of Content tab
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Inserting a table of contents
A table of contents, often be abbreviated as TOC, is a list of key parts of a document. It is often constructed by headers or key titles in a document, to
present readers with and outline of the whole document.

Report composer lets you insert a table of contents into a report. A table of contents can be formed not only from traditional headings styles like
Heading 1 (VP) and Heading 2 (VP), but from any kind of style, even from user-defined styles.  In generated report, table of contents provide readers
with access to different part of the report content.

Inserting a table of contents

Through toolbar
By inserting a table of contents through the toolbar, the table of contents will be put right under the currently selected content, if any, or at the end of
report if there is no active selection made in the report.

Creating a table of contents below the Revision Log

To insert a table of contents through toolbar, click on the plus button and select Table of Contents from the toolbar. Configure the table of contents and
click OK to create it. About the configuration of table of contents, please read the next section Configuring table of contents.

Through popup menu
You can insert a table of contents to a specific location in report by right clicking on a part of contents (e.g. the "Children" table of a diagram) and
selecting Insert > Table of Contents from the popup menu. This will add the table of contents below the clicked content.

Creating a table of contents below a page break

If you right click on the background (i.e. whitespace) within a report and select Insert > Table of Contents, this will add the table of contents to the end
of report.
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Configuring table of contents
To edit a table of contents for chaging its title, maximum number of level, level detection or styles, you need to configure it. Right click on the table of
contents and select Configure Table of Contents... from the popup menu.

The overview of Configure Table of Contents window

Option Description

1 The title of the table of contents. This is the text that appear above the table of contents in report.

2 Determines the depth of the table of contents.

3 Specify the style to check for each level. If you want level 1 shows all content with Heading 1 as style, select Level 1 on the left hand side,
Heading 1 on right hand side, and click < to match them up.

4 Specify the appearance of text in table of contents. You can apply different styles for different rows (levels).

Description of Configure Table of Contents window

Updating table of contents
To update a table of contents to make it reflect the structure of the latest report content, right click on the table of contents and select Update Table of
Contents from the popup menu.

Updating a table of contents

NOTE: Refreshing a report would not update a table of contents. The only way to update a table of contents is to update via its popup menu
Update Table of Contents.
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Deleting table of contents
To remove a table of contents from a document, either select it in the report and press the Delete key, or right click on it and select Delete from the
popup menu.
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Inserting a revision log
When your team attempt to or has made signaficant changes on a report, you may want to record the version of report, the date/time when the change
took place, the person who made the change and other necessarily remarks regarding the changes. Revision log is a piece of content you can add to a
report to record all these information. With a revision log, you fill in the revision detail, as well as to add/remove columns to suit the requirement of your
team.

Inserting a revision log

Through toolbar
By inserting a revision log through the toolbar, the revision log will be put right under the currently selected content, if any, or at the end of report if
there is no active selection made in the report.

Creating a revision log through the toolbar

To insert a revision log through toolbar, click on the plus button and select Revision Log from the toolbar.

Through popup menu
You can insert a revision log to a specific location in report by right clicking on a part of contents (e.g. the "Children" table of a diagram) and selecting
Insert > Revision Log from the popup menu. This will add the revision log below the clicked content.

Creating a revision log through a popup menu

If you right click on the background (i.e. whitespace) within a report and select Insert > Revision Log, this will add the revision log to the end of report.

Editing a revision log
To enter a revision, simply double click on the cells and enter the values one by one.

Editing a log
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Inserting a column
If you want to record an extra kind of content for revisions, you can add a column to the revision log table. Right click at the column where you want to
insert a column after it, select Insert Column from the popup menu.

Inserting a column

After that, double click on the header and enter the column header.

Entering the column header

Inserting a row
If you want to record a new revision, you need to insert a row. Right click at the row where you want to insert a row after it, select Insert Row from the
popup menu.

Inserting a new row



Inserting a revision log P. 412

After that, fill in the cells to record the new revision.

Entering a log
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Inserting a cover page
A cover page is a page that can be added at the beginning of a report. Whether or not to add such page is up to the writer. There are two kinds of
cover page you can add into a report. The first one is to print the cover page in a program defined way. This approach require you fill in some of the
background information like the report title, organization name and author name, etc. The second kind of cover page is fully designed by you, the
writer. It is called a free style cover page.

Build-in cover page (through Report Inspector)
When you export a report from report composer to a report file, a default cover page would be generated for you. You should configure the cover page
to make your company logo, report title, organization name and author name print on it. Otherwise, only a blank page would be printed. To configure
the default cover page:

1. Click on Report Inspector... in the toolbar.

Open the Report Inspector

2. Open the Cover Page tab.

Open the Cover Page tab

3. Configure the cover page by specifying file path of logo image, title, orgainzation name, author name. You can preview the page at the right
hand side of the Report Inspector.

Configure the cover page

4. Click OK.

NOTE: You will only see the cover page in the generated report.

Free style cover page
Free style cover page provides you with a page that appear at the beginning of a report for you to design the page. You can add any text and image
freely on the cover page, and position them in any position you like, within the cover page. To insert a free style cover page:
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1. Click on the plus button and select Cover Page from the toolbar.

Insert a free style cover page

2. When you insert a free style page the first time, you are prompted to override the generate cover page option. By default, the build in cover
page (as described in the above section) would be chosen as cover page. When you try to insert a free style cover page, the build in cover page
would be ignored. This option is to ask for your confirmation for ignoring the build in cover page. Click OK to confirm.

To overwrite the default cover page option

3. You will see an empty cover page is added to the beginning of the report. Note that the page MUST be added to the beginning of report. You
cannot control its location. If you want to add a free style page in the middle of the report, insert a Free Style page instead.
You can start editing the page by inserting text and image. To insert text or image into the page, right click on the background of cover page and
select Insert Free Style Text or Insert Free Style Image from the popup menu.

Insert a free style text in cover page
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4. Fill in the text or select the image file to insert to the page. Repeat step 3 and 4 to complete the page.

Cover page designed



Report composer template P. 416

Report composer template
Other than using the build-in templates in developing a report, you can also define your own templates, to construct report in your own way.

 

Introduction

Gives you an introduction to template development.

 

Creating a template

Shows you the steps of creating a template from an existing one through duplication.

 

Beginning of template

The template elements to use at the beginning of template.

 

Reading model - Looping

The template elements to use for looping through a type of model element through its parent.

 

Reading model - Conditional checking

The template elements to use for performing checking, i.e. to do something only when a condition is met.

 

Reading model - Model/diagram element

The template elements to use to query diagram/model element from a model element.

 

Text and break

The template elements to use for printing text or break to report. Text can be a custom text or to extract from a property of model element.

 

Table

The template elements to use at the beginning of template.

 

Miscellaneous

The template elements to use to build a table.
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Introduction
Report diagram provides you with a dynamic and efficient report design experience by letting you design report through simple drag-and-drop. You just
need to select a piece of model data, like a use case or a sequence diagram, then drag out a build-in template and drop it onto the report diagram to
create content.

All the build-in templates are opened for editing. To make report design more adoptable to your company&rsquo;s needs, you can edit a template or to
design your own templates and re-use it report-by-report. For example, design a class specification by printing out the documentation of classes that
contains "Controller" in their names.

This section is divided into two main parts. The first part is going to talk about the steps for creating a template in report diagram. The second part
comes with a detailed specification of template constructs you can use in constructing a template.

An element template
An element template is a XML-based document which defines the way to construct a part of a report. You can form a report by dragging and dropping
appropriate element templates onto report diagram. You can program a template by right clicking on it in property pane and selecting Edit in the popup
menu.

An element template is an XML based document
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Creating a template
Although report diagram comes with a complete set of build-in element templates, you may still want to customize, or even to create a template for
maximizing the efficiency of report design. You can accomplish this by creating and programming your own element template.

Before you create a template, please pay attention to the following points:

• Element templates are product installation based. All the projects opened under the same VP Suite installation share the same set of element
templates.

• If you need to open a project file that used an edited or new template in another environment, make sure that environment has the element
templates ready. Otherwise, the content may lost upon refreshing, or even make it unable to export report.

To create a template:

1. Editing or creating template must be done when report diagram is active. Open any report diagram.

2. Select the type of element to create template. For example, select ANY use case diagram in diagram navigator if you want to create a template
to list specific shapes in use case diagram. You can select project/diagram/model element/diagram element in various trees like Diagram
Navigator, Model Explorer or Class Repository.

Select a use case diagram

3. The Property pane lists the templates available for the selected element type. If your Property pane is hidden, select View > Panes > Property
(or press Ctrl+Shift+P) to show it.

Property pane
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4. To simplify the programming of template, you are suggested to duplicate an existing template and start editing it, rather than do do everything
from scratch. Target on a template that gives the cloest outcome to what you want to show in report. If you want to start from an empty
document, select any templates. Right click on your selection and select Duplicate... from the popup menu.

Duplicate a template

5. In the Duplicate Template dialog box, specify the following information and click OK to continue.
File - The physical file path of template file. You MUST store the template to the folder where the build-in templates are stored, which is the
suggested path.
ID - A string that can uniquely identify the template.
Name - The name of the template. This is also the name to appear in Property pane.

Duplicate template dialog box

6. In the Edit Template dialog box, customize your template and click OK to apply the changes.

Editing a template
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Beginning of template

<Template>

Description
<Template> is the root element of a template document.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Basic Information" description = "/" type = "table" default = "true"/>
    ...
</Template>

<TemplateInformationHeader>

Description
<TemplateInformationHeader> is an element that must exist as a child of <Template>. It is used primarily for specifying the name, description and type
of template. For details, please refer to the attributes section.

Attributes

Name Description/Usage Required?

id :
string

A value for uniquely identifying a template. Optional

name :
string

The name of template. It serves two purposes:
Act as the template display name to show in Template pane in report diagram
Act as a key to relate the content displayed in report diagram and the template file
Account for the second reason, do not change the name once the template has been used by a project, or else the linkage between
report content and template file will lost, making it failed to update the content upon refreshing.

Required

description :
string

A text to describe the template. Optional

default :
boolean
=
false

Specifies whether the template is the default template of the type of model element/diagram the template serves.
When editing a report diagram, you may select a template, drag and drop it onto the diagram to form content. Alternatively, drag and
drop a model element/diagram onto the diagram. At that moment, the default template will be applied.
Note that each model element/diagram can have zero or up to one default template. If there are more than one default templates, just
one of them will be chosen during report editing.

Optional

type
=
text

{text
|
image
|
table}

A template can be classified as text, image or table template, depending on what the template will print on report diagram.
A text template prints paragraphs of content, such as the documentation of model elements. An image template prints a diagram
image, such as the image of a use case diagram. A table template prints a table of model element, diagram or their properties, such
as a table of elements inside a package.
The selection of type affects just the icon to use in Template pane. If you do not specify a type, the template will be classified as a text
template.

Optional

Supported attributes for <TemplateInformationHeader>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Basic Information" description = "/" type = "table" default = "true"/>
    ...
</Template>

<ElementBaseInitiationBlock>

Description
<ElementBaseInitiationBlock> is an element that must exist as a child of <Template>. As an initiation block, <ElementBaseInitiationBlock> provides
a hints to the template engine, to tell the engine that the template is going to apply on a model element, not for any other kind of project data. In other
words, if you are creating a template for a model element (e.g. use case, package...), add a <ElementBaseInitiationBlock> under <Template>.

<ElementBaseInitiationBlock> represents the beginning of template. The remaining parts of template, its logic, shall be defined as children of
<ElementBaseInitiationBlock>.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Children of Package" description = "/" type = "table" default = "true"/>
    <ElementBaseInitiationBlock>
    ...
    </ElementBaseInitiationBlock>
</Template>
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<DiagramBaseInitiationBlock>

Description
<DiagramBaseInitiationBlock> is an element that must exist as a child of <Template>. As an initiation block, <DiagramBaseInitiationBlock> provides a
hints to the template engine, to tell the engine that the template is going to apply on a diagram, not for any other kind of project data. In other words, if
you are creating a template for a diagram (e.g. class diagram), add a <DiagramBaseInitiationBlock> under <Template>.

<DiagramBaseInitiationBlock> represents the beginning of template. The remaining parts of template, its logic, shall be defined as children of
<DiagramBaseInitiationBlock>.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "My Diagram" description = "/" type = "image" default = "true"/>
    <DiagramBaseInitiationBlock>
    ...
    </DiagramBaseInitiationBlock>
</Template>

<DiagramElementBaseInitiationBlock>

Description
<DiagramElementBaseInitiationBlock> is an element that must exist as a child of <Template>. As an initiation block,
<DiagramElementBaseInitiationBlock> provides a hints to the template engine, to tell the engine that the template is going to apply on a diagram
element, not for any other kind of project data. A diagram element is a view (shape) of model element. You can visualize a model element (on multiple
diagrams) to create as many diagram element(s) as you need. If you are creating a template for a diagram element (e.g. a class on class diagram), add
a <DiagramElementBaseInitiationBlock> under <Template>.

<DiagramElementBaseInitiationBlock> represents the beginning of template. The remaining parts of template, its logic, shall be defined as children of
<DiagramElementBaseInitiationBlock>.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Children of Package (diagram base)" description = "/" type = "text" default = "true"/>
    <DiagramElementBaseInitiationBlock>
    ...
    </DiagramElementBaseInitiationBlock>
</Template>

<ProjectBaseInitiationBlock>

Description
<ProjectBaseInitiationBlock> is an element that must exist as a child of <Template>. As an initiation block, <ProjectBaseInitiationBlock> provides a
hints to the template engine, to tell the engine that the template is going to apply on a project &ndash; the origin of model, not for any other kind of
project data. In other words, if you are creating a template for project, add a <ProjectBaseInitiationBlock> under <Template>.

<ProjectBaseInitiationBlock> represents the beginning of template. The remaining parts of template, its logic, shall be defined as children of
<ProjectBaseInitiationBlock>.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "My diagrams in project" description = "/" type = "text" default = "true"/>
    <ProjectBaseInitiationBlock>
    ...
    </ProjectBaseInitiationBlock>
</Template>
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Reading model &ndash; Looping

<ForEachSimpleRelationship>

Description
<ForEachSimpleRelationship> is a construct for retrieving SimpleRelationship elements from model element, or connector from diagram element. 

Attributes

Name Description/Usage Required?

Type : string
[Deprecated]

Deprecated. Replaced by @modelType. Optional

modelType :
string

Filter relationship by specified model element type (e.g. Generalization). Note that not all kinds of relationship belong to
simple relationship. Here are the possible types of simple relationship:
Abstraction, ActivityObjectFlow, AnalysisComposition, AnalysisDiagramTransitor, AnalysisParentChild,
AnalysisReference, AnalysisRelationship, AnalysisSubDiagram, AnalysisTransitor,  AnalysisUsed,
AnalysisView, Anchor, ArchiMateAccess, ArchiMateAggregation, ArchiMateAssignment, ArchiMateAssociation,
ArchiMateCommunicationPath, ArchiMateFlow, ArchiMateNetwork, ArchiMateProvide, ArchiMateRealization,
ArchiMateRequire, ArchiMateSpecialization, ArchiMateTriggering, ArchiMateUsedBy, AssociationClass, BPAssociation,
BPDataAssociation, BPMessageFlow, BPSequenceFlow, BindingDependency, BusinessRuleAssociation, Constraint,
ControlFlow, ConversationLink, DBForeignKey, DFDataFlow, Dependency, Deployment, EPCControlFlow,
EPCInformationFlow, EPCOrganizationUnitAssignment, ExceptionHandler, Extend, Generalization, GenericConnector,
GlossaryFactTypeAssociation, Include, InteractionDiagramDurationConstraint, Link, MindConnector, MindLink, OCLine,
ObjectFlow, PMProcessLink, Permission, RQRefine, RQTrace, Realization, RequirementDerive, Satisfy, Transition,
Transition2, Usage, Verify

Optional

modelTypes :
string

Filter relationships by modelTypes. If @modelType is defined, @modelTypes will be ignored. Optional

direction
{all | from | to}

Filter relationship by direction. Optional

ignoreParagraphBreakForLastModel :
boolean =
false

Ignore the break for the last element of current for-each loop.

Break can be <ParagraphBreak> or <StaticText @content= "\n" or ",">.

Optional

breakString :
string

Insert a string between model elements of current for-each. Optional

sortBy
[Deprecated]

Deprecated. Replaced by @sortBys. Optional

sortBys
{name |
modelType
| property |
followTree}

Used in sorting model elements in the for-each loop. This is to sort model elements by name and/or model type and/or
property.

E.g. sortBys="modelType, name"

Sorts model elements with their model type first. When same model type is met, sort by their names.

Optional

sortProperty :
string

Used in sorting. This is to sort model elements by specific property. This attribute works together with sortBys="property".

E.g. sortBys="property" sortProperty="visibility"

Sort model elements by their "visibility" property.

Optional

sortValues :
strings

Used in Sorting. This is to sort model elements base on the value of specific property.

E.g. sortValues="private, protected, public" sortBys="property" sortProperty="visibility"

The model elements will be sorted by "visibility" property in the order private -> protected -> public.

Optional

defaultPropertyValue :
string

Used in Sorting. This is to specify a default value for the model elemet(s) that have no value for its property. This works
together with sortBys="property".

Optional

descendingSort :
boolean =
false
[Deprecated]

Deprecated. Replaced by @descendingSort. Optional

descendingSorts :
booleans

Determines whether the sorting is in descending order or not. True for descending, false for ascending.
The numbers of descendingSorts should match the number of sortBys. For example, when @sortBy="name, modelType",
@descendingSorts="true, false". This means to sort by name in descending order, and sort by modelType in ascending
order.

Optional

Supported attributes for <ForEachSimpleRelationship>

Sample template fragment

<Template>
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    <TemplateInformationHeader name = "Generalizations of class" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <ForEachSimpleRelationship type="Generalization" direction="all">
            <StringPropertyText propertyText = "name"/>
        </ForEachSimpleRelationship>
    </ElementBaseInitiationBlock>
</Template>

<ForEachSubDiagram>

Description
<ForEachSubDiagram> is a construct for retrieving sub-diagram(s) from a model element. For example, retrieve sub-sequence-diagrams of a controller
class. Note that you can only use <ForEachSubDiagram> to retrieve sub-diagram(s) of model element. If you want to retrieve diagrams from project,
use <ForEachDiagram> instead.

Attributes

Name Description/Usage Required?

diagramType :
string

The type of diagram to retrieve. Optional

ignoreParagraphBreakForLastModel :
boolean =
false

Ignore the break for the last element of current for-each loop.

Break can be <ParagraphBreak> or <StaticText @content= "\n" or ",">.

Optional

sortBy
[Deprecated]

Deprecated. Replaced by @sortBys. Optional

sortBys
{name |
modelType
| property |
followTree}

Used in sorting model elements in the for-each loop. This is to sort model elements by name and/or model type and/or property.

E.g. sortBys="modelType, name"

Sorts model elements with their model type first. When same model type is met, sort by their names.

Optional

sortProperty :
string

Used in sorting. This is to sort model elements by specific property. This attribute works together with sortBys="property".

E.g. sortBys="property" sortProperty="visibility"

Sort model elements by their "visibility" property.

Optional

sortValues :
strings

Used in Sorting. This is to sort model elements base on the value of specific property.

E.g. sortValues="private, protected, public" sortBys="property" sortProperty="visibility"

The model elements will be sorted by "visibility" property in the order private -> protected -> public.

Optional

defaultPropertyValue :
string

Used in Sorting. This is to specify a default value for the model elemet(s) that have no value for its property. This works together with sortBys="property". Optional

descendingSort :
boolean =
false
[Deprecated]

Deprecated. Replaced by @descendingSort. Optional

descendingSorts :
booleans

Determines whether the sorting is in descending order or not. True for descending, false for ascending.
The numbers of descendingSorts should match the number of sortBys. For example, when @sortBy="name, modelType", @descendingSorts="true, false". This means to sort by name in descending order, and sort by modelType in ascending order.

Optional

Supported attributes for <ForEachSubDiagram>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Name of sub-diagrams" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <ForEachSubDiagram>
            <StringPropertyText propertyText = "name"/>
        </ForEachSubDiagram>
    </ElementBaseInitiationBlock>
</Template>

<ForEachOwnerDiagram>

Description
<ForEachOwnerDiagram> is a construct for retrieving the diagram(s) that owns a specific model element. For example, class diagram "Domain
Diagram" and "Security" both contain class "Login" (same model element), by applying <ForEachOwnerDiagram> on the "Login" class, diagram
"Domain Diagram" and "Security" will be returned.

Attributes
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Name Description/Usage Required?

diagramType :
string

The type of diagram to retrieve. Optional

ignoreParagraphBreakForLastModel :
boolean =
false

Ignore the break for the last element of current for-each loop.

Break can be <ParagraphBreak> or <StaticText @content= "\n" or ",">.

Optional

sortBy
[Deprecated]

Deprecated. Replaced by @sortBys. Optional

sortBys
{name |
modelType
| property |
followTree}

Used in sorting model elements in the for-each loop. This is to sort model elements by name and/or model type and/or property.

E.g. sortBys="modelType, name"

Sorts model elements with their model type first. When same model type is met, sort by their names.

Optional

sortProperty :
string

Used in sorting. This is to sort model elements by specific property. This attribute works together with sortBys="property".

E.g. sortBys="property" sortProperty="visibility"

Sort model elements by their "visibility" property.

Optional

sortValues :
strings

Used in Sorting. This is to sort model elements base on the value of specific property.

E.g. sortValues="private, protected, public" sortBys="property" sortProperty="visibility"

The model elements will be sorted by "visibility" property in the order private -> protected -> public.

Optional

defaultPropertyValue :
string

Used in Sorting. This is to specify a default value for the model elemet(s) that have no value for its property. This works together with sortBys="property". Optional

descendingSort :
boolean =
false
[Deprecated]

Deprecated. Replaced by @descendingSort. Optional

descendingSorts :
booleans

Determines whether the sorting is in descending order or not. True for descending, false for ascending.
The numbers of descendingSorts should match the number of sortBys. For example, when @sortBy="name, modelType", @descendingSorts="true, false". This means to sort by name in descending order, and sort by modelType in ascending order.

Optional

Supported attributes for <ForEachOwnerDiagram>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Name of parent diagrams" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <ForEachOwnerDiagram>
            <StringPropertyText propertyText = "name"/>
        </ForEachOwnerDiagram>
    </ElementBaseInitiationBlock>
</Template>

<ForEachDiagram>

Description
<ForEachDiagram> is a construct for retrieving diagram(s) from project. Like other for-each constructs, you can specify the type of diagram to retrieve.
For example, retrieve all class diagrams from project. Note that you can only use <ForEachDiagram> to retrieve diagram from project. If you want to
retrieve sub-diagrams from model element, use <ForEachSubDiagram> instead.

Attributes

Name Description/Usage Required?

diagramType :
string

The type of diagram to retrieve. Optional

ignoreParagraphBreakForLastModel :
boolean =
false

Ignore the break for the last element of current for-each loop.

Break can be <ParagraphBreak> or <StaticText @content= "\n" or ",">.

Optional

sortBy
[Deprecated]

Deprecated. Replaced by @sortBys. Optional

sortBys
{name |
modelType
| property |
followTree}

Used in sorting model elements in the for-each loop. This is to sort model elements by name and/or model type and/or property.

E.g. sortBys="modelType, name"

Sorts model elements with their model type first. When same model type is met, sort by their names.

Optional
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sortProperty :
string

Used in sorting. This is to sort model elements by specific property. This attribute works together with sortBys="property".

E.g. sortBys="property" sortProperty="visibility"

Sort model elements by their "visibility" property.

Optional

sortValues :
strings

Used in Sorting. This is to sort model elements base on the value of specific property.

E.g. sortValues="private, protected, public" sortBys="property" sortProperty="visibility"

The model elements will be sorted by "visibility" property in the order private -> protected -> public.

Optional

defaultPropertyValue :
string

Used in Sorting. This is to specify a default value for the model elemet(s) that have no value for its property. This works together with sortBys="property". Optional

descendingSort :
boolean =
false
[Deprecated]

Deprecated. Replaced by @descendingSort. Optional

descendingSorts :
booleans

Determines whether the sorting is in descending order or not. True for descending, false for ascending.
The numbers of descendingSorts should match the number of sortBys. For example, when @sortBy="name, modelType", @descendingSorts="true, false". This means to sort by name in descending order, and sort by modelType in ascending order.

Optional

Supported attributes for <ForEachDiagram>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Name of diagrams" description = "/" type = "text" default = "false"/>
    <ProjectBaseInitiationBlock>
        <ForEachDiagram>
            <StringPropertyText propertyText = "name"/>
        </ForEachDiagram>
    </ProjectBaseInitiationBlock>
</Template>

<IterationBlock>

Description
<IterationBlock> is a construct for retrieving children elements from project/model element/diagram/diagram element. Iterating through project and
model element will retrieve a list of model element, while iterating through diagram and diagram element will retrieve a list of diagram element.

If you want to retrieve sub-diagrams of a model element, check <ForEachDiagram>. If you want to retrieve all diagrams of project, check <
ForEachSubDiagram>.

Attributes

Name Description/Usage Required?

elementType :
string
[Deprecated]

Deprecated. Replaced by @modelType. Optional

modelType : string Filter the children by specified model element type (e.g. package). Optional

elementTypes :
string
[Deprecated]

Deprecated. Replaced by @modelTypes. Optional

modelTypes :
string

Filter the children by a number of model element types. (e.g. actor, usecase) Optional

stereotypes :
string

Filter the children by a number of stereotypes. Optional

name : string Filter the children by their name. Optional

filterhidden :
boolean = false

Filter hidden children diagram element. This is for retrieving from diagram/diagram element only. Optional

includeConnector :
boolean = false
[Deprecated]

Deprecated. Replaced by @includeConnectors. Optional

includeConnectors :
boolean = false

Determines whether to retrieve shape or shape+connectors from diagram. This is for retrieving from diagram only. Optional

byBounds :
boolean = false

Determines whether to retrieve shape by their bounds. This is for retriever from diagram or diagram element only. Optional
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byBoundsInAllLevel :
boolean = false

Determines whether to retrieve shape by their bounds (include nested level). This is for retriever from diagram or
diagram element only.

Optional

allLevel : boolean
= false

Determines whether to retrieve all model elements from project. When false, only the root level elements will be
retrieved. This attribute is only useful when retrieving elements from project.

Optional

ignoreParagraphBreakForLastModel :
boolean = false

Ignore the break for the last element of current for-each loop.

Break can be <ParagraphBreak> or <StaticText @content= "\n" or ",">.

Optional

breakString :
string

Insert a string between model elements of current for-each. Optional

sortBy
[Deprecated]

Deprecated. Replaced by @sortBys. Optional

sortBys
{name |
modelType
| property |
followTree}

Used in sorting model elements in the for-each loop. This is to sort model elements by name and/or model type and/or
property.

E.g. sortBys="modelType, name"

Sorts model elements with their model type first. When same model type is met, sort by their names.

Optional

sortProperty :
string

Used in sorting. This is to sort model elements by specific property. This attribute works together with
sortBys="property".

E.g. sortBys="property" sortProperty="visibility"

Sort model elements by their "visibility" property.

Optional

sortValues :
strings

Used in Sorting. This is to sort model elements base on the value of specific property.

E.g. sortValues="private, protected, public" sortBys="property" sortProperty="visibility"

The model elements will be sorted by "visibility" property in the order private -> protected -> public.

Optional

defaultPropertyValue :
string

Used in Sorting. This is to specify a default value for the model elemet(s) that have no value for its property. This
works together with sortBys="property".

Optional

descendingSort :
boolean = false
[Deprecated]

Deprecated. Replaced by @descendingSort. Optional

descendingSorts :
booleans

Determines whether the sorting is in descending order or not. True for descending, false for ascending.
The numbers of descendingSorts should match the number of sortBys. For example, when @sortBy="name,
modelType", @descendingSorts="true, false". This means to sort by name in descending order, and sort by
modelType in ascending order.

Optional

Supported attributes for <IterationBlock>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Children" description = "/" type = "table" default = "false"/>
    <ElementBaseInitiationBlock>
        <IterationBlock modelType="class">
            <StringPropertyText propertyText = "name"/>
        </IterationBlock>
    </ElementBaseInitiationBlock>
</Template>
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Reading model - Conditional checking

<DefaultConditionChecker>

Description
<DefaultConditionChecker> is a construct which enables you to check whether the value of a property of a model element is the same as the default
value, to control whether or not to continue processing the children template nodes base on the result of checking. Let&rsquo;s take use case, a kind
of model element, as example. For each use case, you can optionally set its rank to Low/Medium/High. When you are preparing a report to list the use
cases with respect to their ranks, you probably interested in seeing the use cases that have rank set, but not those without rank set. In that situation
you can make use of <DefaultConditionChecker> to make the report ignore those use cases with rank be Unspecified, which is the default value of
rank.

Attributes

Name Description/Usage Required?

property : string  The property to check. Required

equalFlag : boolean = false
[Deprecated]

Deprecated. Replaced by @flag. Optional

flag : boolean = false Determines whether you expect the value to be the same as the default or not. Optional

Supported attributes for <DefaultConditionChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Visibility of classes" description = "/" type = "text" default = "false"/>
    <DiagramBaseInitiationBlock>
        <IterationBlock>
            <DefaultConditionChecker property="visibility" flag="false">
                <StringPropertyText propertyText = "visibility"/>
            </DefaultConditionChecker>
        </IterationBlock>
    </DiagramBaseInitiationBlock>
</Template>

<ValueConditionChecker>

Description
<ValueConditionChecker> is a construct which enables you to check whether the value of a property of a model element is the same as what you
expect, to control whether or not to continue processing the children template nodes base on the result of checking. For example, print out the name of
classes that contain "Controller" in their names.

Attributes

Name Description/Usage Required?

property : string The property to check. Required

propertyType : string
{string | int | boolean | model}

The type of property. Optional

operator : string
{equals, not equals, less than, equals or less than, greater than, equals or
greater than, like, not like, equals, not equal}

Specify the way to compare the property value of model against
your expectation.
equals - The value of property must be the same as the
expected value
not equals - The value of property must be different from the
expected value
less than - The value of property must be smaller than the
expected value.
equals or less than - The value of property must be the same or
smaller than the expected value.
greater than - The value of property must be larger than the
expected value.
equals or greater than - The value of property must be the
same or larger than the expected value.
like &ndash; The value of property must contain the expected
value
not like - The value of property must not contain the expected
value
equal &ndash; Deprecated. Replaced by "equals ".
not equal - Deprecated. Replaced by "not equals ".

Required

value : string The value expected for the property Optional

caseSensitive : boolean = true Determines whether the checking of string property need to
take care of the use of upper and lower case.

Optional
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Supported attributes for <ValueConditionChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Controller classes" description = "/" type = "text" default = "false"/>
    <DiagramBaseInitiationBlock>
        <IterationBlock>
            <ValueConditionChecker property="name" operator = "like" value = "Controller" >
                <StringPropertyText propertyText = "name"/>
            </ValueConditionChecker>
        </IterationBlock>
    </DiagramBaseInitiationBlock>
</Template>

<HasChildElementChecker>

Description
<HasChildElementChecker> is a construct which enables you to check whether a project or a model element contains a child element, to control
whether or not to continue processing the children template nodes base on the result of checking.

Attributes

Name Description/Usage Required?

flag : boolean =
true

Check whether you want any child exists or not. Optional

type : string
[Deprecated]

Deprecated. Replaced by @modelType. Optional

modelType :
string

The type of model element you want the parent to contain or not contain. Optional

elementTypes :
string
[Deprecated]

Deprecated. Replaced by @modelTypes. Optional

stereotypes :
strings

Filter the children by a number of stereotypes. Optional

includeConnector :
boolean
[Deprecated]

Deprecated. Replaced by @includeConnectors Optional

includeConnectors :
boolean = false

Determines whether to retrieve shape or shape+connectors from diagram. This is for retrieving from diagram only. Optional

allLevel :
boolean = false

Determines whether to retrieve all model elements from project. When false, only the root level elements will be
retrieved. This attribute is only useful when retrieving elements from project.

Optional

Supported attributes for <HasChildElementChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Package has children?" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <HasChildElementChecker flag = "true">
            <StaticText content = "This package has children!"/>
        </HasChildElementChecker>
    </ElementBaseInitiationBlock>
</Template>

<HasDiagramChecker>

Description
<HasDiagramChecker> is a construct which enables you to check whether a project contains any diagram, or a specific type of diagram, to control
whether or not to continue processing the children template nodes base on the result of checking.

Attributes

Name Description/Usage Required?

flag : boolean = true Check whether you want any diagram exists or not. Optional

type : string
[Deprecated]

Deprecated. Replaced by @diagramType. Optional
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diagramType : string The type of diagram you want the project to contain or not contain. Optional

Supported attributes for <HasDiagramChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Has Class Diagram?" description = "/" type = "text" default = "false"/>
    <ProjectBaseInitiationBlock>
        <HasDiagramChecker type = "ClassDiagram">
            <StaticText content = "This project contains class diagram!"/>
        </HasDiagramChecker>
    </ProjectBaseInitiationBlock>
</Template>

<HasMetaModelPropertyChecker>

Description
<HasMetaModelPropertyChecker> is a construct which enables you to check whether a model element contains any model element, or a specific type
of model element, to control whether or not to continue processing the children template nodes base on the result of checking.

Attributes

Name Description/Usage Required?

flag : boolean = true Check whether you want the model element exists or not. Optional

property : string The name of model element property you want to contain or not contain. Required

Supported attributes for <HasMetaModelPropertyChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Has Stereotype?" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <HasMetaModelPropertyChecker property = "stereotypes" flag = "true">
            <StaticText content = "This element contains stereotype!"/>
        </HasMetaModelPropertyChecker>
    </ElementBaseInitiationBlock>
</Template>

<HasParentModelChecker>

Description
<HasParentModelChecker> is a construct which enables you to check whether a model element is contained by another model element, to control
whether or not to continue processing the children template nodes base on the result of checking. For example, check whether a class is under (i.e.
contained by) a package.

Attributes

Name Description/Usage Required?

flag : boolean = true Check whether you want the parent exists or not. Optional

modelType : string The type of parent model element you want the model element to be/not to be contained by. Optional

Supported attributes for <HasParentModelChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Contained by parent?" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <HasParentModelChecker flag = "true">
            <StaticText content = "This element is contained by a parent!"/>
        </HasParentModelChecker>
    </ElementBaseInitiationBlock>
</Template>

<HasSubDiagramChecker>

Description
<HasSubDiagramChecker> is a construct which enables you to check whether a model element contains any sub-diagram, to control whether or not to
continue processing the children template nodes base on the result of checking.

Attributes

Name Description/Usage Required?
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flag : boolean = true Check whether you want any sub-diagram exists or not. Optional

type : string
[Deprecated]

Deprecated. Replaced by @diagramType Optional

diagramType : string The type of sub-diagram you want the model element to contain. Optional

Supported attributes for <HasSubDiagramChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Contained sub-diagram?" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <HasSubDiagramChecker flag = "true">
            <StaticText content = "This element contains sub-diagram!"/>
        </HasSubDiagramChecker>
    </ElementBaseInitiationBlock>
</Template>

<ReportOptionChecker>

Description
<ReportOptionChecker> is a construct which enables you to check specific report option, to control whether or not to continue processing the children
template nodes base on the result of checking.

Attributes

Name Description/Usage Required?

equalFlag : Boolean
[Deprecated]

Deprecated. Replaced by @flag Optional

flag : boolean = false Check whether you want a report option to be true or false. Optional

option : string
[Deprecated]

The option to check. For example, basicInformationShowsDocumentation. Optional

Supported attributes for <ReportOptionChecker>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Documentation" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <ReportOptionChecker option = "basicInformationShowsDocumentation" equalFlag = "true">
            <StringPropertyText propertyText = "documentation"/>
        </ReportOptionChecker>
    </ElementBaseInitiationBlock>
</Template>
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Reading model - Model/diagram element

<MetaModelElement>

Description
<MetaModelElement> is a construct which enables you to retrieve a model element from another model element.

Attributes

Name Description/Usage Required?

modelProperty :
string

The name of property to query from model element, which should result in returning a model element from the given
model element.

Optional

Supported attributes for <MetaModelElement>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Tagged values" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <MetaModelElement modelProperty = "taggedValues">
            <IterationBlock>
                <StringPropertyText propertyText = "name"/>
            </ IterationBlock >
        </MetaModelElement>
    </ElementBaseInitiationBlock>
</Template>

<FromEnd>

Description
<FromEnd> is a construct for retrieving the from-side of a relationship. Here are some of the key points you need to know when using <FromEnd> in
your template:

• The from-end of relationship is determined by the side a connector (shape) begins with. It has nothing related to the semantic or definition of
notation. Take generalization as example, the from-side is the side with arrow head (unless you have configured the beginning of generalization
in Options window).

• When you try to retrieve the from-end of an association, you are retrieving the connected element (e.g. a class, a use case) instead of a role. If
you need to retrieve a role, use <ForEachRelationshipEnd>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Associations and Generalizations" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <!-- Print from ends of associations -->
        <ForEachRelationshipEnd type = "AssociationEnd" endPointer = "self">
            <RelationshipEndEndRelationship>
                <FromEnd>
                    <StringPropertyText propertyText = "name"/>
                </FromEnd>
            </RelationshipEndEndRelationship>
        </ForEachRelationshipEnd>
        <!-- Print from ends of generalizations -->
        <ForEachSimpleRelationship type = "Generalization" direction = "all">
            <FromEnd>
                <StringPropertyText propertyText = "name"/>
            </FromEnd>
        </ForEachRelationshipEnd>
    </ElementBaseInitiationBlock>
</Template>

<ToEnd>

Description
<ToEnd> is a construct for retrieving the to-side of a relationship. Here are some of the key points you need to know when using <ToEnd> in your
template:

• The to-end of relationship is determined by the side a connector (shape) begins with. It has nothing related to the semantic or definition of
notation. Take generalization as example, the to-side is the side without arrow head (unless you have configured the beginning of generalization
in Options window).

• When you try to retrieve the to-end of an association, you are retrieving the connected element (e.g. a class, a use case) instead of a role. If you
need to retrieve a role, use <ForEachRelationshipEnd> to retrieve the association ends of an elements. The association ends returned is then
the roles.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Associations and Generalizations" description = "/" type = "text" default = "false"/>
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    <ElementBaseInitiationBlock>
        <!-- Print to ends of associations -->
        <ForEachRelationshipEnd type = "AssociationEnd" endPointer = "self">
            <RelationshipEndEndRelationship>
                <ToEnd>
                    <StringPropertyText propertyText = "name"/>
                </ToEnd>
            </RelationshipEndEndRelationship>
        </ForEachRelationshipEnd>
        <!-- Print to ends of generalizations -->
        <ForEachSimpleRelationship type = "Generalization" direction = "all">
            <ToEnd>
                <StringPropertyText propertyText = "name"/>
            </ToEnd>
        </ForEachRelationshipEnd>
    </ElementBaseInitiationBlock>
</Template>

<RelationshipEndEndRelationship>

Description
<RelationshipEndEndRelationship> is a construct for retrieving relationship from a relationship end (e.g. association end). Note that
<RelationshipEndEndRelationship> has no effect with <FromEnd> and <ToEnd>.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Associations" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <!-- Print to ends of associations -->
        <ForEachRelationshipEnd type = "AssociationEnd" endPointer = "self">
            <RelationshipEndEndRelationship>
                <ToEnd>
                    <StringPropertyText propertyText = "name"/>
                </ToEnd>
            </RelationshipEndEndRelationship>
        </ForEachRelationshipEnd>
    </ElementBaseInitiationBlock>
</Template>

<RelationshipEndOppositeEnd>

Description
<RelationshipEndOppositeEnd> is a construct for retrieving the opposite end of a relationship end (e.g. association end). Note that
<RelationshipEndOppositeEnd> has no effect with <FromEnd> and <ToEnd>.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Associations" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <ForEachRelationshipEnd type = "Print myself" endPointer = "self">
            <RelationshipEndOppositeEnd>
                <MetaModelElement property="EndModelElement">
                    <StringPropertyText propertyText = "name"/>
                </ MetaModelElement>
            </RelationshipEndOppositeEnd>
        </ForEachRelationshipEnd>
    </ElementBaseInitiationBlock>
</Template>

<ParentModel>

Description
<ParentModel> is a construct for retrieving the parent model element that contains a model element. For example, retrieve the package of a class.

Attributes

Name Description/Usage Required?

modelProperty : string The type of parent model element you want the model element to be/not to be contained by. Optional

Supported attributes for <ParentModel>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Parent" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <ParentModel>
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            <StringPropertyText propertyText = "name"/>
        </ParentModel>
    </ElementBaseInitiationBlock>
</Template>

<DiagramProperty>

Description
<DiagramProperty> is a construct for retrieving a diagram from property. For example, retrieve embedded process diagram of a BPMN sub-process.
Note that <DiagramProperty> is not for retrieving sub-diagrams. If you want to retrieve sub-diagrams, use <ForEachSubDiagram> instead.

Attributes

Name Description/Usage Required?

property : string The name of diagram property to retrieve from model element. Required

Supported attributes for <DiagramProperty>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Diagram name of analysis diagram" description = "/" type = "text" default = "false"/>
    <DiagramBaseInitiationBlock>
        <IterationBlock elementType="AnalysisDiagramNode">
            <DiagramProperty property="analysisDiagramId">
                <StringPropertyText property="name"/>
            </DiagramProperty>
        </IterationBlock>
    </DiagramBaseInitiationBlock>
</Template>

<OwnerDiagram>

Description
<OwnerDiagram> is a construct that enables you to retrieve the diagram where a diagram element exists.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Diagram name of analysis diagram node" description = "/" type = "text" default = "false"/>
    <DiagramBaseInitiationBlock>
        <IterationBlock elementType="AnalysisViewNode">
            <DiagramElementProperty property="analysisViewId">
                <OwnerDiagram>
                    <StringPropertyText property="name"/>
                </OwnerDiagram>
            </ DiagramElementProperty >
        </IterationBlock>
    </DiagramBaseInitiationBlock>
</Template>

<ElementImage>

Description
<ElementImage> is a construct for printing an image of diagram or diagram element, or icon for model type.

Attributes

Name Description/Usage Required?

imageType : string = icon
{diagram | icon}

Specify the type of image.
diagram &ndash; image for diagram/diagram element
icon &ndash; icon for model type

Optional

imageFormat = png
{png | jpg | wmf}

The image format (png/jpg/wmf) of the image to present. Optional

alignment = left
{left | center | right}

The position of image &ndash; left/center/right. Optional

width : integer Restrict the image to specific width. Optional

height : integer Restrict the image to specific height. Optional

maxWidth : integer Set the maximum width of image. Optional

maxHeight : integer Set the maximum height of image. Optional

landscape : boolean = false Adjust the orientation of image. True for landscape. False for portrait. Optional
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Supported attributes for <ElementImage>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Class diagrams in project" description = "/" type = "text" default = "false"/>
    <ProjectBaseInitiationBlock>
        <ForEachDiagram diagramType="ClassDiagram">
            <ElementImage imageType="diagram"/>
        </ForEachDiagram>
    </ProjectBaseInitiationBlock>
</Template>
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Text and break

<StaticText>

Description
<StaticText> is a construct which enables you to insert your own text into a report, at the position where <StatcText> is processed. You can add your
text with custom formats.

Attributes

Name Description/Usage Required?

content : string The text to add. Optional

isBold : boolean Set the text to bold. Optional

isItalic : boolean Set the text italic. Optional

isUnderline : boolean Set the text to underline. Optional

isSuperscript : boolean Set the text to superscript. Optional

fontFamily : string = Times New Roman Specify the name of font to apply to the text. Optional

alignment = left
{left | center | right}

Set the alignment of text. Optional

fontSize : integer = 12 Set the font size. Optional

style : string Set the name of style. You can add and edit style in report diagram. Optional

numberingLevel : short Detemine the Numbering Level if the text is showing as a number or bullet list. Optional

foreColor = color The color of text. Optional

indentation : double Determine the left margin of text. Optional

hyperlink : boolean = false Specify whether the text is a hyperlink or not. If true, the text will be linkable. Optional

Supported attributes for <StaticText>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Say Hello" description = "/" type = "text" default = "false"/>
    <ProjectBaseInitiationBlock>
        <StaticText content="Hello!" />
    </ProjectBaseInitiationBlock>
</Template>

<StringPropertyText>

Description
<StringPropertyText> is the most commonly used construct in a report template document. It is used to extract a string property from model element
(e.g. name of a class) and print it to report.

Attributes

Name Description/Usage Required?

propertyText : string Deprecated. Replaced by @property. Optional

isIgnoreHTMLFontSize : boolean = false Ignore the font size on the HTML text. Optional

isIgnoreHTMLFontFamily : boolean = false Ignore the font selection of the HTML text Optional

forcePlainText : boolean Force HTML text to show as plain text by removing formatting, if any. Optional

defaultValue : string The text to show when the value of property has not ever been specified. Optional

property : string The name of string property to retrieve from model element. Required

isBold : boolean Set the text to bold. Optional

isItalic : boolean Set the text italic. Optional

fontFamily : string = Times New Roman Specify the name of font to apply to the text. Optional

alignment = left
{left | center | right}

Set the alignment of text. Optional
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fontSize : integer = 12 Set the font size. Optional

style : string Set the name of style. You can add and edit style in report diagram. Optional

numberingLevel : short Detemine the Numbering Level if the text is showing as a number or bullet list. Optional

foreColor = color The color of text. Optional

indentation : double Determine the left margin of text. Optional

hyperlink : boolean = false Specify whether the text is a hyperlink or not. If true, the text will be linkable. Optional

Supported attributes for <StringPropertyText>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Name of use cases" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <StringPropertyText propertyText="name/>
    </ElementBaseInitiationBlock>
</Template>

<IntPropertyText>

Description
<IntPropertyText> is a construct which enables you to extract an integer property from model element (e.g. length of an entity column) and print it to
report.

Attributes

Name Description/Usage Required?

propertyText : string Deprecated. Replaced by @property. Optional

isIgnoreHTMLFontSize : boolean = false Ignore the font size on the HTML text. Optional

property : string The name of integer property to retrieve from model element. Required

isBold : boolean Set the text to bold. Optional

isItalic : boolean Set the text italic. Optional

fontFamily : string = Times New Roman Specify the name of font to apply to the text. Optional

alignment = left
{left | center | right}

Set the alignment of text. Optional

fontSize : integer = 12 Set the font size. Optional

style : string Set the name of style. You can add and edit style in report diagram. Optional

numberingLevel : short Detemine the Numbering Level if the text is showing as a number or bullet list. Optional

foreColor = color The color of text. Optional

Supported attributes for <IntPropertyText>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Entity columns" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <IterationBlock elementType = "DBColumn">
            <IntPropertyText propertyText = "length"/>
        </IterationBlock>
    </ElementBaseInitiationBlock>
</Template>

<BooleanPropertyText>

Description
<BooleanPropertyText> is a construct which enables you to extract a boolean property (i.e. true/false) from model element (e.g. abstract of a class)
and print it to report.

Attributes

Name Description/Usage Required?

propertyText : string Deprecated. Replaced by @property. Optional
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property : string The name of boolean property to retrieve from model element. Required

isBold : boolean Set the text to bold. Optional

isItalic : boolean Set the text italic. Optional

fontFamily : string = Times New Roman Specify the name of font to apply to the text. Optional

alignment = left
{left | center | right}

Set the alignment of text. Optional

fontSize : integer = 12 Set the font size. Optional

style : string Set the name of style. You can add and edit style in report diagram. Optional

numberingLevel : short Detemine the Numbering Level if the text is showing as a number or bullet list. Optional

foreColor = color The color of text. Optional

Supported attributes for <BooleanPropertyText>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Is class abstract?" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <StaticText content = "Abstract?" style = "Row caption 1"/>
        <BooleanPropertyText propertyText = "abstract"/>
    </ElementBaseInitiationBlock>
</Template>

<ParagraphBreak>

Description
<ParagraphBreak> is a construct which enables you to add a break in report to separate text into paragraphs. <ParagraphBreak> does not carry any
text.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Two paragraphs" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <StaticText content = "Paragraph 1" style = "Row caption 1"/>
        <ParagraphBreak>
        <StaticText content = "Paragraph 2" style = "Row caption 1"/>
    </ElementBaseInitiationBlock>
</Template>

<PageBreak>

Description
<PageBreak> is a construct which enables you to insert a new page at where <PageBreak> is processed.

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Two pages" description = "/" type = "text" default = "false"/>
    <ElementBaseInitiationBlock>
        <StaticText content = "Page 1" style = "Row caption 1"/>
        <ParagraphBreak>
        <StaticText content = " Page 2" style = "Row caption 1"/>
    </ElementBaseInitiationBlock>
</Template>
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Table

<TableBlock>

Description
<TableBlock> is a construct that enables you to insert a table to report diagram. It is typically used to present table of elements or element properties.
You must combine the use of <TableRow> and <TableCell> in order to form a complete table. Most of the build-in templates are formed by tables and
contains <TableBlock>. You can look for references easily.

Attributes

Name Description/Usage Required?

tableWidth :
integer

The width of table, in percentage. For example: 50% means to occupy 50% of page width. Optional

colWidths :
integers

Specify the widths of table columns in ratio, separate by comma. Note that the number of columns specify in
@colWidths must match the number of <TableCell> to add under <TableRow>, under this table.
For example, specify "1, 1, 2" for a table with 20000 as width will result in creating a table with three columns, and have
widths 5000, 5000, 10000.

Optional

alignment = center
{left | center |
right}

Alignment of table. Optional

rowBackgroundColors :
colors

Background color of rows in table. Optional

generateHeaderOnNewPage :
boolean = false

When true, generate the header (the first row of this table) again if this table is generated across multiple pages. Optional

margin Specify the space around the table by providing the value of top, right, bottom, and left margins.
For example, specify "10, 20, 30, 40" for a table that has 10 as top margin, 20 as right margin, 30 as bottom margin
and 40 as left margin.

Optional

margin-top:
integer

Specify the top margin of table. Optional

margin-right:
integer

Specify the right margin of table. Optional

margin-bottom:
integer

Specify the bottom margin of table. Optional

margin-left:
integer

Specify the left margin of table. Optional

Supported attributes for <TableBlock>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Classes in diagram" description = "/" type = "table" default = "false"/>
    <DiagramBaseInitiationBlock>
        <TableBlock tableWidth="10000" colWidths="1,3" alignment="right">
            <IterationBlock modelType="Class">
                <TableRow>
                    <TableCell>
                        <StringPropertyText propertyText="name"/>
                    </TableCell>
                    <TableCell>
                        <StringPropertyText propertyText="documentation"/>
                    </TableCell>
                </TableRow>
            </IterationBlock>
        </TableBlock>
    </DiagramBaseInitiationBlock>
</Template>

<TableRow>

Description
<TableRow> is a construct that enables you to add rows to a <TableBlock>. Without <TableRow>, <TableBlock> is useless. You should add
<TableCell> to <TableRow> in order to complete a table.

Attributes

Name Description/Usage Required?

height : integer How tall it is for the table row. Optional



Table P. 439

backgroundColor : color Background color of row. Optional

Supported attributes for <TableRow>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Classes in diagram" description = "/" type = "table" default = "false"/>
    <DiagramBaseInitiationBlock>
        <TableBlock tableWidth="10000" colWidths="1,3" alignment="right">
            <IterationBlock modelType="Class">
                <TableRow>
                    <TableCell>
                        <StringPropertyText propertyText="name"/>
                    </TableCell>
                    <TableCell>
                        <StringPropertyText propertyText="documentation"/>
                    </TableCell>
                </TableRow>
            </IterationBlock>
        </TableBlock>
    </DiagramBaseInitiationBlock>
</Template>

<TableCell>

Description
<TableCell> is a construct that enables you to add cells to a <TableRow>.

Attributes

Name Description/Usage Required?

topBorderEnable :
boolean = true

True to draw the top border of cell. Optional

bottomBorderEnable :
boolean = true

True to draw the bottom border of cell. Optional

leftBorderEnable :
boolean = true

True to draw the left border of cell. Optional

rightBorderEnable :
boolean = true

True to draw the right border of cell. Optional

color : color The background color of cell. Optional

splitted : boolean
= false

Determine this cell is splitted. If true, <TableRow> + <TableCell> cannot be added into this cell to make the cell splitted
by more cells.

Optional

mergeColumns :
integer

Deprecated. Replaced by @colspan. Optional

colspan : integer Specify the number of cell this cell consumes horizontally. For example, a colspan of 2 means to consume this and the
cell on the right. This is equivalent to HTML&rsquo;s colspan.

Optional

rowspan : integer Specify the number of cell this cell consumes vertically. For example, a rowspan of 2 means to consume this and the
cell below. This is equivalent to HTML&rsquo;s rowspan.

Optional

Supported attributes for <TableCell>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Classes in diagram" description = "/" type = "table" default = "false"/>
    <DiagramBaseInitiationBlock>
        <TableBlock tableWidth="10000" colWidths="1,3" alignment="right">
            <IterationBlock modelType="Class">
                <TableRow>
                    <TableCell>
                        <StringPropertyText propertyText="name"/>
                    </TableCell>
                    <TableCell>
                        <StringPropertyText propertyText="documentation"/>
                    </TableCell>
                </TableRow>
            </IterationBlock>
        </TableBlock>
    </DiagramBaseInitiationBlock>
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</Template>
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Miscellaneous

<BPProcedures>

Description
<BPProcedures> is a construct that prints in report the procedures of task/sub-process, if specified.

Attributes

Name Description/Usage Required?

tableWidth : integer The width of table. Optional

showRowBorder : boolean = false True to draw border between rows. Optional

showColumnBorder : boolean = true True to draw border between columns. Optional

showName : boolean True to show the name of procedure. Optional

name : string Filter procedures by name. Optional

Supported attributes for <BPProcedures>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Procedures" description = "/" type = "table" default = "false"/>
    <ElementBaseInitiationBlock>
        <BPProcedures/>
    </ElementBaseInitiationBlock>
</Template>

<TestPlans>

Description
<TestPlans> is a construct that prints in report the test plans of a requirement test case, if specified.

Attributes

Name Description/Usage Required?

tableWidth : integer The width of table. Optional

showRowBorder : boolean = false True to draw border between rows. Optional

showColumnBorder : boolean = true True to draw border between columns. Optional

Supported attributes for <TestPlans>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Test Plans" description = "/" type = "table" default = "false"/>
    <ElementBaseInitiationBlock>
        <TestPlans/>
    </ElementBaseInitiationBlock>
</Template>

<TestPlanStepIterationBlock>

Description
<TestPlanStepIterationBlock> is a construct that enables you to retrieve the steps within a test plan. 

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Test Plans" description = "/" type = "table" default = "false"/>
    <TestPlanStepIterationBlock>
        <StringPropertyText propertyText="index" />
        <StringPropertyText propertyText="name"/>
        <StringPropertyText propertyText="expectedResults"/>
    </TestPlanStepIterationBlock>
</Template>

<MatrixDiagram>

Description
<MatrixDiagram> is a construct that prints in report the content of matrix diagram.

Sample template fragment
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<Template>
    <TemplateInformationHeader name = "Matrix diagram" description = "/" type = "table" default = "false"/>
    <DiagramBaseInitiationBlock>
        <MatrixDiagram/>
    </DiagramBaseInitiationBlock>
</Template>

<GridDiagram>

Description
<GridDiagram> is a construct that prints in report a grid&rsquo;s content.

Attributes

Name Description/Usage Required?

tableWidth : integer The width of table. Optional

Supported attributes for <GridDiagram>

Sample template fragment

<Template>
    <TemplateInformationHeader name = "Grid" description = "/" type = "table" default = "false"/>
    <DiagramBaseInitiationBlock>
        <GridDiagram/>
    </DiagramBaseInitiationBlock>
</Template>
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Visual simulation
With simulacian, you can simulate the execution of business process for studying the resource consumption (e.g. human resources, devices, etc.)
throughout a process, identifying bottlenecks, quantifying the differences between improvement options which help study and execute process
improvements. This chapter provides you with detailed information about simulacian.

 

What is simulacian?

Introduce simulacian, and shows you some of the key features like simulation and resource chart.

 

Simulacian control panel

The simulacian control panel is where you can configure and run a simulation. It consists of several parts, and will be described in detail.

 

Simulating business process

This page is aimed to give you an example to show you how to simulate a business process diagram.
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What is simulacian?
The objective of performing business process modeling is to facilitate the communication with stakeholders, to perform cost and benefit analysis and
to perform process improvement, etc. Simulacian is a set of value-added tools designed to aid business process modeling. With simulacian, you
can simulate the execution of business process for studying the resource consumption (e.g. human resources, devices, etc.) throughout a process,
identifying bottlenecks, quantifying the differences between improvement options which help study and execute process improvements.

Simulating a business process with Simulacian

Key concepts
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Resources
Resources refer to any kind and form of input essential for the execution of a process. Each resource has three properties - name, type and amount.
There are two types of resources - available resources and required resources. Available resources refer to the resources that can be used by
business process, but may not be fully used. For example, a post office has 10 counters as resources, but only 3 are in used at peak hours. Required
resources are a flow object wide option. You can set the resource and the amount of resource required by completing a flow object. For example, task
Answering Enquiry requires 1 counter as resource.

Required and available resources

Very often, the allocation of resource is critical to the efficiency of a business process. For example, if there are more available staffs and counters, this
helps increase the efficiency of customer service. But of course, if the available staffs and counters are more than enough, those non-used resources
are wasted. With simulacian, you can determine the optimal resource allocation by evaluating the resource consumption of current process.

Duration
Duration is the time elapsed from the entering of flow object until the leaving of that flow object. It is understandably that the duration of flow object has
significant effect to the efficiency of a business process. Imagine if it takes 5 minutes to complete the process of just one payment in a supermarket,
there will accumulate a long queue waiting for paying.

Input
Input is a way of simulating a given business process. It has a name that describe the input, and an instance, which is a number that represent the
number of time the input will happen at a particular instant. If you have modeled a general order processing system, you can add an input public
holiday, with instance 100 to represent the case that in public holiday there will be 100 customers that need to undergo payment. In order to help you
improve your process, you must set input that reflects the reality. If you set 10000 as instance of input public holiday which will never happen, you will
not obtain useful information to aid in process improvement.

Simulation
Once you have specified the available and required resources, the duration of flow objects and added input(s), you can run simulation. During
simulation, diagram will be locked to avoid collision between your edit action and the simulation operation. Executing jobs are represented by a running
green gear shape, with a number indicating the number of running job, and are attached to the task where the job is being processed. Pending jobs are
represented by inverted triangles, with a number indicating the number of pending jobs.

Executing and pending jobs
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Performance analysis through charts
During simulation of business process, you can identify the bottleneck(s) by observing the occurrence of pending jobs (i.e. the inverted triangle). This
works well in a relatively small process. However, if your business process diagram is large you may not be able to study the simulacian outcome
just by observation because the simulacian can be lengthy and involve several bottlenecks. Furthermore, you may want to know the exact figure of
resource consumption for conducting a more accurate resource re-allocation plan. In those cases, you can produce simulacian charts that report the
completion of inputs, resource usage and queue time of flow objects against time.

Different kinds of chart
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Simulacian control panel
In order to simulate a business process you need to define simulation details like available and required resources, duration of tasks/sub-processes,
instances of pools/lanes and inputs. All these information can be defined in simulacian control pane, which is a pane that display at the bottom of
diagram, important for adjusting any settings related to simulacian. The panel will be updated base on your selection in active diagram. Besides setting
simulacian details, start/pause of simulation can also be done in the panel.

Opening simulacian control panel
To open the simulacian control panel, right click on the business process diagram that you want to simulate and select Show Simulacian Control
Panel from the popup menu.

Open simulacian control panel

NOTE: You can open simulacian control panel only for diagram that has selected Simulacian as diagram type. To check/edit diagram type, right
click on the background of business process diagram and select Diagram Type from the popup menu.

Overview of simulacian control panel

Common

An overview of simulacian control panel

No.Name Description

1 ProfileTo create a new profile for simulacian, select Configure Profile... from the drop-down menu and name the newly created profile in the Configure
Profile dialog box.

2 Start /
Pause

Click to start simulation when paused or stopped, base on the resource, duration and input settings, or to pause a simulation when it is playing.

3 Stop Stop a simulating business process.

4 ClockDisplays the time elapsed from the beginning of simulation until the current moment. It is for reflecting the duration of the execution of business
process, and is based on the selection of time scale.

5 Time
scale

Control the speed of simulation. For example, a selection of 10 mins scale simulates the business process in speed 10 min per second.

6 Current
unit

Click to select the current unit, such as US Dollar, Hong Kong Dollar and Yen, for the consumption during simulating.
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7 Simulacian
charts

Click to display a new window that display the completion, resource usage and queue time charts base on the settings of resource, duration and
input. You can treat it as a chart form of simulation outcome.

8 CloseClick to close the simulacian control panel. You can open it again by right clicking on the business process diagram and selecting Show
Simulacian Control Panel from the popup menu.

Description of simulacian control panel

When selected pool/lane

An overview of simulacian control panel while selected pool/lane

No. Name Description

1 Instance When you model a business operation in business process diagram, you use pools and lanes to represent participants and sub-
participants of the process, such as Client and Receptionist. No matter how many actual participants are there, you will still use a single
pool (or lane) to represent all of them. For example, you will draw a pool Receptionist to represent all receptionists instead of drawing 5
pools for representing the fact that there are 5 receptionists.

Here the Instance field let you set the number of instances of selected pools or lanes. If there are 5 receptionists, enter 5 for instance of
pool/lane Receptionist.

Provided that there are sufficient resources for performing jobs, the number of instances affects the performance of process - The
more instances, the more efficient. During process improvement, you can adjust the instance to evaluate the impact of increasing or
decreasing the number of staff to handle certain job.

2 Show
inputs

Inputs are the expected way of executing a business process during simulacian. Click Show Inputs to list the inputs, and add/remove
inputs in further.

3 Available
resources

The table of available resources list the resources needed by the business process. For example, a process of body checking has
resources X-Ray room and reception counter. Each resource has a name, a type and its amount.

4 Add
available
resource

Click to add an available resource by giving its name, selecting/entering its type and setting its amount.

5 Remove
available
resource

Select an available resource and click this button to remove it.

Description of simulacian control panel while selected pool/lane

When selected flow objects

An overview of simulacian control panel while selected flow object

No. Name Description
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1 DurationThe time the selected flow object needs to take to process and complete a job. The 4 boxes d, h, m and s mean day, hour, minute and
second, respectively. For example, it takes five 5 minutes to present a report to client in a body check operation, set the business task
Present Report's duration to be 5 m, meaning 5 minutes.

The duration setting affects the performance of process - The less time needed, the more efficient. However, do not forget that the less time
it takes to complete a task may affect the quality of work. During process improvement, you need to keep the balance between efficiency
and quality of work, and adjust the duration accordingly.

2 Cost The cost the selected flow object needs to consume to process and complete a job. The current unit you selected in common control pane
will be shown in here as the unit of cost. For example, you select US dollar in current unit, it will be shown USD in here.

3 Show
inputs

Inputs are the expected way of executing a business process during simulacian. Click Show Inputs to list the inputs, and add/remove
inputs in further.

4 Required
resources

The resources the participant needed in order to complete a job when processing the selected flow object. The Resource column shows
the names of resources. The Amount column shows the number of resource needed to use in completing the task per participant. For
example, to present report to client, you need one resource Meeting Room, and one resource Projector.

5 Add
required
resource

Click to add the resource the participant needed in order to complete a job when processing the selected flow object. Make sure you have
available resources defined in order to select a required resource. Also note that you cannot set an amount that exceed the amount set in
available resource. For example, if you have 6 available projectors (resource), the maximum of projector a flow object can require is from 0
to 6.

6 Remove
required
resource

Select a required resource and click this button to remove it.

7 Available
resources

The table of available resources list the resources needed by the business process. For example, a process of body checking has
resources X-Ray room and reception counter. Each resource has a name, a type and its amount.

8 Add
available
resource

Click to add an available resource by giving its name, selecting/entering its type and setting its amount.

9 Remove
available
resource

Select an available resource and click this button to remove it.

Description of simulacian control panel while selected flow objects

When selected diagram background / showing inputs

An overview of simulacian control panel while selected diagram background or showing inputs

No. Name Description

1 Inputs Inputs are the definitions of how to execute a business process during simulation. An input consists of a selection of possible execution
path formed by flow objects in diagram, with the number of instances, which represents the number of time the path will be executed at
a specific instant.

For example, if you want to simulate the case that there are 10 clients needed to perform body checking in a business process of
body checking, to see if the process can handle this situation well, you will add an input Performing body check, with 10 as number of
instances.

2 Add input Click this button to add an input with name and number of instances.

3 Remove
input

Select an input and click this button to remove it.

4 Path The flow objects involved in an input. If there is a gateway in your diagram, you need to make a decision to the outgoing path of the
gateway object.
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5 Highlight
in
diagram

Check this button to make the diagram highlight the path involved in the input selected in Inputs table.

6 Available
resources

The table of available resources list the resources needed by the business process. For example, a process of body checking has
resources X-Ray room and reception counter. Each resource has a name, a type and its amount.

7 Add
available
resource

Click to add an available resource by giving its name, selecting/entering its type and setting its amount.

8 Remove
available
resource

Select an available resource and click this button to remove it.

Description of simulacian control panel while selected diagram background or showing inputs

When simulating

An overview of simulacian control panel while simulating

No. Name Description

1 Pause To pause a simulation temporarily.

2 Stop To stop simulating the business process.

3 Clock To display the time elapsed from the beginning of simulation until the current moment. It is for reflecting the duration of the execution of
business process, and is based on the selection of time scale.

4 Inputs A list of inputs with their completeness throughout the simulation. The Processing column shows the jobs under processing by the
simulating process. The Instances column shows the amount of non-completed jobs. It should keep decreasing, and become 0 at the end
of simulation.

5 ResourcesA list of resources with the status of consumption throughout the simulation. The Processing column shows the amount of resources be
consumed by the simulating process. The Instances column shows the total amount of resources. You can observe this table to study the
current resource allocation.

6 Results A list of completed inputs. The Instances column shows the amount of completed inputs.

Description of simulacian control panel while simulating
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Simulating business process
In order to simulate a business process, you must provide performance-related information to the business process diagram, such as resource
consumption and duration of flow objects, so that simulacian can analyze the information and conduct a simulation. Below are what you have to do to
start simulation.

1. Right click on the background of the business process diagram that you want simulate and select Diagram Type > Simulacian from the pop-up
menu.

Set diagram's type to Simulacian

2. In the Simulacian Control Panel, click Add under Available resources to define the resources that can be used by the flow objects in the
business process diagram in order to complete the tasks. If you want to know more about resources, please refer to the chapter What is
simulacian?.

Add available resources

3. For each of the flow objects, select it in diagram, and click Add under Required Resources in Simulacian Control Panel to add the
resource(s) the participant needed to complete the job when reaching the selected flow object.

Add required resources
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4. For each of the flow objects, select it in diagram, and set in Simulacian Control Panel its duration, which is the time it takes to get completed. If
you want to know more about duration, please refer to the chapter What is simulacian?.

Set the duration of flow object

5. For each lane and pool (without lane), select it in diagram, and set its instance in Simulacian Control Panel, which represents the number of
participants that take part in the process.

Set instance of pools or lanes

6. Click on the background of diagram or click Show Inputs in Simulacian Control Panel.

7. Click Add under Inputs in Simulacian Control Panel to add the paths to be executed during simulation. For each input, set the name that
describes the path, and the number of instances for the number of copies of the path to execute.

Add input
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8. Click Start in Simulacian Control Panel to start simulation.

Start simulation

Now, you can watch the simulation in diagram, to see the executions of inputs and identify bottlenecks.

Simulation is running
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Simulacian charts
In addition to process simulation, you can produce charts to aid in the analysis of process performance. This chapter describes the six charts in details.

 

Completion

The completion chart primarily shows the status of inputs completion against time.

 

Resource usage

The resource usage chart shows the percentage of resource consumption throughout simulation.

 

Queue time

The queue time chart shows the time the flow objects spent on waiting, which corresponds to the time an inverted triangle appear during simulacian.

 

Cost per flow object

The cost per flow object chart shows the cost each flow object consumed throughout simulation.

 

Cost per input

The cost per input chart shows the cost each input consumed throughout simulation.

 

Time cost

The time cost chart shows the cost consumed against time spent throughout simulation.
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Completion
Sometimes, just by watching the simulacian outcome is not enough in finding out the bottleneck, especially when the diagram is large, and has many,
many bottlenecks. In such cases, you can produce charts for simulacian outcome, which helps quantify resource consumption and queuing time for
each flow object.

To read the charts, click Simulacian Charts in simulacian control panel.

Open simulacian charts window

Completion chart
The completion chart primarily shows the status of inputs completion against time.

An overview of completion chart

No. Name Description

1 Resource
usage

Click to show resource usage chart.

2 Queue time Click to show queue time chart.

3 Cost Per Flow
Object

Click to show cost per flow object chart.

4 Cost Per Input Click to show cost per input chart.

5 Time Cost Click to show time cost chart.

6 Time scale Control the length of chart by selecting a time scale.

7 Auto refresh Check to let the chart body auto update against chart settings such as time scale and selection of inputs. Uncheck to update
manually by clicking Refresh.

8 Refresh Click to update the chart body against the chart settings such as time scale and selection of inputs. This button is available only
when Auto Refresh is unchecked.
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9 Not yet started
inputs

Check or uncheck the inputs to show or hide in chart the change of the amount of not-yet-started inputs throughout simulation.

10 Processing
inputs

Check or uncheck the inputs to show or hide in chart the change of the amount of processing inputs throughout simulation.

11 Completed
inputs

Check or uncheck the inputs to show or hide in chart the change of the amount of completed inputs throughout simulation.

12 Chart body The chart body.

13 Export Click to export the opening chart to Microsoft Excel or image file.

14 OK Click to close the simulacian charts window and go back to the diagram.

Description of completion chart
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Resource usage
Sometimes, just by watching the simulacian outcome is not enough in finding out the bottleneck, especially when the diagram is large, and has many,
many bottlenecks. In such cases, you can produce charts for simulacian outcome, which helps quantify resource consumption and queuing time for
each flow object.

To read the charts, click Simulacian Charts in simulacian control panel.

Open simulacian charts window

Resource usage chart
The resource usage chart shows the percentage of resource consumption throughout simulation. If a resource has its peak reaching 100%, it means
that the allocation of that resource is in optimum state. If the peak is below 100%, it means that some of the resources are not used throughout the
simulation, which usually signifies that they are wasted, and you should consider adjusting the amount of available resource to optimize the resource
consumption.

An overview of resource usage chart

No. Name Description

1 Complete Click to show completion chart.

2 Queue
time

Click to show queue time chart.

3 Cost Per
Flow
Object

Click to show cost per flow object chart.

4 Cost Per
Input

Click to show cost per input chart.

5 Time
Cost

Click to show time cost chart.

6 Show by Select what to present in the chart.

Resource - Cause the chart to presents the resource consumption of each available resource.
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Resource Type - Cause the chart to presents the resource consumption of resource types.

7 Time
scale

Control the length of chart by selecting a time scale.

8 Auto
refresh

Check to let the chart body auto update against chart settings such as whether to show by resource or resource type, time scale and
selection of resources and resources type. Uncheck to update manually by clicking Refresh.

9 Refresh Click to update the chart body against the chart settings such as whether to show by resource or resource type, time scale and
selection of resources and resources type. This button is available only when Auto Refresh is unchecked.

10 Resources Check or uncheck the resources to show or hide their usage in chart. This pane is active only when Resource is selected in the drop
down menu Show By.

11 Resource
types

Check or uncheck the resource types to show or hide their usage in chart. This pane is active only when Resource Type is selected in
the drop down menu Show By.

12 Chart
body

The chart body.

13 Export Click to export the opening chart to Microsoft Excel or image file.

14 OK Click to close the simulacian charts window and go back to the diagram.

Description of resource usage chart
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Queue time
Sometimes, just by watching the simulacian outcome is not enough in finding out the bottleneck, especially when the diagram is large, and has many,
many bottlenecks. In such cases, you can produce charts for simulacian outcome, which helps quantify resource consumption and queuing time for
each flow object.

To read the charts, click Simulacian Charts in simulacian control panel.

Open simulacian charts window

Queue time chart
The queue time chart shows the time the flow objects spent on waiting, which corresponds to the time an inverted triangle appear during simulacian.
You may study whether the queue time of certain flow object is reasonable or not, and think of the improvement.

An overview of queue time chart

No. Name Description

1 Completion Click to show completion chart.

2 Resource
usage

Click to show resource usage chart.

3 Cost Per Flow
Object

Click to show cost per flow object chart.

4 Cost Per Input Click to show cost per input chart.

5 Time Cost Click to show time cost chart.

6 Time scale Control the length of chart by selecting a time scale.

7 Auto refresh Check to let the chart body auto update against chart settings such as time scale and selection of nodes. Uncheck to update
manually by clicking Refresh.
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8 Refresh Click to update the chart body against the chart settings such as time scale and selection of nodes. This button is available only
when Auto Refresh is unchecked.

9 Nodes Check or uncheck flow objects nodes to show or hide their queue time in chart.

10 Chart body The chart body.

11 Export Click to export the opening chart to Microsoft Excel or image file.

12 OK Click to close the simulacian charts window and go back to the diagram.

Description of queue time chart
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Cost per flow object
Sometimes, just by watching the simulacian outcome is not enough in finding out the bottleneck, especially when the diagram is large, and has many,
many bottlenecks. In such cases, you can produce charts for simulacian outcome, which helps quantify resource consumption and queuing time for
each flow object.

To read the charts, click Simulacian Charts in simulacian control panel.

Open simulacian charts window

Cost per flow object chart
The cost per flow object chart shows the cost each flow object consumed throughout simulation.

An overview of cost per flow object chart

No. Name Description

1 Completion Click to show completion chart.

2 Resource
Usage

Click to show resource usage chart.

3 Queue
Time

Click to show queen time chart.

4 Cost Per
Input

Click to show cost per input chart.

5 Time
Cost

Click to show time cost chart.

6 Auto
refresh

Check to let the chart body auto update against chart settings such as time scale and selection of inputs. Uncheck to update manually
by clicking Refresh.

7 Refresh Click to update the chart body against the chart settings such as time scale and selection of inputs. This button is available only when
Auto Refresh is unchecked.

8 Nodes Check or uncheck flow objects nodes to show or hide their cost per flow object in chart.
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9 Chart
body

The chart body.

10 Export Click to export the opening chart to Microsoft Excel or image file.

11 OK Click to close the simulacian charts window and go back to the diagram.

Description of cost per flow object chart
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Cost per input
Sometimes, just by watching the simulacian outcome is not enough in finding out the bottleneck, especially when the diagram is large, and has many,
many bottlenecks. In such cases, you can produce charts for simulacian outcome, which helps quantify resource consumption and queuing time for
each flow object.

To read the charts, click Simulacian Charts in simulacian control panel.

Open simulacian charts window

Cost per input chart
The cost per input chart shows the cost each input consumed throughout simulation.

An overview of cost per input chart

No. Name Description

1 Completion Click to show completion chart.

2 Resource
Usage

Click to show resource usage chart.

3 Queue Time Click to show queen time chart.

4 Cost Per Flow
Object

Click to show cost per flow object chart.

5 Time Cost Click to show time cost chart.

6 Auto refresh Check to let the chart body auto update against chart settings such as time scale and selection of inputs. Uncheck to update
manually by clicking Refresh.

7 Refresh Click to update the chart body against the chart settings such as time scale and selection of inputs. This button is available only
when Auto Refresh is unchecked.

8 Nodes Check or uncheck flow objects nodes to show or hide their cost per input in chart.

9 Chart body The chart body.
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10 Export Click to export the opening chart to Microsoft Excel or image file.

11 OK Click to close the simulacian charts window and go back to the diagram.

Description of cost per flow object chart
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Time cost
Sometimes, just by watching the simulacian outcome is not enough in finding out the bottleneck, especially when the diagram is large, and has many,
many bottlenecks. In such cases, you can produce charts for simulacian outcome, which helps quantify resource consumption and queuing time for
each flow object.

To read the charts, click Simulacian Charts in simulacian control panel.

Open simulacian charts window

Time cost chart
The time cost chart shows the cost consumed against time spent throughout simulation.

An overview of time cost chart

No. Name Description

1 Completion Click to show completion chart.

2 Resource
Usage

Click to show resource usage chart.

3 Queue Time Click to show queue time chart.

4 Cost Per Flow
Object

Click to show cost per flow object chart.

5 Cost Per Input Click to show cost per input chart.

6 Time Scale Control the length of chart by selecting a time scale.

7 Auto refresh Check to let the chart body auto update against chart settings such as time scale and selection of inputs. Uncheck to update
manually by clicking Refresh.

8 Refresh Click to update the chart body against the chart settings such as time scale and selection of inputs. This button is available only
when Auto Refresh is unchecked.



Time cost P. 466

9 Nodes Check or uncheck flow objects nodes to show or hide their cost per input in chart.

10 Chart body The chart body.

11 Export Click to export the opening chart to Microsoft Excel or image file.

12 OK Click to close the simulacian charts window and go back to the diagram.

Description of cost per flow object chart
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Textual analysis
Textual analysis is a useful technique for documenting customers' requests and forming model elements. This chapter teaches you how to record
requirements with textual analysis and identifying candidate objects from the problem description.

 

Recording requirements

Shows you how to create a textual analysis and enter problem description in it.

 

Identifying important terms

Shows you how to identify key words from problem description to build a glossary.

 

Identifying candidate tasks and sub-processes

Besides terms, you can also identify candidate tasks and sub-processes.

 

Forming diagram from candidate objects

With the identified tasks and sub-processes, you may form a diagram from them.

 

Candidate pane view

Candidate pane view lists candidate objects in visualized form.
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Recording requirements
Before you start business process modeling, you usually have to discuss with your customers about their needs and to familiarize yourself with their
company's operations as well as their problems. During the meeting you can collect useful information from customer, which include the conversation
log, documents. You can make use of textual analysis, a text-based editor, to help record those textual information. In addition to a plain text editor, you
can identify important terms or objects (e.g. class, use case) from the problem description.

Creating textual analysis
To create textual analysis, right click Textual Analysis on Diagram Navigator and select New Textual Analysis from the pop-up menu.

Create a textual analysis

Problem statement editor
The problem statement editor is where you can record the textual information you obtain from your customers.

Problem statement editor

All buttons on editor's toolbar are depicted in the following table:

Editor's toolbar

No. Name Description

1 Bold Set the highlighted text to bold.
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2 Italic Set the highlighted text to italic.

3 Underline Underline the highlighted text.

4 Left Justify Set the alignment of highlighted text to the left.

5 Center Justify Set the alignment of highlighted text to the center.

6 Right Justify Set the alignment of highlighted text to the right.

7 Ordered list Add a numbered list.

8 Un-ordered list Add a list with bullet points.

9 Font Select the font family of highlighted text.

10 Font size Select the size of highlighted text.

11 Font color Select the color of highlighted text.

12 Table Add a table.

13 Background color Select the background color of highlighted text.

14 Clear formats Clear formats of the whole editor to convert the content to plain text.

15 Link Add a hyperlink.

16 Image Add an image.

17 Add Model Element... Insert an existing model element or create a new one.

The description of buttons on problem statement's toolbar

Entering problem statement
Three ways of entering problem statement are provided in Logizian.

• Typing on the editor

• Importing an external text file

• Copying and pasting from an external source

To type in the editor, type the problem statement directly on the editor.

To import a text file, click Import File on the toolbar.

Import file

When the Open dialog box pops out, select a text file to import. As a result, the imported problem statement will be shown on the text area.

To copy and paste from an external source, press Ctrl + C on the selected text and press Ctrl + V for pasting it on the editor.

Formatting text
Since Logizian supports rich text format (RTF), you can format the problem statement on the editor, such as making it bold, italic, or inserting a table.

1. To format text, highlight the target word/ phrase in advance.

Highlight OTV
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2. Next, click a corresponding button on the toolbar. i.e. Click Italic button to make the target word italic.

Click Italic button

Finding a keyword
You can search your target word/phrase in problem statement in shortcut through Find feature. Click Find button on the toolbar and then enter the
word/ phrase in Search Text. Finally, click Find button next to Search Text. As a result, the word/ phrase matching you typed will be highlighted.

The word memberships is highlighted in problem statement
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Identifying important terms
A word usually can have various meaning under different domains. To clarify and standardize the meaning of your specific word, you can extract it from
textual documentation to define it as a glossary term. After adding the word as glossary term, you can define its aliases and enter its documentation to
provide additional information. In textual analysis, you can define a specific word by highlighting it on problem statement editor and add it to glossary.
After that, define aliases and enter documentation for the glossary term in term editor.

1. Highlight the specific term on problem statement editor, right click on it and select Add [the highlighted term] to Glossary from the pop-up
menu.

Add "OTV" to Glossary

2. When the Glossary Grid page unfolds, enter name for the glossary grid and then right click on the newly created term and select  Open Term
Editor from the pop-up menu.

Right click to open term editor

3. In the Term Editor page, open  Definition tab.

4. You can define aliases for the term and enter documentation as definition for the term. To insert an alias, click Add button to type the alias in the
pop-up Input dialog box. To enter the definition of the term, enter under Definition directly.

Define aliases and enter documentation

5. As a result, the columns of Aliases and Documentation are filled when you return Glossary Grid page.

Completed glossary grid

NOTE: If the  Aliases column is hidden, you can click  Configure Columns... button to make it revealed. Open Properties tab and select it
under Details folder.
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Identifying candidate objects
By studying the problem statement, you can extract words or phrases that are relevant to the system and convert them into model elements, such as
task and sub-process, etc. Those objects are regarded as candidate objects. You can extract words or phrases from problem statement to become
specific type of candidate objects, and edit their properties when necessary.

Identifying candidate objects
Highlight the word/ phrase from the problem statement and select Add text as [model element type] from the pop-up menu.

Select actor as its type

Editing candidate objects
You can rename candidate objects, change their type, write their description and change their color of highlight in the grid at the bottom of textual
analysis.

To rename the candidate object:

Double click on the Candidate Class cell and rename the candidate object.

Rename candidate object

To change the candidate object's type:

Double click on the Type cell and select a type from the combo box.

Select task as its type

To add description for the candidate object:
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Double click on  Description cell and type text inside the cell.

Enter description

NOTE: The text you typed in Description cell will become the documentation of the model element which you used to create candidate object.

To change the highlight color of candidate object in problem statement:

1. Click the Highlight cell and press the inverted triangle.

2. Select a color from the combo box.

Select the highlight color
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Forming diagram from candidate objects
In problem statement editor, you can form a diagram from candidate objects, or show it in an existing diagram by visualizing it.

1.  Right click on the target candidate object and select Create [candidate object&rsquo;s type] Model Element from the pop-up menu.

Create a model element

2. In the Visualize Model Element dialog box, either check Create new diagram to show your model element on a new diagram or check Show
in existing diagram to show on an existing diagram. Finally, click the Show button to proceed.

Check an option in Visualize Model Element dialog box

As a result, the model element will be shown on the selected diagram.

NOTE: If you have already made a model element for the candidate object, the Create Model Element option will be hidden even after you right
click on it.

Dragging and dropping candidate objects
You can visualize existing candidate objects by dragging from Model Explorer and dropping on the diagram.

To visualize a candidate object or several candidate objects, select a candidate object (or a few candidate objects) from Model Explorer, drag and
drop it(or them) on the target diagram. As a result, the view of the selected candidate object(s) will be shown on diagram.

Drag from Model Explorer and drop on the diagarm
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Candidate pane view
Textual analysis can be divided into two views: problem statement view and candidate pane view. While you can edit problem statement and format
text in problem statement view, you can edit and organize candidate objects in candidate pane view. The main characteristic of candidate pane view is,
you can visualize candidate objects as boxes on candidate pane for easy arrangement.

To switch to candidate pane view:

Click Candidate Pane View button.

Click  Candidate Pane View button

The overview of candidate pane view

Candidate pane view

Editing candidate objects
Candidate pane view is similar to problem statement view where you can rename candidate objects, enter their description, change their highlight color
and type. Except editing in the grid at the bottom, you can also edit through candidate object's box on candidate pane.

To change the model element type of a candidate object, move the mouse over the target candidate object's box. Click the inverted triangle next to the
model element's icon when it reveals. Select a model element type from the pop-up menu.

Change model element type



Candidate pane view P. 476

To change the highlight color of a candidate object, move the mouse over the target candidate object's box. Click the inverted triangle on its top-right
corner when it reveals. Select a color from the pop-up menu.

Change highlight color

Filtering candidate objects
To filter specific model element of candidate objects, click Model Filter button. Check target model element(s) from the pop-up menu you want to view
on candidate pane.

Check Task

To filter specific highlight of candidate objects, click Highlight Filter button. Check target highlight from the pop-up menu you want to view on
candidate pane.

Filter color

Freely moving candidate objects
To move candidate object's box, just press the target box and drag it to your preferred location.

Press and drag Update program schedule
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Selecting candidate objects
When you click a specific candidate object in the grid at the bottom of candidate pane, the corresponding candidate object's box will be selected on
candidate pane, and vice versa.

Click candidate object in grid

Setting tile layout
Tile layout refers to the selected objects are arranged in horizontal row.

To set tile layout for all candidate object's boxes on candidate pane :

Right click on candidate pane's background and select Tile Layout from the pop-up menu.

Set tile layout

As a result, all candidate objects are arranged in tile layout.

Tile layout
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Working with glossary
Glossary lets you specific project specific vocabularies, and add description and aliases to them. This chapter will guide you through the process of
adding terms in glossary and how to work with glossary grid.

 

Identify glossary term

Terms can be identified from text written in working procedure editor. This page tells you how to do.

 

Glossary grid

Glossary grid is a place for managing glossary. You will learn more about it here.
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Identify glossary term
You identify specific terms by adding them to glossary, and clarify them by defining aliases and entering documentation in any textual documents.

1. Highlight the specific term on Documentation editor, right click on it and select Add "[the highlighted term]" to Glossary from the pop-up
menu.

Add "online register" to Glossary

2. When the Glossary Grid page is opened, right click on the newly created term and select Open Term Editor from the pop-up menu.

Right click to open term editor

3. In the Term Editor page, open Definition tab.

4. You can define aliases for the term and enter documentation as description for the term. To insert an alias, click Add button and type the alias in
the pop-up Input dialog box. To enter definition, enter under Definition directly.

Define aliases and enter documentation

5. As a result, the columns of Aliases and Documentation are filled when you return Glossary Grid page.

Completed glossary grid

Identify term from flow of events
Highlight the specific term on flow of events editor, right click on it and select Add "[the highlighted term]" to Glossary from the pop-up menu.

Add "online register" to Glossary



Identify glossary term P. 480

Identify term from textual analysis
Highlight the specific term on textual analysis, right click on it and select Add "[the highlighted term]" to Glossary from the pop-up menu.

Add "archived TV programs" to Glossary

Identify term from shape name
Highlight the specific term when editing a shape inline. Right click on it and select Add "[the highlighted term]" to Glossary from the pop-up menu.

Add term to glossary when renaming shape

Opening term
To read the definition of a term, press the Ctrl key and click on the term from documentation/flow of events content/shape name. By doing so, the
glossary grid will be opened, with the selected term highlighted.

To open a term
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Glossary grid
Glossary grid is a table where you can identify specific glossary term. In addition, you can define aliases and enter documentation for the glossary
term. With Logizian, you can categorize the terms by defining and assigning label(s) to them.

Creating the glossary grid
To open a grid diagram, select Requirement > Glossary Grid from the toolbar.

Open Glossary Grid

Overview of glossary grid

Glossary grid

No. Name Description

1 Name You can enter the name of grid in here.

2 Model Element You can select the model element you want to be listed in grid from the drop-dwon menu.

3 Configure Grid Click this button to reveal Name and Model Element. To hide these them, click this button again.

4 Create Term
(Insert)

Click this button to create a new term.

5 Find To search a term/ phrase, click this button. Enter the keyword of your term/ phrase in Search Text text field and check the
searching field: Name, Aliases, Label or Documentation.

6 Open Term Editor Click this button to open Term Editor page of the selected term. In Term Editor page, you can define the term, stereotypes
and tagged values.

7 Open
Specification...

Click this button to open the specification dialog box of the selected term. In Term Specification dialog box, you can define
aliases, assign label and enter documentation.

8 Export to Excel To save and export the selected term into a new Excel.

9 Import to Excel To import the selected term to an existing Excel.

10 Show View Click this button to show the orginal model element of the selected term.

11 Visualize... Click this button to duplicate the selected model element on the chosen digram (in either new diagram or existing diagram).
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12 Manage Label Label can be defined to categorize terms. This button is for adding, editing and deleting labels.

13 Configure
columns...

Add/ remove property column(s) in Term list.

14 Fresh To update the display on the Term list.

15 Project To select the scope for showing mdoel elements on Term list.

16 Filter Term To enter the keyword of your target term with *, you can find it in shortcut.

17 Clear filter To clear all words you typed in Filter Term.

18 Term list All created term will be listed in here.

The overview of glossary grid

Organizing terms with labels
With Logizian, you can categorize the terms by defining and assigning label(s) to them.

Defining label
1. After you have selected a term in any textual documentation to add it to glossary, the glossary grid is opened. Click Manage Label button.

Click Manage Label

2. In the pop-up Manage Label dialog box, click Add... button to create a label.

Add a label
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3. In the Glossary Label Specification dialog box, name the label and select a color for it. Click OK button to confirm.

Enter name and select a color

4. Click OK button in the Manage Label dialog box.

Assigning label
1. Let's assign a specific label to the corresponding term. Click the small plus button under  Labels column of your target term.

Click the small plus button

NOTE: If the Labels column doesn't show on the grid, you can click the Configure columns... button. Open  Properties tab and select it under
Others folder..
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2. In the pop-up Add Label dialog box, check a label and then click OK button.

Check a label

NOTE: You can apply multiple labels to a term. Check the applicable labels in the Add Label dialog box.

3. As a result, a specific label is assigned to the corresponding term.

Membership is assigned to general

Filtering terms with specific label
1. If you want to list terms of specific label, click the combo box of Project and select With Label....

Select With Label...
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2. In the Scope dialog box, check the specific label you want to be listed and then click OK button.

Check Membership

3. As a result, terms with specific label are listed in the grid.

Terms with Membership label are listed

Exporting glossary to Excel
You can export the glossary, along with its terms into an Excel file, and import it back to share with your teammates.

1. In the Glossary Grid, click Export to Excel button.

Click Export to Excel button

2. In the Export Excel dialog box, enter the output directory. Click Export button.

Enter the output directory

3. To import the Excel back to your project for a mass modification or review, select File > Import > Excel... from the main menu.
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Grid diagram
A grid enables you to list elements in tabular form. The columns are the properties of model elements.

 

Creating grid diagram

Shows you how to create a grid.

 

Creating element in grid

Create elements through the grid interface.

 

Adding/removing property columns

Add extra property columns to grid.

 

Setting the scope of grid content

Adjust the range of elements to list, like to list elements in specific model.

 

Filter and find

Filter and find elements in grid.
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Creating grid diagram
Logizian introduces model element grids to provide a convenient way to model and overview model elements within your project. You can create a grid
to list whatever model element type you like, and customize the properties of model element being shown inside the grid.

To create a grid diagram:

1. Select Diagrams > Grid Diagram from the toolbar.

Click  Grid Diagram

2. When the Grid Diagram is opened, enter name for the grid.

Enter grid's name

3. Select a model element type from the combo box of Model Element.

Select Business Rule

The model element of selected type will then be shown on the grid.

The model element of selected type is shown
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Creating element in grid
Besides creating elements by drawing them on diagram, you can also create them in grid. Creating elements in grid gives you an overview on all
elements of same type.

1. After you select model element from the combo box of Model Element, the corresponding model element button will appear. To create the
model element, click the model element button.

Click  Create Model button

2. Enter name for the newly created model element and then press Enter to confirm.

Enter name
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Adding/removing property columns
In grid, rows represent model elements while the columns show their properties. Name and documentation columns are shown by default, in addition,
you can optionally add or remove columns to display the data you are interested in.

To add an extra property column:

1. Click Configure Columns... button.

Click Configure Columns... button

2. In the Configure Columns dialog box, select your preferred property under Properties tab and then click OK button.

Select Model Type

As a result, the selected property column is inserted in the grid.

Model Type column is added

To remove a property column:

1. Click Configure Columns... button.
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2. In the Configure Columns dialog box, select your undesired property under Selected Columns and then click  OK button.

Remove Model Type column

As a result, the deselected property column will be removed from the grid.
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Setting the scope of grid content
In grid, you can customize the scope of grid content after you have created various types of model elements. After that, your desired model elements
within a particular scope will be shown on the grid.

To set the scope of grid content:

1. Select your desired scope from the combo box of Project.

Select scope

NOTE: Within Model or Package: Select this when you want to show all selected model element types within a particular model/ package.
Root Model Element: Select this when you want to show all selected model element types under root node.
All Diagrams: Select this when you want to show all selected model element types within all diagrams.
Within Diagram: Select this when you want to show all selected model element types within a particular diagram.
No Diagram: Select this when you want to show all selected model elements without diagram.

2. As a result, grid content is updated to list the model elements that fit the selected scope.

The scope of grid content
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Filter and find
Logizian enables you to create a grid to list whatever model element type you like, and customize the properties of model element being shown inside
the grid. Except creating a grid with your preferred model element type, you can also search your target model element in shortcut through filter and
find.

Filtering
1. Type the word/ phrase in filter.

2. Model element(s) matching the word/ phrase you typed will be shown in the grid subsequently.

Model elements match the word/ phrase you typed

Finding
1. Click Find button.

Click Find button

2. Type the word/ phrase in Search Text and then check either Name or Documentation (or both). Check Name if you want to search the name
model elements matches the word/ phrase you typed while check Documentation if you want to search the documentation of model elements
matches the word/ phrase you typed. Check both if you want to search the name or the documentation of model elements matches the word/
phrase you typed.

Check  Name

3. Click  Find button behind Search Text.

Click Find button

4. Model element(s) matching the word/ phrase you typed will be highlighted in the grid subsequently.

Model elements are highlighted
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WS-BPEL
Logizian supports exporting BPEL from process modeled by business process diagram. In this chapter you will learn how to model your process
properly and how to produce the necessary files for working with BPEL.

 

Introduction to WS-BPEL support

Gives you a general idea about how Logizian supports WS-BPEL.

 

Writing WSDL

You can write create a WSDL definition through a WSDL diagram. The XML editor helps you create WSDL definition in quick. You will learn how to
work with the editor.

 

Pool (process)

Shows the role of BPMN pool in terms of WS-BPEL and a description of properties.

 

Start event (receive)

Shows the role of BPMN start event in terms of WS-BPEL and a description of properties.

 

Task

Shows the role of BPMN task in terms of WS-BPEL and a description of properties.

 

Sub-process

Shows the role of BPMN sub-process in terms of WS-BPEL and a description of properties.

 

Gateway

Shows the role of BPMN gateway in terms of WS-BPEL and a description of properties.
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Introduction to WS-BPEL support
WS-BPEL, short for Web Services Business Process Language, is an XML based execution language for specifying how to interact with Web service
and WS-BPEL.

Logizian supports exporting BPEL from process modeled by business process diagram. You can model process with business process diagram with
elements like pools/lanes, events, task/sub-processes, gateways, define properties needed by BPEL, export the required BPEL files (the *.bpel and
*.wsdl file) and eventually deploy the exported file to process engine. Currently, Logizian supports Oracle and  ODE  as workflow engine.

An overview of workflow from analyzing process to deploying and executing WS-BPEL in workflow engine

This part is aimed to guide you through the mapping between business process diagram and WS-BPEL. It assumes that you have some basic
familiarity with XML, web service and BPMN. You are strongly advised to read through the chapters sequentially or else you may get lost.

Defining a BPEL diagram
In order to export BPEL files, you need not only to draw the business process diagram, but also to define properties needed by BPEL. Those properties
cannot be set unless you have set BPEL to be the type of diagram.

To define a BPEL diagram, right click on the backgroup of business process diagram where the process (will be) modeled, and select Diagram Type
> BPEL from the popup menu. If the diagram is designed for multiple purposes like BPEL and Simulacian, choose Others from menu Diagram Type
and check the types from the popup dialog box. Yet, this is not preferred. We always recommend to let a diagram serve a single purpose, like only for
BPEL.

To define a BPEL diagram

 

Setting BPEL properties
Once a BPEL diagram is defined, you will find in some of the model elements that a tab BPEL is added. It is where you can define BPEL properties.

The BPEL tab of message trigger

http://ode.apache.org/
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Writing WSDL
WSDL, short for Web Service Description Language, is an XML based language for describing the interface of web services. You can write WSDL
definition in Logizian with WSDL diagram. By combining with business process model, a full set of WSDL and BPEL can be generated.

Creating a WSDL diagram
A WSDL diagram is where you can create or edit a WSDL document. Different to other diagram types, WSDL diagram does not contain any shapes
but the structure of WSDL document, and an editor for editing the document. To create a WSDL diagram, right click on WSDL Diagram in Diagram
Navigator and select New WSDL Diagram from the popup menu.

To create a WSDL diagram

This creates an empty WSDL diagram. To continue, you need to select any of the four methods listed below to locate the source of WSDL definition.

Different ways to select the source of WSDL definition

Method Description

1 Import the WSDL definition from a .wsdl file.

2 Import the WSDL definition from a URL of wsdl.

3 Select the WSDL definition that exists in your project.

4 Create a new definition by first selecting the definition type. Apache ODE (Orchestration Director Engine) and Oracle are both supported by
Logizian.
Then, click on either to create from a synchronous or asynchronous template. Different template selection will give a different document
structure.
Synchronous - Once a synchronous process is being invoked, its business operations had to be completed before the invoking process move
on.
Asynchronous - Once an asynchronous process is being invoked, the invoking process proceed with the asynchronous process in parallel
without waiting it to complete.

Ways to select the source of WSDL
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Alternative way to create WSDL diagram - from BPMN pool to WSDL
A process is the interactions between collaborators. Other than creating a WSDL diagram from diagram navigator, an alternative way is to create a
from a pool (i.e. the collaborator) that initiate the process.

1. Define the business process diagram of where the pool reside as BPEL diagram by right clicking on the background of diagram and selecting
Diagram Type > BPEL from the popup menu. If you have done this before, ignore this step and move to step 2.

Set diagram type to be BPEL
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2. Right click on the pool which initiate the process and select WSDL Diagram from the popup menu. Base on the type of process, and the type of
workflow engine, select the appropriate option.

Create WSDL diagram

Option Description

Create
ODE
Synchronous

Apache ODE (Orchestration Director Engine) is a kind of workflow engine supported by Logizian. Select this option to create
a WSDL diagram for a synchronous process that can be executed by ODE. Once a synchronous process is being invoked, its
operations had to be completed before the invoking process move on.

Create
ODE
Asynchronous

Apache ODE (Orchestration Director Engine) is a kind of workflow engine supported by Logizian. Select this option to create a
WSDL diagram for an asynchronous process that can be executed by ODE. Once an asynchronous process is being invoked,
the invoking process proceed with the asynchronous process in parallel without waiting it to complete.

Create
Oracle
Synchronous

Oracle workflow engine is a kind of workflow engine supported by Logizian. Select this option to create a WSDL diagram for a
synchronous process that can be executed by Oracle. Once a synchronous process is being invoked, its operations had to be
completed before the invoking process move on.

Create
Oracle
Asynchronous

Apache ODE (Orchestration Director Engine) is a kind of workflow engine supported by Logizian. Select this option to create a
WSDL diagram for an asynchronous process that can be executed by Oracle. Once an asynchronous process is being invoked,
the invoking process proceed with the asynchronous process in parallel without waiting it to complete.

Description of options for creating WSDL diagram

Starting from a blank WSDL document...
If you create a blank WSDL diagram (document) there are some points that you need to pay attention to in order to create an executable definition.

1. Take Oracle Synchronous as an example. Once selected, a WSDL diagram will be created, with a tree on the left hand side listing the WSDL
file structure, and the Details pane on the right, where you can edit the chosen node in tree.

WSDL diagram is created
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2. Those fields labelled red in Details pane are fields that you must enter in order to export BPEL. One of them is the Target Namespace field of
the root wsdl:definition node. Things that you will name in the WSDL definition (e.g. a message, portType) will automatically becomes part of the
target namespace.

Defining target namespace

3. Navigate through the tree and edit the nodes in it. Some of the properties are preset, but you can change them. Again, do remember that the red
fields are compulsory. For instance, target namespace for xsd:schema.

4. At the end, click the button Check and Fix in toolbar, which helps you make appropriate changes to the WSDL definition in further (if you
haven't done), such as to add property xmlns in wsdl:definitions element which refers to the target namespace specified.

Check and fix

Summary of WSDL elements

wsdl:definition
The WSDL definition element is the root element which may contain elements like wsdl:import, wsdl:documentation, wsdl:types, wsdl:message,
wsdl:portType, wsdl:binding and wsdl:service. In wsdl:definition, the target namespace (attribute) must be specified. Elements contained by
wsdl:definition will be part of the target namespace specified. Here is an example of WSDL definitions, with target namespace and some other
fundamental attributes defined.

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions name="Shipment Team"
  targetNamespace="http://mycompany.org/shipment/"
  xmlns="http://mycompany.org/shipment/"
  xmlns:bpws="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
  xmlns:ns1="http://mycompany.org/shipment/"
  xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  ...
  <wsdl:types>...</wsdl:types>
  <wsdl:message>...</wsdl:message>
  <wsdl:portType>...</wsdl:portType>
  ...
 
</wsdl:definitions>

wsdl:types
The WSDL types element is responsible for describing data types used by the operation(s) within the web service. To be clear, the type definition is to
be used as input, output and/or fault types of operations. Most often data types are specified using XML schema. Here is an example of WSDL types
element that defines an input type, an output type and a fault type.

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions name="Shipment Team"
  targetNamespace="http://mycompany.org/shipment/"
  xmlns="http://mycompany.org/shipment/"
  xmlns:bpws="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
  xmlns:ns1="http://mycompany.org/shipment/"
  xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">
 
  ...
 
  <wsdl:types>
    <xsd:schema targetNamespace="http://mycompany.org/shipment/">
    <xsd:element name="requestReceived" type="typeRequestReceived"/>
    <xsd:complexType name="typeRequestReceived">
      <xsd:sequence>
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        <xsd:element name="receiveDate" type="xsd:date"/>
      </xsd:sequence>
    </xsd:complexType>
    <xsd:element name="requestBody" type="xsd:string"/>
      <xsd:element name="invalidRequest" type="xsd:string"/>
    </xsd:schema>
  </wsdl:types>
  ...
</wsdl:definitions>

wsdl:message
The WSDL message defines the data for input or output of an operation. Each WSDL message can include one or more WSDL parts element. A part
serves as a parameter of WSDL operation.

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions name="Shipment Team"
  targetNamespace="http://mycompany.org/shipment/"
  xmlns="http://mycompany.org/shipment/"
  xmlns:bpws="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
  xmlns:ns1="http://mycompany.org/shipment/"
  xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  ...
    
  <wsdl:message name="getOrderRequest">
    <wsdl:part element="requestReceived" name="num" type="xsd:string"/>
    <wsdl:part name="createDate" type="xsd:date"/>
  </wsdl:message>
 
  ...
    
</wsdl:definitions>

wsdl:portType (Interface)
The WSDL portType, also known as interface, defines operations in a web service. It encloses the operations that can be performed, and each
operation contains the input and output which refer to the messages (wsdl:message) defined. You may also add a fault element in addition to input and
output for defining the message to send to client when a fault happen.

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions name="Shipment Team"
  targetNamespace="http://mycompany.org/shipment/"
  xmlns="http://mycompany.org/shipment/"
  xmlns:bpws="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
  xmlns:ns1="http://mycompany.org/shipment/"
  xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  ...
    
  <wsdl:portType name="shipment">
    <wsdl:operation name="shipOrder">
      <wsdl:input message="getOrderRequest" name="getOrderRequest"/>
      <wsdl:output message="getOrderRequest" name="getOrderResponse"/>
    </wsdl:operation>
  </wsdl:portType>
 
  ...
    
</wsdl:definitions>

wsdl:binding
For ODE, in order to make your web service accessible by others, you must defining the WSDL binding to describe the how your web service is bound
to a network protocol.

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions name="Shipment Team"
  targetNamespace="http://mycompany.org/shipment/"
  xmlns="http://mycompany.org/shipment/"
  xmlns:bpws="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
  xmlns:ns1="http://mycompany.org/shipment/"
  xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  ...
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  <wsdl:binding name="mybinding" type="shipment">
    <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
    <wsdl:operation name="shipOrder">
      <soap:operation soapAction="" style="document"/>
      <wsdl:input name="order">
        <soap:body namespace="http://mycompany.org/shipment/" use="literal"/>
      </wsdl:input>
      <wsdl:output name="order">
        <soap:body namespace="http://mycompany.org/shipment/" use="literal"/>
      </wsdl:output>
    </wsdl:operation>
  </wsdl:binding>
    
  ...
    
</wsdl:definitions>

wsdl:service
For ODE, the WSDL service element defines the end points (i.e. address) of web service. It contains one or more port elements which references the
binding element.

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions name="Shipment Team"
  targetNamespace="http://mycompany.org/shipment/"
  xmlns="http://mycompany.org/shipment/"
  xmlns:bpws="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
  xmlns:ns1="http://mycompany.org/shipment/"
  xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  ...
    
  <wsdl:service name="OrderShipment">
    <wsdl:port binding="mybinding" name="shipmentEndPoint">
      <soap:address location="http://localhost:8080/ode/processes/ProviderPortService"/>
    </wsdl:port>
  </wsdl:service>
  ... 
 
</wsdl:definitions>
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Pool
In terms of business process modeling, participants of a process, such as companies or departments, are modeled by pools. When dealing with the
mapping from BPMN to BPEL, each pool represents a business process.

Internal and external pool
Internal pool refers to the pool that contains the flow objects of the execution process. When drawing a business process diagram for mapping with
BPEL, there must be one and only one internal pool. You can create external pools which represent external partners or external process that interacts
with the internal pool. Usually, external pools (or participants in business perspectively) are out of the interest for internal process, and hence presented
as black box.

Internal and external pools

To define an internal pool, right click on the pool to select Internal from the popup menu.

Set a pool to be internal pool

NOTE: There MUST be one and ONLY one internal pool per each business process diagram you need to export BPEL.

Partner link types
In every process, partner link types need to be defined. Partner link types define the interaction between a process and the parties. To edit partner link
types, right click on the pool and select Open Partner Link Specification... from the popup menu. In the specification dialog box there are four fields
you can fill in.

Partner link of pool

Field Description

WSDL The WSDL definition where the service needed was defined.

Partner Link
Type

The interaction between the process and pool.

My Role For internal pool, specify provider to be my role. For external pool, specify requester to be my role.

Partner Role For internal pool, specify requester to be partner role. For external pool, specify provider to be partner role.
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Description of fields in partner link specification

Variables
A variable correspond to a message that send to/from partners. It also can be defined for internal logic usage. You need to add variable(s) to internal
pool and select the WSDL message type. To add a variable:

1. Right click on a pool and select Open Variables Specification... from the popup menu.

2. In the specification dialog box, click Add... at the bottom of dialog box.

3. Give a name to the variable.

4. Click on the Message drop down menu and select the WSDL message.

Selecting a WSDL message for variable

Correlation sets
When an asynchronous BPEL process flows, it will invoke an external process, and wait for the external process's call back before continuing. When
the workflow engine receives a message, it need to know which instance the message should pass to. In this case, some values within the received
message can be used as id for identifying the instance the message should pass to. Such ID is represented by a correlation set. To add a correlation
set:

1. Right click on a pool and select Open Correlation Sets Specification... from the popup menu.

2. In the specification dialog box, click Add... at the bottom of dialog box.

3. Give a name to the set and click OK to confirm.

Correlation Sets added
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Start Event (Receive)
To represent the initiation of a BPEL process, you need a start event, which correspond to, in BPEL a receive element with attribute createInstance set
to yes. You can specify the partnerLink, portType and operation to be invoked by the start event.

NOTE: An alternative way to start a process is to start by a receive task. Create a receive task, open its specification and check Instantiate in its
General tab.

Editing BPEL properties
To edit BPEL properties for a start event, right click on the start event and select Open BPEL Specification... from the popup menu. In the
specification dialog box you can specify partner link, operation and variable.

Open BPEL specification
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Invoke (Task)
In BPEL, an invoke activity (i.e. an <invoke> element) is used by a process to invoke Web service provided by partner. An invocation can be either
synchronous (request and response) or asynchronous (one-way). For a synchronous invocation, only one task is drew. For an asynchronous
invocation, two tasks are drew, with one connecting to external pool and another connecting from external pool.

A sample BPD with tasks

Note that not all types of task are supported by BPEL. Below is a list of supported type. The different in type support different kinds of BPEL properties.

• Service

• Send

• Receive

• User

• Manual

• Script

• Typeless (Without type)

Editing BPEL properties
To edit BPEL properties for a task, right click on the task and select Open BPEL Specification... from the popup menu. In the specification dialog box
you can specify partner link, operation and/or variable.

To open BPEL specification
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Sub-process
In BPMN, there are two kinds of activity - task and sub-process. To represent either an empty BPEL activity or an invoke of BPEL activity, you use a
task with proper type set. Sub-process, on the other hand acts as a placeholder of a set of tasks. You can draw a sub-process, expand it and draw the
tasks in the sub-process diagram. Note that only sub-process with type Embedded is considered in BPEL generation. The other types will be ignored.

A sub-process and its sub-process diagram

When you generate BPEL, the flow modeled in sub-process diagram will be merged to the ordinary flow. The following code fragment shows a BPEL
file generated from the above BPDs. The empty activities STask1 and STask2 were modeled in the sub-process diagram, and they follow the empty
activty Task in the main flow.

 

<?xml version="1.0" encoding="UTF-8"?>
<process name="BusinessProcessDiagram1" targetNamespace="http://BusinessProcessDiagram1" xmlns="http://schemas.xmlsoap.org/ws/2003/03/
business-process/" xmlns:Pool="http://a" xmlns:tns="http://BusinessProcessDiagram1" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <partnerLinks>
        <partnerLink myRole="provider" name="Pool" partnerLinkType="Pool:PartnerLinkType"/>
    </partnerLinks>
    <variables>
        <variable messageType="Pool:Message" name="Variable"/>
    </variables>
    <sequence>
        <receive createInstance="yes" operation="perform" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable"/>
        <empty name="Task"/>
        <empty name="STask1"/>
        <empty name="STask2"/>
        <reply operation="perform" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable"/>
    </sequence>
</process>

 

Creating an embedded sub-process
1. Select Embedded Sub-process in diagram toolbar.

Selecting Embedded Sub-Process from diagram toolbar

2. Click inside the pool to create an embedded sub-process. If you tend to create a sub-process through the resource-centric interface of the
previous flow object, you can change the type by right clicking on the sub-process and selecting Type > Embedded Sub-Process from the pop-
up menu.

3. Click on the + icon at the bottom of embedded sub-process. You can now model the sub-process in the diagram created.

To expand a sub-process
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Gateway with WS-BPEL

Different types of gateway modeling
Although gateway does not come along with any BPEL property, the place you put it in a flow does influence the flow of BPEL process, hence the
content of BPEL. Below are several types of gateway modeling, with respect to the generated BPEL content.

Scenario 1 - As switch
By drawing a pair of gateway, with the beginning one typed as XOR and the other one typeed as OR, this stands for a selection (switch in terms of
BPEL) of the task exhibited from the XOR gateway. To set the type of gateway, right click on the gateway and select Type, then the type from the
popup menu.

Note also that you can set up the default flow (otherwise in terms of BPEL) by specifying the condition type of the sequence flow as Default. To set the
condition type of a sequence flow, right click on the flow and select Condition Type, then the type from the popup menu.

Drawing in this way will cause switch to be generated

<?xml version="1.0" encoding="UTF-8"?>
<process name="BusinessProcessDiagram1" targetNamespace="http://BusinessProcessDiagram1" xmlns="http://schemas.xmlsoap.org/ws/2003/03/
business-process/" xmlns:Pool="http://mypool" xmlns:tns="http://BusinessProcessDiagram1" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <partnerLinks>
        <partnerLink myRole="provider" name="Pool" partnerLinkType="Pool:PartnerLinkType"/>
    </partnerLinks>
    <variables>
        <variable messageType="Pool:Message" name="Variable"/>
    </variables>
    <sequence>
        <receive createInstance="yes" operation="perform" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable"/>
        <empty name="Task"/>
        <switch name="Gateway">
            <case condition="true()">
                <sequence>
                    <empty name="Task2"/>
                </sequence>
            </case>
            <case condition="false()">
                <sequence>
                    <empty name="Task3"/>
                </sequence>
            </case>
            <otherwise>
                <sequence>
                    <empty name="Task4"/>
                </sequence>
            </otherwise>
        </switch>
        <empty name="Task5"/>
        <reply operation="perform" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable"/>
    </sequence>
</process>

Scenario 2 - As pick
By drawing an event-driven XOR gateway, follwed by different events, this indicates the selection of path base on a condition.

Drawing in this way will cause pick to be generated

<?xml version="1.0" encoding="UTF-8"?>
<process name="BusinessProcessDiagram1" targetNamespace="http://BusinessProcessDiagram1" xmlns="http://schemas.xmlsoap.org/ws/2003/03/
business-process/" xmlns:Pool="http://b" xmlns:tns="http://BusinessProcessDiagram1" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
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    <partnerLinks>
        <partnerLink myRole="provider" name="Pool" partnerLinkType="Pool:PartnerLinkType" partnerRole="requester"/>
    </partnerLinks>
    <variables>
        <variable messageType="Pool:Message" name="Variable"/>
    </variables>
    <sequence>
        <receive createInstance="yes" operation="perform" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable"/>
        <pick createInstance="no">
            <onMessage operation="continue" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable">
                <sequence>
                    <empty name="Task"/>
                </sequence>
            </onMessage>
            <onAlarm for="'PT5S'">
                <sequence>
                    <empty name="Task2"/>
                </sequence>
            </onAlarm>
        </pick>
        <invoke inputVariable="Variable" operation="performCallback" partnerLink="Pool" portType="Pool:RequesterPortType"/>
    </sequence>
</process>

Scenario 3 - As looping (while)
By having a sequence flow back into a gateway, forming a loop, this indicates the need of repeating a flow as long as a condition satisfy.

Drawing in this way will cause while to be generated

<?xml version="1.0" encoding="UTF-8"?>
<process name="BusinessProcessDiagram1" targetNamespace="http://BusinessProcessDiagram1" xmlns="http://schemas.xmlsoap.org/ws/2003/03/
business-process/" xmlns:Pool="http://mypool" xmlns:tns="http://BusinessProcessDiagram1" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <partnerLinks>
        <partnerLink myRole="provider" name="Pool" partnerLinkType="Pool:PartnerLinkType"/>
    </partnerLinks>
    <variables>
        <variable messageType="Pool:Message" name="Variable"/>
    </variables>
    <sequence>
        <receive createInstance="yes" operation="perform" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable"/>
        <empty name="Task"/>
        <while condition="false()">
            <sequence>
                <empty name="Task2"/>
                <empty name="Task3"/>
            </sequence>
        </while>
        <empty name="Task4"/>
        <empty name="Task5"/>
        <reply operation="perform" partnerLink="Pool" portType="Pool:ProviderPortType" variable="Variable"/>
    </sequence>
</process>
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jPDL
Logizian supports modeling business process in BPD and generating jPDL from it. You will learn the relationship between BPMN notations and jPDL
and how to generate jPDL.

 

From BPD to jPDL

Shows you a list of supported jPDL element with respect to BPMN notations, and the steps of generating jPDL.
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From BPD to jPDL
jPDL, short for jBPM Process Definition Language, is a language defined by JBoss for specifying an XML and the mechanism to package all the
process definition related files into a process archive.

Logizian supports modeling business process in BPD and generating jPDL from it.

Process
A process stands for a business process. In a BPD, process is modeled by a pool. In a process, there are tasks and transitions. Normally, no process
details need be specified for jPDL.

A pool

Participant
A participant stands for a user of the business process. In a BPD, participant is modeled by lane in pool. Same as process, no participant details need
be specified for jPDL besides the participant name.

A lane

Task
A task stands for something needed to be handled. In a BPD, task is directly modeled by a task. If the task is a User Task or Manual Task, the task
need be started and completed by user. Otherwise, it will be completed automatically.

A task

To set the type of task, right click on the task and select Type, and the type from the popup menu.

Setting a task's type
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Supported element types
The following model element types are supported by jPDL generation. The rest will be ignored.

Element Supported Model Element Type

Task-
node

• Manual task

• User task

Node • Typeless task (i.e. task without type specified)

• Business rule task

• Receive task

• Reference task

• Script task

• Send task

• Service task

Decision • Typeless gateway (i.e. gateway without type specified)

• Complex gateway

• Data-Based Exclusive gateway (XOR)

• Event-Based Exclusive gateway (XOR)

• Inclusive gateway (OR)

Fork • Parallel gateway (AND)

Super-
state

• BP Group

End-state • Typeless end event (i.e. end event without result specified)

• Cancel end event

• Compensation end event

• Error end event

• Escalation end event

• Link end event

• Message end event

• Multiple end event

• Signal end event

• Terminate end event

Start-
state

• Typeless start event (i.e. start event without trigger specified)

• Compensation start event

• Error start event

• Escalation start event

• Link start event

• Message start event

• Multiple start event

• Parallel start event

• Rule start event

• Signal start event

• Timer start event

Supported model element types

Generating JPDL
For jPDL, all components in a process, including flow objects and flows, must be named, and named uniquely. Note that if an element has no name
given, a default name Unnamed{N} will be assigned to that element. If the name is duplicated. The {N} will be appended to that element, where the {N}
is a sequence number.

1. Right click on the background of BPD and select Diagram Type > jPDL from the popup menu.
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2. Right click on the background of BPD and select Utilities > Generate jPDL from the popup menu.

To generate jPDL

NOTE: If you have received an error, make sure your process was correctly modeled. For example, did you draw a non supported shape type
like sub-process? If yes, revise the design by removing those non supported shape and possibly replace with others.

3. Enter the folder and click OK. The output files are generated. They includes:
• BookStore.zip (Deployable process archive)

• gpd.xml (Graphical process definition)

• processdefinition.xml (Process definition)

• processimage.jpg (Process image)
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XPDL
Logizian supports modeling business process in BPD and generating XPDL for Open Business Engine (OBE) from it. You will learn the relationship
between BPMN notations and XPDL and how to generate XPDL.

 

From BPD to XPDL

Shows you how to draw a BPD that supports generating XPDL, and the steps of generating jPDL.
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From BPD to XPDL
The XML Process Definition Language (XPDL) is a standard developed for the interchange of business process definitions between different workflow
products. Logizian supports modeling business process in BPD and generating XPDL for Open Business Engine (OBE) from it.

Before you start, make sure you have set the diagram type of the BPD to be XPDL. To achieve this, right click on the background of BPD and select
Diagram Type > XPDL from the popup menu. Without this, you cannot see and hence define the XPDL properties (e.g. Formal Parameter, Data Field)
for model elements.

Process
A process stands for a business process. In a BPD, process is modeled by a pool. In a process, there are tasks and transitions. Each process contains
the variables, applications. There are two kinds of variables: Formal Parameter, Data Field. Formal Parameters' values will be specified when
starting the process instance. Both variables will be used by the applications. Application will be triggered by activity. OBE provides a list of default
applications that is enough for running a simple process.

A pool

Those XPDL properties for a process can be specified in the specification of pool. Right click on a pool and select Open Specification... from the
popup menu. In the specification, you can find the tabs Formal Parameters, Data Fields and Applications where you can specify the properties.

Participant
A participant stands for a user of the business process. In a BPD, participant is modeled by lane in pool. 

A lane

Participant's id and type can be specified in the specification of lane. OBE's configure file BasicSecurityRealm.xml has defined a list of entries
(users). Participant id is used to reference to an entry in BasicSecurityRealm.xml. Participant type defines which user will be assigned a work item
when the activity is triggered. To specify participant id and type, right click on a lane and select Open Specification... from the popup menu. In the
specification, you can find the tabs XPDL where you can specify the properties.

Activity
In XPDL, the instance of activity is called work item. User can work with the application(s) when the work item is assigned to him/her. An activity is
modeled by task in BPD.

A task

To define the tools for task, set the task type first. To set task type, right click on the task and select Type, then the type from the popup menu.

Setting a task's type

Note that the types that support specifying tool include Service, Send, Receive and User. For the rest, tools cannot be specified.

To specify tools, right click on the task again and select Open Tools Specification... from the popup menu. Then, add tools in the specification dialog
box.
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Transition
Transition represents the flow between activities. Normally, no transition details need be specified for XPDL, except those conditional transitions that
need to have their conditions specified. 

Sequence flow between tasks

To set the condition type, right click on a sequence flow and select Open Specification... from the popup menu. In the specification dialog box, set the
condition type and enter the condition expression.

Condition type and expression for sequence flow

Deadline
Deadline is used to define a time condition on the activity. You can model it with an intermediate event with timer trigger, and have the event attached
to the border of task.

An intermediate event attached to task

To create such an intermediate event:

1. Move the mouse pointer over the task and click on the resource icon for intermediate event. You can optionally reposition the event by dragging
it along the border. But make sure you do not drag it out of the shape.

To create an intermediate event along task border
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2. Right click on the intermediate event and select Trigger > Timer Trigger from the popup menu.

To set an event's trigger to be Timer Trigger

You need also to specify the time cycle or time date. Right click on the intermediate event and select Open Specification... from the popup menu.
Then, enter the Time date or Time cycle in General page. Time date can be used to specify a real time, like 2010-05-31, while time cycle can be used
to specify a period of time, like every Friday.

The Time date and cycle fields

Generating XPDL
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1. Right click on the background of BPD and select Utilities > Generate XPDL from the popup menu.

To generate XPDL

2. Enter the folder and click OK. An XPDL file will be generated.
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Export and import XML
Interoperability is the ability to exchange information between two systems and to use the information that has been exchanged. This chapter focuses
on the interoperability with XML file.

 

Exporting XML

Shows you how to export project data to XML file.

 

Importing XML

Shows you how to import XML to an opening project.
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Exporting XML
Interoperability is the ability to exchange information between two systems and to use the information that has been exchanged. Logizian supports
interoperability with XML file. You can export project data to an XML, manipulate it externally, and feed the changes back to Logizian. In this chapter,
you will see how to export XML file of whole project or specific diagram in project.

Exporting whole project to XML
1. Select File > Export > XML... from the main menu.

2. Specify the output destination.

3. Check Export project to export everything in the project to XML, or keep it unchecked, and check the diagram(s) to export only their content.

4. Click Export. Upon finishing, you can visit the output destination specified to obtain the XML.

Exporting active diagram to XML
1. Right click on diagram and select Export > Export XML... from the popup menu.

2. In the Export to XML dialog box, specify the output destination, which is a folder for containing the exported XML files and optionally the image
files of diagrams.

3. Click Export.

Overview of exporting XML

Overview of Export XML dialog box

No. Name Description

1 Output destination The location where you want to save the file.

2 XML structure Controls how model data is to be presented in the exported XML file.

Traditional: XML elements are named in more general manner. For example, Model, StringProperty, etc.

Simple: XML elements are named using the name of the model. For example, BPTask, BPSubProcess, etc.

3 Export project By checking Export project, all models in the project will be exported.

4 Export sub-diagrams
when export parent

By selecting Export sub-diagrams when export parent, the sub-diagram(s) will also be exported when the parent
diagram(s) is exported.

For example, package MyWorks contains diagrams A and B. If you select to export diagram A, its parent "MyWork" will
get exported, too. With the option Export sub-diagrams when export parent on, B will get exported too since B is a
sub-diagram of package MyWorks. By turning off the option, B will be ignored when export.

5 Diagram list A list of diagram of your project. Select the diagrams to export to XML.

6 Model elements A list of model elements of your project. Select the model elements to export to XML.

7 Preview window By checking the selected diagram and Show preview, it will be shown in preview window.
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8 Preview mode You can choose either Stretch or Real size to preview your diagram.

Stretch: The ratio of your diagram will be fit in the size of preview window.

Real size: The ratio of your diagram will be shown on the preview window as its real size.

9 Export diagrams as
images

When checked, image file of the selected diagrams will also be exported along with the exported XML.

10 Export Click Export to proceed with exporting to XML.

11 Cancel Click Cancel to discard exporting to XML.

Description of Export XML dialog box

Exporting diagrams to XML with command line interface
1. Start the command console.

2. In the console, change directory to the scripts folder (e.g. C:\Program Files\Logizian 10.1\scripts) and execute ExportXML with parameters
required (e.g. ExportXML.bat -project C:\MyProjects\sample.vpp -out C:\MyXML). Upon finishing, you can visit the output destination specified to
obtain the XML files.

Parameter Description Example

-project Project path C:\Demo\Demo.vpp

-out Folder for storing the exported XML and images C:\Demo\Output

-diagram One or more diagrams to be exported "Diagram A" "Diagram B"

-noimage Do not export image files for diagrams N/A

Parameters for ExportXML

Upon finishing, you can visit the output destination specified to obtain the XML files.
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Importing XML
You can import changes made externally in XML back to Logizian, to update the project data. In this chapter, you will see how to import an XML
exported before. Notice that XML import is made in response to XML export in Logizian. Only XML exported from Logizian can be imported.

Importing XML to current project
1. Select File > Import > XML... from the main menu.

2. Specify the file path of the XML to import.

3. Click OK.

NOTE: All changes made in project will be overwritten by data in XML. For example, if class Foo is renamed to Bar. By importing an XML
exported before renaming class, Bar will be renamed to Foo.

Importing XML to project with command line interface
1. Start the command console.

2. In the console, change directory to the scripts folder (e.g. C:\Program Files\Logizian 10.1\scripts) and execute ImportXML with  the parameters
required (e.g. ImportXML.bat -project C:\MyProjects\sample.vpp -file C:\MyXML\project.xml). Upon finishing, the project file will be updated with
the data presented in the XML file.

Parameter Description Example

-project Project path C:\Demo\Demo.vpp

-file The filepath of the XML file to import C:\Demo\input\sample.xml

Parameters for ImportXML
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Export and import VP project
Interoperability is the ability to exchange information between two systems and to use the information that has been exchanged. This chapter focuses
on the interoperability with native .vpp project file.

 

Exporting VP project

Shows you how to export project data to project file.

 

Importing VP project

Shows you how to import project file to an opening project.
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Exporting VP project
Interoperability is the ability to exchange information between two systems and to use the information that has been exchanged. Logizian supports
interoperability with native .vpp project file. You can export some of the diagrams to a project file, send to your team member for editing, and feed the
changes back to Logizian. In this chapter, you will see how to export project file for diagrams in project. To export VP project:

1. Select File > Export > Logizian  Project... from the main menu.

2. Specify the output destination.

Inputting output destination

3. Check in the diagram tree the diagrams to export. If you want to export the whole project, check the top most root node.

4. Click Export. Upon finishing, you can visit the output destination specified to obtain the .vpp project file.

Overview of exporting VP project

Overview of Export Project dialog box

No. Name Description

1 Output destination The location where you want to save the file.

2 Diagrams All diagrams in your project will be shown in here.

3 Preview window By checking the selected diagram and Show preview, it will be shown in preview window.

4 Preview mode You can choose either Stretch or Real size to preview your diagram.
Stretch: The ratio of your diagram will be fit in the size of preview window.
Real size: The ratio of your diagram will be shown on the preview window as its real size.

5 Export Click Export to proceed with exporting to VP project.

6 Cancel Click Cancel to discard exporting to VP project.
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7 Help More information about how to export VP Project can be obtained by clicking this button.

Description of Export Project dialog box
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Importing VP project
You can import a VP project to Logizian for importing changes made in an exported project, or to import model in another project. In this chapter, you
will see how to import a VP project. To import a project:

1. Select File > Import > Logizian Project... from the main menu.

2. Select the file path of the .vpp file to import in file chooser.

3. Click Open.

NOTE: All changes made in project will be overwritten by imported project. For example, if task Foo is renamed to Bar. By importing a project
exported before renaming task, Bar will be renamed to Foo.
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Export and import Microsoft Excel
Interoperability is the ability to exchange information between two systems and to use the information that has been exchanged. This chapter focuses
on the interoperability with Microsoft Excel file.

 

Exporting to Microsoft Excel

Shows you how to export project data to Excel file.

 

Importing Microsoft Excel file

Shows you how to import Excel file to an opening project. (The Excel must be exported from BP-VA through the export feature)

 

Excel modification guidelines

Non-desired changes made in Excel may damage its structure and cause import failed to work. This page outlines some of the points you need to pay
attention to when modifying an exported Excel file.
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Exporting diagrams to Microsoft Excel format
Interoperability is the ability to exchange information between two systems and to use the information that has been exchanged. Logizian supports
interoperability with Microsoft Excel file. You can export project data to an excel file, make changes in exported Excel's worksheets, or further
processing like to query data with formula, and eventually feed the changes back to Logizian. In this chapter, you will see how to export an Excel file
from a project. To export Excel:

1. Select File > Export > Excel... from the main menu.
This opens the Export Excel dialog box.

2. Specify the output path of Excel file.

3. Select the diagrams to export to Excel.

4. On the Model Types list at the right hand side, you can optionally select the type(s) of model elements to be exported.

5. Click Export. Upon finishing, you can visit the output destination specified to obtain the Excel file.

The exported Excel file

An overview of Export Excel dialog box
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Overview of the Export Excel dialog box

No. Field Description

1 Output
Path

The file path of the Excel file.

2 Launch
Editor

Check to open the exported Excel file after exported.

3 Export
Style

Determine how data will be presented in Excel.
Diagram Per Sheet - Selected diagrams will be exported to separate sheets.
All in One Sheet - Selected diagrams will be exported to a single sheet.
Model Type Per Sheet - Selected model elements will be exported to separate sheets, grouped by type.
Raw - Only one sheet will be generated with all elements listed in it. All the properties of selected elements will be listed as columns, which
each row represents a model element.

4 Export
Tagged
Values

Tagged values can be added to model elements to specify domain specific properties. You can add tagged values in the specification
dialog box of model element. Check Export Tagged Values if you want to export tagged values of model elements.

5 Export
Comments

You can add your own comments to model elements in their specification dialog box. Check Export Comments if you want to export the
comments to the Excel file.

6 Export
PM
Properties

PM properties is the short form of project management properties. You can set project management properties, such as version, phrase,
author, in the specification dialog box of a model element. Check Export PM Properties if you want to export PM properties of model
elements.

7 Model
Elements

Select this tab and check the model elements you want to export to Excel.

8 DiagramsAll diagrams in the opening project are listed here. Select the diagrams to export to Excel.

9 Model
Types

When you have updated the diagram selection in Diagrams list, the Model Types list will be updated to list the types of diagram elements
that appear in the chosen diagrams. By default, all diagram element types are checked, meaning that diagram elements in those types will
be exported to Excel. You can uncheck type(s) to ignore certain type(s) of diagram elements when exporting.

10 Export Click Export to proceed with exporting Excel.

11 Cancel Click Cancel to diacard exporting to Excel.

Overview of the Export Excel dialog box
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Importing Microsoft Excel file
You can import changes made externally in Excel file back to Logizian, to update the project data. In this chapter, you will see how to import an Excel
exported before. Notice that Excel import is made in response to Excel export in Logizian. Only Excel exported from Logizian can be imported.

Importing an Excel file
1. Select File > Import > Excel... from the main menu.

2. In the file chooser, select the Excel file to import and click Open to confirm.

3. In the Import dialog box, you can preview the changes you have made in the previous Excel file. If you want to keep a record of changes, click
on Save Details... at the bottom of dialog box to export the changes to an Excel file.

The Import dialog box

4. Click OK to proceed.
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Excel modification guidelines
When you are going to modify Excel file exported from Logizian, make sure the changes you make are all valid. Making invalid changes will cause the
file cannot be imported back to Logizian. In this chapter, we will go through some of the points that you need to pay attention to when editing.

Caution
When you start to modify the Excel, pay attention to the following points to avoid having problems when importing the file back to project:

• Do NOT modify the gray cells

• Do NOT just delete a row for deleting a model element. Instead, change the value No to Yes under the Delete? column.

• Do NOT modify the System Data sheet

Renaming a model element
Double click on a cell and enter a new name.

Renaming task in Excel

Deleting a model element
To delete a model element, change No to Yes under the Delete? column. Do NOT delete the row.

Deleting task in Excel

Adding a model element
Suppose you want to add an attribute, select the last attribute row and insert a row in Excel, right under the last one. Then, start editing it. The gray
cells can leave blank.

Adding task in Excel
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Importing Visio drawing
You can import your previous work drawn in Visio to BP-VA through the import feature, and continue modeling in BP-VA. This chapter shows you how
to do.

 

Importing Visio drawing

Outlines the steps involved in importing an Visio drawing.
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Importing Visio drawing into Logizian
You may have drew flow charts in Visio. You can import your previous work through the import feature, and continue modeling in Logizian.

1. Save your Visio drawing as a .vdx file.

A Visio drawing

2. To import a Visio drawing into Logizian, select File > Import > Visio... in the main menu of VP-UML.

3. Specify the file path of the Visio drawing.

NOTE: Only valid XML Drawing (*.vdx) can be imported. If your Visio drawing does not have a .vdx as extension, open it in Visio and save it as
a .vdx file.
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4. Click OK to start importing. This popup another Import Visio dialog box. As the model structure is different among Visio and Visual Paradigm,
this dialog enables users to resolve inconsistency between Visio and Logizian.

The Import Visio dialog box

The left hand side of the dialog box represents the structure of Visio drawing, while the right hand side represents the expected outcome in
Logizian through importing. Users can perform the following actions in this dialog box.

Action Description and steps

Not to import a shape Click on the button beside the shape node and select Not Import in the popup menu.

Rename a shape when importing Click on the button beside the shape node and select Rename in the popup menu. Then, enter the
new name of shape and press the Enter key to confirm renaming/.

Reset the shape to another type Click on the button beside the shape node and select an appropriate shape type to reset to.

Description of available import options on individual shape

5. Click OK when the import is configured. The drawings can then be accessible in the Diagram Navigator. You can then double click on the
diagram node to open the diagram.

An overview of Import Visio dialog box

An overview of Import Visio dialog box

No. Name Description

1 File path The path of Visio .vdx file to be imported.

2 Import Color
and Font

By selecting this option, colors and fonts of the shapes to be imported will remain unchanged. Otherwise, Visual Paradigm's
default settings will be applied.

3 Auto Fit Size By selecting this option, shapes' size will be optimized to their minimum possible size. Otherwise, the original size of the imported
shapes will remain unchanged.

4 OK Click to import.

5 Cancel Click to cancel importing.

Description of Import Visio dialog box
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Import Telelogic System Architect
You can import your previous work drawn in Telelogic System Architect to BP-VA through the import feature, and continue modeling in BP-VA. This
chapter shows you how to do.

 

Importing Telelogic System Architect

Outlines the steps involved in importing Telelogic System Architect file.
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Importing Telelogic System Architect into Logizian
Through the interoperability support, you can import legacy work did in Telelogic System Architect to Logizian, and continue modeling in Logizian.

1. Save your work in Telelogic System Architect.

2. Select File > Import > Telelogic System Architect... in the main menu of Logizian.

3. In the Import telelogic System Architect dialog box, specify the file path of the .xml file and click OK.

4. The drawings can then be accessible in the Diagram Navigator. You can then double click on the diagram node to open the diagram.

5.

Diagram Navigator listing the imported diagram(s)
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Importing BizAgi
You can import your previous work drawn in BizAgi to Logizian through the import feature, and continue modeling in Logizian. This chapter shows you
how to do.

Importing BizAgi

Outlines the steps involved in importing a BizAgi project.
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Importing BizAgi Project
BizAgi is one of the BPM softwares in the market. With Logizian, you can import BizAgi's .bpm file into Logizian directly. Importing BizAgi is as simple
as migrating the work from BizAgi to Logizian. You can perform further modeling on the imported models in Logizian when necessary.

1. Save your BizAgi drawing.

A BizAgi drawing

2. To import a BizAgi project into Logizian, select File > Import > BIZ AGI ... from the main menu.

3. Specify the file path of the BizAgi project.

Specify BizAgi model path

4. Click OK to start importing.

5. It will notify you that your BizAgi drawing is imported successfully in Message pane.

Successful import message
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6. The drawing can then be accessible in the Diagram Navigator. You can then double click on the diagram node to open the diagram.

Diagram Navigator lists the imported diagram(s)
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Export diagram to various graphic formats
You can export the opening diagram to image file. There are three ways of exporting. This chapter will shows you the instruction as well as some of the
configuration of export, like how to slice diagram into parts.

 

Exporting active diagram as image

Shows you how to export the opening diagram to image.

 

Exporting multiple diagrams as images

Shows you how to export selected diagrams to image, as well as the steps of slicing image into parts.

 

Exporting portion of diagram as image

You can export part of a drawing (i.e. some shapes) as an image. This page shows you how to do.
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Exporting active diagram as image
You can export the opening diagram to image file. To export the active diagram as an image file:

1. Select File > Export > Active Diagram as Image... from main menu.

2. In the Save dialog box, set the image quality. The higher the quality, the clearer the image, the larger the image size.

Set image quality

3. Select the image format at the bottom of dialog box.

NOTE: There are two options for exporting as PNG files - with and without background. With background will export diagram's background color.
Without diagram will ignore the background color by exporting transparent background.

NOTE: You can export diagram to native PDF format. Since the exported PDF is of a small size, it can save a lot of space. Also, since  the
diagram in PDF is a vector, it is scalable.
There are two different options when you export. For PDF(diagram per page), all the diagrams selected will be exported in the same PDF
file. Each diagram will occupy one page. For PDF(diagram per file), each diagram selected will be exported in one new PDF file.

4. Specify the filename.

5. Click Save to export.



Exporting Multiple Diagrams as Images P. 541

Exporting multiple diagrams as images
You can export diagrams in your project to image files. You can specify not only the quality and format (e.g. JPG, PNG, SVG, EMF, PDF) of images,
but also to slice diagram into pieces, for easier insertion into documents.

Export diagrams
1. Select  File > Export > Diagrams as Image... from main menu.

2. In the Export Diagrams as Image dialog box, select the diagram(s) to export.

3. Specify the output destination for storing the image files.

4. Click Export button to export the diagrams.

An overview of Export Diagrams as Image

An overview of Export Diagrams as Image dialog box

No. Name Description

1 Output
destination

The  Output destination  is the directory where all the exported images are saved to. You can enter the path in the text field directly, or
you can click on the ... button to browse for the directory.

2 Export
type

To select the image format of the exported image click on the pull-down box beside the  Export type  field and select the format you want
to use.
There are two options for exporting as PNG files - with and without background. With background will export diagram's background color.
Without diagram will ignore the background color by exporting transparent background.
You can export diagram to native PDF format. Since the exported PDF is of a small size, it can save a lot of space. Also, because the
diagram in PDF is a vector, it is scalable. There are two different options when you export. For PDF(diagram per page), all the diagrams
selected will be exported in the same PDF file. Each diagram will occupy one page. For PDF (diagram per file), each diagram selected will
be exported in one new PDF file.

3 Quality The quality of image. By applying a higher quality, the images will be more clear, but larger in file size. By applying a lower quality, the
images will look more blur, but smaller in file size.

4 Auto
overwrite
existing
files

You can check the  Auto overwrite existing files  checkbox to allow overwriting of files in the export process.

5 DiagramsThe  Diagrams pane shows the diagrams in the current project. Check the checkbox beside the diagram you want to export. The number
of selected diagrams is displayed at the bottom of the Diagram pane. The Preview pane also allows you to preview the exported image of
the selected diagram.

6 Show
preview

Check or uncheck to enable or disable the preview.

7 PreviewThe  Preview pane shows the preview of the exported image of the selected diagram in the Diagrams pane. 
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8 Preview
mode

Select the size of the preview image by selecting from the pull-down box beside the  Preview mode  field. Selecting  Stretch will show the
image in scaled size that fits to the preview area, while selecting  Real size  will show the image in its actual size.

9 Diagram
slicer

Click to configure how diagram is sliced into pieces. This is enabled only when the check box for Slice Diagrams (for slicing all diagrams)
is unchecked. For details about slicing diagrams, please refer to the following section.

10Graphics
Anti-
aliasing

Anti-aliasing is a method which handles the staircase pixels of slanted lines and curves to make them look smoother. You can apply anti-
aliasing to the exported images. To apply anti-aliasing to graphics, check the Graphics Anti-aliasing checkbox.

11Text
Anti-
aliasing

Anti-aliasing is a method which handles the staircase pixels of slanted lines and curves to make them look smoother. You can apply anti-
aliasing to the exported images. To apply anti-aliasing to text, check the Text Anti-aliasing checkbox.

12Max.
Size

Maximum size of exported images. If the diagram size is larger than the maximum size, it will be resized.

13Slice
Diagrams

Enable it to slice all diagrams into pieces to obtain multiple image files for a single diagram. For details, please refer to the following
section.

14Slice
all
diagrams

Click to configure slice settings on all diagrams.

15Export
image
with
frame

A frame is a border that prints around a diagram. By selecting None, frame won't be printed. By selecting Export with frame, a frame will
be added to exported images, making the diagram name show at the top left of diagram. By selecting Export with border, a black and thin
border will be added to exported images.

16Export Click to proceed with exporting.

17Cancel Click to close the exporter without exporting diagrams.

18Help Click to show the help contents.

Description of Diagram Exporter dialog box

Slice a diagram into pieces with diagram slicer
You can slice diagrams into pieces (number of files), as well as restrict the size of the exported diagrams.

The slice diagram dialog box
The way how diagram is sliced can be set per diagram, or to all diagrams. To slice a diagram, click on the slice button right under the diagram preview
in the Diagram Exporter dialog box. To slice all diagrams, enable Slice Diagrams and click on Slice All Diagrams button. Both ways open the
Diagram Slicer for configuring how diagram(s) is to be sliced.
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An overview of Diagram Slicer dialog box

Below is the description of different parts of the dialog box.

No. Name Description

1 No slicing Do not slice diagram.

2 Fixed size A simple strategy which slice exported diagram into pieces that have the same size.

3 Free slicing User can customize how to slice the exported diagram by specifying the position of vertical slices and horizontal slices.

4 Fixed ratio User can customize how to slice the exported diagram by specifying the position of vertical slices and horizontal slices.

5 Add row Slice the diagram into specific number of rows.

6 Add column Slice the diagram into specific number of columns.

7 Remove row Reduce the number of rows to slice.

8 Remove
column

Reduce the number of columns to slice.

9 Rows The number of rows for slicing a diagram.

10 Columns The number of columns for slicing a diagram.

11 Zoom in Magnify the diagram content.

12 Zoom out Magnify the diagram content.

13 Zoom fit to
screen

Adjust the diagram to make it fit well on the slicer window.

14 Show label Click to show/hide index label.

15 Scale The way of scaling. When configuring slicing for all diagrams, this part will not be displayed.

16 Width The total width of diagram.

17 Height The total height of diagram.

18 Ruler Shows the size of the diagram. When the slicing strategy Free Slicing is selected, a new row and column can be created by
dragging a new one from the ruler.

19 Slice line Lines that divide the diagram into pieces. The show the vertical and horizontal position that the diagram will be sliced at. When
Free Slicing or Fixed Ratio is selected, the lines can be dragged and moved.

20Index label Shows the index of the pieces. This index will be printed on the exported file as well.

21Diagram The diagram being sliced.

22Total pieces The number of pieces to produced.

23OK Click to confirm the slice settings.

24Cancel Click to close the diagram slicer with changes discarded.

Description of Diagram Slicer dialog box
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Slicing strategies
There are three slicing strategies - Fixed Size, Free Slicing and Fixed Ratio. Each gives a distinct way of slicing images.

Fixed size
Fixed Size is a simple strategy which slice exported diagram into pieces that have the same size. User specifies the number of columns and rows to
slice and then the exported diagram will be sliced into specific pieces.

Fixed Size

Free slicing
User can customize how to slice the exported diagram by specifying the position of vertical slices and horizontal slices. It is particularly useful to
prevent a shape from being sliced into pieces.

Free Slicing

Fixed ratio
Fixed Ratio strategy gains the benefit of Fixed Slice and Free Slicing. The width and height of pieces are the same but last row and column.
User can also customize the width and height of sliced pieces. Like Free Slicing, Fixed Ratio is size oriented. User modifies the size of pieces and
Diagram Slicer  calculates the number of row and column to slice.

Fixed Ratio

Controlling size of exported image
Diagram Slicer  not only slice diagram into pieces but also controls the total size of the exported diagrams. There are scale controls on the right of
the toolbar from the Diagram Slicer  dialog. By default, the type of scale is Original. And it shows the size of diagram. The following are some of the
possible ways of controlling diagram size.

Control by size
To control the total size of the exported diagram by specific width and height, select Size from the Scale combo box, and then enter the width and
height of the diagram. The ruler shows the size of the diagram.

Control by ratio
To control the total size of the exported diagram by specific ratio, select Ratio from the Scale combo box and enter the ratio in the field next to the
combo box. The total size of the exported diagram shows next to that field.
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Exporting portion of diagram as image
You can export some shapes in a diagram as an image file by selecting the shapes you want to export then perform export. To export selected shapes
to image:

1. On a diagram, select the shapes to be exported.

Selecting shapes to export as image

2. Select File > Export > Selection as Image... from main menu.

3. In the Save dialog box, set the image quality. The higher the quality, the clearer the image, the larger the image size.

Set image quality

4. Select the image format at the bottom of dialog box.

NOTE: There are two options for exporting as PNG files - with and without background. With background will export diagram's background color.
Without diagram will ignore the background color by exporting transparent background.

NOTE: You can export diagram to native PDF format. Since the exported PDF is of a small size, it can save a lot of space. Also, because the
diagram in PDF is a vector, it is scalable.
There are two different options when you export. For PDF(diagram per page), all the diagrams selected will be exported in the same PDF
file. Each diagram will occupy one page. For PDF(diagram per file), each diagram selected will be exported in one new PDF file.

5. Specify the filename of the image file.

6. Click Save to export.
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The Open API
Plugin Support provides an interface for developers to integrate with BP-VA. Developers can develop their plugins to achieve domain related
operations. In this chapter, the overview of API architecture as well as the development of plugin will be covered.

 

Introduction to plugin support

Provides basic information about plugin support. Some of the key concepts like diagram, model element and action will be mentioned.

 

Implementing plugin

Detailed information about how to implement (code) a plugin will be covered.

 

Deploying plugin

Shows you how to deploy a plugin to BP-VA.
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Introduction to plugin support
Plugin Support provides an interface for developers to integrate with Logizian. Developers can develop their plugins for what they want. In this chapter,
we will introduce the structure of a plugin.

Plugin.xml
A plugin is defined in a XML file (plugin.xml). It includes the information (such as plugin id, provider, required libraries, etc...), custom actions (menu,
toolbar and popup menu) and custom shapes/connector of the plugin.

For working with Logizian in plugin, there are 4 main components must be known by developers: Model, Diagram, Diagram Element and Action/Action
Controller.

Model element
Model Elements are basic construct of a model. Plugin allows developer to create, retrieve, update and delete model elements through the popup
menu context or through the project (by iterating model elements within a project).

Diagram
Diagram is contains diagram elements on different domain (such as Business Process Diagram, DFD, etc...).

Plugin allows developer to create, retrieve, update and delete diagrams through the popup menu context or through the project (by iterating diagrams
within a project)

Diagram element
A model element does not contain information of appearance (such as x, y, width, height, etc...). It is the diagram element, which appear on the
user interface, that owns the appearance data. Diagram Element represents a view of a model element. A model element can be shown on different
diagrams (such as a class can be shown on 2 different class diagrams).

There are 2 kinds of diagram element: Shape and Connector. Shape represents the non-relationships diagram element (such as sub-process).
Connector represents the relationships (such as sequence flow). Plugin allows developer to create, retrieve, update and delete diagram elements
through the popup menu context or through the project (to iterate all the diagrams and then the diagram elements appear on a diagram).

Action/Action controller
Action represents buttons and menus (menu, toolbar and popup menu), which contains the information on outlook (such as label, icon, mnemonic,
etc...) and responses to trigger the function call.

Action is used to represent the button on 3 regions: menu/toolbar, popup menu and diagram toolbar

Action Controller is the control (function call) of actions. Developer needs to implement different Action Controller on different region's actions.

Menu with user-defined menus

Toolbar with user-defined buttons

Popup menu with user-defined menus

Diagram toolbar with user-defined buttons
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Implementing plugin

Configuring development environment
Plugin Support API is placed on %Logizian -Install-Dir%/lib/openapi.jar. In order to work with Logizian, developer must import the jar into the
development classpaths.

Beginning of plugin.xml
plugin.xml  is the base of a plugin, to develop a plugin, should be start from writing the plugin.xml. The basic directory structure is "Logizian-Install-Dir/
plugins/YOUR_PLUGIN_ID/plugin.xml"

For improving the variability of the plugin.xml, a properties file (plugin.properties) can be used for storing the value of the xml. Developer can
assignment the value of the attributes in xml starts with '%', then the value will be read from the properties file. For example

In plugin.xml: <plugin id="sample.plugin name="%plugin.name" .../>

In plugin.properties: plugin.name=sample.plugin

Sample on XML:

<  plugin
id= "sample.plugin"
name= "Sample Plugin"
description= "Sample Plugin"
provider= "Visual Paradigm"
class= "sample.plugin.SamplePlugin">
<  runtime >

< library path= "lib/sampleplugin.jar" relativePath= "true"/>
</  runtime >
<!-- to be continued -->

</  plugin >

Table shows the description of elements in the plugin.xml.

Element Attribute Description

plugin  The root element of plugin.xml, specify the basic information of the plugin (id, name, provider, etc...)

plugin class The class of the plugin, required to implements com.vp.plugin.VPPlugin.

runtime  The element specified the runtime environment of the plugin.

library
(1..*)

 Specifies the .jar or directory as the classpaths required on the plugin. Such as the classes of the plugin and
some libraries the plugin required.

library
(1..*)

Path The path of the .jar or directory.

library
(1..*)

relativePath (optional,
default:  true )

Specifies whether the path is relative path.

plugin.xml element description

Description on Code:

VPPlugin (com.vp.plugin.VPPlugin)

This class must be implemented and ref on <plugin class="xxx"... Otherwise, the plugin will not be loaded completely. In fact, the class can do nothing
on it.

The following is the sample code:

package sample.plugin;
public class SamplePlugin implements com.vp.plugin.VPPlugin {

// make sure there is a constructor without any parameters
public void loaded(com.vp.plugin.VPPluginInfo info) {

// called when the plugin is loaded
// developer can get the current plugin's id and the
// current plugin directory (default: % Logizian -Install-DIR%/plugins)of Logizian  from the VPPluginInfo.

}
public void unloaded() {

// called when the plugin is unloaded (when the Logizian  will be exited)
}

}

Implementing custom action
There are 2 main components for an Action: Action and Action Controller. Action represents the outlook, Action Controller responses to work as
function call. In order to create custom action, developer needs to define the Action on xml, and implement the Action Controller on code.

Sample on XML:

<plugin>
< actionSets>
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<!-- to be continued -->
</ actionSets>
<!-- to be continued -->

</plugin>

Table shows the description of elements in the above XML.

Element Attribute Description

actionSets It is a collection of ActionSet. There 2 kinds of ActionSet: actionSet  and contextSensitiveActionSet. actionSet is a set of actions
which will be shown on menu/toolbar or diagram toolbar. contextSensitiveActionSet is set of actions which will be shown on
popup menu.

XML sample for custom action

There are differences on xml definition and code implementation of the 3 kinds of Actions (menu/toolbar, popup menu, diagram toolbar).

Custom action on menu/Toolbar
Developer can define the menu, menu item, toolbar, toolbar button and etc... on the plugin.xml. In order to trigger the menu item and toolbar button's
function call, Action Controller is required to be implemented and added into the Action. The Action Controller class on menu/toolbar actions is
com.vp.plugin.action.VPActionController.

There are 2 important attributes used on menu, action and separator:  menuPath and  toolbarPath .

menuPath is the path specified where is the item placed on menu, toolbarPath is the path specified where is the item placed on toolbar. The path is
formed by a set of 'name'. The 'name' is similar with the caption of the menu items (caption in English, ignores the "..." and remind the 'space'). '/' is
used as delimiter of the path. '#' is used to represent the front of the menu. Here is 4 examples will be given:

Custom Action on MenuBar

Below is the menupaths required for implementing the menus shown in the above images.

Menu "label" in XML "menupath" in XML Remarks

1 Tools Tools After the Tools menu

2 Tools/Report Tools/Report Under the Tools menu, after the Report menu

3 Tools/Report/# Tools/Report/# Under the Tools menu, and under the Report menu, place on the front

4 Tools/Report/Generate
HTML Report

Tools/Report/Generate
HTML Report

Under the Tools menu, and under the Report menu, after the Generate HTML
Report menu item

Different menupaths settings

Sample on XML:

< actionSet id="sample.plugin.actions.ActionSet1">
< toolbar

id= "sample.plugin.actions.Toolbar1"
orientation= "north"
index= "last"/>

< menu
id= "sample.plugin.actions.Menu1"
label= "Sample Menu 1"
mnemonic= "M"
menuPath= "Tools/Report"/>

< action
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id= "sample.plugin.actions.Action1"
actionType= "generalAction"
label= "Sample Action 1"
tooltip= "Sample Action 1"
icon= "icons/red.png"
style= "normal"
menuPath= "Tools/Report"
toolbarPath= "sample.plugin.actions.Toolbar1/#">
< actionController class= "sample.plugin.actions.ActionController"/>

</ action>
< separator

id= "sample.plugin.actions.Separator1"
menuPath= "Tools/sample.plugin.actions.Action1"
toolbarPath= "sample.plugin.actions.Toolbar1/sample.plugin.action.Action1"/>

</ actionSet>

Table shows the description of elements in the above XML.

Element Attribute Description

actionSets It is a collection of ActionSet. There 2 kinds of ActionSet: actionSet and contextSensitiveActionSet. actionSet
is a set of actions which will be shown on menu/toolbar or diagram toolbar. contextSensitiveActionSet is set of
actions which will be shown on popup menu.

toolbar
(0..*)

 Specifies a toolbar, contains the location information of the toolbar.

toolbar
(0..*)

orientation [north |
east |south | west]

Specifies which side will be the toolbar placed on.

toolbar
(0..*)

index [(number) |
last |new]

Based on the orientation, where will be the toolbar placed. e.g. the orientation is "north" and there is 2 rows
toolbars already. If the index is "0", then the toolbar will be placed on the first row's last position. If the index is
"last", the toolbar will be placed on the last row, last position. If the index is "new", the toolbar will be placed on the
third row (new row).

menu
(0..*)

 Specifies a menu or pull down button on menu bar or toolbar. It contains the outlook information of the menu.

action
(0..*)

 Specifies a menu item or button on menu bar or toolbar. It contains the outlook information of the menu item.

action
(0..*)

actionType
[generalAction
| shapeAction |
connectorAction]
(optional, default:
generalAction)

There are 3 types: generalAction, shapeAction and connectorAction. As the action on menu/toolbar, generalAction
should be assigned.

actionController Specifies the Action Controller for the action (the parent node in the xml).

actionController The class name of the Action Controller. For the action on menu/toolbar, it is required to implement
com.vp.plugin.action.VPActionController.

separator
(0..*)

 Specified a separator on menu bar or toolbar.

XML sample for menus and toolbars

Description on Code:

VPActionController (com.vp.plugin.action.VPActionController)

This class is used to perform the function call when the action is clicked. One Action Controller class refers to multi Actions is allowed.

Sample:

package sample.plugin.actions;
public class ActionController implements com.vp.plugin.action.VPActionController {

// make sure there is an constructor without any parameters
public void performAction(com.vp.plugin.action.VPAction action) {

// called when the button is clicked, the parameter action represents the Action which be clicked.
// developer also can set the properties of the action

}
public void update(com.vp.plugin.action.VPAction action) {

// *for the actions located on menu bar only
// when the parent menu is selected, this will be called,
// developer can set the properties of the action before it is shown (e.g. enable/disable the menu item)

}
}
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Custom action on popup menu (context sensitive)
Developer can define the menu, menu item and separator on the popup menu shown on the diagram. The popup menu on diagram is context sensitive
which based on what diagram element or diagram is selected. In order to make the menu item trigger the function call, Action Controller is required to
be implemented. For popup menu, com.vp.plugin.action.VPContextActionController is the interface required developer to implement.

Same as Action on Menu/Toolbar, menuPath is used to specify the location of the action (menu/menu item on popup menu).

Sample on XML:

< contextSensitiveActionSet id= "sample.plugin.actions.ActionSet2">
< contextTypes all= "false">

< include type="Class"/>
<!-- ignored when contextTypes.all = true -->
< exclude type="Package"/>
<!-- ignored when contextTypes.all = false -->

</ contextTypes>
<action

id= "sample.plugin.actions.ContextAction1"
label= "Sample Action [1]"
icon= "icons/blue.png"
style= "toggle"
menuPath= "OpenSpecification">
< actionController class= "sample.plugin.actions.ContextActionController"/>

</action>
</contextSensitiveActionSet>

Table shows the description of elements in the above XML.

Element Attribute Description

contextSensitvieActionSet
(0..*)

 It is a collection of menu, action, separator on the popup menu of the plugin. The child elements should be ordered
if they have the relationship on the position (e.g. developer prefers Action1 is placed into Menu1, then please
define the Menu1 on the xml first

contextTypes  It is a collection of the model of diagram element of diagram types which the contextSensitiveActionSet is
considering.

contextTypes all [true
| false]
(optional,
default:
false)

Specify whether all the types of the models, diagram elements and diagrams will be considered by this actionSet.

Include  Specify the model, diagram element or diagram type will be considered by this ActionSet. (This will be ignored if
the contextType's  attribute 'all' is assigned 'true'.

Include type It is type of the element. Such as "Class", "Actor", "ClassDiagram", "Attribute", etc...

exclude  Specify the model, diagram element or diagram type will not be considered by this ActionSet. (This will be ignored
if the contextType's  attribute 'all' is assigned 'false'.

type  It is type of the element. Such as "Class", "Actor", "ClassDiagram", "Attribute", etc...

actionController  Specifies the Action Controller for the action (the parent node in the xml)

actionController class The class name of the Action Controller. For the action on popup menu, it is required to implement
com.vp.plugin.action.VPContextActionController.

XML sample for popup menu

Description on Code:

VPContextActionController (com.vp.plugin.action.VPContextActionController)

This class is used to perform the function call when the action is clicked. One Action Controller class refers to multi Actions is allowed.

Sample:

package sample.plugin.actions;
import java.awt.event.ActionEvent;
public class ContextActionController implements com.vp.plugin.action.VPContextActionController {

// make sure there is an constructor without any parameters
public void performAction(

com.vp.plugin.action.VPAction action,
com.vp.plugin.action.VPContext context,
ActionEvent e

) {
// called when the button is clicked

}
public void update(

com.vp.plugin.action.VPAction action,
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com.vp.plugin.action.VPContext context
) {

// when the popup menu is selected, this will be called,
// developer can set the properties of the action before it is shown (e.g. enable/disable the menu item)

}
}

VPContext ( com.vp.plugin.action.VPContext)

Context will be passed into the Action Controller when the popup menu is shown or action is trigger. It is what the user selected on the diagram, can be
model, diagram element or/and diagram.

A diagram may contain many diagram elements, when user right-click on the diagram element or the diagram, a popup menu will be shown. So, the
context may be diagram element or diagram. However, the diagram element must be contained by diagram, then if popup menu shown on a diagram
element, the context must contain both diagram element and diagram. And the diagram element always represents for a model, so that is possible the
context contains model, diagram element and diagram as same time. However, sometime, the popup menu is shown for a model only (e.g. select on
an attribute of a class, because there is no diagram element for the attribute, the class's diagram element will be contained in the context).

Custom diagram element (shape and connector)
Developer can define the shape of connect on the specified diagram. But it is not allowed to develop a custom model. ActionSet and Action are used
on definition of custom diagram element.

Sample on XML:

<actionSet id= "sample.plugin.actions.ShapeActionSet">
<action

id=  "sample.plugin.actions.ShapeAction1"
actionType=  "shapeAction"
label=  "Sample Action {1}"
tooltip=  "Sample Action {1}"
icon=  "icons/yellow.png"
editorToolbarPath= "com.vp.diagram.ClassDiagram/Class">
< shapeCreatorInfo

shapeType= "sample.plugin.shape.Shape1"
defaultWidth= "30"
defaultHeight= "30"
controllerClass= "sample.plugin.actions.ShapeController1"
multilineCaption= "false"
captionStyle= "north"
resizable= "true"/>

</action>
<action

id=  "sample.plugin.actions.ConnectorAction1"
actionType= "connectorAction"
label=  "Sample Action {2}"
tooltip=  "Sample Action {2}"
icon=  "icons/green.png"
editorToolbarPath= "com.vp.diagram.ClassDiagram/sample.plugin.actions.ShapeAction1">
<connectorCreatorInfo

shapeType= "sample.plugin.connector.Connector1"
fromArrowHeadStyle= "Arrow1"
toArrowHeadStyle= "Arrow2"
fromArrowHeadSize= "verySmall"
toArrowHeadSize= "large"
dashes= "7,10"
lineWeight= "3"
connectorStyle= "rectilinear">
< connectionRules>

< connectionRule
fromShapeType= "sample.plugin.shape.Shape1"
toShapeType= "sample.plugin.shape.Shape1"
bidirection= "true"/>

< connectionRule
fromShapeType= "Class"
toShapeType= "sample.plugin.shape.Shape1"
bidirection= "true"/>

<connectionRule
fromShapeType= "Package"
toShapeType= "sample.plugin.shape.Shape1"
bidirection= "true"/>

</connectionRules>
</connectorCreatorInfo>

</action>
</actionSet>



Implementing Plugin P. 553

Table shows the description of elements in the above XML.

Element Attribute Description

Action It is a collection of menu, action, separator on the popup menu of the plugin. The child elements should be
ordered if they have the relationship on the position (e.g. developer prefers Action1 is placed into Menu1,
then please define the Menu1 on the xml first

Action actionType
[generalAction
| shapeAction |
connectorAction]
(optional, default:
generalAction)

There are 3 types: generalAction, shapeAction and connectorAction. As the action for custom shape,
"shapeAction" should be assigned. For custom connector, "connectorAction" should be assigned.

Action editorToolbarPath Specify which diagram toolbar contains this action. e.g. to add a shapeAction on class diagram after
the button for creating a new class, "com.vp.diagram.ClassDiagram/Class" should be assigned.
"com.vp.diagram.ClassDiagram" is the id of the class diagram. "/" is the delimiter. "Class" is the button id.

shapeCreatorInfo If the actionType is "shapeAction", shapeCreatorInfo is required. It is used to specify the details of the
custom shape.

shapeCreatorInfoshapeType The shape type assigned by developer, unique value is required.

shapeCreatorInfocaptionStyle [center |
north | none] (optional)

Specify where the caption of the shape is displayed.

shapeCreatorInfocontrollerClass The class name which the class is responsible to draw the shape on the diagram,
com.vp.plugin.diagram.VPShapeController  is required to be implemented. 
com.vp.plugin.diagram.AbstractShapeController  is an abstract class of the VPShapeController.

connectorCreatorInfo If the actionType is "connectorShape", connectorCreatorInfo is required. It is used to specify the defails
of the custom connector.

connectorCreatorInfoshapeType The shape type assigned by developer, unique value is required.

connectorCreatorInfoconnectorStyle [oblique
| rectilinear] (optional,
default: oblique)

Specify the style of the connector.

connectorCreatorInfofromArrowHeadStyle
(optional)

Specify the arrow head style of the "from" side of the connector.

connectorCreatorInfotoArrowHeadStyle
(optional)

Specify the arrow head style of the "to" side of the connector.

connectorCreatorInfofromArrowHeadSize
[verySmall | small
| medium | large |
extraLarge | jumbo |
colossal] (optional)

Specify the arrow head size of the "from" side of the connector.

connectorCreatorInfotoArrowHeadSize
[verySmall | small
| medium | large |
extraLarge | jumbo |
colossal] (optional)

Specify the arrow head size of the "to" side of the connector

connectorCreatorInfodashes (optional) Specify the dashes pattern of the connector. A list of float, written in the pattern "%f, %f, %f, ...".

connectorCreatorInfolineWeight (optional) Specify the weight of the connector.

connectorRules It is a collection of connectorRule.

connectorRule
(1..*)

 Specify this connector can connect with what diagram element.

XML sample for diagram element

Description on Code:

VPShapeController ( com.vp.plugin.diagram.VPShapeController)

It response to handle the outlook of the shape on the diagram.

Sample:

package sample.plugin.actions;
// import the necessaries
public class ShapeController implement com.vp.plugin.diagram.VPShapeController {

public void drawShape(
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Graphics2D g, Paint lineColor, Paint fillColor, Stoke stroke,
Com.vp.plugin.diagram.VPShapeInfo shapeInfo

){
// draw the shape by the graphics
// shapeInfo contains the information of the shape, e.g. the bounds of the shape.

}
public boolean contains( int x, int y, com.vp.plugin.diagram.VPShapeInfo shapeInfo) {

// check whether the x, y is inside the shape,
// it is used to checking what is selected by the user

}
}

Working with models
Plugin Support provides interface for the developer to create, retrieve update and delete the models in Logizian. The base class of the model is
com.vp.plugin.model.IModelElement. All models are contained in the project ( com.vp.plugin.model.IProject). Each model has a model type, to
access all the model type, please refers to the class com.vp.plugin.model.IModelElementFactory, it is the class to create the models.

Creating model
Developer can use the model element factory ( com.vp.plugin.model.IModelElementFactory) to create the model. Or based on a parent model (
com.vp.plugin.model.IModelElementParent) to create a child model.

IModelElementFactory can be access by IModelElementFactory.instance().  It provides the functions to create all the models.

IModelElementParent is subclass of IModelElement. It provides the function to create the child into it. If the parent class is more specified, it may
support a more details function to create the child. For example, IClass is subclass of IModelElementParent, it provides createOperation() to create
an operation into it.

Sample on Code:

/*
* create model by IModelElementFactory
* result of the 2 methods: "class model is created and added into the project"
*
// assume in a code segment
IClass classModel1 = IModelElementFactory.instance().createClass();
IClass classModel2 = (IClass) IModelElementFactory.instance().create(IModelElementFactory. MODEL_TYPE_CLASS);
/*
* create model by IModelElementParent
* result of the first 2 methods, "operation model is created and added into the class model"
* result of the last method, "actor model is created and added into project", because actor cannot be the child of class model
*/
// assume in a code segment
IOperation operationModel1 = classModel1.createOperation();
IOperation operationModel2 = (IOperation) classModel1.create(IModelElementFactory. MODEL_TYPE_OPREATION);
IActor actorModel1 = (IActor) classModel1.create(IModelElementFactory. MODEL_TYPE_ACTOR);

Retrieving model
Developer can use the project ( com.vp.plugin.model.IProject) or the context ( com.vp.plugin.action.VPContext) from ActionController to retrieve
the models.

IProject is the project of Logizian. The project contains all models, diagram and diagram elements. It provides function ( modelElementIterator())  for
the developer to iterate the models.

VPContext is the context of a popup menu. Developer can access the context by popup menu's action controller (
com.vp.plugin.action.VPContextActionController). Context may contain a model element if the popup menu is shown on a diagram element or
model.

Sample on Code:

/*
* retrieve model by IProject
*/
// assume in a code segment
IProject project = ApplicationManager.instance().getProjectManager().getProject();
Iterator iter = project.modelElementIterator();
while (iter.hasNext()) {

IModelEmenet modelElement = (IModelElement) iter.next();
// model element retrieved

}
/*
*retrieve model by VPContext
*/
// assume on a sub-class of com.vp.plugin.action.VPContextActionController
public void update(VPAction action, VPContext context) {

IModelElement modelElement = context.getModelElement();
// model element retrieved, but please take care,
// context.getModelElement() may return null if the popup menu is shown for the diagram
// or the selected diagram element doesn't refer to a model element.

}
/*
* retrieve relationship model from a class model
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* there are 2 kinds of relationships: IRelationship and IEndRelationship
*/
// assume in a code segment
IClass classModel = ...; // retrieved the class model from somewhere
// retrieve a generalization (IRelationship)
Iterator genIter = classModel.fromRelationshipIterator();
while (genIter.hasNext()) {

IRelationship relationship = (IRelationship) genIter.next();
// found out the another side's model of the relationship
IModelElement otherModel = relationship.getTo();

}
// retrieve am association (IEndRelationship)
Iterator assoIter = classModel.fromRelationshipEndIterator();
while (assoIter.hasNext()) {

IRelationshipEnd relationshipEnd = (IRelationshipEnd) assoIter.next();
IModelElement otherModel = relationshipEnd.getEndRelationship().getToEnd().getModelElement();

}

Updating model
Developer can call a set of get/set methods on a model. Different model type has different properties. For setting and getting the model's property, cast
the IModelElement into it sub-class is necessary. For example, developer get the IModelElement from the popup menu's context. Developer check
whether the model is a IClass, then developer cast the IModelElement into IClass, and call the function IClass.setVisibility(xxx).

Sample on Code:

/*
* update a class model
*/
// assume in a code segment
IModelElement model = ...; // model is retrieved from somewhere
If (IModelElementFactory. MODEL_TYPE_CLASS.equals(model.getModelType()) ) {

IClass classModel = (IClassModel) model;
// set the class to be 'private'
classModel.setVisibility(IClass. VISIBILITY_PRIVATE);
// set super class
IClass superClassModel = ...; // another class model is retrieved, it will be set to be the previous model's super class
IGeneralization generalizationModel = IModelElementFactory.instance().createGeneralization();
generalizationModel.setFrom(superClassModel);
generalizationModel.setTo(classModel);
// get all "setName" operation from the class and set to be "protected final"
Iterator operationIter = classModel.operationIterator();
while (operationIter.hasNext()) {

IOperation operation = (IOperation) operationIter.next();
if ( "setName".equals(operation.getName()) ) {

operation.getJavaDetail( true).setJavaFinal( true);
operation.setVisibility(IOperation. VISIBILITY_PROTECTED);

}
}

}

Deleting model
Developer can delete the model by simple way, just call the IModelElement.delete().

Working with diagrams/Diagram elements
Plugin Support provides interface for the developer to create, retrieve update and delete the diagrams or diagram elements in Logizian. The base class
of the diagram is co m.vp.plugin.diagram.IDiagramUIModel. The base class of the diagram element is com.vp.plugin.diagram.DiagramElement.
All diagrams are contained in the project ( com.vp.plugin.model.IProject). And the diagram elements can be found in the diagrams. The diagram
elements can contains by the diagrams.

Creating diagrams/Diagram elements
Developer can create the diagram or diagram element by com.vp.plugin.DiagramManager. DiagramManager can be access by
ApplicationManager.instance().getDiagramManager().

Sample on Code:

// assume in a code segment
DiagramManager diagramManager = ApplicationManager.instance().getDiagramManager();
/*
* create diagram
*/
IDiagramUIModel diagram = diagramManager.createDiagram(DiagramManager. DIAGRAM_TYPE_CLASS_DIAGRAM);
/*
* create diagram element with exists models
*/
IModelElement classModel1 = ...; // retrieved a class model from somewhere
IModelElement packageModel1 = classModel1.getParent(); // assume the class model is contained by a package
IDiagramElement packageDiagramElement1 = diagramManager.createDiagramElement(diagram, packageModel1);
IDiagramElement classDiagramElement1 = diagramManager.createDiagramElement(diagram, classModel1);
// class's diagram element should be a shape, not a connector
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packageDiagramElement1.addChild((IShapeUIModel) classDiagramElement1);
/*
* create diagram element without models (the model will be created automatically)
*/
IDiagramElement newClassDiagramElement =
diagramManager.createDiagramElement(diagram, IClassDiagramUIModel. SHAPETYPE_CLASS);
IModelElement newClassModel = newClassDiagramElement.getModelElement();
/*
* open the created diagram
*/
diagramManager.openDiagram(diagram);

Retrieving diagrams/Diagram elements
Developer can use the project ( com.vp.plugin.model.IProject) to retrieve the diagrams. Use a diagram ( com.vp.plugin.diagram.IDiagramUIModel)
to retrieve the contained diagram elements. Or use the context ( com.vp.plugin.action.VPContext) from ActionController to retrieve the diagram and/
or diagram element.

IProject is the project of Logizian. The project contains all models, diagram and diagram elements. It provides function ( diagramIterator())  for the
developer to iterate the diagrams.

IDiagramUIModel is a diagram, which may contain many diagram elements.

VPContext is the context of a popup menu. Developer can access the context by popup menu's action controller (
com.vp.plugin.action.VPContextActionController). Context may contain a diagram and/or diagram elements.

Sample on Code:

/*
* retrieve diagram from IProject
*/
// assume in a code segment
IProject project = ApplicationManager.instance().getProjectManager().getProject();
Iterator diagramIter = project.diagramIterator();
while (diagramIter.hasNext()) {

IDiagramUIModel diagram = (IDiagramUIModel) diagramIter.next();
/*
* retrieve diagram element from IDiagramUIModel
*/
Iterator diagramElementIter = diagram.diagramElementIterator();
while (diagramElementIter.hasNext()) {

IDiagramElement diagramElement = (IDiagramElement) diagramElementIter.next();
}

}
/*
* retrieve diagram and diagram element from VPContext
*/
// assume on a sub-class of com.vp.plugin.action.VPContextActionController
public void update(VPAction action, VPContext context) {

IDiagramUIModel diagram = context.getDiagram();
IDiagramElement diagramElement = context.getDiagramElement();
// diagramElement may be null, if the popup menu shown for the diagram

}
/*
* retrieve connected connector from a shape
* because a connector can connected with both Shape and Connector, please check the
* both getToShape() and getToConnector() or getFromShape() and getFromConnector()
*/
// assume in a code segment
IShapeUIModel shape = ...; // retrieved the shape from somewhere
IConnectUIModel[] connectors = shape.toFromConnectorArray();
int count = connectors == null ? 0 : connectors. length;
for ( int i = 0; i < count; i++) {

IDiagramElement toDiagramElement = connectors[i].getToShape();
if (toDiagramElement == null) {

toDiagramElement = connectors[i].getToConnector();
}

}

Updateing diagrams/Diagram elements
IDiagramUIModel provides the functions to set the diagram outlook (size, background, etc...).

IDiagramElement is the super class of IShapeUIModel and IConnectorUIModel. Because there is difference between shape and connector, the
IShapeUIModel and IConnectorUIModel provide different set of functions to update them.

Sample Code:

/*
* update a shape's size and set a connector's connector style
*/
// assume in a code segment
IShapeUIModel shape = ...; // retrieved the shape from somewhere
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shape.setBounds(20, 20, 400, 400);
IConnector connector = ...; // retrieved the connector from somewhere
connector.setConnectorStyle(IConnector. CS_CURVE);

Deleting diagrams/Diagram elements
Developer can delete the diagram and diagram element by simple way, just call the IDiagramUIModel.delete() and IDiagramElement.delete().

Showing dialog on Logizian
There is special method to show any dialog with Swing technology.

com.vp.plugin.ViewManager is an interface provides function for developer to show the dialog as same as show dialog by JOptionPane. Besides
that, Viewmanager supports developer to show message on Logizian's message pane and show custom dialog by implementing an interface (
com.vp.plugin.view.IDialogHandler).

Same as JOptionPane, to show a dialog, it is better to have a component as the invoker/parent component. To get the component in LogizianL, just
call ViewManager.getRootFrame().

Showing message on message pane
ViewManager provides function showMessage(msg:String, msgTabId:String) to show the message on Message Pane. The parameter msg is the
content of the message, msgTabId is the id to identify the tab on Message Pane, which can be defined by developer.

Sample on Code:

// assume in a code segment
ViewManager viewManager = ApplicationManager.instance().getViewManager();
viewManager.showMessage( "Thank you for reading Logizian  Plugin Support User's Guide. >=)", "sample.plugin");

Showing simple message dialog
In Swing, we may use the javax.swing.JOptionPane to show a message dialog (e.g. JOptionPane.showMessageDialog(...)). ViewrManager 
provides the functions which simulate the JOptionPane. ViewManger provides a set of showXXXXDialog(...) functions for showing the dialog. The
signature of the functions are same with the JOptionPane. Developer need not feel strange on calling the showXXXXDialog(...) functions.

Showing custom dialog
In Swing, we may implement the javax.swing.JDialog and add our component on the dialog's content pane. But in plugin, developer is required to
implement an interface com.vp.plugin.view.IDialogHandler to work for the dialog.

IDialogHandler specify the behaviors of a dialog. There are 4 functions need to be implemented.

getComponent() : java.awt.Component

It is called once before the dialog is shown. Developer should return the content of the dialog (similar to the content pane).

prepare(dialog : com.vp.plugin.view.IDialog) : void

It is called after the getComponent().  A dialog is created on Logizian internally (it still not shown out). Developer can set the outlook of the dialog on
prepare(), such as title, bounds and modal, etc... For your convenience, the dialog will be shown on the screen center as default. If developer don't
want change the location, there is no necessary to call the setLocation() function.

shown()

It is called when the dialog is shown. Developer may need to do something when the dialog is shown, such as checking something before user to input
data on the dialog.

canClosed()

It is called when the dialog is closed by the user clicking on the close button of the frame. Developer may not allow the user to close the dialog (e.g.
failed on validation check), then please return 'false' on canClosed().

Sample on Code:

package sample.plugin.dialog;
// assume imported necessary classes
public class CustomDialogHandler implements IDialogHandler {

private IDialog _dialog;
private Component _component;
private JTextField _inputField1, _inputField2, _answerField;
public Component getComponent() {

this._inputField1 = new JTextField(10);
this._inputField2 = new JTextField(10);
this._answerField = new JTextField(10);
JLabel addLabel = new JLabel( " + "); JLabel equalLabel = new JLabel( " = ");
JButton okButton = new JButton( "Apply");
okButton.addActionListener( new ActionListener() {
public void actionPerformed(ActionEvent e) { ok();}
} );
JPanel pane = new JPanel();
pane.add( this._inputField1); pane.add(addLabel); pane.add( this._inputField2);
pane.add(equalLabel); pane.add( this._answerField); pane.add(okButton);
this._component = pane;
return pane;

}
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public void prepare(IDialog dialog) {
this._dialog = dialog;
dialog.setModal(true);
dialog.setTitle( "Maths Test");
dialog.setResizable( false ); dialog.pack();
this._inputField1.setText(String.valueOf(( int)(Math.random()*10000)));
this._inputField2.setText(String.valueOf(( int)(Math.random()*10000)));

}
public void shown() {

ApplicationManager.instance().getViewManager().showMessageDialog(
this._component, "Maths Test is started, you have an half hour to finish this test.",
"Maths Test", JOptionPane. INFORMATION_MESSAGE
);

}
public boolean canClosed() {

if ( this.checkAnswer()) { return true; }
else {

ApplicationManager.instance().getViewManager().showMessageDialog(
this._component, "Incorrect",
"Maths Test", JOptionPane. ERROR_MESSAGE

);
return false;

}
}
private void ok() {

if ( this.checkAnswer() ) { this._dialog.close(); }
else {

ApplicationManager.instance().getViewManager().showMessageDialog(
this._component, "Incorrect",
"Maths Test", JOptionPane. ERROR_MESSAGE

);
}

}
private boolean checkAnswer() {

try {
int a = Integer.parse Int( this._inputField1.getText());
int b = Integer.parse Int( this._inputField2.getText());
int c = Integer.parse Int( this._answerField.getText());
return (a+b == c);

}
catch (Exception ex) { return false; }

}
}



Deploying Plugin P. 559

Deploying plugin
After prepared all the required files for a plugin (plugin.xml, plugin.properties, classes/libraries and other resources), developer can plug the plugin into
Logizian.

First, create a folder named plugins (notice the ' s') in the Logizian installation directory. Put the plugin files into "%Logizian-Install-Dir%\plugins\
%PLUGIN_ID%\". %PLUGIN_ID% is a directory named as the plugin id (use the id as the directory name to avoid duplicated directories defined in
plugins)

The following structure should be obtained:

%Logizian-Install-Dir%

bin
lib
...
plugins

sample.plugin (%PLUGIN_ID %)
plugin.xml
plugin.properties
classes

sample (package)
... (other packages or classes or resources)

lib
sampleplugin.jar
... (others .jar)

icons (others resources)
red.png
...(other resources)

Below is an example of Logizian installation folder with plugin created in the plugins folder.

Plugin folder structure

After all, restart Logizian will see the plugin available. If not, make sure the code was written correctly and can be compiled, and you have setup the
above folder structure correctly.
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Command line interface
Instead of executing command through graphic user interface, you can also execute certain command in background, through the command line
interface. In this chapter, all the supported command will be described in detail.

 

Exporting diagram image

The command needed to export diagram as image.

 

Exporting and importing XML

The command needed to export project data as XML.

 

Generating report

The command needed to generate HTML/PDF/Word report

 

Project publisher

The command needed to publish a project

 

Updating teamwork project from server

The command needed to update a local teamwork project by getting changes from server.

 

Executing operations with Apache Ant

How to execute commands with Ant script.
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Exporting diagram image
To export images from a project through command line:

1. Browse the scripts folder under the Logizian installation directory.

The scripts folder inside Logizian installation directory

2. Copy the script file ExportDiagramImage.bat and paste to the bin folder of Logizian installation directory.

3. Start the command prompt.

4. Navigate to the bin folder of Logizian installation directory.

5. Execute the script with parameters. For example:
ExportDiagramImage -project C:\Demo\Demo.vpp -out C:\Demo\Output -diagram "*" -type jpg
Below is a description of parameters:

Parameter Description Example

-
project

Project path C:\Demo
\Demo.vpp

-out Folder for storing the exported images C:\Demo
\Output

-
diagram

A list of diagram required to export images. User can enter "*" for representing all diagrams, to supply the names
of diagrams, or to supply a text file which includes the names of all diagrams. Notice that when you use an
asterisk to indicate all diagrams, quote it.

diagram_1
diagram_2

-
type
[optional]

Type of diagrams. Here are the possible types:
• png

• png_with_background

• jpg

• svg

• pdf

png

Parameters for ExportDiagramImage
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Exporting and import XML
You can export project data to an XML, manipulate it externally, and feed the changes back to Logizian. In this chapter, you will see how to export and
import XML file through the command line interface.

Exporting XML
To export XML and images from a project through command line:

1. Browse the scripts folder under the Logizian installation directory.

The scripts folder inside Logizian installation directory

2. Copy the script file ExportXML and paste to the bin folder of Logizian installation directory.

3. Start the command prompt.

4. Navigate to the bin folder of Logizian installation directory.

5. Execute the script by supplying the required parameters. For example:
ExportXML -project C:\Demo\Demo.vpp -out C:\Demo\Output
Below is a description of parameters:

Parameter Description Example

-project Project path C:\Demo\Demo.vpp

-out Folder for storing the exported XML and images C:\Demo\Output

-diagram One or more diagrams to be exported "Diagram A" "Diagram B"

-noimage Do not export image files for diagrams N/A

-refmodel Whether to embed referenced projects' content inline true

Parameters for ExportXML

Importing XML
To import XML to a project through command line:
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1. Browse the scripts folder under the Logizian installation directory.

The scripts folder inside Logizian installation directory

2. Copy the script file ImportXML and paste to the bin folder of Logizian installation directory.

3. Start the command prompt.

4. Navigate to the bin folder of Logizian installation directory.

5. Execute the script by supplying the required parameters. For example:
ImportXML -project C:\Demo\Demo.vpp -file C:\Demo\Input\project.xml
Below is a description of parameters:

Parameter Description Example

-project Project path C:\Demo\Demo.vpp

-file The filepath of the XML file to import C:\Demo\input\sample.xml

Parameters for ImportXML
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Generating report through command line
To generate HTML/PDF/Word report from a project through command line:

1. Browse the scripts folder under the Logizian installation directory.

The scripts folder inside Logizian installation directory

2. Copy the script file GenerateReport and paste to the bin folder of Logizian installation directory.

3. Start the command prompt.

4. Navigate to the bin folder of Logizian installation directory.

5. Execute the script by supplying the required parameters. For example:
GenerateReport -project C:\Demo\Demo.vpp -out C:\Demo\Output\MyReport.pdf -type pdf -all
Below is a description of parameters:

Parameter Description Example

-project Project path C:\Demo
\Demo.vpp

-out The file or folder path of generated report file(s) C:\Demo\Output
\MyReport.pdf

-type Type of report to generate. Here are the possible options:
• html

• pdf

• word

pdf

-all
[optional]

By default, only the selected diagrams (saved in vpp) will be covered when generating report. By
including -all, all diagrams will be covered.

-all

Parameters for GenerateReport
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Project publisher
To publish project through command line:

1. Browse the scripts folder under the Logizian installation directory.

The scripts folder inside Logizian installation directory

2. Copy the script file ProjectPublisher and paste to the bin folder of Logizian installation directory.

3. Start the command prompt.

4. Navigate to the bin folder of Logizian installation directory.

5. Execute the script by supplying the required parameters. For example:
ProjectPublisher -project C:\Demo\Demo.vpp -out C:\Demo\Output
Below is a description of parameters:

Parameter Description Example

-project Project path C:\Demo\Demo.vpp

-out The folder path of the files to be published C:\Demo\Output

Parameters for ProjectPublisher
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Updating teamwork project from server
To update teamwork project from server through command line:

1. Browse the scripts folder under the Logizian installation directory.

The scripts folder inside Logizian installation directory

2. Copy the script file UpdateTeamworkProject and paste to the bin folder of Logizian installation directory.

3. Start the command prompt.

4. Navigate to the bin folder of Logizian installation directory.

5. Execute the script by supplying the required parameters. For example:
UpdateTeamworkProject -project "C:\vpworkspace\teamwork_client\projects\Demo\Demo.vpp" -workspace "C:\vpworkspace"
Below is a description of parameters:

Parameter Description Example

-project Project path C:\Demo\Demo.vpp

-workspace The path of workspace of the supplied project C:\vpworkspace

Parameters for UpdateTeamworkProject
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Executing operations with Apache Ant
Apache Ant is a software tool for automating software build processes. It is written in the Java language and is primarily intended for use with Java. If
you are not familiar with Ant, you can find more information about it at   Ant's webpage . To execute commands with Ant:

1. Browse the scripts folder under the Logizian installation directory.

The scripts folder inside Logizian installation directory

2. Copy the script file build.xml and paste to the bin folder of Logizian installation directory.

3. Open the build file in any text editor. Modify the properties vpsuiteInstallationPath, vpproduct, vpworkspace and headless to suit your
environment.

4. Modify task(s) specific parts by changing the values of parameters. For details about the parameters, refer to previous sections.

5. Save the changes and exit.

6. Start the command prompt and navigate to the bin folder of Logizian installation directory.

7. Enter ant build.xml, and then the task name to execute specific task.

http://ant.apache.org/
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Exporting report through command line (Report Composer)
To export reports created by report composer through command line:

1. Browse the scripts folder under the Logizian installation directory.

2. Copy the script file ExportReportDiagram and paste to the bin folder of Logizian installation directory.

3. Start the command prompt.

4. Navigate to the bin folder of Logizian installation directory.

5. Execute the script by supplying the required parameters. For example:
ExportReportDiagram.bat -project "C:\Demo\Demo.vpp" -diagram "Report1" -out "C:\Demo\Output" -type word
Below is a description of parameters:

Parameter Description Example

-
project

Project path C:
\Demo
\Demo.vpp

-
diagram

The name of the report(s) to be exported. You can provide a list of diagram like "Report1" "Report2", or enter "*" to export
all reports, or enter @diagramlist.txt to let the batch read the diagram list from file diagramlist.txt placed in bin folder.

"Report
1"
"Report
2"

-
out

The folder to store the exported file C:
\Demo
\Output\

-
type

Type of report to generate. Here are the possible options:
• html

• pdf

• word

word

Parameters for ExportReportDiagram
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Printing diagrams
This chapters covers the steps needed to print diagram(s) to printing devices.

 

Printing diagrams

Introduces the standard way of printing diagram with description to several printing configuration.

 

Quick print

Quick print is a lite way of printing diagram by ignoring some of the configuration options and preview of outcome.
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Printing diagrams
The Print window dialog box allows you to preview the printout and provides a set of options for changing the printout style. To unfold the Print window
dialog box, select File > Print... from main menu.

An overview of Print window

Print preview dialog box
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The toolbar of the print preview pane allows you to configure the print settings. The buttons and their description are shown in the table below:

Button Name Description

Print Print the diagram(s). The Print dialog box will be opened.

Quick Print Print the diagram(s) without previewing them. The Quick Print dialog box will be opened.

Page Setup Set up the page properties, such as paper size and orientation.

Adjust Margin Adjust the margins of the pages.

Use Gradient Color Select the use gradient color in printout. Since printing gradient color will use up lots of memory, it is
recommended to turn this option off for better performance.

Zoom Select the percentage to reduce/enlarge the print preview of diagrams.

 / 
Paper Base
Layout/ Diagram
Base Layout

If the Fit to Pages option is chosen, and there are multiple pages in the printout, choosing Paper Base Layout
will cause the distribution of pages to be paper-oriented (the diagram size is ignored in arranging the preview);
while choosing Diagram Base Layout will cause the distribution of pages to be diagram-oriented. Note that this
option affects the preview only; the order of the printout remains unchanged.

 / 
Paper Place Style Change the order of the printout. A large diagram is divided into many pages, choosing From left to right will

arrange the printout order from the pages on the left to the pages on the right, while choosing  From top to
bottom will arrange the print order from the pages on the top to the pages on the bottom.

Fit to Ratio Set the diagram size to fit to the specified ratio.

Fit to Pages Set the diagram to be printed on the specified number of pages.

Overlapping Set the percentage of the margins to overlap among adjacent pages.

Border Determine whether to add frame or boder around diagram in printout.

Show/ Hide Clip
Marks on Page

Select/ deselect to show/hide the clip marks on the printout.

Edit Header/
Footer

Edit the header and the footer of the printout.

Multiple Page
Mode

Switch to the Multiple Page Mode to set the multiple page options.

Help Call the Logizian help file.

Close Print
Preview

Close the print preview pane and return to the design area.

Details of toolbar

Printing a diagram with preview
You can use the Print command to select the printer. Set the range of pages and number of copies to be printed.
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1. Select the desired diagram(s) for printing. The selected diagram(s) will be shown in the preview area.

Diagram preview

2.
Click the Print button  on the Print preview toolbar. The Print dialog box will be shown.

The  Print dialog box

3. Select a specific printer, the page range and the number of copies to be printed. You may click the Properties... button to configure the printer-
specific properties as well.

4. Click OK to start printing.
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Page setup
Page Setup allows you to specify the page size, orientation, as well as the margins of the pages.

The Page setup dialog box

1.
Click the Page Setup button  on the toolbar. The Page Setup dialog box will appear.

2. You can click the Size drop-down menu to select the paper size for printing.

3. You can check either Portrait or Landscape udner Orientation.

4. You can enter the value into the Left,  Right, Top and Bottom text fields to adjust the size of the corresponding margin.

5. Click OK to confirm the settings.

Adjusting margins
The Margins pane allows user to specify the margins of the pages, header and footer.

Adjusting margins

1. Click the Adjust Margin button  on the toolbar. The margin setting page will be shown in the preview area.

2. You can edit the margins size by entering the sizes into the text fields. Alternatively, click the spinner buttons to increase/ decrease the margin sizes.

3. Click the  Finish Adjust Margin button  when you finish configuring the margin settings. The margin sizes will then be updated.

Zooming pages
Diagrams can be zoomed in or zoomed out according to the user's preference.
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1. Click the Zoom drop-down menu to select the desired zoom ratio.

Set zoom ratio

2. The preview area will show the diagrams in the zoom ratio that you have selected.

Preview in Preview dialog box

Selecting the preview layout
There are two layouts that you can choose for the print preview, the Paper Base Layout and the Diagram Base Layout.

If the Fit to Pages option is chosen and there are multiple pages in the printout, choosing Paper Base Layout will cause the distribution of pages to be
paper-oriented (the diagram size is ignored in arranging the preview); while choosing Diagram Base Layout will cause the distribution of pages to be
diagram-oriented.

Note that this option affects the preview only; the order of the printout remains unchanged.

To select a layout of the preview, click the Paper Base Layout button  or Diagram Base Layout button  on the toolbar.  A pop-up menu where
you can choose the layout will appear.
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The preview after applying the Paper Base Layout:

Preview in paper base layout

The preview after applying the Diagram Base Layout:

Preview in diagram base layout

Setting paper place style
You can select the paper place style to change the order of the printout. To select the paper place style, click the Paper Place Style button on the
toolbar. A pop-up menu where you can choose a paper place style will appear.

Considering a large diagram is divided into many pages, choose From left to right will arrange the printout order from the pages on the left to the
pages on the right, while choosing From top to bottom will arrange the print order from the pages on the top to the pages on the bottom.
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The order of the printout after choosing From left to right:

Printout order is left to right

Fit to ratio
Fit to Ratio is used to resize the diagrams in the printout to a specific ratio.

Click the Fit to drop-down menu and select Ratio.

You can enter the ratio into the text field. After editing the ratio, the diagrams in the printout will be resized at once.

Fit to ratio

Fit to pages
Fit to Pages is used to split the diagram to a desired number of pages when printing.

1. Click the  Fit to drop-down menu and select pages.
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2.
Click the Multiple Page Mode button  on the toolbar. The page selector will appear.

Select multiple pages

3. Click the row-column combination to select it (note that you can click and drag on the page selector to extend the selection). The diagram will be
split into multiple pages by the rows and columns that you have selected.

Fit to page

Setting the diagram overlap percentage
Overlapping is used when users want the diagrams to be overlapped at the boundaries between pages. This is particularly useful when you have a
large diagram that span multiple pages and you want to stick the pages of the printout together; the overlapping area can then be used as a hint when
sticking the pages.

Multiple page without overlap

1. Input the overlapping percentage and press Enter in Overlapping text field.

2. The printing area near the boundaries of the pages will be duplicated through the input value of overlapping percentage.

Multiple page with overlap

Printing with frame/Border option
You can print your diagram with a frame or border. There are three options available:

• With frame
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• With border

• No border

Select With frame/ With border/ No border option from the drop-down menu.

Select an option from drop-down menu

Output of printing with frame:

Printing with frame

Output of printing with border:

Printing with border

Output of printing with no border:

Printing with no border

Showing/Hiding clip marks on page
Clip marks act as an indication of the boundary of a page.

Clip marks

To show clip marks on the printout, click the Show Clip Marks on Page button . The boundaries of the pages will be surrounded by clip marks. To

hide the clip marks, click the  Hide Clip Marks on Page button  again.
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Editing header/footer of the pages

To edit the header/ footer of the printout, click the Edit Header/Footer button  on the toolbar. You will then switch to the edit header/footer pane.

Editing header/footer of pages

You can edit the header and the footer in the Header panel and the Footer panel respectively. Each of the panel consists of the Left Section, Center
Section and the Right Section, which represents the position that the content will be located in the header/footer.

There is a toolbar between the Header panel and the Footer panel, which facilitates the editing of header/footer. The description of the buttons in the
toolbar can be found in the following table:

Button Name Description

Select Font Select the font format. Note that you have to click the section you want its font to be formatted before you start setting the
font format.

Insert Page
Number

Insert the page number. Note that you have to click the section you want page number to be inserted into before you click it.

Insert Number of
Pages

Insert the total number of pages. Note that you have to click the section you want the number of pages to be inserted into
before you click it.

Insert Date Insert the date that the printing starts. Note that you have to click the section you want the date to be inserted into before
you click it.

Insert Time Insert the time that the printing starts. Note that you have to click the section you want the time to be inserted into before you
click it.

Insert File Name Insert the file name of the Logizian project. Note that you have to click the section you want the file name to be inserted into
before you click it.

Insert Project
Name

Insert the name of the Logizian project. Note that you have to click the section you want the project name to be inserted into
before you click it.

Insert Diagram
Name

Insert the diagram name. Note that you have to click the section you want the diagram name to be inserted into before you
click it.

Insert Parent
Package

Insert the parent package. Note that you have to click the section you want the parent package to be inserted into before
you click it.

Insert Parent
Hierarchy

Insert the parent hierarchy. Note that you have to click the section you want the parent hierarchy to be inserted into before
you click it.

The description of editing of header/ footer toolbar
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After you have finished editing the header/footer, click the Close Edit Header/Footer button  to switch to the print preview mode. A sample page
with the header and footer is shown in the figure below:

Page with header and footer

The multiple page mode
The Multiple Page Mode allows users to configure how the diagrams should be distributed in multiple pages. To switch to the Multiple Page Mode, click

the Multiple Page Mode button  on the toolbar.

Click the icon behind Multiple Pages will pop the page selector out, where you can select the row-column combination for the printout. Alternatively,
you can type in the Row and Column text field directly.

Select multiple pages
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Click the icon behind  Page Style to change the printout order. Considering a large diagram is divided into many pages, choosing From left to right
will arrange the printout order from the pages on the left to the pages on the right, while choosing From top to bottom will arrange the print order from
the pages on the top to the pages on the bottom.

Distribute diagram in multiple page

After you have finished configuring the multiple page settings, click the  Close Multiple Page Mode button to close it.
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Printing a Diagram with Quick Print
In Logizian, you can print a diagram with simple and easy setting by using quick print feature. The Quick Print feature allows you to print diagrams
without previewing them, hence speeding up the print job.

Printing with quick print
To perform quick print:

1. Select File > Quick Print... from main menu.

NOTE: Alternatively, you can select Print > Quick Print... on the toolbar to launch quick print.

2. In the Quick Print dialog box, select printout setting for the diagram.

3. Click OK button to proceed printing.

The overview of Quick Print

Quick Print dialog box

 

No. Name Description

1 Print
Range

Click on either of the below options to specify the print range:
• All - Print all the diagrams within the current project.

• Active - Print only the active diagram.

• Diagrams - Check from the diagram tree to select the diagram(s) for printing.

2 Scaling Select No scaling to print with diagrams' original size. Numbers of pages used for each diagram are subject to the scale of
diagrams. Select Fit to pages to print with specified number of pages per diagram with respect to the specified number of rows and
columns.

3 Border
option

Select border option of printout.

4 Page
Setup...

It allows you to specify the page size, the orientation as well as the margins of the pages.

5 Page
numbers

Select it to print diagrams with page number.

6 Use
gradient
color

Select it to use gradient color in printout.

Details of quick print dialog box
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Introduction of impact analysis
Impact analysis is the technique to find out what the potential influences are when updating a design blueprint. This chapter provides you with general
understanding about impact analysis.

 

Introduction of impact analysis

Describe the several ways of impact analysis supported by BP-VA.
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Introduction of impact analysis
Impact analysis is the technique to find out what the potential influences are when updating a design blueprint. For example, when we want to
restructure pools and lanes in BPD, we may also want to take a look at the related organization chart and make changes accordingly. Analysis diagram
and matrix are the two ways of performing impact analysis in Logizian.

Matrix diagram

 

Analysis diagram
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Matrix diagram
A matrix is a table, which shows the relationships among model elements of particular types. By reading a matrix, you can tell easily whether two model
elements are related or not, and what kind of relationship do they have. This chapter not only tells you how to create a matrix but also how to read it, to
get the information you need.

 

Creating a matrix

Shows you how to create a matrix.

 

Reading a matrix

Explains each part of a matrix in detail.

 

Showing the Use of Terms with Matrix

Shows you how to present the the use of terms by forming a matrix.
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Creating a matrix
A matrix is a table, which shows the relationships among model elements of particular types. By reading a matrix, you can tell easily whether two model
elements are related or not, and what kind of relationship do they have.

1. Right click on Matrix Diagram, under the category Others in Diagram Navigator, and select New Matrix Diagram from the pop-up menu.
• Click on Diagrams on toolbar and select Matrix Diagram from the drop down menu .

• Right click on Matrix Diagram   in Diagram Navigator, under the Impact Analysis category, and select New Matrix  Diagram from the
popup menu.

• Select File > New Diagram > Impact Analysis >  Matrix  Diagram from the main menu.

2. Configure the matrix.

Configure matrix

Field Description

Diagram
Name

The name of diagram which is also the name of matrix.

Scope The source of model elements to compare in matrix, in Project (all model elements), Diagram (only model elements in specific
diagrams which are selected by users) or under Model/Package.

Template Template offers a default setup to Models on Column, Models on Row and By. It is available according to the project
content. For example, template "Task <-> Data Object" appears for selection when a project has task and data object.

Available
Models

All available models in your selected scope are listed here. You can select a model to add it in the target Models on Row and/
or Models on Column.

Models
on
Column

The type of model element to list at the column side of matrix. In order to list multiple types of model element, select it/them on

Available Models and click button to insert it/them in here.

Models
on Row

The type of model element to list at the row side of matrix. In order to list multiple types of model element, select it/them on

Available Models and click button to insert it/them in here.

By The way how matrix will match against rows and columns.
Sub Diagram  - The column/row model element is placed in a sub diagram of the matching model element.
Child - The column/row model element is a child of the matching model element.
Relationship - The column/row model element is related with the matching model element.
Reference - The column/row model element is referencing the matching model element.
As Classifier - The column/row model element takes the matching model element as classifier.
Transitor - The column/ row model element is traceable between the matching model element.
Dependent - The column/row model element has properties that depend on the matching model element.

Fields for matrix configuration

3. Click OK button to form the matrix.
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Reading a matrix
To know how to read a matrix helps you to understand your model better, and to perform further modifications more efficiently. In this chapter, we will
see how to read a matrix, and how to refine the matrix content with the help of functionalities like showing columns and rows with matches and filter.

A matrix is a table, with rows and columns, which represents sets of model elements of specific types. A cell in table is an intersection of a row and
a column that reflects the relationship of the row and column. If the cell is filled either by a tick, or by a kind of relationship (when a matrix was set to
match things by Relationship), this means that the model elements of the row and column are related. You can select the type of relationship in the
drop-down menu of By.

Overview of a matrix diagram

No. Name Description

1 Sort Click this button to sort the model elements by their name or by their ID.

2 Show rows/
columns

You can determine how model elements are shown in rows and columns. Select Matches only if you want to view model
elements with matches while select Not matches only if you want to view model elements without matches. Otherwise, select 
All to view all entries.

3 Filter row Type the full name of a model element or just keyword that you are looking for to narrow down the searching field in rows when
too much data is displayed.

4 Clear row filter Delete all you have typed in Filter row.

5 Filter column Type the full name of a model element or just keyword that you are looking for to narrow down the searching field in columns
when too much data is displayed.

6 Clear column
filter

Delete all you have typed in Filter column.

7 Refresh You can update the content of matrix by clicking this button manually, for reflecting the changes you have made in models.

8 Export to Excel Click this button to export the opening matrix to Excel.

9 Configure Click this button to configure the content to display in matrix.

10 By It shows how matrix will match against rows and columns.

11 Rows The model elements have been chosen will be displayed in rows.

12 Move up and
move down

Rows and columns are ordered alphabetically by default. They help to re-order rows and columns in moving vertically.

13 Swap rows and
columns

It helps to change the presentation between rows and columns, but not switch the actual relationships between model
elements being represented by them.

14 Move left and
move right

Rows and columns are ordered alphabetically by default. They help to re-order rows and columns in moving horizontally.

15 Columns The model elements have been chosen will be displayed in columns.

Description of matrix diagram



Reading a Matrix P. 588

Exporting Excel
You can export Excel file from matrix, and analyze relationships between model elements in worksheet in Excel. To export Excel:

1. Click Export to Excel above the matrix, near the Configure button.

Click Export to Excel

2. In the Export Excel dialog box, specify the output destination and click Save button.
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Showing the Use of Terms with Matrix
Glossary is a function to let you identify important terms from name and documentation of model elements, so that you can build a glossary with terms,
and describe them in detail. For details about the use of glossary, please read the page Identify glossary term.

When you want to access the elements whose names or documentations have terms included, you may form a matrix to illustrate the relationships
between elements and terms. You can even see how frequent the terms are referred to in different model elements in a matrix view.

To create such matrix:

1. Take any of the following approach to create a matrix:
• Diagram Navigator - Right click on Matrix Diagram in Diagram Navigator and select New Matrix Diagram from the popup menu.

• Toolbar - Click on the Diagrams button in toolbar and select Matrix Diagram from the drop-down menu.

• Menu - Select File > New Diagram > Impact Analysis > Matrix Diagram from the main menu.

2. Configure the matrix. If you want to place the terms at the top of matrix, add Term to Models on Column. If you want to place the terms on the
left hand side of matrix, add Term to Models on Row.

Elements are selected for row and column

3. Select Using Term under the drop down menu By.

Select Using Term

4. Click OK. The ticks show in the matrix indicate the use of term for specific element.

Matrix formed
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5. If you want to open a view of a model element, right click on the element and select Show View... from the popup menu. in the Show View
window, select the diagram to open and click Go to View.

Show view of pool
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Analysis diagram
By analyzing a model element, you can know its relationships with other elements. This chapter shows you how to analyze things by forming and
reading an analysis diagram.

 

Analyzing a model element

Shows you how to analyze a shape.

 

Updating analyzed result

When the model keep growing, you may need to update the analysis diagram to reflect the latest project content.

 

Grouping of nodes

Instead of having many many nodes show on analysis diagram, you may want to group nodes of same type to make the diagram tidier.

 

Opening view from node

Shows you how to open a view from a view node.
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Analyzing a model element
We analyze a model element when we want to identify its related elements so as to foresee the potential impact that may cause on the model resulted
by modifying the model element. The term "related" here represents any kinds of connection between two elements, such as a general to-and-from
relationship, a parent-child relationship, transitor, or even a sub-diagram relationship with a diagram.

Analyzing a model element
By analyzing a model element, you can know its relationships with other elements. To analyze:

1. Right click on the diagram element you want to analyze, and select Related Elements > Analysis... from the pop-up menu.

Analyze a diagram element

NOTE: To analyze a model element in Model Explorer, right click on the desired element node in Model Explorer and select Analysis... from the
pop-up menu.
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2. The result of analysis will be presented in analysis diagram. In the Analysis dialog box, check either Create new diagram to present the result
in a new analysis diagram, or Select an existing diagram to present in an existing analysis diagram. The check boxes under the Analyse
section manage the type(s) of relationship to be analyzed. Click OK button when ready.

The Analysis dialog box

Type Description

TransitorThe transited element of the chosen element, or the element where the chosen element was transited from.

ReferenceThe shape or diagram references of the chosen element.

Parent-
Child

The parent (e.g. package) or the child of the chosen element.

Sub-
diagram

The sub-diagram(s) of the chosen element.

RelationshipThe relationship(s) of the chosen element, such as association, dependencies, sequence flow, etc

Used The connection with the chosen element, other than any other kinds of relationship types. For example, requirement owned by
use case added through use case description is a kind of Used relationship.

View The view(s) of a model element, which can be seen as the shapes of a model element.

Kinds of relationships that can analyze
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Reading analysis diagram
The result of analysis is shown in an analysis diagram.

An analysis diagram

The oval node at the center of diagram represents the element you have chosen to analyze, while the connectors are the relationships between the
analyzing element and its related elements.

Inside a node of a related element, you can see a tag (e.g. <<View>>), which represents the type of that related element. At the bottom part of a node
box is the name of the related element.

With analysis diagram, you can identify the relationship of a model element and determine the impact that may act upon the model when modifying the
model element.
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Updating analyzed result
If a model is refined, the previous analysis result may no longer reflect the latest changes. You, thereofore, need to update the analysis result in order
to perform impact analysis for the chosen element with the latest model.

1. Move the mouse over the node that you want to update its relationships with others.

Analyze a diagram element

NOTE: Besides the central node, you may update/show the relationships of other Model nodes on diagram too.

2. Click its resource icon Analyze.

Click resource icon Analyse

3. Select a type of relationship to analyze.

Analyze all kinds of relationships
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Grouping of nodes
To make it easier to identify the relationships of a chosen element, you can group all relationships of a particular kind into a single node, thereby it
reduces the connectors being shown on diagram.

To group, right click on the background of analysis diagram, select Presentation Options > Group By, and then the type of node from the pop-up
menu.

Select a kind of relationship to group by

As a result, nodes of same type are grouped.

Diagrams are grouped

To ungroup, simply uncheck the node type by walking through the same pop-up menu path.
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Opening view from node
When reading an analysis diagram, you may find the related model elements, or related diagrams, such as sub-diagram, of the chosen model element.
You can open the view of such related elements through the resource icons of nodes.

Opening a diagram of diagram node
Move the mouse over a Diagram node and click its resource icon Open Diagram.

Open diagram of diagram node

As a result, the diagram is opened.

Opening a view of model node
Move the mouse over a Model node and click its resource icon Open View.

Open view of model node

If the target model has only one view, the view will be opened. If there are multiple views, the Show View dialog box will pop out. Select a view to
open, and click Go to View button at the bottom right of dialog box to view the model element.
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Chart diagram
Chart diagram enables you to specify and show the relationship between model elements by mean of chart. This chapter shows you how to create and
configure chart.

 

Chart diagram

Shows you how to create and configure chart.
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Chart Diagram
Logizian enables you to build a chart. In addition to the built-in RACI chart available for general purposes, you can define your own type of chart for
problem-specific purposes. In this page, you can learn how to develop a chart, define color for roles and define a new code type.

Developing a chart
1. Right click on Chart Diagram on Diagram Navigator and select New Chart Diagram from the pop-up menu.

• Click on Diagrams on toolbar and select Chart Diagram from the drop down menu .

• Right click on Chart Diagram   in Diagram Navigator, under the Impact Analysis category, and select New  Chart  Diagram from the
popup menu.

• Select File > New Diagram > Impact Analysis >  Chart  Diagram from the main menu.

2. Name the chart diagram.

Name the chart diagram

3. Select a model element type for row and column respectively to identify which participant is involved in an activity.

Select a model element type for row and column

NOTE: The choice of model element types will be in accordance with your existing model elements in the same project.

4. Click OK button.

5. You can then assign the role to participant(s) by clicking Mark Code to Cell button on the top of chart.

Click Mark Code to Cell button
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6. When the roles reveal, click the target role and select the target cell to assignment.

Assign role

Adding an item
Apart from selecting existing model elements on chart, you can also create objects without model view. Those objects will have the similar properties
with model elements, which you can assign role to them.

To create an item without model view:

1. Right click on a model element where you want to insert an item in font of that model element and select Add item... from the pop-up menu.

Add an item



Chart Diagram P. 601

2. Enter name for new item in the pop-up Input dialog box. Click OK button to confirm and close the dialog box.

Enter item's name

As a result, the newly created item is shown.

The newly created item is shown

Specifying background color for column/ row
The background color of columns and rows are white by default. You can specify background color for the entire columns/ rows by right clicking on the
target row/ column and then selecting color for it.

To set background color for column/ row:

Right click on the target row/ column and select Color > [target color] from the pop-up menu. You can select a color from either Default category or
Custom category.

Select a background color
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As a result, the background color for selected row/ column is set.

Background color is set

Opening model element's specification
You can view and specify the properties of model elements by opening their specification dialog box.

To open a model element's specification:

1. Right click on the target model element and select Open Specification... from the pop-up menu.

Open Lane's Specification dialog box

2. In specification dialog box, specify its properties, for example, documentation, references, tagged values and comments. Click OK button.

The Lane Specification

Selecting model element in Tree
You can view a model element on Model Explorer by selecting it on chart.

To select a model element on Model Explorer:
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Right click on the target model element and select Select in Tree from the pop-up menu.

Select in Tree

As a result, the model element is highlighted on Model Explorer.

Model element is highlighted on Model Explorer

Showing the view of model element
When reading the chart, you may want to view the model element on its source diagram.

You can view the model element by right clicking on the target model element and selecting Show View... from the pop-up menu.

Show the view of model element
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As a result, the view of model element is selected on the diagram.

Model element is selected on its source diagram

Reordering row/ column
You can arrange the order of model elements with your preference.

Right click on target row/ column and select Move up or Move Down from the pop-up menu.

Move model element up

Defining color for roles
1. To define a color for roles, you can modify the existing chart by clicking the ... button of Code Type in Chart Diagram.

Define code type
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2. To define a color for a role, click the target role you want to change its color on the left, click the ... button next to Color and select a color from
the pop-up menu.

Select a color for target role

3. Click OK button.

Defining a new type of chart
1. In Chart Diagram, apart from the built-in code type, you can configure a new code type by clicking the ... button of Code Type.

Define a new type of chart

2. In the pop-up Configure Code Type dialog box, select Add > Code Type from the pop-up menu at the bottom to add a code type.

Add a code type
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3. Rename the newly created code type in Name.

Rename the code type

4. To configure the roles under the new code type, select Add > Code from the pop-up menu.

Add a new code

5. Enter the name of the code in Name and a letter which presents the code in Code. Click the ... button next to Color and select a color for the
code from the pop-up menu.

Enter the properties of code

6. Click  OK button.
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7. The code type you created previously is currently available from the combo box of Code Type. Select it from the combo box of Code Type.

Select a chart type from the combo box of Code Type
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Team collaboration in Logizian
Team collaboration is the practice of working in a team instead of by one person. Team members can work individually on their own specific parts
of a project, and eventually combine works together to form a complete project. This chapter provides you with clear information on Logizian's team
collaboration support.

 

Introduction to team collaboration

Describes the key concepts about team collaboration like administration, commit, update, revert, etc.

 

The teamwork client

Teamwork Client, where you can manage, checkout and open projects, involves all teamwork activities that you can perform with.
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Introduction to team collaboration
Team collaboration  is the practice of working in a team instead of by one person. Team members can work individually on their own specific parts of
a project, and eventually combine works together to form a complete project. As a result of collaborations between members by employing the unique
skills of each, works can be done more effectively and in higher quality.

Logizian's team collaboration support provides access to a central repository for managing, sharing and versioning projects. You can let team members
get project from repository, start working on their own parts, let them commit (i.e. upload) their work to server, and update others' works. Visual
Paradigm Teamwork Server, SVN, CVS, ClearCase and Perforce are the supported standards of versioning systems. This chapter outlines some of
the key concepts in team collaboration in Logizian.

Administration
Administration is the process of setting up projects and users (i.e. team members), and deciding the access rights of members against projects.
Administration is a must in order to start working.

Edit project

Checkout project
Checkout project is a process done by team members, for getting a project from repository to start working with. Team members should login into the
server, then checkout the projects to work with, provided that they have the permission to do so, as granted by administrator.

Commit
Commit is the process of uploading changes done in working copy to server. As team members make changes in a project, they can share their works
by committing those changes to the server. Logizian will try to merge changes from working copy to server copy. When merging, there may be conflict
when any changes a team member made cause an unresolvable contradiction with changes made by others. Team member is required to decide
whether to keep his/her change (i.e. overwrite) or to take the co-worker&rsquo;s change (i.e. revert). All conflicts must be resolved in order to proceed
with committing.

Update
Update is the process of refreshing the working copy by merging changes that others had made and committed to server before. Similar to commit,
update is a process of merging differences instead of overwriting. If your changes overlap the changes others had made, you will be asked to resolve
conflict. All conflicts must be resolved in order to proceed with updating.

Conflict
Conflict is a situation that happens when committing or updating. It occurs during the merging between working and server copy of project, when
a contradiction is detected between them. For example, a team member has renamed a shape from A to B and has committed the change. Then,
another team member has renamed the same shape from A to C and attempt to commit. Due to difference in the name of shape, a conflict is occurred.
Whenever a conflict occurred, users have to resolve it or else to abort before commit/update operation.

Branching
Branching is the process of creating a branch from trunk (i.e. main development flow), for isolating changes that are not supposed to be available on
trunk, either at the moment or permanently. By working in a branch, team members can carry out half-broken or risky changes without worrying the risk
of damaging the work in trunk. Once the works done in branch is examined, and confirmed alright, team member can make changes available in trunk
through merging. Merging can also be done from trunk to branch to ensure that the branch is always up-to-date.

Tagging
Tagging is the process of producing a snapshot (i.e. tag) of a project in time. People often create tags for archiving releases of works. Therefore, tags
are often named as release-1.0 where 1.0 is the number of version. Since a tag is a snapshot, team members can never commit under a tag.

Revision history
Every time a team member performs a commit with success, a new revision is created as a snapshot of project. More and more revisions will be
created through repeated committing. A list of revisions that shows the changes of project is called the revision history. In Logizian, you can review the
works done in specific revision(s) by exporting them in project files. You can identify the differences between revisions by comparing them.

http://www.visual-paradigm.com/product/lz/provides/teamwork.jsp
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Revert changes
Revert is the process of undoing changes. In Logizian's team collaboration support, there are two kinds of revert actions that you can perform. The
first one is to revert locally modified changes to make the working copy back to the original state. Another revert action is for undoing changes made in
revisions. Team members can undo changes made in revisions by reverting them.
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The Teamwork Client
Teamwork Client is where you can manage, checkout and open projects. It involves all teamwork activities that you can perform with.

To launch teamwork client:

1. Select Teamwork > Open Teamwork Client... from the main menu of Logizian.

2. In the Login window, select the type of server you try to connect to (i.e. Standalone VP Teamwork Server/VP Teamwork Server in Web Server/
VPository/Subversion/CVS/Perforce/ClearCase), enter the connection settings and click OK to login to the server.

The Login window

3. If this is the first time you login to the server, you are prompted the Manage Project window where you can select your project and click > button
to manage it. Click OK to continue.

Overview of Teamwork Client window

The Teamwork Client window

No. Name Description

 1 Main
menu

Session: It is a period of active connection with server.

               Login: Login the server. After you choose it, you will be able to execute all actions.

                Logout: Logout the server. After you choose it, you will not be able to execute any actions.

Project: Provides an access to main functions, such as commit and update.

              Manage Project: Select a project that you get involved in.

             Import Project to Repository: Import a new project to the server.

             Commit: Commit your current modified project to the server.

             Update: Update the latest copy of project from the server to your computer.
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             Checkout: Click it to checkout the project selected in Projects list. It will be disabled when the selected project has already been
checked out.

             Open: Click it to open the checkout project on your computer.

             Check Update: Click it to check whether the project is up-to-date or not.

             Tag: Create a new tag for your current project. It allows you to produce a static release version of project.

             Branch: Create a new branch for your current project. It becomes a duplication of project to perform isolated changes.

             Merge: Combine the selected branch(es) with the trunk (main project). When some changes made in branch, it will be made in trunk
as well.

             Switch: Switch from a branch/ tag to another branch/ tag or from the trunk (main project) to a branch/ tag and vice versa.

             Delete Branch: Select a branch to delete, for preventing accidental modifications in branch.

             Reset Password: Reset your account's password.

             Revert Local: Click it to undo un-committed changes made on the local project copy.

Repository:

             Synchronize Design Pattern to Server: Synchronize the template files stored in workspace with those stored in repository. When
a conflict occurs, you will be asked which design template files to keep.

Maintenance: All the functions under the Maintenance menu are prepared for diagnosis purposes. You should not run them unless you are
requested by Visual Paradigm support team. And when you are requested to execute any maintenance function, you will be briefed.

 2 ToolbarLogin: Log into the server. After you choose it, you will be able to execute all actions.

Logout: Log out the server. After you choose it, you will not be able to execute any actions.

Manage Project: Select a project that you get involved in.

Import Project to Repository: Import a new project to the server on the list.

Update: Update the latest copy of project from the server to your computer.

Commit: Commit your current modified project to the server.

Checkout: Click it to checkout the project selected in Projects list. It will be disabled when the selected project has already been checked
out.

Open: Click it to open the checkout project on your computer.

Revert Local: Click it to undo un-committed changes made on the local project copy.

Check for Update: Click it to check whether the project is up-to-date or not.

Tag: Create a new tag for your current project. It allows you to produce a static release version of project.

Branch: Create a new branch for your current project. It becomes a duplication of project to perform isolated changes.

Merge: Combine the selected branch(es) with the trunk (main project). When some changes are made in branch, it will be made in trunk as
well.

Switch: Switch from a branch/ tag to another branch/ tag or from the trunk (main project) to a branch/ tag and vice versa.

Delete Branch: Select a branch to delete, for preventing accidental modifications in branch.

 3 Show
all
user

By checking it, the list of all eligible users who have logged into the server in this workspace will be displayed. On the contrary, by
unchecking it, only the current user will be displayed.

4 RepositoryIt refers to the list of available project(s). Select  All from the drop-down menu  means all projects managed by all eligible users who have logged into server in this workspace will be

listed. On the other hand, the project(s) managed by a specific user can be selected from the drop-down menu. If you uncheck Show all user and do not select the current user in

Repository, no project will be listed.

5 ProjectsIt lists the project(s) you selected to manage.

6 Project
name

The name of selected project.

7 File
path

The path of the selected project file. It is shown only when project is checked out from the server.

8 Checkout
time

It displays the date and time of your first checkout for the project.

9 RevisionIt displays the revision of your local project copy. Note that the revision here does not always mean the latest revision on the server.

10 StatusIt displays the status of selected project, such as "Not Checked Out" will be shown when the project has not been checked out yet.

11 CommentIt shows the textual description of selected project written by administrator when creating project.

12 UpdateUpdate the latest project from the server to your computer.

13 CommitCommit your current modified project to the server.
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14 CheckoutClick it to checkout the selected project.

15 Open
Project

Click it to open the checkout project on your computer. If the project has not checked out yet, it will perform a checkout prior to opening
project.

16 Close Click to close the Teamwork Client.

17 Help Click it to get assistance from help system.

The description of the Teamwork Client window

The Revisions tab of the Teamwork Client

No. Name Description

18 Show drop-down menu Select the number of latest project revision to view from the drop-down menu.

19 Project revisions It lists all the latest project revisions. The number of revisions is in accordance with the show drop-down menu.

20 Open Click it to open the selected revision of project.

21 Export Export selected revisions: Export the selected revision(s) to a folder.

Export all revisions from repository: Export all the projects in repository to a folder.

22 Revert Selected Undo changes committed by the selected revisions.

23 Commit Comment A textual description of commit given by you or your teammates before committing.

24 Modified model
elements

It displays the modified model elements of the selected revision.

25 Modified diagrams It displays the modified diagrams of the selected revision.

26 Modified diagram
elements

It displays the modified diagram elements of the selected revision.

27 Modified files It displays the modified Teamwork Files of the selected revision.

The description of Revisions tab
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Basic Team Collaboration Features in Logizian
Check out the team collaboration features supported by Logizian.

 

Checkout project

Checkout project is a process that you download a managed project from repository to your computer and start working with.

 

Commit

Commit refers to the process of uploading local modifications to the server.

 

Support commit part of project to Teamwork

Other than committing the whole project, you may commit specific model elements/diagrams to Teamwork.

 

Update

Update is the process of refreshing your current copy by merging changes that others have made and committed previously to server.

 

Revert local modification

Since VP teamwork collaboration allows the feature of revert, you can undo all modifications you made in the local project copy when the changes
haven't been committed yet.

 

Import project

Import project refers to the process of adding project file in server so that team members can check that out and start working on it.
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Checkout project
Checkout project is a process done by team members, for getting a project from repository to start working with. Team members should login into the
server, then checkout the project(s) to work with, provided that they have the permission to do so, as granted by administrator.

1. Select Teamwork > Open Teamwork Client... from the main menu.

2. When the Manage Project window pops out, select the project you are going to take part in and click > button. Click OK button to proceed.

Select a project

3. When the Teamwork Client window pops out, select the project under Projects, and click Checkout.

Checkout project

4. Finally, click Open Project. You can now start to work on it.

Checkout multiple projects
Instead of checking out a single project, you can checkout multiple project files at the same time, for those listed in the Teamwork Client window as
managed projects.

1. Select Teamwork > Open Teamwork Client... from the main menu.

2. From the list on the left hand side, select the projects to checkout.

3. Right click on the selection and select Checkout from the popup menu.
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Commit
Commit refers to the process of uploading local modifications to the server. As team members make changes in a project, they can share their works
by committing those changes to the server. Logizian can help to merge changes from working copy to server copy. During merging, a conflict may be
caused when there is a contradiction between team members. Decision have to be made whether to keep the current modified copy (i.e. overwrite) or
to accept others' copy (i.e. revert). All conflicts have to be solved before proceeding to commit. To commit changes:

1. Select Teamwork > Commit... from the main menu.

2. If the change you made contradicts the change made by another team member, this will result in a conflict. You must resolve all the conflicts in
order to continue. For details, read the Resolving conflicts section below. Clear the conflicts, if any, and continue.

3. The Commit window displays the changes to be committed to the server. Click  Commit to proceed.

The Commit window

Overview of Commit window

The Commit window
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No. Name Description

1 Diagrams
tab

The diagram level changes to be performed when you execute commit.

2 Model
Elements
tab

The model element level changes to be performed when you execute commit.

3 Nicknames
tab

The changes of nickname to be performed when you execute commit.

4 Files
tab

The file changes to be performed when you execute commit.

5 Changes
tab

All the changes to be performed when you execute commit.

6 Filter When you commit, local changes will be merged to the server copy and meanwhile, changes in server copy will be merged to the local
copy, too. The filter let you filter the tree on the left hand side to list the commit changes, which are changes to perform on server copy,
and/or update changes, which are changes to perform on local copy.

7 Expand
All

Expand the tree nodes in the tree below.

8 Collapse
All

Collapse the tree nodes in the tree below.

9 Tree List out the changes to be performed when you execute commit.

10 CompareClick this button to compare local and server copy side by side.

11 PreviewThe preview of the element as selected in the tree on the left hand side.

12 Project
name

Name of current project.

13 Checkout
revision

The number of current checkout revision.

14 Checkout
time

The time for latest checkout.

15 Latest
server
revision

The number of latest revision in the server.

16 Commit
comment

You can give a comment for your current commit by typing here.

17 CommitProceed committed

18 Cancel Cancel committing and close the window.

The description of  Commit window

Committing multiple projects
Instead of commtting a single project, you can commit multiple project files at the same time, for those listed in the Teamwork Client window as
managed projects.

1. Select Teamwork > Open Teamwork Client... from the main menu.

2. From the list on the left hand side, select the projects to commit.

3. Right click on the selection and select Commit... from the popup menu.

Resolving conflict
If the change you made contradicts the change made by another team member, this will result in a conflict. For example, your colleague has renamed
a class from School to University and performed a commit, and then you rename the same class to College and perform a commit. This produces a
conflict.
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When a conflict occur, you must resolve it in order to continue committing. You have to resolve conflict either by overwriting or reverting the change.
Overwrite means to adopt the server copy's change, while Revert means to adopt the local's change.

Conflicts when committing

No. Name Description

1 List of change (action) List of changes to be performed. Initially only conflicted changes are listed. You can uncheck Show conflicts only to list
all changes.

2 Preview The preview of the element as selected in the tree on the left hand side.

3 Conflicted properties The properties that cause conflicts are listed in this panel.

4 Open Specification Click on this button to open the specification of element selected in the tree on the left hand side.

5 Property name The names of conflicted properties.

6 Local change The value of property in local project copy.

7 Original value The value of property before changed. In other words, it is the value in checkout copy.

8 Server value The value of property in server project copy.

9 Show conflicts only Check it to list only conflicted changes in the tree on the left hand side. Uncheck it to list all changes.

10 Overwrite by local Click on this button to adopt the source copy.

11 Revert to server Click on this button to adopt the target copy.

12 Preview Click this button to continue committing.

13 Cancel Cancel committing and close the window.

The description of  Commit window when have conflicts



Commit part of a project P. 619

Commit Part of a Project
In addition to committing all the changes you have made within the session, you can commit change(s) made on specific model element(s), shape(s) or
diagram(s). This way of committing is called a partial commit. To work with partial commit, simply right click on the project data you want to commit and
Teamwork > Commit... from the popup menu. You may select multiple items (e.g. two shapes) and commit them at once.
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Update
Update is the process of refreshing your current copy by merging changes that others have made and committed previously to server. Similar to
commit, update is a process of merging differences instead of overwriting. When any of your changes contradicts the changes others have made, you
will be asked to resolve conflict. All conflicts have to be resolved before proceeding with updating. To update:

1. Select Teamwork > Update from the main menu.

2. If the change you made contradicts the change made by another team member, this will result in a conflict. You must resolve all the conflicts in
order to continue. For details, read the Resolving conflicts section below. Clear the conflicts, if any, and continue.

3. The Update window displays the changes to be made upon updating. Click  Update to proceed.

The Update window

Overview of Update window

The Update window

No. Name Description

1 Diagrams tab The diagram level changes to be performed when you execute update.

2 Model Elements tab The model element level changes to be performed when you execute update.

3 Nicknames tab The changes of nickname to be performed when you execute update.
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4 Files tab The file changes to be performed when you execute update.

5 Changes tab All the changes to be performed when you execute update.

6 Expand All Expand the tree nodes in the tree below.

7 Collapse All Collapse the tree nodes in the tree below.

8 Tree List out the changes to be performed when you execute update.

9 Preview The preview of the element as selected in the tree on the left hand side.

10 Open Specification Click on this button to open the specification of element selected in the tree on the left hand side.

11 Property name The name of conflicted property.

12 Server update The value of property in server project copy.

13 Original value The current value of property (before updating).

14 Update Proceed updating

15 Cancel Cancel updating and close the window.

The description of  Update window

Updating multiple projects
Instead of updating a single project, you can update multiple project files at the same time, for those listed in the Teamwork Client window as
managed projects.

1. Select Teamwork > Open Teamwork Client... from the main menu.

2. From the list on the left hand side, select the projects to update.

3. Right click on the selection and select Update... from the popup menu.

Resolving conflict
If the change you made contradicts the change made by another team member, this will result in a conflict. For example, your colleague has renamed
a class from School to University and performed a commit, and then you rename the same class to College and perform an update. This produces a
conflict.

When a conflict occur, you must resolve it in order to continue updating . You have to resolve conflict by overwriting or reverting the conflicted change.
Overwrite means to adopt the server copy's change, while Revert means to adopt the local's change.

Conflicts when updating

No. Name Description

1 List of change (action) List of changes to be performed. Initially only conflicted changes are listed. You can uncheck Show conflicts only to list
all changes.

2 Preview The preview of the element as selected in the tree on the left hand side.
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3 Conflicted properties The properties that cause conflicts are listed in this panel.

4 Open Specification Click on this button to open the specification of element selected in the tree on the left hand side.

5 Property name The name of conflicted property.

6 Local change The value of property in local project copy.

7 Original value The value of property before changed. In other words, it is the value in checkout copy.

8 Server value The value of property in server project copy.

9 Show conflicts only Check it to list only conflicted changes in the tree on the left hand side. Uncheck it to list all changes.

10 Overwrite by local Click on this button to adopt the source copy.

11 Revert to server Click on this button to adopt the target copy.

12 Preview Click this button to continue updating.

13 Cancel Cancel updating and close the window.

The description of  Update window when have conflicts
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Revert local modifications
You can undo all the non-committed modification you made in the local project copy. The operation of giving up non-committed modifications is called
Revert. To revert:

1. Select Teamwork > Revert Local from the main menu.

2. Click Yes when you are asked for confirmation.
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Import project
Import project refers to the process of adding project file in server so that team members can check that out and start working on it. For  Teamwork
Server  users, project can be imported both in the server, via its Web interface, and through the client. For the other servers, import can only be done
through client. Note that you cannot manually place a project file in server to imitate the import process. You must import through the Teamwork Client
step by step, as described below.

1. Select Teamwork > Open Teamwork Client... from the main menu.

2. In the Teamwork Client window, select Project > Import Project to Repository from the main menu.

3. In the Import Project window, enter the project name.

4. Next to the name field you can see the option Create folder for project. When checked, a folder with same name as project will be created to
containthe project.

5. Select the source of project file:
Currently opened project - This will import the opening project to server as a new project.
Create new project - This will import a blank new project as a new project.
Import existing project - This will start with an existing .vpp project file. If you select this option, click ... and choose the .vpp file to import to
server.

Project sources

6. In the Repository pane, select the folder where the project file will be stored. Some servers (e.g. SVN) allows you to create new folder in
repository. You can create folder through the popup menu.

7. You can optionally describe the import action by entering your comment in the Comment field.

8. Assign users or user groups to project. Select the users or user groups from the list of available users. Note that there must be at least one user
be assigned to the project in order to add the project.

9. Click on either Add as Read Only or Add as Read and Update for the selected users against this project. The Read permission means that
user can only checkout the project and read its content. The Read & Update permission means that user can both read the project content and
commit changes to server.

User assigned

10. Click OK. This will import the

http://www.visual-paradigm.com/product/bpva/provides/teamwork.jsp
http://www.visual-paradigm.com/product/bpva/provides/teamwork.jsp
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Advanced Team Collaboration Features in Logizian
Check out the advanced team collaboration features supported by BP-VA.
Branching

Branch is defined as a copy of work derived from a certain point in the trunk. It sets up an extra space for users to work on and make modifications
without disturbing the trunk. As soon as the modifications in branch are done, you can merge it back to the trunk.

 

Tagging

Tag refers to a named version of your work at a point of time on the trunk.

 

Roll back past revision changes

Undo changes made in specific revision(s).

 

Export revision

Export revisions to project files.

 

Managing Teamwork Files

Add, commit teamwork files in Teamwork Files pane

 

Diagram protection

You can prevent a diagram from being edited by another team member by locking it. In this chapter, you will see how to protect diagram by locking.
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Branching
In terms of team collaboration, a trunk refers to the main stream of development.  If you create a new project, you will spend the majority of your time
making changes and committing them to the trunk of your repository.

Branch is defined as a copy of work derived from a certain point in the trunk. It sets up an extra space for users to work on and make modifications
without disturbing the trunk. As soon as the modifications in branch are done, you can merge it back to the trunk.

Creating a branch
1. Select Teamwork > Branch... from the main menu.

2. When the Create Branch window appear, enter its name in the Branch Name field for your new branch and select whether to start working on
the branch or to stay in trunk. Click OK to confirm.

The Create Branch window

The three options in the drop-down menu are Start working in branch, Checkout branch and Stay in trunk. Selecting Start working in
branch means you create, checkout and open a new branch and then start working on it. Selecting Checkout branch means you create and
checkout a new branch, but just keep it in repository for working on it later on. Selecting Stay in trunk mean you create a new branch, but do
not check it out and do not show it in repository either.

NOTE: For Teamwork Server, SVN and Perforce user, you can create branch from a specific revision of trunk by selecting Specific revision
in the repository and entering the revision number. On the other hand, select HEAD revision in the repository if you want to create a
branch from the latest revision in trunk. Finally, click OK button to confirm.

Merging a branch
When the development activity of branch has been completed, you can optionally merge the branch back to trunk. To merge:

1. Work in trunk. Select Teamwork > Merge... from the main menu.

2. When the Merge window appear, select the branch you want to merge to the working trunk. A specified revision of project can be merged both
from/to by selecting From Revision and entering the revision number of from and/or to revision. You can also click on the Show Log... button to
popup a window with revisions listed and then select the revision from the list. Click OK to continue.

The Merge window
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Tagging
Tag refers to a named version of your work at a point of time on the trunk. The best application of a tag is to create it for every major release or
milestone. Note that you cannot merge a tag to the trunk nor commit it to the server.

To create a tag:

1. Select Teamwork > Tag... from the main menu.

2. In the Create Tag window, enter the name of the new tag in the Tag Name field. Click OK to confirm.

The Create Tag window

NOTE: For Teamwork Server, SVN and Perforce user, check HEAD revision in the repository if you want to create a tag from the latest
revision of trunk while check Specific revision in the repository if you want to create a tag from a specific revision.
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Roll back past revisions changes
Logizian maintains the histories of changes team members made. If changes were made by mistake, you can undo it by performing a revert on the
revision where the change was made in.

Select Teamwork > Open Teamwork Client... from the main menu to open the Teamwork Client. In Teamwork Client, all your project's revisions
are shown in Project revisions under Revisions tab. Select the number of project's revisions you want to list from the drop-down menu Show. Select
the revision(s) that contain the unwanted changes and click Revert Revisions.

Revert a revision

 

A new revision will be created for the result of reverting. Therefore, you are asked to commit here. Sometimes, the undo action may cause a conflict
with a more recent revision, or revisions. Just like the normal commit process, you must resolve all the conflicts in order to continue committing. You
have to resolve conflict either by overwriting or reverting the change. Overwrite means to adopt the server copy's change, while Revert means to adopt
the local's change.
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Export revision
You can export revision(s) from server to your machine for checking the project content of certain phase of development. You can export specific
revision, or all revisions.

Export the selected revision
1. Select Teamwork > Open Teamwork Client... from the main menu.

2. In the Teamwork Client window, open the Revisions tab.

3. Select the revisions(s) you want to export under Project revisions. Click Export and choose Export selected revisions... from the pop-up
menu.

Export selected revision

4. In Select Directory window, select an existing folder or make a new folder for storing the selected revision(s). Click OK to proceed.

Export all revisions from repository
1. Select Teamwork > Open Teamwork Client... from the main menu.

2. In the Teamwork Client window, open the Revisions tab.

3. Click Export and choose Export all revisions from repository... from the pop-up menu.

4. In Select Directory window, select an existing folder or make a new folder for storing all revisions. Click OK to proceed.
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Managing Teamwork Files
When modeling, there may be external resources you want to attach to a model which help describe it in detail or include data that cannot be modeled
within the tool, like a text document. For example, you may want to attach a scanned image of a transaction receipt to a diagram that describes the
transaction process so that the analyst can design the new system based on the image. Or maybe an image file showing the user's expectation of the
user interface.

The reference function enables you to add file references to model elements and diagrams. You, as a user who work in a team-based environment
with Teamwork Server do not need to copy any referenced files for other team members to open. Instead, you could commit your model along with
the referenced files to the server by referencing a teamwork file. Teammates can then get the referenced files from server and open them in their
environment.

In VP, there is a folder under the workspace for storing files that are readily be committed to Teamwork Server for versioning. Those files are called
teamwork files. The file revision will follow the model, i.e. whenever you open a particular revision of work from server, the file of that revision will be
obtained and thus there is always a consistency between the file and the design.

NOTE: "Teamwork Files" is supported by Teamwork Server Corporate Edition.

The Teamwork Files pane
Teamwork Files pane is a user interface component where you can manage and see the teamwork files. If you are running in the default perspective,
the Teamwork Files pane is placed within the pane group at bottom left of the user interface. You may show it by selecting View > Panes > Teamwork
Files from the main menu, or press Ctrl-Shift-F.

The Teamwork Files pane

Adding teamwork files/folder
Adding a teamwork file/folder will copy that file/folder to under the workspace folder. Once added, the teamwork file/folder can be versioned by
Teamwork Server. To add a teamwork file:

1. Select the node in Teamwork Files pane for creating file/folder. You may select the project root node or a folder node.

2. Click on the plus button in Teamwork Files pane and select Add Files/Folder... from the popup menu.

Add file/folder

3. In the Add window, select the file or folder to add and click Open.

4. You are prompted to confirm copying the file or folder to workspace. Click OK.

Teamwork file added

Opening the containing folder of file
You can open the containing folder of a teamwork file/folder so that you can access it with file explorer provided by the operating system. Right click on
the file/folder and select Show in Folder from the popup menu.

Organizing teamwork files with folder
You may organize the added physical files/folder by adding folders. Note that when you create a folder, a physical folder will be created in your
workspace folder. To add folder:
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1. Select the node in Teamwork Files pane for creating folder. You may select the project root node or a folder node.

2. Click on the plus button in Teamwork Files pane and select New Folder... from the popup menu.

Create a folder

3. Enter the name of folder in the popup dialog box. Click OK. Once a folder is created, you may add files/folder in it, or drag existing teamwork
files/folders into it.

Folder added

Committing teamwork files
You may make use of the commit function to commit teamwork files to Teamwork Server. When you perform a commit globally (i.e. commit the whole
project), teamwork files will get committed. If you want to perform commit on specific teamwork file/folder, right click on it and select Commit... from the
popup menu.

Commit teamwork files to server

Removing teamwork files
To remove a teamwork file from Teamwork Files pane, select the file/folder to remove and press Delete. Alternatively, right click on the file/folder and
select Delete from the popup menu.

Revert changes
Revert is the process of discarding non-committed modifications. To revert a file/folder, right click on the file/folder and select Revert from the popup
menu. In the Revert window, select the files to revert.

Revert changes of teamwork files

Referencing a teamwork file
When you try to add a file reference to a teamwork file, you may manually navigate through the folders to locate the teamwork file to add. Or to speed
things up, Logizian lets you create a shortcut that brings you to the folder where the teamwork files are stored. In order to have such shortcut, you need
to define a user path of project files to create a corresponding shortcut in file chooser. After that, you may add the reference easily.

1. Select Tools > Application Options... from the main menu to open the Options window.
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2. In the Options window, select User Path on the left hand side.

3. On the right hand side, click Add... and select Project Files Path from the popup menu.

4. Click OK at the bottom of the Options window to close it.

5. From now on, when you try to add file reference to model elements, you can select the shortcut Project Files Folder in file chooser to jump to the
folder where the teamwork files are listed.

Project files folder
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Diagram protection
When you are working on a project with your team members, you probably don't want your work be modified by others by mistake. To protect your
work, you can lock your current diagram with password to make it uneditable by others.

Locking diagram
1. To lock a diagram which you don't want it to be modified by others, right click on the diagram's background and select Diagram Content >

Lock ... from the pop-up menu.

2. Enter your password in the pop-up Lock dialog box and then click  OK button. For your safety, always keep your password secret.

Enter password

Your diagram is then locked.

NOTE: Lock by password: If you check this option, you need to set password for locking diagram. If you uncheck it, you don't have to enter
password but you can still lock the diagram.
Save password: You can save your password in the project under your user account by checking this option. Thereafter, you don't have
to enter password when you edit the diagram. Otherwise, you need to enter password to edit the diagram after you uncheck it.
Show password: Check this option to reveal the password. The password will be hidden by asteriks when you keep it unchecked.

Trying to edit a locked diagram
If your team members want to modify any model elements of the locked diagram, they need to provide the password set by you in the pop-up
Authorization Required dialog box in order to proceed modification.

Require to enter password to proceed editing
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If you try to modify any model elements of the locked diagram, an Authorization Required dialog box will prompt out. Click Remove Lock button if
you want to unlock the diagram permanently while click Unlock button if you want to unlock it temporarily.

Unlock the diagram

NOTE: If you uncheck Save password when you lock the diagram, you will be asked to enter password to edit the locked diagram.

Moreover, you can also unlock the diagram permanently in Configure Lock dialog box. Right click on the diagram's background and select Diagram
Content > Configure Lock... from the pop-up menu. Choose Remove lock and enter password.

Removing lock
You can remove the lock or change the password after you lock the diagram.

1. Right click on the diagram's background and select Diagram Content > Configure Lock... from the pop-up menu.

NOTE: Configure Lock... option is available on the pop-up menu only after you have locked the diagram.

2. In Configure Lock dialog box, choose  Change password if you want to change the current password and set a new password; otherwise,
choose Remove lock if you want to remove the lock permanently. Click OK button to confirm.

Remove lock
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Using PostMania
 

PostMania Overview

Learn what PostMania is.

 

The PostMania Page

Learn how to start using PostMania.

Posting Discussion Topic in PostMania

Learn how to post a discussion topic.

 

Replying in PostMania

Learn how to reply a post.

 

Watching Diagram

Learn how to get notified by changes.
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PostMania Overview
As long as your design is not made for yourself, you must need to share it with others, like your boss, your teammates, your client, etc. You need to
communicate with them for confirmation of work, for clarifying needs, for notification, etc. All these are what PostMania offers.

PostMania is a social networking tool that lets people both inside and outside the development team to see the designs, discuss the designs and
keep track of design changes. Stakeholders can review process designs from time to time to see if the process behaves as expected. Developers
can get up-to-date system specification and design guidelines. Everybody can discuss and debate the designs for clearing doubts, requesting for
improvements and exchange ideas.

PostMania overview
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The PostMania Page
PostMania page provides a central place for you to access the discussion topics in diagrams and projects.

Enabling PostMania Page
To enable the PostMania page, select Teamwork > PostMania Page from the main menu.

Opening Project in PostMania page
In order to view diagrams of a project or to post, read and reply discussions for diagrams in that project, you need to open the project first. You may
open project in PostMania page. Note that only projects that have PostMania enabled in server can be opened via PostMania page. 

1. On the top left of PostMania page, click on the name of project you currently work on.

Click on the working project

2. You are prompted to select the project that you want to review and/or discuss. Select the project on the left hand side. Its description, if written,
is presented on the right hand side.

Select project

3. Click Open Project to open it.
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Posting Discussion Topic in PostMania
Any people who want to say something about a diagram or its content, no matter for what purpose, can post a discussion topic. Discussion topic can
be posted for a diagram or a shape. Viewers can use this function to report status ("I have approved."), to ask for action ("Please implement this."), ask
whatever questions ("When do you need this?"), seek for confirmation ("May I remove this from the model?"), request changes ("Fix it please"), etc.

Posting Discussion Topic
1. Browse and open the diagram that you want to post discussion.

2. The diagram must exist in the server in order for you to post discussion. If the diagram is newly created, commit it first. You can commit the
entire project or just commit the diagram partially.

3. You can post discussion topic for a diagram or for specific shape (including connector) in diagram. Click on the background of diagram or the
shape to discuss.

Click on a diagram to add discussion topic for it

4. In the Topics Pane on the right hand side, click New Topic.

Create a new topic

5. Enter the title and content.

Enter the content of a topic

6. If you want specific team member be informed about your post, click the + button next to the Notify field and choose the team member(s) to
notify. Members who are set notified will receive notification under the Notify me section in the home page of PostMania.

7. Click Post. This creates a topic and the topic is listed in the Topic pane.

Created topic is listed in Topic pane
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Replying in PostMania
When someone has posted a discussion topic, you can give him a reply if you have any comment about what he/she says. Reply can be made to a
topic, which gives a general reply that is not responding any previous reply. Besides, you can also reply to a specific reply.

Replying a Discussion Topic
1. Open the discussion topic you want to reply.

2. Click Reply.

3. Enter the message and click Post.

Enter reply content

Replying a Specific Reply
1. You can reply someone's post instead of giving a general reply to the whole topic. There are two ways you can do this. First, open a discussion

topic and click on the tiny reply button next to the reply you want to reply.

Reply a specific reply

Alternatively, in main page click the Reply link on the post you want to reply.

Reply in main page

2. Enter the message and click Post.

Enter reply content
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Watching Diagram
If you want PostMania inform you that certain diagram has discussion topic posted/replied, or has been modified, you can watch that diagram. By
watching a diagram, if someone has posted a discussion/reply, or when someone has committed changes made in that diagram, you will be informed
in the main page.

Watching a Diagram
1. Browse and open the diagram that you want to post discussion. 

2. On top of the Topics Pane, click on the gray flag to make it green. A green flag indicates that the diagram is being watched.

Watch the diagram

About Notification
Once you have set yourself watching a diagram, when someone has posted a discussion/reply, or when someone has committed changes made in
that diagram, you will be informed in the main page. On the left hand side of the main page, check the Watch Diagrams section. The Discussions flag
reports the number of new discussions made to the watched diagram(s). The Updates flag reports the number of modification made to the watched
diagram(s). You can click on them to see the list of updated diagrams.

Notification of updates
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General Options
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Project Options
Option Name Description

Default author for
non-teamwork
project

The name of person who edit the project. This will be filled in as the author within project management properties.

Auto save project Save the opening project as backup periodically.

Auto save interval
(mins)

Time needed to wait until the next auto saving.

Delete model
element when
deleting its view

Action that happen when all views of a model element are being deleted:
• Ask - (default) Prompt if you want to delete the model element as well.

• Delete without ask - Delete the model element as well.

• Don't delete - Do not delete the model element.

Open exported
image file

Action that happen after exporting images
• Ask - (default) Prompt if you want to open the exported image file.

• Yes - Open image file (when export single image) or image folder (when export multiple images) directly.

• No - Do not take any action.

Backup level  The number of files that will be saved as backup. When reached the limit, the next backup will overwrite the earliest one.

Confirm diagram
deletion

 (default true) Prompt if you really want to close diagram.

Confirm shape
deletion

 (default true) Prompt if you really want to delete a shape on diagram.

Never delete model
elements with
views

(default false) If a model element has multiple views, delete any of them will never cause the model element to be deleted,
even if you are deleting a master view.

Open last project
on startup

 (default true) If checked, it will open the last opened project immediately when starting VP-UML. If unchecked, it will open new
project.

Export as image
with frame

• None - (default) Do not surround the diagram with neither frame nor border.

• Export with frame - Add a frame around image to show a border with the name of diagram appear at top left of diagram.

• Export with border - Add a thin border around image.

Show password in
lock dialog pane

 

Lock by password  

Project Options details
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Referenced Project Options
Option Name Description

Duplicate Model from Linked Project Duplicating a model element from linked project will cause a local copy to be created.
• Prompt - (default) Prompt if you really want to duplicate.

• Yes - Confirm duplication. A local copy of selected shape(s) will be created.

• No - Discard duplication.

Show warning when failed to add
child to model from linked project

You cannot place a shape inside a linked shape, such as a linked package. If you try to do this you will be
warned by default. This option determines whether the warning will appear or not.

Caption Here
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Appearance Options
Option Name Description

Look and feel It controls the appearance of application screen.

Theme (for Office 2003 L&F
only)

The tone of the application screen.

User Language Language being applied on the user interface. This affects the text in menus, tooltips, dialog content, report content,
etc.

Change application font Select the font family and size of font to apply for the application user interface.

Date Format Format of date values that appears in the application.

Date Sample The sample of date is shown after you select the format of date.

Time Format Format of time values that appears in the application.

Time Sample The sample of time is shown after you select the format of time.

Measurement Unit • inch - (default) Set the measurement unit to be inch

• cm - Set the measurement unit to be centimeters

Appearence Options details
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Connection Options
Option Name Description

E-mail Enter the Email field to specify your email address.

Use proxy (default false) To check/uncheck in order to use a proxy server for connecting to the Internet.

Host The host of the proxy server.

Port The port of the proxy server.

Login name The user name of the proxy server (if the proxy server required the user to login).

Password The password of the proxy server (if the proxy server required the user to login).

ElaborView server Connection -
Connection Name

A name to describe the connection of ElaborView server.

ElaborView server Connection -
Hostname

The host of the ElaborView server.

ElaborView server Connection -
Port

The port of the ElaborView server.

ElaborView server Connection -
Email

The Email to log into the ElaborView server.

ElaborView server Connection -
Password

The Password to log into the ElaborView server.

ElaborView server Connection -
Add

Visual Paradigm can store multiple ElaborView connection. You may add a new one by clicking Add, and specify
the connection properties after added.

ElaborView server Connection -
Remove

Click to remove the current connection.

ElaborView server Connection -
Test Connection

Click to test if the connection is valid or not.

Connection Options details
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Printing Options
Option Name Description

Use gradient color when print diagrams Control whether to use gradient or solid color for shapes and diagrams when printing.

Print diagram background when printing diagrams Control whether to print the diagram background color when printing diagram.

Printing Options details
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Edition Options
Option Name Description

Enable non-
supported
feature

(default true) When checked, executing features that are not available in the running edition will be prompted, asking whether you
want to advance to higher edition in order to use the feature. When unchecked, those non supported features will be disabled.

Edition Options details
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Teamwork Options
Option Name Description

Show Export/Import
Teamwork project

(default false) Determines whether the export/import Teamwork project menus will appear in the Projects menu of
Teamwork Client dialog box

Teamwork Options details
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Update Options
Option

Name

Description

Auto
update

Let the application checks for available updates with respect to the running build/version, and notify you to perform update whenever possible.
• Never - Do not inform product update

• On every start - Check for updates everytime when starting Logizian

• Daily - Check for updates daily

• Weekly - (default) Check for updates weekly

• Monthly - Check for updates monthly

Update Options details
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Diagramming Options
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Appearance Options
Option Name Description

Global Pallet
Option - Show
name

(default true) Determines whether the name of items will be shown in the pallet.

Global Pallet
Option - Expand
group

(default false) Determines whether the group will be expanded to display all items.

Show Hidden
Layer Indicator

• Yes - When move the mouse over a shape, the hidden layer indicator is shown

• No - The hidden layer indicator isn't shown even when move the mouse over a shape

• Prompt -Ask if users want to show hidden layer indicator when move the mouse over a shape

Highlight
Glossary Terms

Underline the text in shape name or documentation if it is a term.

Appearance Options details
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Environment Options
Option Name Description

Alignment Guide
- Show diagram
alignment guide

(default true) Show alignment guide which appear when moving a shape on a diagram.

Alignment Guide • Show edges - (default) Show guides at edges of the closest shape

• Show center - Show a guide that lies on the center of the closest shape

Shape Selection
Detection

• Inside selection area - (default) When selecting a range of shape, only shapes that are completely inside the selection
range are included in selection

• Overlapped with selection area - When selecting a range of shape, shapes that are partly or completely covered by the
selection range are included in selection

Copy as XML with
RTF style

• Yes - When copy Use Case, the rich text format of Use Case Details will also be copied (size of copied content will
increase considerably)

• No - When copy Use Case, Use Case Details will be copied as plain text

• Prompt - Ask if user want to copy rich text for Use Case Details when copying XML

Delay until
showing Quick
Preview in
Diagram Navigator
(seconds)

• Never show - Never show Quick Preview when moving mouse cursor over diagram node in Diagram Navigator

• 1.0 - 3.5 - The number of seconds that a Quick Preview will disappear after moving the mouse cursor out of a diagram

Show "Copy to
Clipboard as OLE"
in menu

(default false) Determines whether the Copy to Clipboard as OLE menu is available or not

Default Copy
cction

• Within Logizian - (default) When triggering the hotkey  for Copy (Ctrl-C, by default), it will perform copying within Logizian

• Copy to Clipboard as Image (JPG) - When triggering the hotkey  for Copy (Ctrl-C, by default), it will perform copying as
JPG image

• Copy to Clipboard as Image (EMF) - When triggering the hotkey  for Copy (Ctrl-C, by default), it will perform copying as
EMF image

Copy as image
with frame

• Unspecified - (default) Prompt for adding a frame or a border when copying shapes as image

• None - Do not add border nor frame to image when copy shapes as image

• Copy with frame - Add a frame around image to show a border with the name of diagram appear at top left of diagram

• Copy with border - Add a thin border around image

Show shape
content when
dragging

(default true) Show the shape content such as shape name when dragging shape.

Prompt for
clearing undo
history before
applying design
pattern

(default true) Prompt for applying design pattern even when there are remaining undo or redo due to the undo and redo records
will be cleared after applying design pattern.

Number of
stereotypes shown
in popup menu

You can assign stereotypes to a shape through its popup menu. This option determines the number of stereotypes to display in
that popup menu.

Auto expand
diagram borders

Sometimes, the diagram border may be wrongly calculated. You may click the Reset to default button to reset the range of
diagram border.

Enable Mouse
Gesture

Mouse gesutre enables you to create and connect elements by forming a gesture with the right mouse button.

Show Logical
View selector
when naming new
diagram

When there is at least one logical view in your project, you can optionally select the logical view to store a diagram during the
creation of diagram. If you want to turn this option off, uncheck here.

Show diagram
element tooltip

Show the tooltip of shape when moving mouse pointer over shape

Environment Options details
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Shape Options
Option Name Description

Initial Shape Size When Set
to Display Image

• Fit shape to image - Resize the image placeholder to fit the selected image

• Fit image to shape - (default) Resize the image to fit into the image placeholder

Add Covered Shapes as
Children After Resize

• Yes - Automatic contain the covered shapes after resizing a container to cover shapes

• No - Do not contain covered shapes after resizing a container to cover shapes

• Prompt - (default) Ask if you want to contain covered shapes after resizing a container to cover shapes

No View Model as Master
View

When you try to create a shape from existing model element, like to drag and drop model element from Model
Explorer to diagram, and if the new shape is the only view of the model element, you can control whether to set the
shape to be master view or not.
• Yes - Set the created shape to be master view

• No - Do not set the created shape to be master view

• Prompt - (default) Ask if you want to set the created shape to be master view

Show Added Member in
Other View

When you try to create a new member, like a column of an entity, on a shape, and if there is another view of the
model element, you can set whether to show the member on other view as well.
• Yes - Show the member on other view(s)

• No - Do not show the member on other view(s)

• Prompt - (default) Ask if you want to show the member on other view(s)

Auto Expand Parent When
Moving Child

Determines whether to expand the parent when moving the shape around the parent's border.

Create new line key • <Ctrl> + <Enter> - Press Ctrl-Enter to create a new line when inline editing

• <Alt> + <Enter> - (default) Press Alt-Enter to create a new line when inline editing

• <Enter> - Press Enter to create a new line when inline editing

Show unlimited level in
preview shape (May slower
the diagram display)

(default false) Determines whether a diagram overview will show contents for all nested diagrams.

Show rich text content in
preview shape

(default false) Determines whether diagram overview will show rich text content.

Name completion (Classes,
Entities and Requirements)

(default true) When creating a class/ requirement/ an entity, you can select an existing class/requirement/entity from
a list so that a view of the selected class/requirement/entity can be created. You can enable or disable the popup of
such list.

Resize shape when add
member

(default true) For shapes that have member, like class and entitiy, when you add a member, it will or will not resize
the owner against the length of member, base on this option.

Auto resize parent when
resizing child

(default true) When you resize a shape that makes it touches the boundary of parent, this option determines whether
the parent will be expanded accordingly.

Shape Options details
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Connector Options
Option Name Description

Default pin from connection point (default false) Automatically pin connector's from end when connector is being created.

Default pin to connection point (default false) Automatically pin connector's to end when connector is being created.

Show relationship connectors for dropped
models

(default true) Show connectors when dragging and dropping inter-related model elements/views from
tree to diagram.

Auto relocate connector when overlapped
with other shapes

(default false) Auto relocate connector when connector is being overlapped by another shape.

Scroll connector delay (second) • No delay - Immediately scroll to the other side of connector

• 1 - 9 - Time provided for scrolling to the other side of connector

Highlight selected connector (default true) Increase the thickness of selected connector(s).

Connector Options details
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Resource Centric Options
Option Name Description

Show resources (default true) Show resource icons around shapes.

Show group
resources

(default true) Show group resources that appear when selecting multiple shapes.

Show extra
resources

(default false) Show also uncommon resource icons.

Show generic
resources only

(default false) Show generic resource but hide other resource icons.

Show resources
delay (second)

0 - 2 - Time needed to wait from having mouse cursor hover on shape till the resource icons appear.

Auto hide resource
delay (second)

Time needed to wait the resource icons to disappear when mouse cursor is moved out of a shape.

Always show model
element indicators

(default true) Always show the reference, subdiagram, transitor, documentation resource icon at the bottom of shape no matter
whether the shape has reference/sub-diagram/transitor/documentation added/defined.

Resource Centric Options details
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Business Process Options
Option Name Description

Invalid
Connection
Handling

• Ignore all - Ignore all invalid actions related to connecting shapes

• Cancel move - Cancel invalid actions related to connecting shapes

• Prompt - (default) Prompt for an action when an invalid actions related to connecting shapes is discovered

Show Lane
Handle

• Auto - (default) Show horizontal/vertical Lane header only when horizontal/vertical Lane exist

• Always Show - Always show both horizontal and vertical Lane headers even when Lane does not exist

• Always Hide - Always hide Lane headers

Show convert
Sub-Process/
Task warning

(default true) Show warning when trying to convert between Sub-Process and Task.

Business Process Options details
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Report Options
Option Name Description

When insert custom
cover page, show
disable generate
cover page warning.

In a report in report composer, there are two ways for you to add a cover page. One is to add a custom cover page, and
another one is to fill in the details of cover page in Report Inspector. You can choose either way to add a cover page, not
both. By checking this option, you will be prompted to disable the report inspector option when you add a custom cover
page.

Report Options details
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View Options
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View Options
Option Name Description

Diagram Navigator Sort
Type

• Sort by name - (default) Sort tree nodes in Diagram Navigator by their names

• Sort by type - Sort tree nodes in Diagram Navigator by their types

Model Explorer Sort
Type

• No sort - Do not sort tree nodes in Model Explorer

• Sort by name - (default) Sort tree nodes in Model Explorer by their names

• Sort by type - Sort tree nodes in Model Explorer by their types

Show data types (default false) Show Data Types node in trees.

Show relationships (default false) Show relationships in trees.

Show sub diagrams (default true) Show subdiagrams in trees.

Show Activation in
Diagram Navigator

(default true) Show activations in Diagram Navigator.

Show project path in
Diagram Navigator

(default false) Show project path in Diagram Navigator.

Sort elements in tree
with case sensitive

(default false) Make sorting of tree nodes case sensitive (consider the case).

Show carriage return
character

(default true) Show carriage return character for line breaks of shape names that are in multiple lines.

View Options details
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User Path Options
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User Path Options
A user path is a variable that refers to a base path in user&rsquo;s computer. You can add a reference to local file using user path so that the reference
refers to a file relative to a user path, instead of an absolute path. This means you can move references files to a different location, or even to a
different computer, and can still open them as long as the user path value is up-to-date.

Option Name Description

Show user path (default false) Select to show user paths in references, instead of displaying resolved absolute paths. A user path is displayed
with its name enclosed by ${ }.

Prompt to specify
user path

(default false) When adding a reference comprises a path that is not defined as a user path, you will be prompted to add path
as user path.

User Path Options details
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File Types Options
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File Types Options
Model Reference lets you add reference(s) to external file or URL into diagram element. You can open the referenced file or
URL
to get more information of the model in later stage. In the Options dialog box, you can configure to use specific application or command to open
different types of file and specify your favorite web browser to open a URL. The system default handling method will be used if you have not configure
the application or command to handle a particular file type.

Configure application/Command for file types
To configure application/command for file types:

1. Press on the upper Add... button. This shows a dialog box where you can add file extension.

2. Specify the Extension. Any file reference with this extension will be opened by the particular application or command. Note that for a valid
extension a dot is required to put in front of the name of that extension, such as .doc.

3. Specify the Application/Command. The application or command for opening a file reference with file extension same as that defined in the
Extension field.
A command can be entered directly to the text field, and can include application arguments, while an application an be chosen from a file
chooser by pressing ... next to the text field.

4. Specify the Name of this application or command. This is an optional field for identifying this file extension.

5. Click OK to close the dialog box.
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Spell Checking Options
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Spell Checking Options
The Spell Checking feature supports spell checking in all inline editing, as well as in Textual Analysis. We support in-place editing of misspelled words,
simply by right-clicking your mouse instead of using the complex spell-check box. Spell-check provides intelligent suggestions for words, and you can
add your own words into your personal dictionary.

Options

Option Name Description

Enable spell
checking

(default true) Enable spell checking.

Dictionary The choose of dictionary affects the judgment of correctness of words.
• American - (default) Perform spell checking using an American dictionary.

• British - Perform spell checking using an British dictionary.

• Canadian - Perform spell checking using an Canadian dictionary.

Check spelling as
you type

(default true) Check spelling when typing.

Ignore words in
UPPERCASE

(default true) Do not classify the use of upper case in a word as a spelling mistake(unless the spelling is wrong).

Ignore words with
numbers

(default true) Do not classify the inclusion of number in word as a spelling mistake (unless the spelling is wrong).

Ignore Internet
and file address

(default true) Do not classify Internet and file address as a spelling mistake.

Spell Checking Options details
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Keys Options
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Keys Options

Customizable program shortcuts
Commands can be invoked by pressing certain keys in the keyboard, as shortcuts. For example, holding down the Ctrl modifier key with the 'S' key
invokes the save command. Now, key bindings, which is the assignment of keys to commands, can be customized. This permits you to use the familiar
keystroke for invoking commands in Logizian.

To assign/re-assign a key:

1. Double-click on the binding cell of the desired action.

2. Click on the Binding field at the bottom of dialog box.

3. Press the key for invoking the command selected. The binding field will be updated accordingly.

4. Press OK button to confirm the updates. You will be prompted to restart the application in order to make the changes take effect. By restarting,
you can invoke commands using the key defined.
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Import/Export Options
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XMI Options
Option Name Description

Enable business process diagram for enterprise architect (experimental feature) Check this to include BPD when import and export XMI.

XMI options
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Diagramming Options
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Appearance Options
Option

Name

Description

Grid
-
Show
grid

(default false) Show grid lines on diagram

Grid
-
Color

 Color of grid lines.

Grid
-
Width

 Determines the horizontal spaces between grid lines.

Grid
-
Height

 Determines the vertical spaces between grid lines.

Grid
-
Snap
to
grid

(default true) When checked, shapes will be docked to the closest grid line when being created/moved. Otherwise, shapes can be moved
freely as if the grid does not exist.

Graphics
anti-
aliasing

(default true) Smoothen the graphics.

Text
anti-
aliasing

(default true) Smoothen the text.

Documentation
Type

Default type of documentation
• HTML - (default) HTML text that consists of formatting such as bold, italic, underline, table

• Plain text - Text without formatting

Model
Element
Name
Alignment

• Top Left - Shape name will appear at top left of shape

• Top Middle - Shape name will appear at top middle of shape

• Top Right - Shape name will appear at top right of shape

• Middle Left - Shape name will appear at middle left of shape

• Middle - (default) Shape name will appear at middle middle of shape

• Middle Right - Shape name will appear at middle right of shape

• Bottom Left - Shape name will appear at bottom left of shape

• Bottom Middle - Shape name will appear at bottom middle of shape

• Bottom Right - Shape name will appear at bottom right of shape

Diagram
background

 Background color of diagrams.

Enable
minimum
size

(default true) Determines whether shapes are restricted to a built-in minimum size.

Fractional
Metrics

(default true) When checked, fit size of shape will be performed correctly. When disabled, the shape may look better but size may not fit.

Show
Package
Name
Style

• Within Package Body - The name of package will be shown at the top of package shape

• Within Package Tab - The name of package will be shown inside the package tab

Appearance Options details
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Environment Options
Option Name Description

Default HTML Documentation Font The default font face, size, color, bold and italic status for HTML content in documentation pane.

Stereotype support HTML tagged
value

Enables you to define tagged value in HTML format for stereotype.

Environment Options details
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Model Generation Options
Option

Name

Description

Default
generate
diagram
type
from
scenario

• Sequence Diagram - (default) Take Sequence Diagram to be the type of diagram that will be generated by Scenario

• Interaction Overview Diagram - Take Interaction Overview Diagram to be the type of diagram that will be generated by Scenario

ID
Generator
Format

Specify the ID format of various element types. If you want ID be generated to a type of model element and you find the type does not exist in the table, click Add to add the type
manually. Then, specify the format of ID by specifying prefix, number of degits and suffix.

Model Generation Options details
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Shape Options
Option Name Description

Font Default font settings for shape content, inlcuding font, size, color, bold and italic.

Shape line format The default line format for shapes.

Shape fill format The default fill format for shapes.

Auto fit size (diagram-based) (default false) Determines whether shapes in diagrams will fit in size automatically.

Shape Options details
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Connector Options
Option

Name

Description

Font Default font settings for connector caption.

Connector
Style

• Rectilinear - Set the default connector style to be rectilinear

• Round Rectilinear - Set the default connector style to be round rectilinear

• Oblique - (default) Set the default connector style to be oblique

• Round Oblique - Set the default connector style to be round oblique

• Curve - Set the default connector style to be curve

Connection
Point
Style

• Round the shape - (default) Set the connector end to attach the round the shape

• Follow center - Set the connector end to point to the center of attached shapes

Line
Jumps

• Off - (default) Disable line jump

• Arc - Show connectors' intersections as an arcs

• Gap - Show connectors' intersections as a gaps

• Square - Show connectors' intersections as a squares

Line
jump
size

• Normal

• Large

• Extra large

Caption
orientation

• Horizontal only - Enforce connector caption to appear horizontally regardless of connector angle

• Horizontal or Vertical only - Enforce connector caption to appear either horizontally or vertically, depending on the connector angle

• Follow Connector Angle - Enforce connector caption to appear an the same horizontal level as the connector

• Follow Connector Angle and Keep Text Upright - Enforce connector caption to appear an the same horizontal level as the connector,
but keep the text upright

ForegroundForeground color of connector.

BackgroundBackground color of connector.

Paint
connector
through
label

(default true) Captions' background will become transparent so that connectors can show completely without having part of it covered by
opaque caption.

Connector Options details
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Business Process Options
Option Name Description

Connect Gateway
with Flow Object in
Different Pool

• Prompt - (default) Prompt if user want to change the Message to Message Flow, Sequence Flow or cancel the action

• Connect with Message Flow - Change or keep the relationship as Message Flow

• Connect with Sequence Flow - Change or keep the relationship as Sequence Flow

Auto stretch pools (default true) Stretch Pools automatically to the reach diagram bound.

Default Type of Sub-
Process

The default type of newly created sub-process.

• Unspecified (default)

• Embedded

• Reusable

• Reference

• Event

Business Process
Diagram default
language

The default value of language property of BPD

ID Generator Format
- Show ID option

• Not Show - (default true) Do not display ID

• Show Below Caption - Display ID as part of the caption, under the name

• Show as Label - Display ID as a label attaching to shape

• Show as Customized - Set the way to show ID per element type

Business Process Options details

Presentation

Option Name Description

Connection Point Style • Round the shape - Set the connection point style to Round the shape

• Follow center - (default) Set the connection point style to Follow center

Connector Style • Rectilinear - Set the connector style to Rectilinear

• Round Rectilinear - (default) Set the connector style to Round Rectilinear

• Oblique - Set the connector style to Oblique

• Round Oblique - Set the connector style to Round Oblique

• Curve - Set the connector style to Curve

Show Activities type
icon (diagram-based)

(default true) Show icons that represent the type of Task and Sub-Process.

Draw text annotation
open rectangle folow
connector end

(default true) Make the open rectangle of text annotation follow the position of end of the attached connector.

Business Process Options details
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DFD Options
Option Name Description

Add Data
Stores and
External
Entities to
Decomposed
DFD

• Yes - When decompose a DFD, Data Stores and External Entities on the current diagram will be copied to the decompose
diagram

• No - When decompose a DFD, Data Stores and External Entities on the current diagram will not be copied to the
decompose diagram

• Prompt - (default) When decompose a DFD, prompt if user want the Data Stores and External Entities on the current
diagram to be copied to the decompose diagram

DFD Options details
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Textual Analysis Options
Option Name Description

Highlight Option • Case insensitive - (default) Words which are the same as the entered word, even in different cases, are highlighted.

• Case sensitive - Words which are the same as the entered word or/and with same case are highlighted.

Generate
Requirement Text
from Candidate
Option

• Extracted text - (default) When create requirement from a candidate requirement, its text property will be filled by the
candidate's extracted text.

• Class description - When create requirement from a candidate requirement, its text property will be filled by the
candidate's class description.

Textual Analysis options details
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Model Quality Options
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Model Quality Options
Option Name Description

Enable
model
quality
checking

Model quality checking is the ability to check project data for potential flaws. The chekcing is done automatically. Whenever a
problem is detected, shapes will be underlined directly in diagram. You may turn this function off by unchecking this option.

Model Quality Options details
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Automatic update
Automatic update refers to the ability to detect and download possible updates from the Internet. This chapters shows you how to work with the
automatic update feature.

 

Updating Logizian

How to perform manual update.

 

Automatic update notification

How automatic update works and how to react to update prompt.
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Updating Logizian to Latest Hotfix Build
Visual Paradigm releases hotfixes from time to time. It is recommended to run the update program once a week to make sure the installation is up-to-
date. With an up-to-date program, latest bug fixes and minor enhancements can be obtained.

1. Run the Logizian update program. You can run it via the Start Menu or by executing Logizian Update under %Logizian_Install_DIR%\bin.

Run Logizian update

2. This shows the update program. Select the place where the update program can look for the update files. If you want to update Logizian to the
latest hotfix build, select Visual Paradigm update server and click Check update. If you have a specific place where the update file is stored,
select Internal update server and fill in the URL. Click Check update button.

Select Visual Paradigm update server

NOTE: If you need to configure a proxy server for connection, click Proxy setting at bottom left.

NOTE: A patch is special build made that contains specific bug fix/enhancement, made for specific users. When and only when you are asked by
Visual Paradigm to update to the latest patch build, click Update to latest patch at bottom left.

3. Let the program download and update the files for you. When a file is found modified both in the latest build and the installation, you need
to select whether to keep the local copy, by clicking Ignore update or to apply the latest version by clicking Overwrite. When a file is found
removed in the latest build but exist in the installation, it will be listed in red. Since the file is obsolete and has already been removed in the latest
version, neither Overwrite button nor Ignore update button will be shown on screen. It will be removed without choice.

4. Click Complete when finish.
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Automatic Update Notification
When you run Logizian, checking of possible updates is done in background. If there are available updates, you will be notified through the message
pane. Then, you can perform an update to advance to the latest build.

Updating when running Logizian
1. When running Logizian, a message " Update is available now. Please click here for more information" may popup in the Message pane.

This message indicates that there is a build newer than the one that you are running, and you are recommended to perform an update to
advance to the latest build.

Notification of available updates

2. Click on the message. This popup the Automatic Update dialog box.

Automatic update options

Here are the available options in the dialog box.

Option Description

Update
now

Run the product update now.

Next
time

Check for product updates next time when starting Logizian.

No Check for product updates after a certain period of time (The invertal can be defined in the Options dialog box. Refer to the
section below for details).

Never Do not check for product updates anymore.

Available options for automatic update

3. Select   Update now and click OK to proceed. This popup the Logizian  Update. In order to update, close all the running VP application and
continue.

4. Let the program update the files for you. When a file is found modified both in the latest build and the installation, you need to select whether to
keep the local copy, by clicking Ignore update or to apply the latest version by clicking Overwrite. When a file is found removed in the latest
build but exist in the installation, it will be listed in red. Since the file is obsolete and has already been removed in the latest version, neither
Overwrite button nor Ignore update button will be shown on screen. It will be removed without choice.

5. Click Complete when finish.

Setting the interval of checking updates
By default, update is checked weekly when starting Logizian. You can change the interval of checking updates through the Application Options
window. To change:

1. Open the Application Options window by selecting Tools >  Application  Options... from the main menu.
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2. In the Application  Options window, select General from the list at the left hand side, then open the Update tab.

Update page in Application Options window

3. Select the interval of performing auto update from the Auto update drop down menu.

Selecting update interval

Here are the available options:

Option Description

Never Do not check for product updates anymore

On every start Check for product updates everytime when starting Logizian

Daily Check for product updates everyday, when starting Logizian

Weekly Check for product updates every week, when starting Logizian

Monthly Check for product updates every month, when starting Logizian

Available update interval

Click OK to confirm updating. From now on, once the interval elapsed, and if there are available updates, you will see the Automatic Update
dialog box, letting you to update to the latest build.

Prompting for update when starting Logizian
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Connection rules
Model elements can be linked together using connectors. There are connection rules to control the type of model elements a connector support.

 

Business process diagram connection rules

Connection rules for shapes in business process diagram

 

Conversation diagram connection rules

Connection rules for shapes in conversation diagram

 

Data flow diagram connection rules

Connection rules for shapes in data flow diagram

 

EPC diagram connection rules

Connection rules for shapes in epc diagram

 

Process map diagram connection rules

Connection rules for shapes in process map diagram

 

Organization diagram connection rules

Connection rules for shapes in organization diagram

 

Entity relationship diagram connection rules

Connection rules for shapes in entity relationship diagram

 

Overview diagram connection rules

Connection rules for shapes in overview diagram
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Business process diagram connection rules
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