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Analisi Testuale 

Si parte dal documento di visione d’insieme, scritto in linguaggio naturale, e si 

esegue un’analisi testuale per individuare classi, attori e casi d’uso candidati. 

Caso di studio 

Power Driver è una società di noleggio auto. Power Driver ha 105 filiali nel 

mondo. Attualmente non vi sono collegamenti tra tali filiali. Power Driver 

necessita di un sistema informatico per connettere assieme tali filiali e fornire 

servizi migliori al cliente, in un modo più efficiente. I requisiti del sistema 

informatico sono i seguenti. 

Il sistema deve poter archiviare le schede dei veicoli. Una scheda di veicolo 

include numero di modello, numero seriale, stato, programma di prenotazione e 

storia di prenotazione. Lo stato del veicolo può essere: disponibile, noleggiato, in 

riparazione o riservato. Il personale può solo consultare le schede dei veicoli. 

Soltanto il direttore di filiale può amministrare le schede dei veicoli. Il sistema 

archivia le schede clienti. La scheda cliente include nome, ID, stato e storia dei 

noleggi. Lo stato del cliente può essere: normale, VIP o sospeso. I clienti in stato 

normale e VIP possono noleggiare veicoli, ma i clienti in stato sospeso non 

possono noleggiare veicoli. Tutto il personale può amministrare le schede dei 
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clienti. Ma solo il direttore di filiale può modificare lo stato dei clienti. Ciascuna 

filiale ha un solo direttore. 

Il sistema deve fornire per il personale una funzione per inserire schede di 

noleggio. Il personale può creare soltanto le schede di noleggio per l’automobile 

nella propria filiale di lavoro. Il personale non può creare una scheda di noleggio 

per altre filiali. Dopo che il veicolo è stato restituito, il personale deve aggiornare 

la scheda di noleggio. Il sistema deve avere una funzione di “auto riservata” per 

prenotare l’automobile. L’inizio del periodo di noleggio deve essere compreso nei 

prossimi 7 giorni. Il personale ordinario non può eseguire una richiesta di 

prenotazione per un’altra filiale. Soltanto il direttore può richiedere una 

prenotazione ad un’altra filiale. 

Il personale può adoperare il sistema per controllare la disponibilità dell’auto 

usando il numero di modello, o il programma di prenotazione. Se vi sono auto 

adatte per il noleggio, il personale può usare il sistema per riservare o noleggiare 

l’auto. Se l’auto è noleggiata, gli altri componenti del personale non possono 

noleggiare l’auto per un altro cliente finché il periodo di noleggio non è terminato. 

Il personale può cercare le schede clienti usando il nome del cliente, l’ID o il 

numero di telefono. 

Il sistema deve fornire una funzione di generazione di rapporto per generare un 

resoconto mensile della filiale. 
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Elenco delle perazioni principali da compiere 

� New Textual Analysis 

� Incolla o importa descrizione testuale 

� Spiegazione dei vari bottoni della barra di sinistra 

� Termine veicolo/veicoli → classe candidata Veicolo 

� Termine cliente/clienti → classe candidata Clienti 

� Termine storia delle prenotazioni → classe candidata StoriaPrenotazioni 

� (tasto destro nello spazio delle classi, add candidate)  

Termine personale → attore candidato Personale 

� Riordina layout, mostra i possibili layout 

� Bottoni per visualizzare solo classi, solo attori, ... 

� Cambia type di Cliente in actor, ed edita la descrizione (Ctrl+enter termina) 

� Cambia nome della classe di Personale in Impiegato 

� Termine amministrare le schede dei veicoli → caso d’uso candidato 

AmministraSchedeVeicoli  

� Genera elementi di modello: tasto desto sull’elemento candidato →  create … 

model. Appare un nuovo elemento nel modello (scheda Model), in aggiunta 

agli elementi candidati, che può essere trascinato su un opportuno diagramma 

UML. 
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� Quando si tenta di creare nuovi elementi con nomi preesistenti, è possibile 

associare l'elemento candidato all'elemento preesistente (es. cliente e clienti 

alla classe Cliente) 

� Differenzia tra elementi di modello e diagrammi 

 

� NOTA: Come si può osservare in Fig.1, l’analisi testuale svolta sinora è 

frammentaria. Solo una minima parte del testo è stata analizzata. Inoltre, 

manca un glossario di progetto che individui correttamente la semantica degli 

elementi, i sinonimi, gli omonimi. Pertanto, i casi d’uso che proveremo a 

generare saranno parziali e non consistenti con l’intera specifica. 

  

� Obiettivo del laboratorio non è produrre una specifica integrale e coerente, ma 

fare pratica con le funzioni basilari di Visual Paradigm relative ai diagrammi 

dei casi d’uso ed all’analisi testuale. 

 

���� NOTA: Le proprietà di un qualsiasi elemento si configurano mediante il 

menu che appare cliccando con il tasto destro sull'elemento medesimo. 
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Fig.1 – Risultato delle operazioni di analisi testuale 
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Primo diagramma dei casi d’uso 

� Create Use Case Diagram 

� Trascina l’attore Impiegato nel diagramma dei casi d’uso 

� Trascina il caso d’uso AmministraSchedeVeicoli nel diagramma dei casi d’uso 

� Crea direttamente l’attore DirettoreFiliale nel diagramma 

� Collega l’attore DirettoreFiliale al caso d’uso AmministraSchedeVeicoli 

� Definisci Impiegato come generalizzazione di DirettoreFiliale (il direttore è 

un impiegato con altre funzioni aggiuntive. Il direttore può sostituire qualsiasi 

impiegato, principio di sostituibilità) 

� Togli grid visible 

� Togli snap to grid 

� Metti il Fill di tutti gli elementi in trasparenza (imposta come default) 

� Prova Layout → gerarchic style,... undo,... orthogonal style 

� Allontana la parte terminale della relazione dal nome DirettoreFiliale, 

bloccandola mediante il pin. 

� Crea il soggetto Sistema di Autonoleggio 

� Inserisci il caso d'uso nel soggetto (nota la struttura della scheda model) 

� Crea il caso d’uso AnalizzaRapportiNoleggio per il DirettoreFiliale 

� Crea il caso d’uso AmministraSchedeClienti per il DirettoreFiliale 
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� Risistema il layout a mano, dopo aver mostrato gli altri layout 

� Zoom al 200% 

� Crea il caso d’uso RichiediNoleggioAdAltreFiliali per il DirettoreFiliale 

� Ridimensiona ovale di RichiediNoleggioAdAltreFiliali 

� Crea il caso d’uso RisolviAutonoleggio 

� RichiediNoleggioAdAltreFiliali estende RisolviAutonoleggio 

� Punto di estensione: VeicoloNonDisponibile 

� Passa ad un altro diagramma per aggiornare 

� Collega RisolviAutonoleggio a Impiegato 

� Crea il caso d’uso AmministraSchedeNoleggi per Impiegato 

� Fare il copia-incolla in formato EMF (vettoriale) su Word 

� Edit → Copy → To Clipboard As Image (EMF) 

� Da Word: Modifica → Incolla. 

� Togliere la filigrana (53% luminosità, 100% contrasto) 
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RisolviAutonoleggio

<<Extend>>

AmministraSchedeNoleggi

Sistema di Autonoleggio
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Visual Paradigm for UML Standard Edition(University of Pisa)

 
Fig.2 – Diagramma in formato EMF 
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���� NOTA: anche se la visualizzazione delle immagini vettoriali può risultare 

distorta (es. le linee tratteggiate possono trasformarsi in linee continue se 

l’imagine è ridimensionata), nella stampa su carta o su stampante virtuale pdf 

ciò non avviene. Si noti la relazione Extend. 

 

� Esportare in formato raster (PNG) 

� File → Export → Selection as Image...PNG with background 

� Ridurre la profondità di colore mediante il Paint di Windows, e notare la 

differenza in dimensioni. Eliminare la filigrana. 

� Da Word: Inserisci → Immagine → Da file. Fig.3 

� Catturare con Stamp e salvare con Paint, ritagliarlo...Fig.4 

� Inserisci una molteplicità 0..* ad 1 tra AnalizzaRapportiNoleggio e 

DirettoreFiliale (Dalla scheda Property o Tasto destro → Open 

Specification... Multiplicity) 
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Fig.3 – Formato PNG esportato 

 
Fig.4 – Formato PNG catturato 

 

Caso d’uso in dettaglio 

� Tasto destro sul caso d’uso AmministraSchedeNoleggi → Use Case Details... 

� Scheda Description.  
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� Tasto su New → Template → Other, sfogliare. Riaprire il Template del corso 

(modello visto a lezione, da usare per i progetti) selezionando New →  other 

→ SistInfoUseCaseDetails.udt. Set as default. 

� Mostrare come è possibile fare degli adattamenti  

� Move Item Brief Description al 3° posto 

� Remove Item Flow of events del template Full 

� Tasto destro → Insert Item Main flow (Add Item lo mette in fondo) 

� Rename Item Alternative Flows and exceptions 

� Inserire il seguente flusso principale: 
1.L'Impiegato esegue il login sul sistema 

2.Il sistema convalida l'identità dell'Impiegato con nome utente e password 

3.L'impiegato seleziona una delle seguenti voci:  "ricerca", "inserisci",  

   "aggiorna" o "logout" 

4.IF L'impiegato ha selezionato "ricerca" 

    4.1 L'impiegato fornisce dei criteri di ricerca 

    4.2 Il sistema visualizza le schede con i criteri 

5.IF L'impiegato ha selezionato "inserisci"  

    5.1 Il sistema crea una nuova scheda di noleggio 

    5.2 L'impiegato inserisce le informazioni di noleggio 

    5.3 L'impiegato conferma le variazioni 

6.IF L'impiegato ha selezionato "aggiorna" 

    6.1 L'impiegato fornisce l'ID della scheda 

    6.2 IF Il sistema trova la scheda corrispondente a tale ID 

           6.2.1 L'impiegato inserisce le informazioni da aggiornare 

           6.2.2 L'impiegato conferma le variazioni 

7.ELSE 

   7.1 Il sistema esegue il logout  
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� Ecco come risulta l’intero caso d’uso in dettaglio: 

 

� Cliccare su Save as Template...  SistInfoUseCaseDetails.udt 
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� Viene salvato lo schema in formato html 

� Per aprire immediatamente tale formato negli altri casi d’uso dettagliati, basta 

cliccare su New e poi Template Type → Other...  

� A questo punto è possibile fare un’analisi testuale del caso d’uso, per scoprire 

nuovi elementi candidati. Chiudendo il dettaglio del caso d’uso, cliccare con 

il tasto destro sul caso d’uso → sub diagrams → textual analysis → create 

textual analysis,... Viene aperto un nuovo diagramma di analisi testuale con il 

dettaglio del caso d’uso in forma testuale, da cui si può procedere come visto. 

� Andando avanti in maniera iterativa ed incrementale, i requisiti assumeranno 

man mano maggiore completezza, integrità e stabilità. Un esempio di caso 

d’uso più completo, ma non definitivo, è a pagina seguente. 

 
Generazione di report HTML o PDF 

� Dal menu Tools → reports → generate HTML report 

� Dal menu Tools → reports → generate PDF report 

� Dal formato HTML è possibile copiare i casi d'uso in dettaglio su un 

documento word, dal quale creare un pdf (stampante virtuale, pdf995). PDF è 

il formato preferito per la documentazione, in quanto è direttamente 

stampabile e non richiede alcuna licenza per essere letto. 

� Dal menu Tool → reports →  Report Writer (occorre ReportEngineWindows.zip) 
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Riferimenti 

• Visual Paradigm Discussion Forum 

http://forums.visual-paradigm.com 

• Visual Paradigm User’s Guide  

http://www.visual-paradigm.com/product/vpuml/vpumldocuments.jsp 

• Adobe Reader, proiettore di file PDF (Portable Document Format), un formato 

aperto per documenti. 

http://www.adobe.it/products/acrobat/readstep2.html 

• SWF Opener, proiettore di file SWF (Shockwave Flash), un formato aperto 

per animazioni grafiche. 

http://www.browsertools.net/ 

• PDF995, stampante virtuale PDF. Consente di avere un file pdf, a partire da 

un qualsiasi programma (es. Microsoft Word), stampando su tale stampante 

virtuale. 

http://www.pdf995.com/download.html 
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Frequently Asked Question 

1)  Dove scaricare Visual Paradigm? 

2)  Come installare l’applicazione a casa? 

3)  Come importare un diagramma in Microsoft Word? 

4)  Come impostare di default lo sfondo bianco senza griglia? 

5)  Come creare uno stereotipo? 

6)  Come applicare uno stereotipo? 

7)  Si possono inserire icone non UML? 

8)  Come dare ad un attributo la visibilità a livello di classe?  

9) Come rinumerare i messaggi in un sequence diagram?  

10) Come creare un gate in un frame di un sequence diagram?  

11) Come inserire la guardia in un frammento combinato di tipo loop? 

12) Come inserire la guardia in un punto di decisione di un activity diagram?  

13) Come inserire i vincoli di molteplicità in una associazione? 

14) Come inserire la direzione in una associazione? 

15) Come inserire i ruoli in una associazione? 

16) Come agganciare l' interfaccia richiesta e quella offerta? 

17) Come attribuire ad una interfaccia lo stile classe o leccalecca? 

18) Come si rende una classe attiva? 

19) Come inserire un frammento combinato di tipo parallelo? 
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20) Come inserire un frammento combinato di tipo sezione critica? 

21) Come inserire un qualificatore in una associazione? 

22) Come costruire un semplice diagramma temporale? 

23) Come inserire la linea del tempo ed il righello del tempo? 

24) Come visualizzare un diagramma temporale in forma compatta? 

25) Come inserire un vincolo di durata nella linea del tempo? 

26) Come inserire un vincolo di istante nella linea del tempo? 

27) Come inserire messaggi tra linee-di-vita? 

28) Come inserire azioni, transizioni ed attività in uno stato? 

29) Come specificare una transizione in una macchina a stati? 

30) Come inserire delle regioni in uno stato composto? 

31) Come far scomparire lo stereotipo «component»? 

32) Come stampare i casi d’uso in dettaglio? 
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1) Dove scaricare Visual Paradigm? 
� Su http://info.iet.unipi.it/~france/p_docs/SistemiInformativi/ 

� Nella sezione Software e licenze, scaricare i seguenti file: 

University_of_Pisa_5301923604186365_vp-uml_7-1_se.zvpl (file-licenza) 

VP_Suite_Windows_NoInstall_4_1_20090918.zip (software, 154 MB) 

2) Come installare l’applicazione a casa? 

� Decomprimere il file zip, cliccare su sul file bin\VPSuite.exe 

� Selezionare solo il prodotto “Visual Paradigm for UML”, quindi “Next” 

� Selezionare “Standard Edition”, eventualmente selezionando i file di 

documentazione nel formato preferito, per scaricare i quali l’applicazione 

cercherà di connettersi ad Internet
1
. I file verranno collocati nella cartella doc. 

                                                
1 La dimensione dei file di documentazione è di qualche decina di MB; essi sono comunque disponibili in formato pdf tra il materiale del corso. 
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� Alla richiesta del file-licenza, selezionare “combined” e localizzare il file 

licenza, di durata annuale. Ad installazione conclusa non è necessario 

riavviare il sistema operativo, l'applicazione si avvia cliccando sul file 

bin\Visual Paradigm for UML 7.1.exe. È buona norma creare subito un 

collegamento dal Desktop a tale file. 

� Ad ogni avvio dell’applicazione occorre connettersi ad Internet per pochi 

secondi, necessari affinché il sistema ottenga da un archivio centrale il 

riconoscimento della licenza. Al termine appare una finestra con alcune note 

sulla licenza: cliccare sul tasto “close”. Dopodiché è possibile disconnettersi. 

� Per evitare tale connessione preliminare negli usi successivi, non chiudere 

l’applicazione a fine lavoro, ma spegnere il computer mediante la 

sospensione (hibernation) che mantiene lo stato delle applicazioni.  

3) Come importare un diagramma in Microsoft Word? 

� Ingrandire al 200% la vista del diagramma e selezionarne la parte da esportare 

� Dal Menu, Edit→ Copy→ To clipboard as Image (EMF) 
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� Passare a Microsoft Word e, dal menu, Modifica→ Incolla 

� Per rendere invisibile l’iscrizione apposta in alto dal tool (filigrana), fare un 

doppio click sull’immagine ed impostare il contrasto al 100% e la luminosità 

al 53%. L’ingrandimento al 200% di cui sopra produce una filigrana di 

dimensioni minime, che non si sovrappone ai costrutti grafici. 

� Ridimensionando la figura, la visualizzazione di un formato vettoriale EMF 

può risultare diverso dall’originale. Ad esempio, una linea tratteggiata può 

trasformarsi in linea continua. Comunque, nella stampa su carta o su 

stampante virtuale pdf ciò non avviene. Se si desidera evitare questo 

inconveniente, generare l’immagine in formato raster (matrice di pixel) PNG, 

selezionando dal menu File→ Export→ Selection as Image→ PNG with 

background. Il file immagine può essere inserito in un documento di 

Microsoft Word selezionando Insert→ Picture→ From file. Prima 

dell'inserimento, è buona norma ridurre il numero di colori dell'immagine 

mediante un editor come Paint di Windows, per mantenere contenute le 

dimensioni del file word. 

 

4) Come impostare di default lo sfondo bianco senza griglia? 
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� Tasto destro su sfondo → Background color... proseguendo poi mediante la 

semplice interfaccia di selezione colore.  

� Tasto destro su sfondo → Grid → Grid Visible  

� Tasto destro su sfondo → Grid → Snap to grid colloca liberamente gli 

elementi senza riferirsi alla griglia. Nello stesso menu, è anche possibile 

ridimensionare le maglie della griglia. 

 

5) Come definire uno stereotipo? 

� Tasto destro su un elemento → Stereotypes → Stereotypes... → Edit 

Stereotypes...  

� Selezionare il tipo di diagramma e poi di elemento di cui si vuole creare lo 

stereotipo, quindi → Add 

� Inserire nome, icona di rappresentazione, semantica, quindi → OK 
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� Nel riquadro All selezionare il nuovo stereotipo e quindi cliccare su “>” per 

portarlo nel riquadro selected e poi OK. 

6) Come applicare uno stereotipo? 

� Tasto destro su un elemento → Stereotypes →  <nome dello stereotipo> 

7) Si possono inserire icone non UML? 

� Sì, mediante gli Stencil, che offrono un set di forme generiche non UML da 

associare a diagrammi UML. Vi sono predefiniti gli stencil per BPEL, 

FlowChart, Basic Shape.  

� È anche possibile sostituire la forma UML di un elemento con una immagine: 

Tasto destro  →  Presentation options... → User-defined  → Select from file. 

8) Come dare ad un attributo la visibilità a livello di classe? 

� Cliccare con il tasto sinistro sull’attributo per selezionarlo. Quindi cliccare 

con il tasto destro → Model Element Properties  → Scope → Classifier. 
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9) Come rinumerare i messaggi in un sequence diagram?  

� Tasto destro sullo sfondo del diagramma → Sequence number → Manual. 

Accanto appare un nuovo menu → Edit sequence numbers... dove si possono 

numerare i messaggi a piacimento. 

10) Come creare un gate in un frame di un sequence diagram?  

� Dopo aver inserito un frame mediante il trascinamento, andandovi con il 

mouse sopra, compare in alto a sinistra il simbolo di inserimento del gate. 

� Per un gate di uscita, creare prima una linea-di-vita esterna al frammento 

verso cui indirizzare il messaggio, dopodichè spostare la destinazione sul 

gate. 

11) Come inserire la guardia in un frammento combinato loop?  

� Tasto destro sul frammento → Open Specification → Interaction Operands, 

selezionare l’operando → Open Specification → Guard → inserire la guardia 

in Constraint 
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12) Come inserire la guardia in un punto di decisione di un activity 
diagram?  

� Tasto destro sul ramo uscente dal punto decisionale  → Guard... 

13) Come inserire i vincoli di molteplicità in una associazione? 

� Tasto destro sull’associazione → Show multiplicity constraints. Appare la 

proprietà unique tra parentesi graffe. 

� Tasto destro sulla proprietà tra parentesi graffe → Open specification. Appare 

una finestra con diverse proprietà, tra cui due caselle di spunta con le voci 

ordered ed unique selezionando le quali appare la corrispondente proprietà 

sul diagramma. 

14) Come inserire la direzione in una associazione? 

� Tasto destro sull’associazione → Show direction. 

� Per invertire tale direzione, tasto destro sull’associazione → Reverse direction 

15) Come inserire i ruoli in una associazione? 

� Tasto destro sull’associazione (dalla parte del ruolo) → Edit role name... 
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16) Come agganciare l'interfaccia richiesta e quella offerta? 
� Passando sopra il mouse su una classe, appare il simbolo per creare da essa 

un'interfaccia (richiesta o offerta). Passando poi su tale interfaccia, appare il 

simbolo della classe che, una volta trascinata, avrà l'interfaccia (di tipo 

complementare) agganciata alla interfaccia di partenza. 

 
17) Come attribuire ad una interfaccia lo stile classe o leccalecca? 
� In un composite structure diagram, inserire una nuova interfaccia. 

� Tasto destro sull’interfaccia → Presentation Option, scegliendo Interface o 

Class è possibile commutare nei due stili. 

18) Come si rende una classe attiva? 

� Nei diagrammi di classe, Tasto destro sulla classe → Open Specification... → 

In basso alla finestra si può selezionare/deselezionare la proprietà active, così 

facendo comparire/scomparire le doppie barre laterali. 

� Nei diagrammi di sequenza, Tasto destro sulla lifeline → Active. Quindi la 

linea-di-vita attiva appare con le doppie barre laterali.  
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19) Come inserire un frammento combinato di tipo parallelo? 
� Trascinare nel diagramma un alternative combined fragment. Poi selezionare 

il frammento con il Tasto destro → Operator → par. 

20) Come inserire un frammento combinato di tipo sezione critica? 
� Trascinare nel diagramma un alternative combined fragment. Poi selezionare 

il frammento con il Tasto destro → Operator → critical. 

21) Come inserire un qualificatore in una associazione? 

� Tasto destro sull’associazione → Open specification quindi, nella finestra che 

appare, a destra della voce Role: selezionare “...” → scheda Qualifier → Add 

→ inserire un nome → OK → OK. 

22) Come costruire un semplice diagramma temporale? 
� Trascinare un timing frame sullo sfondo, ed allargarlo. 

� Tasto destro dentro il timing frame → Add lifeline. 
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� Cliccare con il tasto sinistro sulla linea-di-vita, quindi Tasto destro sulla linea-

di-vita → Add state/condition. (si può anche aggiungere una nuova lifeline 

selezionando Insert lifeline above/below) 

� Tasto desto sullo stato/condizione → Insert state/condition above o below. 

� Se non si creano almeno due stati, la linea del tempo sarà rettilinea.   

23) Come inserire la linea del tempo ed il righello del tempo? 
� La linea del tempo compare in corrispondenza dello stato più in alto, man 

mano che si aggiungono le unità al righello, nel seguente modo. 

� Tasto destro su un punto bianco del frame, non al di sotto dell’elenco di 

stati/condizione  → Add time unit. Inserendo almeno due unità temporali, 

appare in alto la linea del tempo. 

� Per inserire una etichetta in corrispondenza di una unità temporale, eseguire 

un doppio click sulla stessa. É anche possibile spostare le unità. 
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� Per sagomare la linea del tempo, se vi sono almeno due stati, basta trascinare 

con il mouse i segmenti di linea, uno ad uno, in verticale a livello dello stato 

desiderato. 

24) Come visualizzare un diagramma temporale in forma compatta? 

� Tasto destro sul frame → View mode → Compact. 

25) Come inserire un vincolo di durata nella linea del tempo? 

� Tasto destro sulla linea-di-vita → Edit lifeline → Duration costraints → Add, 

quindi inserire start time, end time (supponendo di avere unità temporali 

etichettate) e constraint. Il vincolo sarà visualizzato tra parentesi graffe su una 

freccia a doppia punta, inclusa nei due estremi temporali. 

26) Come inserire un vincolo di istante nella linea del tempo? 

� Tasto destro sulla linea-di-vita → Edit lifeline → Time costraints, quindi 

inserire l’espressione alla riga dell’istante desiderato, che verrà visualizzata in 

corrispondenza di detto istante tra parentesi graffe.  

27) Come inserire messaggi tra linee-di-vita? 



SISTEMI INFORMATIVI – A.A. 2009-10 –  FAQ SU VISUAL PARADIGM 15/17

� Tasto destro sul frame → Edit frame → Time messages → Add. Quindi 

inserire name, start lifeline, start time, end lifeline, end time → OK → OK. 

28) Come inserire azioni, transizioni ed attività in uno stato? 

� Tato destro sullo stato → Open specification... Nella scheda General si può 

editare name, entry/exit actions, do activity. 

� Tasto destro sullo stato → Add region, compare uno spazio bianco nello stato. 

� Tasto destro sulla regione → Open specification... → Internal transitions → 

add, quindi specificare un nome. 

29) Come specificare una transizione in una macchina a stati? 

� Tasto destro sulla transizione → Open specification... si può definire nome 

guardia, effetto (con pre-condizione, post-condizione, e body). 

30) Come inserire delle regioni in uno stato composto? 

� Tasto destro sullo stato → Add region, compare uno spazio bianco nello stato, 

in cui si possono inserire altri stati. 

31) Come far scomparire lo stereotipo «component»? 



SISTEMI INFORMATIVI – A.A. 2009-10 –  FAQ SU VISUAL PARADIGM 16/17

� Tasto destro sullo SFONDO (non sul componente) del diagramma → 

Presentation Options → Show component option → selezionare solo Icon,  

come in figura. 
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32) Come stampare i casi d’uso in dettaglio? 

� Dal menu tools → report → generate HTML report. Quindi selezionare tutto 

ciò che è di interesse.  

� Aprire il documento HTML tramite il browser Internet Explorer (e non 

Firefox o altri, altrimenti si perde la formattazione). 

� Fare copia ed incolla delle specifiche (e di quant'altro) di interesse) nel 

proprio documento Word. 


